Jump to content

New Ralink RT2500-USB Driver [a la Airport Driver] - V 1.5


  • Please log in to reply
380 replies to this topic

#21
Simania_NL

Simania_NL

    Insanely Pac Man

  • Members
  • PipPipPipPip
  • 175 posts
Prasys I adapted the RT2500Replug so it works with with the WUSB54GC from linksys, I think all RT73 usb sticks can work with the RT2500Replug since it's only a USB-thingy, not an actual driver.
The change I made in the Info.plist:
<key>LINKSYS</key>
<dict>
<key>CFBundleIdentifier</key>
<string>ch.walter.thomas.RT2500Replug</string>
<key>IOClass</key>
<string>ch_walter_thomas_RT2500Replug</string>
<key>IOKitDebug</key>
<integer>0</integer>
<key>IOProbeScore</key>
<integer>100000</integer>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>bcdDevice</key>
<integer>1</integer>
<key>idProduct</key>
<integer>32</integer>
<key>idVendor</key>
<integer>5041</integer>
</dict>
If you would like to use it with your WUSB54GC just go to: RT2500 Replug
Download the kext and add this information to the info.plist
If you like it donate some money to the official maker

#22
theofan1960

theofan1960

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:Quebec, Canada
This driver works really great for me with my DWL-G122 on WPA.

However, yesterday I tried to connect to a WPA Enterprise network and the driver said "It is no YET supported". Is there any plan to implant WPA Enterprise for this driver???

Thanks a lot for this wonderful driver :huh:

#23
jhonnypolak

jhonnypolak

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
Prasys mate, any chance of releasing this driver for the PCI version ?

I've got a D-Link DWL-G510 rev C1 (based on RaLink RT2500 chipset) and i'm dying to get it to work

#24
kevinosx

kevinosx

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts
jhonnypolak: I'm not sure if this is what your after but I have a PCI based adaptor (that came on the laptop) with the TR2500 chipset and I just went to the Ralink website and downloaded their driver for the Mac pci. When I install the program it works great, connects to the internet etc.
The only problem I'm having is that when I restart it doesn't detect the internet until I reinstall the program (only takes a couple secs) and restart the computer.
I'm going to try the Replug driver and see if it works even though it's not USB.

#25
bgrau

bgrau

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 414 posts
  • Gender:Male
Hi Prasys, and other geeks like me lol :compress:
Prasys, you advised me to get a Ralink USB wireless, actually I didnt know, but I had one already (the v2000, lucky me) which I used on another old PC...
So initially not aware of this thread, I found the Ralink website and got the latest driver (usb wireless assistant), it installed nicely, and I started getting some network connectivity.
Using the PCI NIC is useless on my system, (or maybe its only because of the NIC's I got)...
Anyhews, I finally installed your gear, and it works too.
I can network all computers, but I still can't get an internet connection through the PC, or via airport.
I can ping the PC (which has the Ralink and is connected to the internet), I can ping airport, and I can get network connections, but no DHCP or internet connections...
Any idea?
Cheers dude/s

#26
bgrau

bgrau

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 414 posts
  • Gender:Male
Anyways, I sorted it out, with the Ralink usb on top...
Maybe not very efficient setting but works...
http://forum.insanel...showtopic=33904

#27
Prasys

Prasys

    Cheese Cheese cheese

  • Retired Developers
  • 338 posts
  • Gender:Male
I will find a way to patch the PCI Drivers , I will see what I can do about it and I will be working back on the project. It might take a long time as I need to focus on other stuff. But dont worry , I will turn it to an Airport-CLone !

#28
bgrau

bgrau

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 414 posts
  • Gender:Male
:censored2: no worry dude...
take care
&
good luck

#29
jhonnypolak

jhonnypolak

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
kevin, it doesnt work for me. i think you're reffering to PCIBus driver, _Prasys_ knows what i'm reffering to.
I will be forever greatful _Prasys_ for your work if you can make the PCI cards work. And you can be sure if there is any way i can help please let me know ? Info dumps on hardware or something...... Next month when i get paid, I'll be even able to make a little donation, as an xmas gift for all your hard work :gun: ... if you accept that kinda of stuff that is :blink:

#30
bgrau

bgrau

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 414 posts
  • Gender:Male
I talked too fast, Internet worked for me for a couple of days, but not anymore... Need to find out why, but until now have not figured it out... The settings were all manual, so might have changed something without knowing, but its a bummer :whistle:

#31
Prasys

Prasys

    Cheese Cheese cheese

  • Retired Developers
  • 338 posts
  • Gender:Male
Info dumps for PCI card be better ...and I will be working on it

so i need your Device IDs and such...I will be doing all sorts of things , let us turn this into an airport clone !

#32
jhonnypolak

jhonnypolak

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
Here are the DEV ID's and VEN ID's that you requested:

http://users.tpg.com...DLINK_DEVID.JPG

if i'm reading it right they are:

VEN_1814
DEV_0302

#33
Prasys

Prasys

    Cheese Cheese cheese

  • Retired Developers
  • 338 posts
  • Gender:Male
Umm missing IOSuperclass , need to fix that , quite tricky

#34
PolishOX

PolishOX

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts
@Prasys

Bro it's been awhile but I'll be back on the scene soon...

Simple recommendation for the icon (dock) issue...just remove the AIRPORT icon from the AIRPORT package contents and remove the ugly icon putting the ripped one in its place...afterall you DO want to make it like an AIRPORT CLONE! :)

Hope you have time to help me remotely soon...
Have you looked at the progress of full sound support?
Your work and their work are really interesting! :)

#35
bgrau

bgrau

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 414 posts
  • Gender:Male
Hi Prasys, All,

After a lot of fiddling, I think found a way for my system to connect to Internet and Network together...
I have no real name for what I have done, just playing with settings.

The USB Ralink Wifi I assigned IP 192.168.0.1, no routing, DNS: 192.168.0.1, 192.168.0.10, Domain:ISP

The Airport Base station: IP 192.168.0.10, Router: 192.168.0.1, DNS:192.168.0.1, 192.168.0.10, Domain:ISP

The Realtek 8139 PCI NIC connected to Airport Base Station: use DHCP with DNS as above, Domain:nothing
(it is just used as dummy to get the Airport working).

The mac mini: IP 192.168.0.20, Router: 192.168.0.1, DNS:192.168.0.1, 192.168.0.10, Domain: ISP

The iBook: IP 192.168.0.21, Router: 192.168.0.1, DNS:192.168.0.1, 192.168.0.10, Domain: ISP

I also used Prasys modified USBWireless detection driver for the Ralink USB Adapter.

As you see from the settings, its the USB Wifi that does much of the work.
Things would have been much easier if it was recognised as an Airport card.

It seems MAC OSX does not implement DHCP for non Airport adapters, which means they will work good with Windows (with windows taking up the DHCP side) but they won't work easily with other Airport cards/adapters.

I also activated BIND in Hackintosh, which is a DHCP server, it didn't seem to make any difference.

I hope my settings give you an idea of what is going on...

PS I am writing this from the iBook linked wirelessly to internet via Hackintosh :D

#36
Prasys

Prasys

    Cheese Cheese cheese

  • Retired Developers
  • 338 posts
  • Gender:Male
Yeah I noticed that DHCP bug

It looks like there is a communication break down . I am working on DHCP . Its very buggy. For some revisions such as ASUS , it works and for the rest it does not. I am creating a newer version with a new GUI.

#37
bgrau

bgrau

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 414 posts
  • Gender:Male
Hi
I do not think its a bug, but a way of stopping from using Airport with non Airport adapters...

#38
bgrau

bgrau

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 414 posts
  • Gender:Male
There is also the problem of network adapter assignments in Internet Sharing. It does not adapt to change of shared adapter, the list remains the same...

#39
Prasys

Prasys

    Cheese Cheese cheese

  • Retired Developers
  • 338 posts
  • Gender:Male
I will fix that , I am messing with the kext , I will add few more device IDs and then put it up here back !

#40
bgrau

bgrau

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 414 posts
  • Gender:Male
Hi Prasys
Do u want my RT2500 ID's. here:
Vendor ID: 0x050d
Device ID: 0x7050
For Realtek its the usual one with Dev ID 0x8139, Vend ID 0x10EC (but a PCI), I will be very impressed if you get that one to work :(, I couldnt get it to co-operate even by compiling the code of its kext from the Apple Dev Site...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy