Jump to content

Mac OS X 10.8.2 on a HP Sleekbook 15-b040sl

I can...

  • Please log in to reply
52 replies to this topic

#1
macos4pc

macos4pc

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
I bought a HP Sleekbook 15-b040sl last month and i want to install Mac OS X on it, it's better than Windows 8.
I have this HW:
-CPU=Intel i5 3317U
-Chipset=Intel HM77 Express
-RAM=4GB DDR3
-GPU=Nvidia Geforce GT 630M 2GB, but i have Intel HD 4000
-Resolution= 1366x768
-WiFi=Qualcomm Atheros AR9485 802.11b/g/n WiFi Adapter
-Ethernet=Realtek PCIe FE Family Controller
-Webcam=HP TrueVision HD
I have 2 USB 3.0 and 1 USB 2.0, Can they work in OSx??
Is it good OSX with this HW???
then Is there someone who can help me with Mac OS X 10.8 or 10.7 on this laptop????????
Thanks,
TheCow

#2
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
Hi,

You can start here: http://www.insanelym...-for-beginners/

OSX can run on your system, if it is a laptop, te 630M will not work.

Good luck,

~Lejenk.

#3
macos4pc

macos4pc

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Thanks, i try the guide linked u

#4
macos4pc

macos4pc

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Hi,

You can start here: http://www.insanelym...-for-beginners/

OSX can run on your system, if it is a laptop, te 630M will not work.

Good luck,

~Lejenk.

Thanks Lejenk but the OSX Installer boot only with: -f -v GraphicsEnabler=No npci=0x2000 cpus=1
I made the USB OSX Installer with this guide: http://www.insanelym...-for-beginners/ (the guide linked by you)
In the first time boot stuck when osx load the kexts,it stuck on the AppleHDAConfig.kext and, for booting OS X Installer i delete AppleHDA.kext
The OSX Installer doesnt recognize the integrated trackpad and the integrated Keyboard and the usb 3.0 don't work for usb stick but work perfectly for usb mouse and keyboard.
i will install OSX to a USB Stick and i have only 1 USB port 2.0 and 2 USB port 3.0.
OSX recognize the second USB Stick (a sandisk with 32 Gigabyte of Memory) only with a Lindy Hub USB in the USB 2.0 port.
OSX installation failed 5 times and here there is the log
Is There someone who can help me for finishing installation succesfully?????

Attached Files



#5
pockitlint

pockitlint

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
um sounds like you did a retail install. For the keyboard to work you need the ps2 drivers. theres a usb 3.0 fix you need to do a legacy boot. check out kexts.com (create account) and look for 10.8 kexts for your hardware and or laptop model. right now im trying to do the same on the Envy 4 Beats.

anyway check out those options and post back ill try to help as much as i can.

Edited by Lejenk, 25 February 2013 - 03:50 PM.
We have filters for a reason!


#6
macos4pc

macos4pc

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Ok but why my laptop doesnt finish the installation

#7
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
The essentials.pkg is damaged, or the installer could not read it for some reason.


PKInstallPackageIdentifier=com.apple.pkg.Essentials, NSLocalizedDescription=An error occurred while extracting files from the package “Essentials.pkg”.} {
   NSFilePath = "/Volumes/Macintosh HD/.OSInstallSandbox-tmp/Root";
   NSLocalizedDescription = "An error occurred while extracting files from the package \U201cEssentials.pkg\U201d.";
   NSURL = "Essentials.pkg -- file://localhost/System/Installation/Packages/OSInstall.mpkg";
   NSUnderlyingError = "Error Domain=BOMCopierFatalError Code=1 \"The operation couldn\U2019t be completed. FinishStreamCompressorQueue error\" UserInfo=0x7fc6f7d40750 {destinationPath=/Volumes/Macintosh HD/.OSInstallSandbox-tmp/Root, offset=11099557, type=BOMCopierFatalError, sourcePath=/System/Installation/Packages/Essentials.pkg, NSLocalizedFailureReason=FinishStreamCompressorQueue error}";
   PKInstallPackageIdentifier = "com.apple.pkg.Essentials";
}
Feb 24 09:30:34 localhost OSInstaller[317]: install:didFailWithError:Error Domain=PKInstallErrorDomain Code=110 "An error occurred while extracting files from the package “Essentials.pkg”." UserInfo=0x7fc6f7d3a530 {NSUnderlyingError=0x7fc6f45b7b70 "The operation couldn’t be completed. FinishStreamCompressorQueue error", NSFilePath=/Volumes/Macintosh HD/.OSInstallSandbox-tmp/Root, NSURL=Essentials.pkg -- file://localhost/System/Installation/Packages/OSInstall.mpkg, PKInstallPackageIdentifier=com.apple.pkg.Essentials, NSLocalizedDescription=An error occurred while extracting files from the package “Essentials.pkg”.}
Feb 24 09:30:35 localhost OSInstaller[317]: Install failed: Installer ha incontrato un errore che ha impedito l'installazione. Contatta il produttore del software per ottenere assistenza.

Create a new installer, or replace Essentials.pkg on the installer with the one from the original image. Just copy/paste, can be done from Windows, with transmac or macdrive if needed.

#8
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Also don't worry about certain hardware not working when you boot the installer, you haven't even installed OSX yet :) So for example, USB 3.0 working or not working in installer will have nothing to do with it working/not working in your completed installation. So unless it's something required for you to complete the installation (i.e. SATA working) don't waste any time worrying about it. Instead you will worry about applying any fixes to your new install after it's all done, which is at least a little more fun. Good luck

#9
macos4pc

macos4pc

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Thanks Lejenk!!!!
I replace the essentials.pkg and i finished the installation
i go with the guide.

#10
macos4pc

macos4pc

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Lejenk, i have another problem.
After installation OSX doesn't want to boot
is there someone who can help me???????????

Attached Files



#11
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
Copy NullCPUPowerManagement.kext to the usb installer, in to the Extra/Extensions folder.
Boot with -f -v.

#12
macos4pc

macos4pc

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Thanks Lejenk, i tried your tip and for booting i delete all NVIDIA kexts but i backup they.
After DSMOS arrived the boot freeze.
Is There someone who can help me??????????

Attached Files



#13
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
So, you removed the NVDA* and GeForce* kexts? Boot with -v GraphicsEnabler=No.
Can't think of anything else right now.

#14
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
try: plugging in external monitor and/or using -x bootflag along with GraphicsEnabler=No

#15
macos4pc

macos4pc

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
When i made the screenshots i boot with : -f -v GraphicsEnabler=No npci=0x2000 cpus=1

#16
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
OK, that covers 1 of the 3 suggestions :)

#17
jabirbin

jabirbin

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Gender:Male
  • Location:Norwich,UK
  • Interests:Technology

Thanks Lejenk for booting i delete all NVIDIA kexts but i backup they.
After DSMOS arrived the boot freeze.
Is There someone who can help me??????????


There's no i5 3217 processor.Checked your manual and found your processor is i5 3317U.Check back before you begin.

Try disabling NVIDIA 630m from your BIOS.Search on google.

Try deleting any existing power managment kext.(appleintelpowermanagement.kext and nullcpupowermanagement.kext both) from system/library/extensions and /Extra folder.Now if you are using your USB installer to boot check its Extra folder for these kexts.Extra folder could be hidden.But there must be an extra folder (Check http://code.google.com/p/hide-unhide/ to unhide) .

Use Macdrive to delete them if you are on windows.See if you can boot ML.

If you can you will have to look for a patched powermanagement kext for your system.theres a couple of other Laptops that use same processor so look for one of them.I did a quick google search and found a couple of guide with the i5 processor check them.I am not asking you to follow those tutorials but to use same powermanagement kext as those having the same processors.See if this works.

Edited by jabirbin, 27 February 2013 - 12:15 PM.


#18
macos4pc

macos4pc

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Thanks for the reply, Jabirbin.
Yes, the CPU is a i5 3317U.
In my BIOS the re isn't any option for the NVIDIA Card.
I have nullcpupowermangement.kext on E/E but if i delete it OSX Doesnt boot.
I don't Find any guide about intelcpupowermanagement patched for i5 3117U.
I have a problem because my W8 System with Macdrive pro Doesnt recognize GUID disks, only MBR and i install OSX on a GUID disk.
Can I solve these problems????
thanks to all,
TheCow

#19
macos4pc

macos4pc

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
I try to boot with: -x -v GraphicsEnabler=No npci=0x2000 cpus=1
Always freeze on DSMOS ARRIVE !
I wrote all in the last post.
Is There someone can help me ???????????? Thanks

#20
jabirbin

jabirbin

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Gender:Male
  • Location:Norwich,UK
  • Interests:Technology
Normally there is a option for you to choose between intregated GPU and third party GPU.Maybe not specifically NVIDIA GPU.Maybe you could update your BIOS.But I CAN'T ensure you as I can't see your BIOS.Search on google.

Laptops from different vendors may use same processor as yours.It's not necessarily from HP.I found some laptops from other vendor that uses the same processor.You might want to check them out.(i.e. acer aspire S3).As you have an ivy bridge processor,they have issues with power management.

Macdrive should recognise GPT.Try updating it.Windows 8 also Supports GUID partition table (Gpt) disks.

Try not using cpus=1 bootflag.

This may sound odd.After it sticks at DSMOS Arrived.just leave it as it is for 10-15 mins.See if anything changes.





Also tagged with one or more of these keywords: I can...


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy