Jump to content

HD 7xxx-Can we eliminate the Sleep Trick?

7970 7xxx sleep trick

  • Please log in to reply
186 replies to this topic

#21
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts

AtiConfig= Chutoro in org.chameleon.Boot?


have u tried with graphicsenabler= yes ? you don't need to hardcode the configuration right now till you know everything is working well. put these during chameleon boot where you press any key to select the boot device / partition , it is there you put "GraphicsEnabler=Yes Aticonfig=Chutoro Atiports=5 (if I am correct). You may get the white screen again there you could try the sleep trick.

#22
zumuzza

zumuzza

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
Dont work. with graphicsenabler the bootloader not load. and without don't work the gpu :(

#23
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts

Dont work. with graphicsenabler the bootloader not load. and without don't work the gpu :(


what is the error it is showing ? please use -v for verbose mode so that you can see what error it is displaying or where it is getting stuck.

#24
zumuzza

zumuzza

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
This is in -v http://i.imgur.com/PUCBvwk.jpg

#25
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts

This is in -v http://i.imgur.com/PUCBvwk.jpg


ah it is a problem. This could be the boot loader error too, but I am not too sure. I get this error , what I have done is use the VGA Bios of the card which you could dump using GPUZ in windows and put it in /Extra/ 1002_683f.rom (not sure if it can be done in OSX) and then on the boot flag GraphicsEnabler=Yes UseAtiRom=Yes AtiConfig=Chutoro (There are different configs I think, you can google them) and AtiPorts=5.

The other thing you could try is by checking out rampagedevs blog where he has shown a method to enable the 7xxx series QE/CI.

http://rampagedev.wo...g-with-full-qe/

As I have mentioned in the PM that I don't get QE/CI but can only use the full resolution and a proper option to select different resolutions using the 7750 as an extended card. I awaiting the final release of ML 10.8.3 which should contain the Framebuffer.

#26
P1X3

P1X3

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

This is in -v http://i.imgur.com/PUCBvwk.jpg


Install latest bootloader

#27
zumuzza

zumuzza

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
what bootloader?

#28
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

Chameleon 2.1svn Official PKG Installer & Binaries


#29
zumuzza

zumuzza

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
I use chameleon enoch 2.2

#30
zumuzza

zumuzza

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
I have update at last chameleon and set graphics enabler and detected My GPU but the system block, look my verbose. http://i.imgur.com/1gwVTrP.jpg

#31
sea_man

sea_man

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:Bogota D.C - Colombia
Lol.. in the first post say :

However this is not a support thread.


The last page don't have nothing about to eliminate the sleep trick in the 7*** HD GPU.

I think this threat is more appropriate for support :

http://www.insanelym...g-with-full-qe/


Ontopic:

I'm testing .. and we don't have a real cold bot bug like the 6xxx and gpu... this look like a bad efi initialization , maybe we need mod a gpu bios and flash it.. like the 6870 flashed to show the boot screen in the reals mac pro ... something like this ?

#32
k3nny

k3nny

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 560 posts
  • Gender:Male
I tried a BIOS with GOP support from another subvendor some days ago but this didn't help either.
What's the difference to the 6000 series?

#33
sea_man

sea_man

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:Bogota D.C - Colombia
In the 69xx series .. if you boot first IE: windows.. and latter reboot ( not shutdown) to OsX .. it load without have to make the sleep trick.
In the 7xxx series.. no matter if you have a cold or hot boot ( restart from windows) .. always you need to do the sleep trick.

#34
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
I think a BIOS mod is possible option, maybe once these cards are in real macs to have some comparison to their EFI

#35
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
Hey guys I have the sleep with the button working. I am using the DSDTSE / Power Button hack and I have moved the NullCPUpower kext from /Extra/Extensions and I am using the HD 7750 in ML 10.8.0 with the ATI7000 kext from osx86.net and my card is showing up correctly, though I don't Framebuffer but I am pulling proper resolution and options for different resolutions.

This is an AMD 960T CPU. I am just going to try to check what I can do for the frame buffer. As I need to put XBMC and create a home theater so without FB I cannot play videos.

#36
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

In the 69xx series .. if you boot first IE: windows.. and latter reboot ( not shutdown) to OsX .. it load without have to make the sleep trick.
In the 7xxx series.. no matter if you have a cold or hot boot ( restart from windows) .. always you need to do the sleep trick.

The Radeon Bios Editor from TechPowerUp appears to be dead project with no 7000 support coming either :( Super bummer.

Hey guys I have the sleep with the button working. I am using the DSDTSE / Power Button hack and I have moved the NullCPUpower kext from /Extra/Extensions and I am using the HD 7750 in ML 10.8.0 with the ATI7000 kext from osx86.net and my card is showing up correctly, though I don't Framebuffer but I am pulling proper resolution and options for different resolutions.

This is an AMD 960T CPU. I am just going to try to check what I can do for the frame buffer. As I need to put XBMC and create a home theater so without FB I cannot play videos.

Well, try different framebuffers named after sushi, if none work, modify connector tables on a framebuffer named after sushi :) but running it on anything other than 10.8.3 could cause any number of other issues so I wouldn't put too much effort into it until then

#37
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts

The Radeon Bios Editor from TechPowerUp appears to be dead project with no 7000 support coming either :( Super bummer.

Well, try different framebuffers named after sushi, if none work, modify connector tables on a framebuffer named after sushi :) but running it on anything other than 10.8.3 could cause any number of other issues so I wouldn't put too much effort into it until then


Problem is I cannot use GE=Yes system halts at Number of ports. Using the latest boot loader though.

I would not know how to modify connectors. Both my My LED's are working in Dual mode, VGA and DVI. I can play some .mp4 video files in Quicktime but in VLC is a nono.

#38
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Please see first post...No support, 100% bad ass only :) your welcome to start a new topic if needed. All I'll say here is, you don't need GE=Yes to specify a framebuffer, can be done via DSDT with GE=No, which is how I have it and I believe most others as well. If you need help on the DSDT edits, see Rampage_Dev's guide on his blog (just google "Rampage Dev")

#39
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts

Please see first post...No support, 100% bad ass only :) your welcome to start a new topic if needed. All I'll say here is, you don't need GE=Yes to specify a framebuffer, can be done via DSDT with GE=No, which is how I have it and I believe most others as well. If you need help on the DSDT edits, see Rampage_Dev's guide on his blog (just google "Rampage Dev")


Hmmm I never asked for support in this thread correct me If I did.

I have already posted @Rampagedev. But before that I will try the DSDT on my own.

#40
sea_man

sea_man

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:Bogota D.C - Colombia

Hmmm I never asked for support in this thread correct me If I did.

I have already posted @Rampagedev. But before that I will try the DSDT on my own.


OK.. on topic... are you talking something about to eliminate the sleep trick ?


If you don't have nothing to say about this here, please open a post whit your question or use the 7970 post , there are many people who can help you ( include my self ), but again this threat is not the place , here we are ONLY talking about to eliminate the sleep trick , nothing more.

Thanks !





Also tagged with one or more of these keywords: 7970, 7xxx, sleep trick


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy