Jump to content

iMessage/Messages Fix-How To

iMessage Messages Fix

  • Please log in to reply
102 replies to this topic

#21
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Keep in mind, this is just the bare basics for the Messages fix part and can't possibly cover every different type of system you all may have, there's a full 2 pages of detailed instructions and different hardware config options here Clover v.2 Instructions

#22
dannymichel

dannymichel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Gender:Male
Thanks eep357! iMessage works!

Edited by eep357, 10 January 2013 - 05:10 PM.
Hi5!


#23
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

I've try to change serial but none edits works....
It's randomly generated a serial by Clover.
What I have to do?

I've the "Call Support" error. I tried to change the password, but none of these methods work.

You didn't have a randomly generated serial # when using Chameleon, you had one in your smbios and it's the same one you should be using now. That information should have been copied (by you) into the Clover config.plist, along with renaming of the <key>'s to match the Clover format.

#24
dannymichel

dannymichel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Gender:Male
Hmm, that's weird - this used to simply say Mac Pro, but says Mac Pro,3.1 now

[edit] just realized my phone number was in that screenshot

Dear Daniel,
Your Apple ID (danielxxxxxxx@gmail.com) was used to sign in to iMessage on a Mac Pro named “MacPro3,1”.

#25
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
No host/computer name set in Preferences>Sharing, so default's to that. Changing stuffs will cause it to be erased for that location. Just retype it and hit enter. And I added quite a few missing keys to your SMBIOS section that could also play a part...In a good way I would hope :)

#26
dannymichel

dannymichel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Gender:Male
Thanks again eep357.
I'm assuming you saw that before i deleted it. Just don't call after 10pm.

#27
fffeee

fffeee

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
eep357 (or any other Clover user),

While I'm planning my Sunday bootloader project, in your experience is it necessary to de-authorize a computer in iTunes before switching over? Will any of the iCloud/iTunes authorizations need to be re-done if I keep the same values I'm using in Chameleon (more or less, I realize the iMessage fix requires an added value) or have you seen this be a sufficient change to require another authorization with Apple?

My shuffling with onboard versus PCI ethernet cards last summer left me in a funky state where I have 4 computers and 5 used authorizations and I need to wait a bit still before I can reset them all!

#28
metzz71

metzz71

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
I am unsuccessful with installing clover. I executed the command line and it fails. Can someone post the package to make this a bit simpler? My script error is "line 249: base tools: unbound variable"

#29
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

eep357 (or any other Clover user),

While I'm planning my Sunday bootloader project, in your experience is it necessary to de-authorize a computer in iTunes before switching over? Will any of the iCloud/iTunes authorizations need to be re-done if I keep the same values I'm using in Chameleon (more or less, I realize the iMessage fix requires an added value) or have you seen this be a sufficient change to require another authorization with Apple?

My shuffling with onboard versus PCI ethernet cards last summer left me in a funky state where I have 4 computers and 5 used authorizations and I need to wait a bit still before I can reset them all!

iTunes will ask you to re-authorize, and then will say "this computers already been authorized" like it always does as long as your not making major changes. Keep same SMBIOS values and serial, it will be fine.

#30
mendietinha

mendietinha

    mendi

  • Members
  • PipPipPipPipPipPipPip
  • 835 posts
  • Gender:Male
  • Interests:full hackintosh.

after the 7 appears, just wait like 2-3 mins, trust me. It's just having a little trouble reading something on there, but will come up eventually.


i waited for about 25 min and nothing happens. i can try install in my hdd but, need a fix for the boot1 error.

#31
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

i waited for about 25 min and nothing happens. i can try install in my hdd but, need a fix for the boot1 error.

see here http://www.projectos...opic=2304&st=80 for Slice's answer to your question, but not asked by you :)

I am unsuccessful with installing clover. I executed the command line and it fails. Can someone post the package to make this a bit simpler? My script error is "line 249: base tools: unbound variable"

Once a pkg is made, people will download it, and since this is new fix/first revision, they won't get needed updates or improvements if/when released. It really is better to build it, and you'll want the ability so you can update in the future as well. Check line 249 using a text editor (preferably Text Wrangler or similar that has lines numbered). Should have
echob "  Make EDK II Revision $basetools BaseTools"
with the "" being present, fix it if needed. If already correct, try reinstalling xcode command line tools and verify all your file permissions are correct (home's download folder too which is not checked by Disk Utility), unless dmazar has other suggestions

I'm no Clover guru and Google knows more than I do :)

#32
mendietinha

mendietinha

    mendi

  • Members
  • PipPipPipPipPipPipPip
  • 835 posts
  • Gender:Male
  • Interests:full hackintosh.
thanks, but what i know about boot1 is copy boot1h from the bootloader to a usb, enter the instalation, unmount the osx partition and in the terminal, copy the boot1h to the osx partition from the usb. i did it and remains the boot1 error. i have installed in a mbr scheme.

thanks.

#33
Kynyo

Kynyo

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 245 posts
  • Gender:Male
  • Location:Not your bisnizz...
  • Interests:
Clovers "core" center seems to be manipulation of "config.plist".
I've done to config. for basic use.

#34
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

thanks, but what i know about boot1 is copy boot1h from the bootloader to a usb, enter the instalation, unmount the osx partition and in the terminal, copy the boot1h to the osx partition from the usb. i did it and remains the boot1 error. i have installed in a mbr scheme.

thanks.

Make sure using all (assuming 64bit) files only

Clovers "core" center seems to be manipulation of "config.plist".
I've done to config. for basic use.

exactly, it's boot.plist, smbios.plist and just about any other plist you can think of, all rolled up in one big config :)

#35
neutrl

neutrl

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Works great for getting iMessage working.

Now I just need to figure out how to get my ALC892 working again. :hammer:

#36
dannymichel

dannymichel

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 298 posts
  • Gender:Male

Works great for getting iMessage working.

Now I just need to figure out how to get my ALC892 working again. :hammer:

i am so nowhere near an expert, but wouldnt putting your old DSDT.aml in / fix that?

#37
neutrl

neutrl

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

i am so nowhere near an expert, but wouldnt putting your old DSDT.aml in / fix that?


I'm not an expert either, but I don't believe I was using a DSDT

All I had to do was load the kext previously with chameleon

#38
3square

3square

    InsanelyMac Protégé

  • Members
  • PipPip
  • 76 posts
FYI you can instal it and boot it via USB login to iMessage then revert back to chameleon. Incase you don't want to run Clover and keep Chameleon.

#39
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
or install the kext you were using from /Extra to /System/Library/Extensions, or copy to Clover's kext folder for 10.8, or..other stuff too, probably :)

#40
neutrl

neutrl

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

or install the kext you were using from /Extra to /System/Library/Extensions, or copy to Clover's kext folder for 10.8, or..other stuff too, probably :)


Tried both, it actually loads the kext successfully but no audio device :wallbash:


It's very possible that I just have no idea what I'm doing :o

FYI you can instal it and boot it via USB login to iMessage then revert back to chameleon. Incase you don't want to run Clover and keep Chameleon.


This is what I'm currently doing, but I prefer to get it working so I can install it to the startup disk and use Clover instead of Chameleon.





Also tagged with one or more of these keywords: iMessage, Messages, Fix


2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy