Jump to content

Clover General discussion

Bootloader EFI Clover

  • Please log in to reply
5054 replies to this topic

#241
dmazar

dmazar

    InsanelyMac Sage

  • Coders
  • 256 posts
  • Gender:Male

I don't think I've seen any reports of anyone using Clover on a RAID setup.

I think I saw one report somewhere, maybe AppleLife.ru about RAID and Clover working. This is all about booting from Boot helper partition, right? If Clover can see that partition, then there should be no problems: Clover installed to that Boot helper partition or to EFI partition should work. Clover is just starting OSX's original boot loader (boot.efi) anyway, and this one should handle all OSX cases.

My guess.

#242
Taruga

Taruga

    Retired

  • Retired Developers
  • 527 posts
  • Gender:Male
  • Location:Portugal
I seem to have a problem with kext cache or something else....

Posted Image

#243
airlync

airlync

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
Clover start ML with UEFI mode is veryyyyyy slow on my Thinkpad W520, then, mouse and keyboard no work;
But when i boot with BIOS mode, it is work fine, except screen resolution is lower than UEFI mode.

#244
polkaholga

polkaholga

    InsanelyMac Geek

  • Donators
  • 148 posts
  • Gender:Male
  • Location:Otherland
@ Slice

what is the use for PartitionDxe and VboxExt ?
Just curious and may have overseen some explanation...

thank you

#245
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,848 posts
  • Gender:Male
  • Location:Moscow

@ Slice

what is the use for PartitionDxe and VboxExt ?
Just curious and may have overseen some explanation...

thank you

MY PartitionDxe differs from UEFI one by support of Apple Partitoning of DVD and hybrid MBR/GPT if you need it.
VBoxExt2 supports EXT2/3 file system of Linux if you want to start Linux EFI.

#246
dmazar

dmazar

    InsanelyMac Sage

  • Coders
  • 256 posts
  • Gender:Male

Clover start ML with UEFI mode is veryyyyyy slow on my Thinkpad W520, then, mouse and keyboard no work;
But when i boot with BIOS mode, it is work fine, except screen resolution is lower than UEFI mode.

This looks like the problem that miaumiau and TimeWalker had on their laptops with Phoenix UEFI. You can find more about this here.

I seem to have a problem with kext cache or something else....

Looks like not working after all. Does Clover detects your Boot helper partition? Can you make preboot.log by pressing F2 in Clover GUI. Should be stored on writable FAT32 USB stick partition or EFI partition.

#247
Taruga

Taruga

    Retired

  • Retired Developers
  • 527 posts
  • Gender:Male
  • Location:Portugal
Hi dmazar,

I have several disks, and I can boot from non raid volumes.

When I boot Clover I can see the Boot helper partition, but I can't boot from it.

This is my preboot.log:

Log from Clover size=86:
MsgLog Protocol installed in PartitionDxe
MsgLog Protocol installed in AcpiPlatform

Starting rEFIt rev 800 on CLOVER EFI
SelfDevicePath=PcieRoot(0x0)/Pci(0x1D,0x0)/USB(0x0,0x0)/USB(0x5,0x0)/HD(1,MBR,0x00000000,0x2,0x7A601E) @1F4B3718
banner logo.png
Found best mode 3: 1280x1024
Available graphics modes for refit.conf screen_resolution:
Curr. Mode = 3, MaxMode = 4, FB = E9000000, FB size=0xE00000
- Mode 0: 640x480 PixFmt = 8bit BGR, PixPerScanLine = 640
- Mode 1: 800x600 PixFmt = 8bit BGR, PixPerScanLine = 800
- Mode 2: 1024x768 PixFmt = 8bit BGR, PixPerScanLine = 1024
- Mode 3: 1280x1024 PixFmt = 8bit BGR, PixPerScanLine = 1280
Theme: black_green Path: EFI\BOOT\themes\black_green
Total Memory Slots Count = 4
Type 17 Index = 0
SmbiosTable.Type17->Speed = 1333
SmbiosTable.Type17->Size = 4096
mTotalSystemMemory = 4096
Type 17 Index = 1
SmbiosTable.Type17->Speed = 1333
SmbiosTable.Type17->Size = 4096
mTotalSystemMemory = 8192
Type 17 Index = 2
SmbiosTable.Type17->Speed = 1333
SmbiosTable.Type17->Size = 4096
mTotalSystemMemory = 12288
Type 17 Index = 3
SmbiosTable.Type17->Speed = 1333
SmbiosTable.Type17->Size = 4096
mTotalSystemMemory = 16384
Boot status=0
Clover revision: 800 running on To be filled by O.E.M.
... with board Z77X-UD5H
[0:000 - 0:000] LoadDrivers() start
Starting FSInject-64.efi
Using load options 'FSInject-64.efi '
Starting Ps2MouseDxe-64.efi
Using load options 'Ps2MouseDxe-64.efi '
Starting UsbMouseDxe-64.efi
Using load options 'UsbMouseDxe-64.efi '
Starting VBoxExt2-64.efi
Using load options 'VBoxExt2-64.efi '
Starting XhciDxe-64.efi
Using load options 'XhciDxe-64.efi '
[0:405 - 0:405] LoadDrivers() end
reinit: self device path=PcieRoot(0x0)/Pci(0x1D,0x0)/USB(0x0,0x0)/USB(0x5,0x0)/HD(1,MBR,0x00000000,0x2,0x7A601E)
new SelfHandle=1F4B3718
BrandString = Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz
non-usable FLEX_RATIO = F0000
corrected FLEX_RATIO = E0000
FSBFrequency=105MHz
Corrected FSBFrequency=100MHz
qpimult 2
qpibusspeed 400000kHz
Vendor/Model/Stepping: 0x756E6547/0x3A/0x9
Family/ExtFamily: 0x6/0x0
MaxDiv/MinDiv: 35.0/16
Turbo: 37/38/39/39
Features: 0xBFEBFBFF
Threads: 8
Cores: 4
FSB: 100 MHz
CPU: 3700 MHz
TSC: 3700 MHz
PIS: 400 MHz
PCI (00|00:00.00) : 8086 0150 class=060000
PCI (00|00:01.00) : 8086 0151 class=060400
PCI (00|01:00.00) : 10DE 1200 class=030000
Found NVidia model=Gigabyte GeForce GTX 560 Ti
PCI (00|01:00.01) : 10DE 0E0C class=040300
PCI (00|00:02.00) : 8086 0162 class=038000
PCI (00|00:14.00) : 8086 1E31 class=0C0330
PCI (00|00:16.00) : 8086 1E3A class=078000
PCI (00|00:1A.00) : 8086 1E2D class=0C0320
PCI (00|00:1B.00) : 8086 1E20 class=040300
PCI (00|00:1C.00) : 8086 1E10 class=060400
PCI (00|00:1C.01) : 8086 1E12 class=060400
PCI (00|03:00.00) : 1B4B 9172 class=010601
PCI (00|00:1C.03) : 8086 1E16 class=060400
PCI (00|04:00.00) : 104C 823E class=060400
PCI (00|05:00.00) : 104C 823F class=0C0010
PCI (00|00:1C.04) : 8086 1E18 class=060400
PCI (00|06:00.00) : 14E4 432B class=028000
Found AirPort. Landing enabled...
PCI (00|00:1C.05) : 8086 244E class=060401
PCI (00|07:00.00) : 8086 244E class=060401
PCI (00|08:01.00) : 1106 3044 class=0C0010
PCI (00|00:1C.06) : 8086 1E1C class=060400
PCI (00|09:00.00) : 1969 1083 class=020000
PCI (00|00:1C.07) : 8086 1E1E class=060400
PCI (00|0A:00.00) : 1B4B 9172 class=010601
PCI (00|00:1D.00) : 8086 1E26 class=0C0320
PCI (00|00:1F.00) : 8086 1E44 class=060100
PCI (00|00:1F.02) : 8086 1E02 class=010601
PCI (00|00:1F.03) : 8086 1E22 class=0C0500
SMBus CmdReg: 0x3
Scanning SMBus [8086:1E22], mmio: 0xF6F15004, ioport: 0xF040, hostc: 0x1
SPD[0] (size): 0x92 @0x50
DDR speed 1333MHz
Slot: 0 Type 24 4096MB (DDR3 SDRAM) 1333MHz Vendor=Corsair
PartNo=CMZ16GX3M4X1600C9 SerialNo=00000000
SPD[0] (size): 0x92 @0x51
DDR speed 1333MHz
Slot: 1 Type 24 4096MB (DDR3 SDRAM) 1333MHz Vendor=Corsair
PartNo=CMZ16GX3M4X1600C9 SerialNo=00000000
SPD[0] (size): 0x92 @0x52
DDR speed 1333MHz
Slot: 2 Type 24 4096MB (DDR3 SDRAM) 1333MHz Vendor=Corsair
PartNo=CMZ16GX3M4X1600C9 SerialNo=00000000
SPD[0] (size): 0x92 @0x53
DDR speed 1333MHz
Slot: 3 Type 24 4096MB (DDR3 SDRAM) 1333MHz Vendor=Corsair
PartNo=CMZ16GX3M4X1600C9 SerialNo=00000000
Calibrated TSC frequency =3503496960 =3503MHz
CPU calculated TSC frequency =3700000000
Using OEM config.plist at path: EFI\config.plist
Finally: Bus=100MHz CPU=3500MHz
File=font\WoB_PTMono_10W_NA.png loaded with status=Success length=3049
extension = png
compression method 8 and CINFO=7 FDICT=0
found 25 volumes with blockIO
* PcieRoot(0x0)/Pci(0x1D,0x0)/USB(0x0,0x0)/USB(0x5,0x0)
USB volume
USB volume
this is SelfVolume at index 1
* PcieRoot(0x0)/Pci(0x1D,0x0)/USB(0x0,0x0)/USB(0x5,0x0)/HD(1,MBR,0x00000000,0x2,0x7A601E)
USB volume
USB volume
* PcieRoot(0x0)/Pci(0x1D,0x0)/USB(0x0,0x0)/USB(0x3,0x0)/USB(0x0,0x0)/USB(0x0,0x0)
USB volume
USB volume
USB volume
USB volume
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x0,0x0,0x0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x1,0x0,0x0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x2,0x0,0x0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x3,0x0,0x0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x4,0x0,0x0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x5,0x0,0x0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x0,0x0,0x0)/HD(1,GPT,1399EABD-3B8F-4116-A22D-7B7FC3BD171A,0x28,0x64000)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x0,0x0,0x0)/HD(2,GPT,528BCB5E-39A6-4789-9114-2AAE2F50B810,0x64028,0x1BE80460)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x0,0x0,0x0)/HD(3,GPT,C5D78866-DD70-4F70-83E9-12FB06E9896C,0x1BEE4488,0x40000)
Booting OS 10.8.2
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x1,0x0,0x0)/HD(1,GPT,7831BD74-24D7-44B1-BFB8-7233E0EBEDF0,0x28,0x64000)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x1,0x0,0x0)/HD(2,GPT,275A3C0A-2C01-4F7D-A31E-589612CD10DD,0x64028,0x74662D60)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x2,0x0,0x0)/HD(1,GPT,33815E30-02B7-4461-BFE5-6A3FF45FCA8F,0x28,0x64000)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x2,0x0,0x0)/HD(2,GPT,4C36FA93-024F-4C27-AE2A-ACE92B903554,0x64028,0x3A2E1FE0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x3,0x0,0x0)/HD(1,GPT,C7479120-EF6F-4FB0-80B1-40FBFB7462E5,0x28,0x64000)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x3,0x0,0x0)/HD(2,GPT,58650676-71D4-4C5A-A6A2-09006448A1CA,0x64028,0x1D170FF0)
Booting OS 10.8.2
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x3,0x0,0x0)/HD(3,GPT,927F2BEB-5966-40AC-B1D5-C5FD3E673EAC,0x1D215018,0x1A4CF600)
Booting OS 10.7.5
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x3,0x0,0x0)/HD(4,GPT,85E4EDEC-44AC-453F-977D-8577BB0587B0,0x37724618,0x2C219F0)
Booting OS 10.8
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x4,0x0,0x0)/HD(1,GPT,2F69768E-8F45-4029-AD86-872FDA580F01,0x28,0x64000)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x4,0x0,0x0)/HD(2,GPT,52CB117E-C745-482B-98EC-8C526784423D,0x64028,0x3A2E1FE0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x5,0x0,0x0)/HD(1,GPT,9E7319EC-7716-4551-A18F-EDC1328D01A2,0x28,0x64000)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x5,0x0,0x0)/HD(2,GPT,4DF03E8D-C58F-46BC-B45D-D6FF6E24013B,0x64028,0x1BE80460)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x5,0x0,0x0)/HD(3,GPT,C3B89DCF-AAEC-4209-8B30-DB828E9A30DD,0x1BEE4488,0x40000)
Booting OS 10.8.2
Searching volumes for latest nvram.plist ...
1. Volume '', GUID = <null guid> - not GPT - no nvram.plist - skipping!
9. Volume 'EFI', GUID = 1399EABD-3B8F-4116-A22D-7B7FC3BD171A - no nvram.plist - skipping!
11. Volume 'Boot OS X', GUID = C5D78866-DD70-4F70-83E9-12FB06E9896C Modified = 2012-10-26 22:57:3 (3628882623000 ms) - newer - will use this one
12. Volume '', GUID = 7831BD74-24D7-44B1-BFB8-7233E0EBEDF0 - no nvram.plist - skipping!
13. Volume 'MISC', GUID = 275A3C0A-2C01-4F7D-A31E-589612CD10DD - no nvram.plist - skipping!
14. Volume '', GUID = 33815E30-02B7-4461-BFE5-6A3FF45FCA8F - no nvram.plist - skipping!
15. Volume 'TVSeries', GUID = 4C36FA93-024F-4C27-AE2A-ACE92B903554 - no nvram.plist - skipping!
16. Volume 'EFI', GUID = C7479120-EF6F-4FB0-80B1-40FBFB7462E5 - no nvram.plist - skipping!
17. Volume 'MLion', GUID = 58650676-71D4-4C5A-A6A2-09006448A1CA Modified = 2012-10-28 15:44:16 (3629029456000 ms) - newer - will use this one
18. Volume 'Lion', GUID = 927F2BEB-5966-40AC-B1D5-C5FD3E673EAC - no nvram.plist - skipping!
19. Volume 'Mac OS X Base System', GUID = 85E4EDEC-44AC-453F-977D-8577BB0587B0 - no nvram.plist - skipping!
20. Volume '', GUID = 2F69768E-8F45-4029-AD86-872FDA580F01 - no nvram.plist - skipping!
21. Volume 'TM', GUID = 52CB117E-C745-482B-98EC-8C526784423D - no nvram.plist - skipping!
22. Volume 'EFI', GUID = 9E7319EC-7716-4551-A18F-EDC1328D01A2 - no nvram.plist - skipping!
24. Volume 'Boot OS X', GUID = C3B89DCF-AAEC-4209-8B30-DB828E9A30DD Modified = 2012-10-26 22:57:3 (3628882623000 ms) - older - skipping!
Loading nvram.plist from Vol 'MLion' - loaded, size=320
PutNvramPlistToRtVars ...
Adding Key: fmm-computer-name: Data: Size = 16: Success
Adding Key: LocationServicesEnabled: Data: Size = 1: Success
get anime for os=23
Icon 14 not found at
get anime for os=38
get anime for os=23
get anime for os=23
get anime for os=23
get anime for os=38
get anime for os=23
get anime for os=37
get anime for os=38
get anime for os=38
get anime for os=23
hide volume 0
hide volume 3
hide volume 6
hide volume 8
added legacy entry 10 OSType=3 Name=Legacy HD2 Icon=legacy
added legacy entry 23 OSType=0 Name=Legacy HD2 Icon=<null string>
[1:513 - 1:108] ScanLegacy()
FindBootOptionForFile: 1F404098, \EFI\BOOT\CLOVERX64.EFI
BootOrder: 8: Boot0000, Boot0001, Boot0002, Boot0003, Boot0004, Boot0005, Boot0006, Boot0007
Searching for: PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x3,0x0,0x0)/HD(1,GPT,C7479120-EF6F-4FB0-80B1-40FBFB7462E5,0x28,0x64000)/\EFI\BOOT\CLOVERX64.EFI (Len: 126)
and for: HD(1,GPT,C7479120-EF6F-4FB0-80B1-40FBFB7462E5,0x28,0x64000)/\EFI\BOOT\CLOVERX64.EFI (Len: 98)
FindBootOptionForFile: Not found.
compression method 8 and CINFO=7 FDICT=0
found tools\Shell64.efi
[1:540 - 0:026] ScanTool()
compression method 8 and CINFO=7 FDICT=0
compression method 8 and CINFO=7 FDICT=0
compression method 8 and CINFO=7 FDICT=0
compression method 8 and CINFO=7 FDICT=0
[1:543 - 0:003] FinishTextScreen()
FindDefaultEntry ...
FindStartupDiskVolume ...
GetEfiBootDeviceFromNvram: efi-boot-device-data not found
not found
Default boot entry not found
[1:543 - 0:000] FindDefaultEntry()
File=logo.png loaded with status=Success length=11008
extension = png
compression method 8 and CINFO=7 FDICT=0
File=Selection_small.png loaded with status=Success length=1594
extension = png
compression method 8 and CINFO=7 FDICT=0
File=Selection_big.png loaded with status=Success length=2276
extension = png
compression method 8 and CINFO=7 FDICT=0
Found Mouse device:
- ResolutionX=65536
- ResolutionY=65536
- ResolutionZ=65536
- Left button present
- Right button present
compression method 8 and CINFO=7 FDICT=0
compression method 8 and CINFO=7 FDICT=0
Found BIOS RSDP at F0490
Saving ACPI tables from RSDP F0490 to EFI\ACPI\origin ...
F0490: 'RSD PTR ', Rev: 2 (Acpi 2.0 or newer), Len: 36 -> RSDP.aml
(Xsdt: C82D6078, Rsdt: C82D6028)
C82D6078: 'XSDT', 'A M I', Rev: 1, Len: 108 -> XSDT.aml
C82D6028: 'RSDT', 'A M I', Rev: 1, Len: 72 -> RSDT.aml
Tables in Xsdt: 9
0. C82E16C0: 'FACP', 'A M I', Rev: 4, Len: 244 -> FACP.aml
	 (Dsdt: C82D6178, Facs: C82F1F80, XDsdt: C82D6178, XFacs: 0)
	 C82D6178: 'DSDT', 'A M I', Rev: 2, Len: 46406 -> DSDT.aml
	 C82F1F80: 'FACS', Ver: 2, Len: 64 -> FACS.aml
1. C82E17B8: 'APIC', 'A M I', Rev: 3, Len: 146 -> APIC.aml
2. C82E1850: 'MCFG', 'A M I', Rev: 1, Len: 60 -> MCFG.aml
3. C82E1890: 'SSDT', 'AoacTabl', Rev: 1, Len: 1167 -> SSDT.aml
4. C82E1D20: 'HPET', 'A M I', Rev: 1, Len: 56 -> HPET.aml
5. C82E1D58: 'SSDT', 'SataTabl', Rev: 1, Len: 877 -> SSDT-0.aml
6. C82E20C8: 'SSDT', 'Cpu0Ist', Rev: 1, Len: 2474 -> SSDT-1.aml
7. C82E2A78: 'SSDT', 'CpuPm', Rev: 1, Len: 2706 -> SSDT-2.aml
8. C82E3510: 'MATS', 'A M I', Rev: 2, Len: 52 -> MATS.aml
Tables in Rsdt: 9
0. C82E16C0: 'FACP', 'A M I', Rev: 4, Len: 244
	 (Dsdt: C82D6178, Facs: C82F1F80, XDsdt: C82D6178, XFacs: 0)
	 C82D6178: 'DSDT', 'A M I', Rev: 2, Len: 46406
	 C82F1F80: 'FACS', Ver: 2, Len: 64
1. C82E17B8: 'APIC', 'A M I', Rev: 3, Len: 146
2. C82E1850: 'MCFG', 'A M I', Rev: 1, Len: 60
3. C82E1890: 'SSDT', 'AoacTabl', Rev: 1, Len: 1167
4. C82E1D20: 'HPET', 'A M I', Rev: 1, Len: 56
5. C82E1D58: 'SSDT', 'SataTabl', Rev: 1, Len: 877
6. C82E20C8: 'SSDT', 'Cpu0Ist', Rev: 1, Len: 2474
7. C82E2A78: 'SSDT', 'CpuPm', Rev: 1, Len: 2706
8. C82E3510: 'MATS', 'A M I', Rev: 2, Len: 52
Found UEFI Acpi 2.0 RSDP at 1FF6A014
Printing ACPI tables from RSDP 1FF6A014 ...
1FF6A014: 'RSD PTR ', Rev: 2 (Acpi 2.0 or newer), Len: 36
(Xsdt: 1FF6A120, Rsdt: 1FF6A0AC)
1FF6A120: 'XSDT', 'A M I', Rev: 1, Len: 172
1FF6A0AC: 'RSDT', 'A M I', Rev: 1, Len: 72
Tables in Xsdt: 17
0. 1FF69000: 'FACP', 'A M I', Rev: 4, Len: 244
	 (Dsdt: 1FF55000, Facs: 1FEE8000, XDsdt: 1FF55000, XFacs: 1FEE8000)
	 1FF55000: 'DSDT', 'A M I', Rev: 2, Len: 46406
	 1FEE8000: 'FACS', Ver: 2, Len: 64
1. 1FF68000: 'APIC', 'A M I', Rev: 3, Len: 146
2. 1FF67000: 'MCFG', 'A M I', Rev: 1, Len: 60
3. 1FF66000: 'SSDT', 'AoacTabl', Rev: 1, Len: 1167
4. 1FF65000: 'HPET', 'A M I', Rev: 1, Len: 56
5. 1FF64000: 'SSDT', 'SataTabl', Rev: 1, Len: 877
6. 1FF63000: 'SSDT', 'Cpu0Ist', Rev: 1, Len: 2474
7. 1FF62000: 'SSDT', 'CpuPm', Rev: 1, Len: 2706
8. 1FF61000: 'MATS', 'A M I', Rev: 2, Len: 52
9. = 0
10. = 0
11. = 0
12. = 0
13. = 0
14. = 0
15. = 0
16. = 0
Tables in Rsdt: 9
0. 1FF69000: 'FACP', 'A M I', Rev: 4, Len: 244
	 (Dsdt: 1FF55000, Facs: 1FEE8000, XDsdt: 1FF55000, XFacs: 1FEE8000)
	 1FF55000: 'DSDT', 'A M I', Rev: 2, Len: 46406
	 1FEE8000: 'FACS', Ver: 2, Len: 64
1. 1FF68000: 'APIC', 'A M I', Rev: 3, Len: 146
2. 1FF67000: 'MCFG', 'A M I', Rev: 1, Len: 60
3. 1FF66000: 'SSDT', 'AoacTabl', Rev: 1, Len: 1167
4. 1FF65000: 'HPET', 'A M I', Rev: 1, Len: 56
5. 1FF64000: 'SSDT', 'SataTabl', Rev: 1, Len: 877
6. 1FF63000: 'SSDT', 'Cpu0Ist', Rev: 1, Len: 2474
7. 1FF62000: 'SSDT', 'CpuPm', Rev: 1, Len: 2706
8. 1FF61000: 'MATS', 'A M I', Rev: 2, Len: 52
Found UEFI Acpi 1.0 RSDP at 1FF6A000
Printing ACPI tables from RSDP 1FF6A000 ...
1FF6A000: 'RSD PTR ', Rev: 0 (Acpi 1.0), Len: 20
(Rsdt: 1FF6A038)
1FF6A038: 'RSDT', 'A M I', Rev: 1, Len: 72
Tables in Rsdt: 9
0. 1FF69000: 'FACP', 'A M I', Rev: 4, Len: 244
	 (Dsdt: 1FF55000, Facs: 1FEE8000, XDsdt: 1FF55000, XFacs: 1FEE8000)
	 1FF55000: 'DSDT', 'A M I', Rev: 2, Len: 46406
	 1FEE8000: 'FACS', Ver: 2, Len: 64
1. 1FF68000: 'APIC', 'A M I', Rev: 3, Len: 146
2. 1FF67000: 'MCFG', 'A M I', Rev: 1, Len: 60
3. 1FF66000: 'SSDT', 'AoacTabl', Rev: 1, Len: 1167
4. 1FF65000: 'HPET', 'A M I', Rev: 1, Len: 56
5. 1FF64000: 'SSDT', 'SataTabl', Rev: 1, Len: 877
6. 1FF63000: 'SSDT', 'Cpu0Ist', Rev: 1, Len: 2474
7. 1FF62000: 'SSDT', 'CpuPm', Rev: 1, Len: 2706
8. 1FF61000: 'MATS', 'A M I', Rev: 2, Len: 52
DSDT saved to EFI\ACPI\origin\DSDT-0.aml
ConnectAll after refresh menu
reinit: self device path=PcieRoot(0x0)/Pci(0x1D,0x0)/USB(0x0,0x0)/USB(0x5,0x0)/HD(1,MBR,0x00000000,0x2,0x7A601E)
new SelfHandle=1F4B3718
found 25 volumes with blockIO
* PcieRoot(0x0)/Pci(0x1D,0x0)/USB(0x0,0x0)/USB(0x5,0x0)
USB volume
USB volume
this is SelfVolume at index 1
* PcieRoot(0x0)/Pci(0x1D,0x0)/USB(0x0,0x0)/USB(0x5,0x0)/HD(1,MBR,0x00000000,0x2,0x7A601E)
USB volume
USB volume
* PcieRoot(0x0)/Pci(0x1D,0x0)/USB(0x0,0x0)/USB(0x3,0x0)/USB(0x0,0x0)/USB(0x0,0x0)
USB volume
USB volume
USB volume
USB volume
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x0,0x0,0x0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x1,0x0,0x0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x2,0x0,0x0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x3,0x0,0x0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x4,0x0,0x0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x5,0x0,0x0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x0,0x0,0x0)/HD(1,GPT,1399EABD-3B8F-4116-A22D-7B7FC3BD171A,0x28,0x64000)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x0,0x0,0x0)/HD(2,GPT,528BCB5E-39A6-4789-9114-2AAE2F50B810,0x64028,0x1BE80460)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x0,0x0,0x0)/HD(3,GPT,C5D78866-DD70-4F70-83E9-12FB06E9896C,0x1BEE4488,0x40000)
Booting OS 10.8.2
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x1,0x0,0x0)/HD(1,GPT,7831BD74-24D7-44B1-BFB8-7233E0EBEDF0,0x28,0x64000)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x1,0x0,0x0)/HD(2,GPT,275A3C0A-2C01-4F7D-A31E-589612CD10DD,0x64028,0x74662D60)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x2,0x0,0x0)/HD(1,GPT,33815E30-02B7-4461-BFE5-6A3FF45FCA8F,0x28,0x64000)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x2,0x0,0x0)/HD(2,GPT,4C36FA93-024F-4C27-AE2A-ACE92B903554,0x64028,0x3A2E1FE0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x3,0x0,0x0)/HD(1,GPT,C7479120-EF6F-4FB0-80B1-40FBFB7462E5,0x28,0x64000)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x3,0x0,0x0)/HD(2,GPT,58650676-71D4-4C5A-A6A2-09006448A1CA,0x64028,0x1D170FF0)
Booting OS 10.8.2
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x3,0x0,0x0)/HD(3,GPT,927F2BEB-5966-40AC-B1D5-C5FD3E673EAC,0x1D215018,0x1A4CF600)
Booting OS 10.7.5
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x3,0x0,0x0)/HD(4,GPT,85E4EDEC-44AC-453F-977D-8577BB0587B0,0x37724618,0x2C219F0)
Booting OS 10.8
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x4,0x0,0x0)/HD(1,GPT,2F69768E-8F45-4029-AD86-872FDA580F01,0x28,0x64000)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x4,0x0,0x0)/HD(2,GPT,52CB117E-C745-482B-98EC-8C526784423D,0x64028,0x3A2E1FE0)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x5,0x0,0x0)/HD(1,GPT,9E7319EC-7716-4551-A18F-EDC1328D01A2,0x28,0x64000)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x5,0x0,0x0)/HD(2,GPT,4DF03E8D-C58F-46BC-B45D-D6FF6E24013B,0x64028,0x1BE80460)
* PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x5,0x0,0x0)/HD(3,GPT,C3B89DCF-AAEC-4209-8B30-DB828E9A30DD,0x1BEE4488,0x40000)
Booting OS 10.8.2
PutNvramPlistToRtVars ...
Adding Key: fmm-computer-name: Data: Size = 16: Success
Adding Key: LocationServicesEnabled: Data: Size = 1: Success
get anime for os=23
get anime for os=38
get anime for os=23
get anime for os=23
get anime for os=23
get anime for os=38
get anime for os=23
get anime for os=37
get anime for os=38
get anime for os=38
get anime for os=23
hide volume 0
hide volume 3
hide volume 6
hide volume 8
added legacy entry 10 OSType=3 Name=Legacy HD2 Icon=legacy
added legacy entry 23 OSType=0 Name=Legacy HD2 Icon=<null string>
[70:146 - 68:602] ScanLegacy()
FindBootOptionForFile: 1F404098, \EFI\BOOT\CLOVERX64.EFI
BootOrder: 8: Boot0000, Boot0001, Boot0002, Boot0003, Boot0004, Boot0005, Boot0006, Boot0007
Searching for: PcieRoot(0x0)/Pci(0x1F,0x2)/Sata(0x3,0x0,0x0)/HD(1,GPT,C7479120-EF6F-4FB0-80B1-40FBFB7462E5,0x28,0x64000)/\EFI\BOOT\CLOVERX64.EFI (Len: 126)
and for: HD(1,GPT,C7479120-EF6F-4FB0-80B1-40FBFB7462E5,0x28,0x64000)/\EFI\BOOT\CLOVERX64.EFI (Len: 98)
FindBootOptionForFile: Not found.
found tools\Shell64.efi
[70:146 - 0:000] ScanTool()
[70:146 - 0:000] FinishTextScreen()
FindDefaultEntry ...
FindStartupDiskVolume ...
GetEfiBootDeviceFromNvram: efi-boot-device-data not found
not found
Default boot entry not found
[70:146 - 0:000] FindDefaultEntry()


#248
airlync

airlync

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male

This looks like the problem that miaumiau and TimeWalker had on their laptops with Phoenix UEFI. You can find more about this here.


add the EmuVariableRuntimeDxe.efi to /EFI/drivers64UEFI/ , problem has been resolved, Thank You!

#249
Menno

Menno

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts
Apple software raid boots fine here with clover. (from external usb stick)

#250
dmazar

dmazar

    InsanelyMac Sage

  • Coders
  • 256 posts
  • Gender:Male

Apple software raid boots fine here with clover. (from external usb stick)

Ah, cool. I hope you can help Taruga since I do not have raid setup and actually I'm not any smarter after seeing his log.

#251
Taruga

Taruga

    Retired

  • Retired Developers
  • 527 posts
  • Gender:Male
  • Location:Portugal

Apple software raid boots fine here with clover. (from external usb stick)


I'm glad to know it works with raid volumes

But I can't get it to work... can't you post your Clover config.plist , maybe it will help me

Thanks

ps. What clover build are you using ?

#252
Hacktrix2006

Hacktrix2006

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 423 posts
  • Gender:Male
Mine freezes on UEFI after loading kernelcache it doesn't proceed no errors though.

#253
gothic860

gothic860

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts
  • Gender:Male
  • Location:Germany, Bavaria
Hi there,

thank you for the great work. I have 1 little problem. I Installed Clover on the EFI Partition, but it doesnt show the "Macintosh HD" (Mountain Lion), only "Boot UEFI boot menu from" and "Boot Legacy from Legacy HD2". Any ideas? Did i made something wrong?

#254
Mrengles

Mrengles

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 117 posts
  • Gender:Male
  • Location:United States
Hey Clover users!

I know this is only my first post, Sorry for making it a question. The reason I signed up for this forum was simply to follow this thread. I've got clover working on GPT/EFI booted from BIOS at the moment and its GREAT! In the past i'v using the moron prof tools at tonymacx86 such as unibeat to create my Install USB. The problem with this method does not create the recovery partition during install of OS X. I've read over the instruction in /EFU/doc to install OS X to GPT, the problem i'm having (don't know if its me being a moron, or the guide leave allot to be assumed) but I can't figure it out, it's just not making sense to me.

Will someone explain or provide a link to a guide/install method that will create the recovery partition on a hackintosh? I've managed to get one working by reinstalling 10.8.2 from the application folder, restarting back to my OSX drive, remove /OS X install's kernelcache, and then finishing the install by restarting back into Install OS X from Macintosh SSD. It works but take a long time with allot of steps.

I would like to have a copy of the installer on hand saved onto a USB, that I can just simple install 10.8, that creates the recovery partition, setup OS X and be done.

Again, will someone explain or provide a link to a guide/install method that will create the recovery partition on a hackintosh?

Thanks in advanced,

-Mrengles

Hardware: I know its not needed for this request. =)

ASUS P8Z77-M Pro (Patched 1616 BIOS), 16GB RAM, 3770K, GTX 670, Full custom water loop.

P.S I have some more questions about clover, but figured I would try to fix/config on my own with some more research before I bug everyone with info that has already been posted.

Thanks again!

Edited by mrengles, 29 October 2012 - 05:32 PM.


#255
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,294 posts
  • Gender:Male

Hey Clover users!

I know this is only my first post, Sorry for making it a question. The reason I signed up for this forum was simply to follow this thread. I've got clover working on GPT/EFI booted from BIOS at the moment and its GREAT! In the past i'v using the moron prof tools at tonymacx86 such as unibeat to create my Install USB. The problem with this method does not create the recovery partition during install of OS X. I've read over the instruction in /EFU/doc to install OS X to GPT, the problem i'm having (don't know if its me being a moron, or the guide leave allot to be assumed) but I can't figure it out, it's just not making sense to me.



This forum is not allowed to talk about tony's and his beasts :wink2:

#256
kyndder

kyndder

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 120 posts
  • Gender:Male
  • Location:Brazil

Will someone explain or provide a link to a guide/install method that will create the recovery partition on a hackintosh?


Here a nice guide made by blackosx > http://myhack.sojuga...c.php?f=5&t=445

You can also use Carbon Copy Cloner...

#257
dmazar

dmazar

    InsanelyMac Sage

  • Coders
  • 256 posts
  • Gender:Male

I Installed Clover on the EFI Partition, but it doesnt show the "Macintosh HD" (Mountain Lion), only "Boot UEFI boot menu from" and "Boot Legacy from Legacy HD2". Any ideas? Did i made something wrong?

It looks like you are booting it in UEFI mode, but did not put HFSPlus.efi driver into /efi/drivers64UEFI. The best thing to do is to start Clover and then press F2 to save /efi/misc/preboot.log to EFI partition. If you post that file here, it will be possible to say what went wrong.

I would like to have a copy of the installer on hand saved onto a USB, that I can just simple install 10.8, that creates the recovery partition, setup OS X and be done.

In my case it is enough to restore Applications/Install OS X Mountain Lion.app/Contents/SharedSupport/InstallESD.dmg to USB stick and then I can boot installer from it by Clover without any additional tweaks. This install then creates recovery partition, although I prefer having another full OSX install on another partition (even another disk) from where I can do recovery if needed.

By the way, starting Applications/Install OS X Mountain Lion.app and then restarting with Clover into installer is also possible here. No need to move disk to real Mac.

#258
Mrengles

Mrengles

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 117 posts
  • Gender:Male
  • Location:United States
Thanks everyone! I'll be sure not to talk about Tony and his Beasts, haha!

@dmazar


When restoring and booting the InstallESD.dmg. I have added FakeSMC.kext to EFI/kexts/10.8 and booting with extra kexts and no kernelcache, However when the USB boots and starts I get an error "waiting 10 seconds..." And never able to complete the boot process.

Am I missing anything? Should I post a screen shot, or log? Also do you install/setup clover to the Installer USB's GPT/EFI partition or use another disk completely to boot/load up Clover?

Thanks again!

-Mrengles

#259
Mrengles

Mrengles

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 117 posts
  • Gender:Male
  • Location:United States
Well, I've got a working OS X Mountain Lion Installer USB that creates a working Recovery HD partition during the installation process. The steps were very simple, took about 5-10 minutes to modify the installer (depending on the speed of your Mac). Its was combination of a standard retail InstallESD.dmg restore, with parts of Blackosx's Recovery Partition guide.

Thanks again everyone, for your comments, jokes, advise, and other 2cent posts!

Man, Clover v2 r806 Bootloader is AWESOME!

I was so excited that Find My Mac was working... I just had to send a lock request from iCloud to complete my tests. A few seconds later my Hackintosh, shutdown, restarted, and booted backup to the Lock screen! it WORKED!!! Haha

Entered my 6 digit passkey a few times, none of them worked, and I was locked out of my freshly Installed Hackintosh. Long story short Find My Mac, works but doesn't. Be careful. =)

Thanks SLICE for a great Mac experience on a PC. Best bootloader i've used to date, with only a few small kinks, it really is the most Mac like.

-Mrengles

#260
Mrengles

Mrengles

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 117 posts
  • Gender:Male
  • Location:United States
...If its not to off topic from the OP, I'll edit this post with a complete guide for above (Not the lockout, the Install guide)? =)





Also tagged with one or more of these keywords: Bootloader, EFI, Clover


6 user(s) are reading this topic

2 members, 4 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy