Jump to content

[GUIDE] Install OS X Mountain Lion 10.8.2 and Mavericks 10.9.1 on ASUS N53SN/N53SV/N53SM Notebooks

* * * * * 4 votes Asus N53SN Asus N53SV Asus N53SM Asus N53sn

  • Please log in to reply
162 replies to this topic

#61
cele_82

cele_82

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
Hello all,
I have a AR9002WB-1NG wifi combo card(AR9285 + AR3011 (bluetooth))

From lsusb for BT

Bus 002 Device 005: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth


I got the wifi working just with a plist edit:

<key>IONameMatch</key>
<array>
<string>pci168c,2a</string>
<string>pci168c,2b</string>
</array>


for the bluetooth instead I'm confused… I've seen around two methods for this: Atheros Firmware Uploader or IOath3kfrmwr.kext

The first one (FW uploader) gives me a i5:ath3k-firmware-uploader tom$ ./ath3k-firmware-uploader
Atheros AR3011 not found error.

The second one is a bit cryptic.. I've added the device id in the plist converting it into decimal value.. but I don't get any kind of output in the Console or anywhere else.. is there a log somewhere to understand if this has been loaded or errors etc..?

This my edit for my device(ID 0cf3:3005):

<key>idProduct</key>
<integer>12293</integer>
<key>idVendor</key>
<integer>3315</integer>


PS Is there another method for BT? Suggestions? I'm running 10.8.2



Thanks

#62
eng_matt

eng_matt

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
@cele_82 did you try this bluetooth driver ?


Bluetooth and Ethernet kext here;

http://www.mediafire...9qcwz4758s4ybqs

#63
FavleX

FavleX

    FavleX

  • Members
  • PipPipPipPipPipPipPip
  • 727 posts
any idea if We can use this guide on the asus N56-VZ??
Thanks

#64
eng_matt

eng_matt

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

any idea if We can use this guide on the asus N56-VZ??
Thanks


İf your system hardware similar why not? , by the way most of asus drivers also similar.

#65
anerik70

anerik70

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
  • Gender:Male

I spent many hours for that work. At first I dump the audio codec (ALC269) in linux and than patch the AppleHDA and DSDT by using information from that codec dump with the help of this guide. I forgot to say that DSDT at my previous post also includes wi-fi patch.

I also have same screen gitches like you. It is not too bad and so often, so I will deal with it later.

I just started to work on ssdt :) not working for now :(

cya


INSTALL "FAN CONTROL APP" AND ENJOY!!!

thank you very much, this dsdt works like a charm!!! imy laptop has a very much extended battery life and is cooler now.

but now i have two issues, the one is that i have random graphics glitches and the second is that my fn keys don't work for volume control with this dsdt, with my own dsdt its working the volume control with animations.

please any help with the fn keys and the graphics glitches.

FOR GLITCHES YOU HAVE TO INSTALL "FAN CONTROL" INSTALL, RUN IN SYSTEM PREFERENCES, RESTART AND ENJOY""

#66
eng_matt

eng_matt

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
Like @anerik70 said , i am using fan control app. For screen glitches and freeze. No more HD 3000 screen issue.

Here the apps picture;

Posted Image


I added apps links below and attachment , so you can download and use. ;

Fan Control 1.2 apps ;

Fix screen artifacts HD 3000



Download:

http://www.mediafire...d1grt6dyt7swfvr

RUN IN SYSTEM PREFERENCES


Also added attachment. All you need install and run in System Preferences.

Have a nice day . Guys.

New users please write comment this thread. :)

Attached Files



#67
slayhert

slayhert

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Too bad the hardware in these laptops dont support actual fan control. My Laptop tends to run hot when idle just due to the place it sits. I would love to kick up the fan speed.

#68
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands

Too bad the hardware in these laptops dont support actual fan control. My Laptop tends to run hot when idle just due to the place it sits. I would love to kick up the fan speed.


Fix your SSDT and patch the intelcpupower...kext. Should make a difference.

#69
yalun94

yalun94

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hi guys, I have an Asus N53SN
i7-2630QM, nVidia 550M - 1366x768 res, etc...
I've followed this guide and my computer will refuse to boot into Mac normally, it will boot up thru safemode (-x) but graphics is not fully enabled, along with a whole bunch of other stuff not working.
When I have it boot thru the ###### USB, it will result in a white screen.
When I use verbose boot (-v) it will get stuck on: IOBluetoothHCIController::setConfigState........ and the screen turns grey and I can't read the text anymore...
Please instruct me. Thanks!

#70
slayhert

slayhert

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Fix your SSDT and patch the intelcpupower...kext. Should make a difference.

I am running a custom ssdt, and the BIOS is patched. Its more of a function of where my computer sits, and I would like the fans to come on earlier.

Hi guys, I have an Asus N53SN
i7-2630QM, nVidia 550M - 1366x768 res, etc...
I've followed this guide and my computer will refuse to boot into Mac normally, it will boot up thru safemode (-x) but graphics is not fully enabled, along with a whole bunch of other stuff not working.
When I have it boot thru the ###### USB, it will result in a white screen.
When I use verbose boot (-v) it will get stuck on: IOBluetoothHCIController::setConfigState........ and the screen turns grey and I can't read the text anymore...
Please instruct me. Thanks!


Sounds like the nVidia Kexts are trying to load. You might try deleting them from /S/L/E and see how that goes.

#71
yalun94

yalun94

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Sounds like the nVidia Kexts are trying to load. You might try deleting them from /S/L/E and see how that goes.


I did delete the nVidia Kexts off of S/L/E as instructed by the guide

#72
slayhert

slayhert

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

I did delete the nVidia Kexts off of S/L/E as instructed by the guide


What other extra kexts did you install? Do you have the /Extra folder setup? Did you delete any other kexts?

#73
yalun94

yalun94

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I did not add any extra kexts.
I did install the Intel Graphics kexts via Kext Utility
and what do u mean by the /Extras folder setup? do u mean on the flash drive? if so, then yes I do.
I did not copy anything into the /Extras on the HDD

#74
slayhert

slayhert

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

I did not add any extra kexts.
I did install the Intel Graphics kexts via Kext Utility
and what do u mean by the /Extras folder setup? do u mean on the flash drive? if so, then yes I do.
I did not copy anything into the /Extras on the HDD


Inorder for the computer to boot without the USB, you will have to have /Extra on the HDD setup so chameleon reads the DSDT, and smbios.plist. This may be the cause of your issues.

#75
yalun94

yalun94

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
i dont need it to boot without USB, I am ok with booting off of USB
but the problem is, it won't even let me boot normally using the USB bootloader....

#76
eng_matt

eng_matt

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
@yalun94 ok. I uploaded for you and other users;

1- My Bootable Usb Extra
2- My Mac Osx installed harddisk Extra
3- 10.8.2 All Extensions

Use my files and rechange with yours. Kexts and Extra files. OK.

Here the Download links (Asus-Extensions-Extra-10.8.2) ;


http://www.mediafire...br7jmq9oob2wgz6

#77
yalun94

yalun94

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hi I loaded the USB Extras onto my USB drive and it resulted in a kernal panic, normal boot resulted in a do not sign.
verbose boot showed that it was stuck on this:
Posted Image
and it just gets stuck here.....
any ideas? thanks for all of those helping.

#78
manmal

manmal

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 437 posts
hi eng_matt,
thanks for the guide.
Does hdmi audio work connecting it to an hdmi LCD/LED TV with hdmi cable(audio+video i mean)?
thanks!
mal

#79
mothermonster

mothermonster

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Will this installation work with an ASUS K55A?
Processor
  • 2.50 gigahertz -3210M
    128 kilobyte primary memory cache
    512 kilobyte secondary memory cache
    3072 kilobyte tertiary memory cache
    64-bit ready
    Multi-core (2 total)
    Hyper-threaded (4 total)[/font]
Drives
  • 727.59 Gigabytes Usable Hard Drive Capacity
    636.60 Gigabytes Hard Drive Free Space
BIOS
  • American Megatrends Inc. K55A.404 08/20/2012
Controllers
  • Intel® 7 Series Chipset Family SATA AHCI
Communicationshttp://www.asus.com/...#specifications

#80
manmal

manmal

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 437 posts
hi, i have artefacts in video using mountain lion 10.8.2 with n53sv laptop. Which bootloader do you suggest me to use?
Does hdmi work (audio and video) ?
thanks





Also tagged with one or more of these keywords: Asus N53SN, Asus N53SV, Asus N53SM, Asus, N53sn

  Topic Stats Last Post Info

2 user(s) are reading this topic

1 members, 1 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy