Jump to content

{Guide} DELL INSPIRON N5110

* * * * * 17 votes

  • Please log in to reply
2459 replies to this topic

#161
amiiine

amiiine

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

AA,
I have bought an N7110 which is basically the 17" version of the N5110 with i7-2670QM - 6GB RAM - Intel HD 3000 and Nvidia 525m.
I installed iAtkos L2 on my laptop but I keep getting problems with my gfx. QE/CI can't be enabled. I copied both the DSDT (nvidia +atheros one) and the kexts you uploaded on the first post.
1/ If I start up with GraphicsEnabler=yes I get an error (Unknown Nvidia Nvc1).
2/ When I try to boot up in verbose mode, I get "DSMOS has arrived, Nvidia HAL 100 loaded " then I get a black screen. Keyboard works (so the system is probably running) but I get no display at all (just a black screen)
3/ When I reomve the IntelHD related kexts and reboot, I can get into the OS X, but without QE/CI. My Nvidia card is recognised but my Intel HD isn't (device ID=0x0116). Of course, I cannot change the display resolution (1024x768).

So, 1/ is there a way to disable the Intel gfx (no option in the BIOS) and enable QE/CI with the nvidia?
2/ Otherwise, can anyone who got it working zip his system/Library/Extensions folder and upload it here?
Or at least can you upload Intel and Nvidia gfx related kexts ? (maybe sthg is wrong with my kexts)

Thank you very much !
I have spent more than 2 weeks trying to figure out the error with no luck !


mmmmmm i have iatkos L2 upgraded to 10.7.3 and works very well

my graphic card work nice (intel HD 3000)
i remeber my first install of iatkos i resolve my problem for the screen display
intel HD 3000 with QE/CI work but not intel
here is what i do just simple modification of my DSDT.aml
try this post http://www.tonymacx8...hp?f=15&t=28851
try my extra folder and install these kexts with kext utility
http://www.mediafire...22x7antxrzox960
good luck

#162
andrei221

andrei221

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

http://www.osx86.net...do=file&id=2185 -> can anyone try this kext if it works full speed ? thanks



#163
khannan

khannan

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male

http://www.osx86.net...do=file&id=2185 -> can anyone try this kext if it works full speed ? thanks

Same speed :(

#164
andrei221

andrei221

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Damn. But what can we do for full speed?

#165
amiiine

amiiine

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

Damn. But what can we do for full speed?


just wait !!

#166
samiouanes

samiouanes

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

mmmmmm i have iatkos L2 upgraded to 10.7.3 and works very well

my graphic card work nice (intel HD 3000)
i remeber my first install of iatkos i resolve my problem for the screen display
intel HD 3000 with QE/CI work but not intel
here is what i do just simple modification of my DSDT.aml
try this post http://www.tonymacx8...hp?f=15&t=28851
try my extra folder and install these kexts with kext utility
http://www.mediafire...22x7antxrzox960
good luck


Thank you very much. I got a black screen once again. Connecting the VGA port to an LCD external screen WORKED. But my internal display isn't detected when I press "Detect Displays". So, the laptop works but only through an external screen. Any ideas ?

#167
andrei221

andrei221

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I solved my internet+wireless problems.

For those who want wireless/faster speed over 'ethernet' AND have an Android/iOS phone just get PDANet (http://junefabrics.com/).

What this does?
It creates an network interface in our OSX and then you can use the usb cable to use the phone as an 'usb stick'. Follow the guide from the site and you are ready to go.

#168
Amadeu_Modigliani

Amadeu_Modigliani

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Gender:Male
  • Location:Brazil

Thank you very much. I got a black screen once again. Connecting the VGA port to an LCD external screen WORKED. But my internal display isn't detected when I press "Detect Displays". So, the laptop works but only through an external screen. Any ideas ?


Read: http://www.insanelym...dpost&p=1700218
Script to make: http://www.insanelym...dpost&p=1792174

#169
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male
thinking on trying mountian lion

#170
Amadeu_Modigliani

Amadeu_Modigliani

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Gender:Male
  • Location:Brazil
solution for video freezing

Replaces the display (LCD) for a new one.
The former possessed a black connector problem and gave the new connector is gray and it works perfectly. If your notebook is still under warranty ask to change the LCD that is defective.

#171
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male

solution for video freezing

Replaces the display (LCD) for a new one.
The former possessed a black connector problem and gave the new connector is gray and it works perfectly. If your notebook is still under warranty ask to change the LCD that is defective.


you did that ?

#172
iKxGaMeX

iKxGaMeX

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
<p>I'm having some trouble installing 10.7.2 on an MBR disk. Even with patched files, when I go to install on my selected partition I get an error saying
<p>"Mac OS X could not be installed on your computer. The installer can't prepare the disk for installation. You may need to repair your disk using disk utility."
<p><br>
<p>Any ideas??

#173
Amadeu_Modigliani

Amadeu_Modigliani

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Gender:Male
  • Location:Brazil

you did that ?


Yes!

#174
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male

<p>I'm having some trouble installing 10.7.2 on an MBR disk. Even with patched files, when I go to install on my selected partition I get an error saying
<p>"Mac OS X could not be installed on your computer. The installer can't prepare the disk for installation. You may need to repair your disk using disk utility."
<p><br>
<p>Any ideas??


use 10.7.0 or 10.7.3

Yes!


good can you give us moreinfo about replacment

#175
Amadeu_Modigliani

Amadeu_Modigliani

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Gender:Male
  • Location:Brazil

you did that ?

Yes.

#176
BLooD_LorD

BLooD_LorD

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
Please write tutorial, how to get vga output working.

#177
uwk

uwk

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
how are you mohamed:D..miss you gdn wlahe ya wa7sh:)..the lap is getting too hot and the fan works every minute even if i do nothing..i downloaded istate program to discover the temperature..it's always 56 for cpu A and cpu B and when the fan works the temp is 52..what shall i do????

#178
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male

Please write tutorial, how to get vga output working.


here you go
http://www.insanelym...pic=259705&st=0

i attached 10.7.3 one for lids + vga

how are you mohamed:D..miss you gdn wlahe ya wa7sh:)..the lap is getting too hot and the fan works every minute even if i do nothing..i downloaded istate program to discover the temperature..it's always 56 for cpu A and cpu B and when the fan works the temp is 52..what shall i do????


it is general try cool it and fan will stop
also attached new fakesmc and sensors by kozlek

#179
mokeev1995

mokeev1995

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Location:Russia, Yaroslavl
  • Interests:MacOSX, Apple, Microsoft, Windows, New Computer technologies
you shold be very clever if you do that yourself. I really respect you! thank you 4 all your instructions

#180
iKxGaMeX

iKxGaMeX

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Thank you very much for your advice...10.7.3 worked, and thanks to this thread my lion install on my n5110 is working great. One question though...has there been any development for the Intel Centrino N 1030 wireless card?





3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy