Jump to content

Mobility Radeon HD 4650:Full Resolution with QE & CI working on Internal LVDS screen


  • Please log in to reply
692 replies to this topic

#681
rekoot

rekoot

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Does the ATI Mobility Radeon HD 4330 work with QE/CI under ML ?

#682
KUGLee

KUGLee

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

Does the ATI Mobility Radeon HD 4330 work with QE/CI under ML ?


http://www.insanelym...n/#entry1655903

#683
leonardo.eg

leonardo.eg

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I've ATI 4330 on dell inspiron 1564, I've installed 10.8.2 with iTakos,
I've installed kexts from here and from everywhere
just I've got the native resolution 1366x768, but no qe/ci, No openGL renderer!
I've tried to play with AMDRadeonAccelerator.kext , which is for 5000 series, and got OpenGL Renderer ( Testing with OpenGL Extensions Viewer ) but its just loading, and system is becoming slow in booting and inside the mac itself with no real opengl, even I see the option"Translucent bar" in change ur background.. but its not working really,

And I figured that AMDRadeonAccelerator is loading AMDRadeonX3000GL.bundle and its not compatible with ATi mobility radeon 4000 series, its for 5000, and the other kexts loading ATIRadeonX2000GL with ATIRadeonX2000.kext, which is not making any sense and its not lading in "OpenGL Extensions viewer" it just showing apple software renderer, and video memory is 0 in opengl..

So Is there anyway to let AMDRadeonx2000GL.bundle do as a openGL Renderer or so?

#684
flo9z

flo9z

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi, No solution for mobility HD 3430 ?

#685
Extended

Extended

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Germany

I have followed the Guide but get this:

 

http://www.insanelym...4650/?p=1923995

 

Any solution?



#686
mosi

mosi

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

you it's impossible to gain full advantage of my x95551002 ?

I can't post in Mobility Radeon HD4xxx thread. You know as a new user here.......

New method, try old method...it's better.
10.7.x VGA works, DVD Player + MS Office ppt + Chess don't work.
10.6.8 VGA + Chess work, DVD Player + MS Office ppt don't work.

[EDIT] 2012.03.01
Update pkg for 10.8 ML.
[EDIT] 2011.10.28
Easy way to get QE/CI. Only for 10.6.6 2011 MBP, 10.6.7 2011 MBP, 10.6.8, and Lion

If the resolution is higher than 1366x768 as 1600x900 , you need to try to add Dual-link and EDID too.
http://www.insanelym...p...2061&st=256

Only for 1366x738 and lower resolution.

1-1.All kext used with Lion 10.7.x (nothing modified.)
    ATI4600Controller.kext (add ID)
    ATIFramebuffer.kext
    ATISupport.kext
    ATIRadeonX2000.kext
    ATIRadeonX2000GA.plugin
    ATIRadeonX2000GLDriver.bundle
    ATIRadeonX2000VADriver.bundle
    http://dl.dbank.com/c0f3hgjco8

1-2.All kext used with Snow Ledpard 10.6.8 (nothing modified.)
  kexts from 10.6.8 or Lion
    ATI4600Controller.kext (add ID)
    ATIFramebuffer.kext
    ATISupport.kext
  kexts from 10.6.7 updated from 10.6.3.retail
    ATIRadeonX2000.kext
    ATIRadeonX2000GA.plugin
    ATIRadeonX2000GLDriver.bundle
    ATIRadeonX2000VADriver.bundle

  All kexts used (ATI 10.6.7.update ATIRadeonX2000.kext + 10.6.8 and 10.7.0 )
    http://dl.dbank.com/c0dh6fjdit

2.Add ID of 4330m ( 0x95521002 ) to ATI4600Controller.kext as below.
  ATI4600Controller.kext/Contents/Info.plist
   <key>IOPCIMatch</key>
    <string>0x95521002 0x94881002</string>
  Make sure the ID of 4330m is included in ATIRadeonX2000.kext/Contents/Info.plist as below.
    <key>IOPCIMatch</key>
    <string>0x94001002 0x94011002 0x94021002 0x94031002 0x95811002 0x95831002 0x95881002 0x94c81002 0x94c91002 0x95001002 0x95011002 0x95051002 0x95071002 0x95041002 0x95061002 0x95981002 0x94881002 0x95991002 0x95911002 0x95931002 0x94401002 0x94421002 0x944A1002 0x945A1002 0x94901002 0x949E1002 0x94801002 0x95401002 0x95411002 0x954E1002 0x954F1002 0x95521002 0x95531002 0x94a01002</string>

  If the default values in ATIRadeonX2000.kext didn't include of your card's ID, then you may need to give up. Example, 0x95551002 never got QE/CI since I know so many people have tried this (both old method and new method).

  And you can modify the name of 4330m as attched.
  ATI4600Controller.kext/Contents/MacOS/ATI4600Controller
  attachicon.gif4330mEN.png

3.Use Boot pkg or ATY_init.kext with Peregrine which is not supported by 10.6.6 MBP 2011~Lion, and the kext will use RadeonFramebuffer instead.
<key>GraphicsEnabler</key>
<string>Yes</string>

  Boot for ATI 4xxx Mobility Series only.
    attachicon.gifChameleon_2.1svn_r1820_10.8_Peregrine_NB_780_pkg+boot.zip

  The default IDs included in ati.c and ATIRadeonX2000.kext were as below.
    { 0x10029490, "Peregrine"} ,
    { 0x1002949E, "Peregrine"} ,
    { 0x10029480, "Peregrine"} ,
    { 0x10029488, "Peregrine"} ,
    { 0x10029540, "Peregrine"} ,
    { 0x10029541, "Peregrine"} ,
    { 0x1002954E, "Peregrine"} ,
    { 0x10029552, "Peregrine"} ,
    { 0x10029553, "Peregrine"} ,
    { 0x1002954F, "Peregrine"} ,
  The default IDs included in ati.c but not in ATIRadeonX2000.kext, and you may need to give up.
    { 0x10029498, "Peregrine"} ,
    { 0x100294B3, "Peregrine"} ,
    { 0x100294B5, "Peregrine"} ,

Or
<key>GraphicsEnabler</key>
<string>No</string>


  for 0x10029552
    attachicon.gifATY_Init...eregrine.zip
  for 0x10029553
    attachicon.gifATY_Init...eregrine.zip
    attachicon.gifATY_Init...eregrine.zip
    attachicon.gifATY_Init...eregrine.zip
    attachicon.gifATY_Init...eregrine.zip
  for 0x10029480
    attachicon.gifATY_Init...eregrine.zip

  You can modify the ATY_Init.kext.for.ATI4330m.Peregrine.zip to be yours with HexEdit. (two locations 32+64)
attachicon.gif4330mHexEdit.png

4. Use Kext Wizard to install the modified kext to S/L/E.
  attachicon.gifKext_Wiz....v3.7.10.zip
  attachicon.gif4330mWizard.gif

Then, you get QE/CI with ATI 4330m now.


You don't need to do anything with the following any more.



Old method, better than New method
10.7.x VGA + DVD Player + MS Office ppt work, Chess doesn't work.
10.6.8 VGA + DVD Player + MS Office ppt + Chess work.

All kext used with Lion 10.7.x (nothing modified.)
    ATI4600Controller.kext (add ID)
    ATIFramebuffer.kext
    ATISupport.kext
    ATIRadeonX2000.kext
    ATIRadeonX2000GA.plugin
    ATIRadeonX2000GLDriver.bundle
    ATIRadeonX2000VADriver.bundle
    http://dl.dbank.com/c0f3hgjco8

All kext used with Snow Ledpard 10.6.8 (nothing modified.)
  kexts from 10.6.8 or Lion
    ATI4600Controller.kext (add ID)
    ATIFramebuffer.kext
    ATISupport.kext
  kexts from 10.6.7 updated from 10.6.3.retail
    ATIRadeonX2000.kext
    ATIRadeonX2000GA.plugin
    ATIRadeonX2000GLDriver.bundle
    ATIRadeonX2000VADriver.bundle

  All kexts used (ATI 10.6.7.update ATIRadeonX2000.kext + 10.6.8 and 10.7.0 )
    http://dl.dbank.com/c0dh6fjdit

If the resolution is higher than 1366x768 as 1600x900 , you need to try this too.
http://www.insanelym...p...2061&st=256

Only for 1366x738 and lower resolution.

attachicon.gifradeon_b...mebuffer.zip
1. This is the output from bcc9's radeon_bios_decode .
" ./radeon_bios_decode < 1002_9552.rom > connector.txt "

  ATOM BIOS Rom:
  ...............
  PCI ID: 1002:9552
  Connector at index 0
   Type : LVDS (7)
   Encoder : INTERNAL_UNIPHY2 (0x21)
   i2cid: 0x96, OSX senseid: 0x7
  Connector at index 1
   Type : VGA (1)
   Encoder : INTERNAL_KLDSCP_DAC1 (0x15)
   i2cid: 0x90, OSX senseid: 0x1
  Connector at index 2
   Type : HDMI-A (11)
    Encoder : INTERNAL_UNIPHY (0x1e)
   i2cid: 0x91, OSX senseid: 0x2

Get the data like this, it works for me.

index 0=Connector[0]=Port0=00 =LVDS :HW_Line[6] i2cid: 96 SenseLine = (6 & 0xf)+1 = 07
index 1=Connector[1]=Port1=01 =VGA :HW_Line[0] i2cid: 90 SenseLine = (0 & 0xf)+1 = 01
index 2=Connector[2]=Port2=02 =HDMI-A:HW_Line[1] i2cid: 91 SenseLine = (1 & 0xf)+1 = 02

2. The output from "sudo dmesg > ~/Desktop/Encoder.txt" is as below by using Dong's RadeonHD.kext. Remove some data unuseful.

Object: ID: 310e name: LVDS type: 3 id: e
* SrcObject: ID: 2121 name: UNIPHY2 enum: 1
rhdAtomDDCFromI2CRecord: I2C Record: HW_Line[6] EngineID: 1 I2CAddr: 0

Object: ID: 3105 name: VGA type: 3 id: 5
* SrcObject: ID: 2115 name: INTERNAL_KLDSCP_DAC1 enum: 1
rhdAtomDDCFromI2CRecord: I2C Record: HW_Line[0] EngineID: 1 I2CAddr: 0

Object: ID: 310c name: HDMI_TYPE_A type: 3 id: c
* SrcObject: ID: 211e name: UNIPHY enum: 1
rhdAtomDDCFromI2CRecord: I2C Record: HW_Line[1] EngineID: 1 I2CAddr: 0

Connector[0] {..._PANEL, "LVDS LCD1", .... { RHD_OUTPUT_UNIPHYE, ... } }
Connector[1] {..._VGA, "VGA\^H CRT1", ....{ RHD_OUTPUT_DACA, ... } }
Connector[2] {..._DVI_SINGLE, "HDMI_TYPE_A DFP1", ....{ RHD_OUTPUT_UNIPHYA, ... } }
.........................................
RHDBIOSScratchDACSense
.........................................
Sensing DACA on Output AtomOutputDACA
AtomDACLoadDetection
Calling DAC_LoadDetection
.........................................
DAC_LoadDetection Successful
.........................................
Mapping DIG1 encoder to KLDSKP_UNIPHYE
.........................................
Crtc[0]: found native mode from Monitor[LVDS Panel]:
.........................................
Connector "PANEL" uses Monitor "LVDS Panel":
RHDValidateScaledToMode
rhdModeValidateCrtc
DxModeValid: ATOM CRTC 1
rhdAtomOutputModeValid
Listing modesetting layout:
.........................................
ATOM CRTC 1: tied to Atom PLL 1 and LUT A:
Outputs: AtomOutputUniphyE (PANEL)
ATOM CRTC 2: unused
Unused Outputs: AtomOutputDACA, AtomOutputUniphyA


Get the data like this, it works for me.

CRTC1>DIG1>UNIPHYE>LVDS  Encoder = 0x00  Transmitter = 0x12
CRTC2>DAC > DACA >VGA   Encoder = 0x10  Transmitter = 0x00
CRTC2>DIG2>UNIPHYA>HDMI  Encoder = 0x01  Transmitter = 0x10




3. And the patch is here.
You get Transmitter, Encoder, HotplugID, and SenseLine like this.
02 00 00 00 40 00 00 00 09 01 00 00 12 00 00 07 LVDS
10 00 00 00 10 00 00 00 00 01 00 00 00 10 01 01 VGA
00 08 00 00 00 02 00 00 00 01 00 00 10 01 02 02 HDMI (If you don't have port 02, just copy it to be yours.)

All you need to do is just replace the Transmitter, Encoder, HotplugID, and SenseLine to be yours, and keep the order of LVDS, VGA, HDMI as the example as above.

If Dong's RadeonHD.kext didn't work, you can try some values for Transmitter, Encoder as below, and replace the HotplugID, and SenseLine to be yours.

02 00 00 00 40 00 00 00 09 01 00 00 aa 00 00 07 LVDS
10 00 00 00 10 00 00 00 00 01 00 00 00 10 01 01 VGA
00 08 00 00 00 02 00 00 00 01 00 00 bb 01 02 02 HDMI (If you don't have port 02, just copy it to be yours.)
or
02 00 00 00 40 00 00 00 09 01 00 00 aa 01 00 07 LVDS
10 00 00 00 10 00 00 00 00 01 00 00 00 10 01 01 VGA
00 08 00 00 00 02 00 00 00 01 00 00 bb 00 02 02 HDMI (If you don't have port 02, just copy it to be yours.)

According to bcc9's radeon_bios_decode .
The aa could be one of these three values.
#define UNIPHY_E 0x12 // = UNIPHY_2:LINK_A
#define UNIPHY_F 0x22 // = UNIPHY_2:LINK_B
#define UNIPHY_EF 0x02 // = UNIPHY_2:DUAL_LINK
The bb could be one of these three values.
#define UNIPHY_A 0x10 // = UNIPHY:LINK_A
#define UNIPHY_B 0x20 // = UNIPHY:LINK_B
#define UNIPHY_AB 0x00 // = UNIPHY:DUAL_LINK

The default of Shrike is as below.
02 00 00 00 40 00 00 00 09 01 00 00 02 01 00 03
02 00 00 00 00 01 00 00 09 01 00 00 20 01 02 02
00 04 00 00 04 03 00 00 00 01 00 00 10 00 01 01

4. Modify ATI4600Controller.kext with Shrike for Lion 10.7.x, 10.6.6(MBP 2011), 10.6.7(MBP 2011), and 10.6.8 update.
Or modify ATIFramebuffer.kext with Shrike for Retail 10.6.3, update 10.6.6 (10.6.7).

Need to copy ATI4600Controller.kext or ATIFramebuffer.kext to ~/Desktop, and use HexEdit to edit ATI4600Controller.kext/Contents/MacOS/ATI4600Controller or ATIFramebuffer.kext/Contents/MacOS/ATIFramebuffer.

Use HexEdit to find Shrike
02 00 00 00 40 00 00 00 09 01 00 00 12 00 00 07 10 00 00 00 10 00 00 00 00 01 00 00 00 10 01 01 00 08 00 00 00 02 00 00 00 01 00 00 10 01 02 02
and replace to be yours.
02 00 00 00 40 00 00 00 09 01 00 00 12 00 00 07 10 00 00 00 10 00 00 00 00 01 00 00 00 10 01 01 00 08 00 00 00 02 00 00 00 01 00 00 10 01 02 02
Replace two locations for both 32bits & 64bits.
attachicon.gif4330_Shrike.png

5. And add ID of 4330m ( 0x95521002 ) to ATI4600Controller.kext as below, then you can use Kext Wizard to install the modified kext to S/L/E as below.
ATI4600Controller.kext/Contents/Info.plist
<key>IOPCIMatch</key>
<string>0x95521002 0x94881002</string>
attachicon.gifKext_Wiz....v3.7.10.zip
attachicon.gif4330mSnowWizard.gif

Do not install the Chameleon pkg before the kext is modified and installed as above.
6. Also need to edit the file of /Extra/com.apple.boot.plist as below with attached boot files.
<key>GraphicsEnabler</key>
<string>Yes</string>


Then, you can get QE\CI now.

If you get trouble after reboot, you can remove ATI4600Controller.kext and setup GraphicsEnabler=No, and try it again.

pkg for 0x10029552 & 0x10029553 & 0x10029480 boot file.
attachicon.gifChameleon_2.1svn_r1820_10.8_Shrike_NB_780_pkg+boot.zip

If you want to update Chameleon boot file, you can use ATY_init.kext to replace the function of GraphicsEnabler.
<key>GraphicsEnabler</key>
<string>No</string>

Setup as above, and use Kext Wizard to install the ATY_init.kext to E/E or S/L/E, then you can update the boot file with any revision you want.

Use Shrike for ATIFramebuffer.
for 0x10029552.
attachicon.gifATY_Init...ATI4330m.zip
for 0x10029553
attachicon.gifATY_Init...ATI4530m.zip
attachicon.gifATY_Init...ATI4570m.zip
attachicon.gifATY_Init...ATI5145m.zip
attachicon.gifATY_Init...ATI545vm.zip
for 0x10029480
attachicon.gifATY_Init...ATI4650m.zip



#687
edipo2s

edipo2s

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Brazil
Has anyone successfully achieved QE/CI with Radeon 5650 in Mountain Lion?
I have patch the EDID display overide the file DisplayVendorID-756e6b5e, but when I use the apple kext with GraphicsEnabler=Yes and AtiConfig=Hoolock/Eulemur/Baboon the System Info show the Graphics card name, but without VRAM and the Display info still in other graphic card with only VRAM=4MB.
Can anyone help-me?
Captura%20de%20Tela%202013-08-08%20%C3%A


#688
mmon

mmon

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male

 

Has anyone successfully achieved QE/CI with Radeon 5650 in Mountain Lion?
...

It seems you have AMD , there is a bunch of problems with graphics on this platform.

Anyway try to use Clover bootloader.

One suggestion - don't inject EDID by Display Override, it's wrong. Restore original file and use InjectEDID in Clover.



#689
edipo2s

edipo2s

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Brazil
Hi, thanks mmon. I've installed the Clover and it show the name of my graphic card correctly in options. But I get freeze in boot.
When I was using Chamelleon, I got this erro when I use cpus=4 or no use nothing. But in Clover if I try change the number of cpu, the problem still the same.
I'm using the default npci=x2000.

Here the picture:

2013-08-03%2009.46.01.jpg



#690
Lordadmiral Drake

Lordadmiral Drake

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 408 posts
  • Gender:Male
  • Location:Austria

For Clover issues try the Clover General Discussion thread in the bootloaders section of the forum



#691
casian

casian

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

My laptop is STUDIO XPS 1640 (2009 MODEL) CORE 2 DUO P8700 , MOBILITY RADEON 4670.I get correct resolution 1600x900 and QE/CI but pixels are displaced.Take a look.No matter if I use chameleon chimera or clover, the same result:

poz%25C4%2583+%25281%2529.JPG



#692
osmanos

osmanos

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

is there any way to got work of internal lids on sony laptop. i have searched a lot about but haven't luck on this. HELP...!!



#693
CobraKhan007

CobraKhan007

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Any success story's on patching 10.9.4 ATI kexts for ATI RadeonHD 5470 512MB?

At the moment only got it the internal LCD working under 10.9.4 with 10.9.0 kexts.

Or with the 10.9.4 kext but it needs a connected monitor on hdmi port then.







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy