Jump to content

Mobility Radeon HD 5650 QE/CI WORK! (26/2 Update!)


  • Please log in to reply
112 replies to this topic

#61
vilczech18

vilczech18

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male

Try all monkey's names of framebuffers first, if only resolution changes, than you can join us in hex patching of Ati5000controller.


Heh, about monkey names - I'm not natively english speaker so I gotta translate every option lol

#62
Pockets69

Pockets69

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
LOL vilczech try Langur.

as for repairing permissions (when the next was not loaded) i did it, but it still wasn't showing, on to patching your sense ids

i can say 100% that langur is working for me, i was able to boot, and reboot while i had no screen (only the backlight was on) i can't however say how it looks like since i haven't yet connected it, to an external, i am going to test with my cry today and see whats going on.

#63
Neolo

Neolo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts

Heh, about monkey names - I'm not natively english speaker so I gotta translate every option lol

You think I'm very english man? :halfstar_smile: orangutan, nomascus (but this one failed for me), eulemur, hoolock, elodea, iphomea, vervet etc ^^

#64
Neolo

Neolo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
Here is dump of ati personalities for 10.7.x:
Spoiler


#65
Pockets69

Pockets69

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
NEOLO get me your ATI500 next, i already modified mine for you, but just realized that i was modifying an already modified before, i need a fresh one to work with, also i made it i have qe ci now :)

attach your kext ill modify it :) also i made it with langur :)

also you know why my kext wasn't loaded, because me being an idiot that i am, after modifying the ati5000controller i renamed it to ati5000controllerpatched, and instead of renaming it back, no i copied it like that, no wonder it didn't load -.-

i {censored} hate the autocorrect on this forum ª.ª

Attached Files



#66
Neolo

Neolo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
Congradz. Did you get on internal screen? There is no matter, on modified or not, just do Eulemur for me and hillock, lagur will not work for me, otherwise you have same laptop as me.
Actually I understood how to patch it via console (still don't know how to use editors), but I have 10.7.3 controller and can't find a correct table for it. And I guess you will not find those offsets in my controller which you are used in your.

Attached Files



#67
Pockets69

Pockets69

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
the offsets are exactly the same on every ati5000controller, the patches although are not, anyway i ll patch them for you, ill patch one for eulemur, and the other for hillock, be right back.

#68
Neolo

Neolo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts

the offsets are exactly the same on every ati5000controller, the patches although are not, anyway i ll patch them for you, ill patch one for eulemur, and the other for hillock, be right back.

No it's not. From 10.6.6 - 10.6.8 - 10.7.2 - 10.7.3 are all different. Even sizes are different.
Here is how I'm doing:

MacOSX:rom neolo$ dd if=ATI5000Controller of=1.orig bs=1 skip=163312 count=6464+0 records in
64+0 records out
64 bytes transferred in 0.000211 secs (303317 bytes/sec)
MacOSX:rom neolo$ xxd < 1.orig > 1.new
MacOSX:rom neolo$ cat 1.new
0000000: 0004 0000 0004 0000 0071 0000 1204 0402  .........q......
0000010: 0400 0000 1400 0000 0071 0000 0112 0104  .........q......
0000020: 0002 0000 1400 0000 0071 0000 0000 0603  .........q......
0000030: 0008 0000 0002 0000 0071 0000 2205 0501  .........q.."...

where after that modifying 1.new file with text editor and reversing the process

xxd -r < 1.new > 2.new
dd if=2.new of=ATI5000Controller bs=1 count=48 seek=163312 conv=notrunc

But this is for Vervet (and 64 side only) which not working for me. I don't have proper table for Eulemur :(

#69
Pockets69

Pockets69

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
yup there should be two tables one for 64 the other for 32, i can t find those on yours, now i don't know what the hell to do :S
damn it

#70
Neolo

Neolo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts

yup there should be two tables one for 64 the other for 32, i can t find those on yours, now i don't know what the hell to do :S
damn it

Told ya. It's simple - give me yours. No matter what version, they are all loads fine. Also make patch for your frame buffet framebuffer (omg, what the hell is wrong with this forum?) too. So I can have 3 chances =)

#71
Neolo

Neolo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
Look, he got it and left this topic. How nice.... Thanks! :| I can't get it work at all, patched almost all fb (found controller from 10.7.2 which matching the fb table) - nothing.

Posted Image
What the hell is that?

UPDATE: [Finally SOLVED!!! (Card detected, resolution native but no QE/CI) or I was going crazy]. Delete all ATI kexts from your system, install all kexts from zipped attachment below using kext wizard or manually, repair permissions and rebuild cache. Use next framebuffers: AtiConfig = Orangutan or Elodea or Iphomoea (only these are works for me), if they are not suits to you, try others, if still no luck, you should do hex patching of ATI5000Controller in case you have black screen (see this topic). GraphicsEnabler=Yes. Reboot and enjoy fully enabled QE/Ci.

P.S: [IMPORTANT] Was tested on 10.6.8 + Lion's kexts (attached) running on Acer Aspire 5553G. ATI Radeon Mobility 5650HD 1GB. If you have Lion installed, u probably will not have this problem, but if occurs, try to leave only those kexts, which names matching from attachment (but I thing you don't have to replace them because these ones are older).

Thanks for all participated this topic and sorry for flooding so much, hope you'll win in this 5650 mobility fight. :king:

Attached Files



#72
vilczech18

vilczech18

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male

Look, he got it and left this topic. How nice.... Thanks! :| I can't get it work at all, patched almost all fb (found controller from 10.7.2 which matching the fb table) - nothing. DAMN this bullish*t. I'm freaking mad! Posted Image What the hell is that? UPDATE: [Finally SOLVED!!! or I was going crazy]. Delete all ATI kexts from your system, install all kexts from zipped attachment below using kext wizard or manually, repair permissions and rebuild cache. Use next framebuffers: Elodea or Iphomoea (only these are works for me), GraphicsEnabler=Yes. Reboot and enjoy fully enabled QE/Ci. P.S: Was tested on 10.6.8 + Lion's kexts (attached) running on Acer Aspire 5553G. ATI Radeon Mobility 5650HD 1GB.

Which zip file? I downloaded the last you posted but It started terminal, that was not zip file.

#73
Neolo

Neolo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts

Which zip file? I downloaded the last you posted but It started terminal, that was not zip file.

Sorry, I modified previous post.

#74
vilczech18

vilczech18

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
So here's how it worked for me.:/

Attached Files



#75
Neolo

Neolo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts

So here's how it worked for me.:/

Why so sure it's related to these kexts? Looks like you used wrong kernel flags.
I use arch=i386 npci=0x2000

#76
vilczech18

vilczech18

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
What does ncpi mean?

Graphics works now, in system info I got correct value (2048MB) but I think graphics is still kinda slow. For example in lauchpad, there are no bugs like before but its not smooth at all..

I tried that 3 frame buffers but still slow. Do you think I should try different?

#77
vilczech18

vilczech18

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
I can't even start presentation in keynote..:/ (I couldn't before neither)

#78
Neolo

Neolo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts

I can't even start presentation in keynote..:/ (I couldn't before neither)

That means you have such step as I had where only native resolution without qeci, did you replaced kexts from zip file I gave? Did you removed all kexts with names ATI**** before that? Did you repaired permissions on whole partition? If yes. Than do next in console:

sudo chown -R root:wheel /boot
sudo chmod -R 755 /boot

it helped me in some cases when some kexts were unable to load.
And at last, try all FBs from list using Chameleon Wizard.

#79
vilczech18

vilczech18

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
I did. In System/Library/Extension I`ve searched "Ati" in extension folder and deleted all. Replaced with you zip and repaired + rebuilded cache in OSX86tools.

About that sudo chown -R ..etd - I have to to that in -s flag mode or can I do it in terminal?

OT: After installing yours kexts in that zip file, GPU worked better (in lauchapad no bugs, but slow..) and when I closed the lid or put my acer to sleep, I could not wake it. When I had old kexts, I could wake it on any key, but that wasn't sleep, just turned of display and sound.. Any suggestion how to make sleep working or disable it? (Make it work would b better:D)

That means you have such step as I had where only native resolution without qeci, did you replaced kexts from zip file I gave? Did you removed all kexts with names ATI**** before that? Did you repaired permissions on whole partition? If yes. Than do next in console:

sudo chown -R root:wheel /boot
sudo chmod -R 755 /boot

it helped me in some cases when some kexts were unable to load.
And at last, try all FBs from list using Chameleon Wizard.

Monkeys or every?

#80
Neolo

Neolo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
You can do that in terminal. Sleep - it's another question which not related to this topic. I guess monkeys only, but you can try other too. Something should work.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy