Jump to content

[GUIDE] Dell L701X (xps 17 late 2010)

- - - - -

  • Please log in to reply
455 replies to this topic

#41
Emperor_Mittens

Emperor_Mittens

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

just follow the 1st page procedure and it will be fine. did you remove the extra 12gb ram????


I've tried your solution with a number of different boot programs. Nawcom will not load to the Apple installation screen, however, two others will. I believe my BDROM drive is the main cause of my installation problems. Input / output errors abound in both preboot and Apple installation screen.

I will use another computer to install Mac OS X to a USB drive (when it arrives), and then use it with my L701x. I'm hoping that SAM Multimedia issues are not a persistent problem once I'm using it with my Dell...

*Crosses fingers*

#42
vladlenas

vladlenas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts

I've tried your solution with a number of different boot programs. Nawcom will not load to the Apple installation screen, however, two others will. I believe my BDROM drive is the main cause of my installation problems. Input / output errors abound in both preboot and Apple installation screen.

I will use another computer to install Mac OS X to a USB drive (when it arrives), and then use it with my L701x. I'm hoping that SAM Multimedia issues are not a persistent problem once I'm using it with my Dell...

*Crosses fingers*

Try mine

Attached Files



#43
johnie89

johnie89

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hey


Just wondering will the L701X_Files_v3 work with the exact same spec as you have except I've got
the NVIDIA GeForce GT 435M (1024 MB) and the Intel Core i5-560M.

I'll have a go at it later anyways, I just wanted to see if anyone knows if I'm gona have problems :)


Thanks
~J

#44
johnie89

johnie89

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Hey


Just wondering will the L701X_Files_v3 work with the exact same spec as you have except I've got
the NVIDIA GeForce GT 435M (1024 MB) and the Intel Core i5-560M.

I'll have a go at it later anyways, I just wanted to see if anyone knows if I'm gona have problems :)


Thanks
~J


I've tried your method above. I was able to install Mac OSX (10.6.0) without any issues until I tried updating to 10.6.6 using the Combo update. The update gets near to the end and then while running the scripts the following kernel panic happens.

I've included a pic.

Attached File  IMAG0013.jpg   1.43MB   52 downloads

If anyone could help out with any advice I'd be really grateful :)

#45
vladlenas

vladlenas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts

I've tried your method above. I was able to install Mac OSX (10.6.0) without any issues until I tried updating to 10.6.6 using the Combo update. The update gets near to the end and then while running the scripts the following kernel panic happens.

I've included a pic.

Attached File  IMAG0013.jpg   1.43MB   52 downloads

If anyone could help out with any advice I'd be really grateful :(

Download 10.6.6 Upd.,install,reboot and try this 10.6.7

#46
one9092002

one9092002

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts
  • Gender:Male
  • Location:san bernardino,ca
  • Interests:hackintosh,networking,programming graphic design,video editing

Posted Image

DELL L701X GUIDE!
(WorkInProgress)
a guide for install Snow Leopard and create a fantastic hackintosh (HEAVY) laptop.



Hardware Configuration:
CPU : Intel Core i7-740M
Chipset : Intel Ibex Peak-M HM57, Intel Lynnfield
RAM : 4GB DDR3-1333 (2X2 - 2Slot free)
Video : NVIDIA GeForce GT 445M (3072 MB)
Monitor : 1600X900
Audio : Realtek ALC665
HD : 500GB Sata
WiFi : Intel WiFi Link 1000 BGN (switched to Dell 1510, works OOB)
Ethernet : Gigabit Ethernet Realtek 8168


What work:
- NVIDIA GeForce GT 445M (3072 MB)
- HDMI Video out
- Realtek ALC665
- Gigabit Ethernet Realtek 8168
- 2MP Webcam
- Bluetooth
- Synaptic TrackPad (with 2 finger scrolling)
- Keyboard
- USB Ports (all 2.0 and 3.0)
- Deep Sleep (But No USB2 ports after resume!)


What not work:
- Intel WiFi Link 1000 BGN (switched to Dell 1510, works OOB)
- Sata Port (Not Tested, but probably work)
- SDCard Reader (Not Tested)
- HDMI Audio out
- Display Port (Not Tested)
- DVB-T card (Not Tested, but probably not work)

Bench:
GeekBench v2.1.12 result: 5200
XBench 1.3 (Without HD)result: 130



Installation
  • Use nawcom Mod CD 0.3.1 and a 10.6.3 DVD or USB image.
    NOTE: if you use like me a Installation from USB, don't use USB3 port.
    NOTE: deselect custom option in OSX installation from nawcom before install.
    Install on the first partition on an MBR or GPT HD.
  • After the installation Finish, reboot, and start the partition with nawcom.
  • Copy all necessary files on your desktop (USB not work after 10.6.6 installation)
  • Install 10.6.6 Combo Update dowloaded From Apple Website
  • Reboot and restart your partition with Nawcom.
  • Now, install Chameleon, i have used r699 by iReset, Downloaded Here
    Copy Extra Folder from attached file in your root.
    Delete AppleHDA.kext and IOAudioFamily.kext in System/Library/Extensions of your installation partition.
    Copy the files in "System-Lib-Ext" from attached file in System/Library/Extensions
    Run Kext Utility for repair permissions, recreate system cache And Reboot.
  • Boot From Your Installed Partition
  • Now install tonymacx86 NVIDIA Update, I have used 1.0.1(current).
  • Reboot
  • Now install Lnx2Mac's RTL81xx Driver
  • Reboot

NOTE: If you want DeepSleep, open Terminal and type: sudo pmset -a hibernatemode 5
NOTE: In the attached files is present a .icc for LG LCD panel Profile from ironnerd(notebookreview.com)
NOTE: Probably this guide works also for L401X and L501X with i7-740QM or i7 840QM CPU.

Future improvement:
- DSDT enhancement (nedd help for USB2 sleep problem)

Changes:
v2:
- DSDT from MaLd0n and Nexos™ in the pack default is the MaLd0n one.
- removed Lan from pack and added to the guide
- most recent FakeSMC and intel kext (tnx MaLd0n)
- other little things
v3:
- Removed VoodooHDA
- New patched DSDT (i patched the MaLd0n) for support ALC665 natively. (TNX vladlenas)
- New AppleHDA.kext and IOAudioFamily.kext. (TNX vladlenas)
- Reverted to 64bit.



theSLug



noob here i need your help

i have dell L502x
i7-2
hm67 chipset
nvidia geforce 525m 1gb

i boot with nawcom cd i cant boot with out the cd

i get error message saying no operating system found plz help i have tryed the 699 chamelon ##### and nothing any ideas?

#47
johnie89

johnie89

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Download 10.6.6 Upd.,install,reboot and try this 10.6.7

But I can't install the combo update 10.6.6 thats the problem.

As I said in my last post, when I run the combo update installation, it crashes just before the end (while "Moving items into place").

#48
vladlenas

vladlenas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts

But I can't install the combo update 10.6.6 thats the problem.

As I said in my last post, when I run the combo update installation, it crashes just before the end (while "Moving items into place").

I apologize, has badly read.

HDMI-AUDIO.
Add in PEGP sec.
Method (_DSM, 4, NotSerialized)                    {                        Store (Package (0x2A)                            {                                "@0,AAPL,boot-display",                                 Buffer (Zero) {},                                 "AAPL,slot-name",                                 Buffer (0x07)                                {                                    "Slot-1"                                },                                 "@0,backlight-control",                                 Buffer (0x04)                                {                                    0x01, 0x00, 0x00, 0x00                                },                                 "@0,pwm-info",                                 Buffer (0x18)                                {                                    /* 0000 */    0x02, 0x18, 0x00, 0x64, 0xAE, 0x5A, 0x01, 0x00,                                     /* 0008 */    0x08, 0x52, 0x00, 0x00, 0x82, 0x10, 0x00, 0x00,                                     /* 0010 */    0x00, 0x04, 0x00, 0x00, 0x01, 0x00, 0x00, 0x00                                },                                 "@0,display-cfg",                                 Buffer (0x04)                                {                                    0x03, 0x01, 0x00, 0x00                                },                                 "AAPL,aux-power-connected",                                 Buffer (0x04)                                {                                    0x01, 0x00, 0x00, 0x00                                },                                 "@0,built-in",                                 Buffer (Zero) {},                                 "@0,compatible",                                 Buffer (0x0B)                                {                                    "NVDA,NVMac"                                },                                 "@0,device_type",                                 Buffer (0x08)                                {                                    "display"                                },                                 "@0,name",                                 Buffer (0x0F)                                {                                    "NVDA,Display-A"                                },                                 "@0,use-backlight-blanking",                                 Buffer (Zero) {},                                 "@1,can-hot-plug",                                 Buffer (Zero) {},                                 "@1,compatible",                                 Buffer (0x0B)                                {                                    "NVDA,NVMac"                                },                                 "@1,device_type",                                 Buffer (0x08)                                {                                    "display"                                },                                 "@1,name",                                 Buffer (0x0F)                                {                                    "NVDA,Display-B"                                },                                 "NVCAP",                                 Buffer (0x14)                                {                                    /* 0000 */    0x04, 0x00, 0x00, 0x00, 0x00, 0x00, 0x01, 0x00,                                     /* 0008 */    0x3E, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x0A,                                     /* 0010 */    0x00, 0x00, 0x00, 0x00                                },                                 "VRAM,totalsize",                                 Buffer (0x04)                                {                                    0x00, 0x00, 0x00, 0x80                                },                                 "device_type",                                 Buffer (0x0C)                                {                                    "NVDA,Parent"                                },                                 "model",                                 Buffer (0x10)                                {                                    "GeForce GT 435M"                                },                                 "rom-revision",                                 Buffer (0x0F)                                {                                    "70.16.25.00.25"                                },                                 "hda-gfx",                                 Buffer (0x0A)                                {                                    "onboard-1"                                }                            }, Local0)                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))                        Return (Local0)                    }
in HDEF sec.
Method (_DSM, 4, NotSerialized)                {                    Store (Package (0x06)                        {                            "layout-id",                             Buffer (0x04)                            {                                0x99, 0x02, 0x00, 0x00                            },                             "hda-gfx",                             Buffer (0x0A)                            {                                "onboard-1"                            },                             "PinConfigurations",                             Buffer (Zero) {}                        }, Local0)                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))                    Return (Local0)                }
And in P0P2 sec.
Device (HDAU)                {                    Name (_ADR, One)                    Method (_DSM, 4, NotSerialized)                    {                        Store (Package (0x02)                            {                                "hda-gfx",                                 Buffer (0x0A)                                {                                    "onboard-1"                                }                            }, Local0)                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))                        Return (Local0)                    }                }

Attached Files



#49
robcoffee

robcoffee

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Excellent work theSlug, because of this thread I picked up an L701X from Dell outlet - refurb unit - i7, 750gb hd and 4gb ram for a steal of £500 + VAT, added 4gb more ram and a 500gb 7200rpm hybrid hd for main boot drive and the Dell 1510 wifi card. Loving the laptop, and thanks to your guide I have Snow Leopard running perfect 10.6.7, touchpad is smooth with side scrolling and full graphics acceleration. If there was a competition for the best Hackintosh laptop, the L701X must surely be near the top!

Attached Files



#50
sybexs

sybexs

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts

noob here i need your help

i have dell L502x
i7-2
hm67 chipset
nvidia geforce 525m 1gb

i boot with nawcom cd i cant boot with out the cd

i get error message saying no operating system found plz help i have tryed the 699 chamelon ##### and nothing any ideas?


Have you had any luck in getting it to install and boot up? i am having the same problems on the l702x.

#51
sybexs

sybexs

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts

I apologize, has badly read.

HDMI-AUDIO.
Add in PEGP sec.

Method (_DSM, 4, NotSerialized)                    {                        Store (Package (0x2A)                            {                                "@0,AAPL,boot-display",                                 Buffer (Zero) {},                                 "AAPL,slot-name",                                 Buffer (0x07)                                {                                    "Slot-1"                                },                                 "@0,backlight-control",                                 Buffer (0x04)                                {                                    0x01, 0x00, 0x00, 0x00                                },                                 "@0,pwm-info",                                 Buffer (0x18)                                {                                    /* 0000 */    0x02, 0x18, 0x00, 0x64, 0xAE, 0x5A, 0x01, 0x00,                                     /* 0008 */    0x08, 0x52, 0x00, 0x00, 0x82, 0x10, 0x00, 0x00,                                     /* 0010 */    0x00, 0x04, 0x00, 0x00, 0x01, 0x00, 0x00, 0x00                                },                                 "@0,display-cfg",                                 Buffer (0x04)                                {                                    0x03, 0x01, 0x00, 0x00                                },                                 "AAPL,aux-power-connected",                                 Buffer (0x04)                                {                                    0x01, 0x00, 0x00, 0x00                                },                                 "@0,built-in",                                 Buffer (Zero) {},                                 "@0,compatible",                                 Buffer (0x0B)                                {                                    "NVDA,NVMac"                                },                                 "@0,device_type",                                 Buffer (0x08)                                {                                    "display"                                },                                 "@0,name",                                 Buffer (0x0F)                                {                                    "NVDA,Display-A"                                },                                 "@0,use-backlight-blanking",                                 Buffer (Zero) {},                                 "@1,can-hot-plug",                                 Buffer (Zero) {},                                 "@1,compatible",                                 Buffer (0x0B)                                {                                    "NVDA,NVMac"                                },                                 "@1,device_type",                                 Buffer (0x08)                                {                                    "display"                                },                                 "@1,name",                                 Buffer (0x0F)                                {                                    "NVDA,Display-B"                                },                                 "NVCAP",                                 Buffer (0x14)                                {                                    /* 0000 */    0x04, 0x00, 0x00, 0x00, 0x00, 0x00, 0x01, 0x00,                                     /* 0008 */    0x3E, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x0A,                                     /* 0010 */    0x00, 0x00, 0x00, 0x00                                },                                 "VRAM,totalsize",                                 Buffer (0x04)                                {                                    0x00, 0x00, 0x00, 0x80                                },                                 "device_type",                                 Buffer (0x0C)                                {                                    "NVDA,Parent"                                },                                 "model",                                 Buffer (0x10)                                {                                    "GeForce GT 435M"                                },                                 "rom-revision",                                 Buffer (0x0F)                                {                                    "70.16.25.00.25"                                },                                 "hda-gfx",                                 Buffer (0x0A)                                {                                    "onboard-1"                                }                            }, Local0)                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))                        Return (Local0)                    }
in HDEF sec.
Method (_DSM, 4, NotSerialized)                {                    Store (Package (0x06)                        {                            "layout-id",                             Buffer (0x04)                            {                                0x99, 0x02, 0x00, 0x00                            },                             "hda-gfx",                             Buffer (0x0A)                            {                                "onboard-1"                            },                             "PinConfigurations",                             Buffer (Zero) {}                        }, Local0)                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))                    Return (Local0)                }
And in P0P2 sec.
Device (HDAU)                {                    Name (_ADR, One)                    Method (_DSM, 4, NotSerialized)                    {                        Store (Package (0x02)                            {                                "hda-gfx",                                 Buffer (0x0A)                                {                                    "onboard-1"                                }                            }, Local0)                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))                        Return (Local0)                    }                }


Vladlenas Does your ALC665 kext only work with a dsdt? The l702x uses the same audio as the l701 and I cant seem to get it to work. I am pretty new with dsdt editing and I am not sure if it would have to be remapped.

Also do you plan on releasing a non-dsdt version?

#52
vladlenas

vladlenas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts

Vladlenas Does your ALC665 kext only work with a dsdt? The l702x uses the same audio as the l701 and I cant seem to get it to work. I am pretty new with dsdt editing and I am not sure if it would have to be remapped.

Also do you plan on releasing a non-dsdt version?

There are no problems, try and write result.

Attached Files



#53
styleminister

styleminister

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
isn't there any chance out there to get the Intel WiFi Link 1000 BGN work properly? and if, why it's that difficult? :(

#54
vladlenas

vladlenas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts

isn't there any chance out there to get the Intel WiFi Link 1000 BGN work properly? and if, why it's that difficult? :(

Is not present what in the near future.

#55
bombadil7

bombadil7

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
hi, i want to buy a DELL 1510 wlan card, the install mac os on my xps 17

1. can i use this card also with windows 7 (i want to try a dual boot for first)

2. it's difficult to remove the intel card and install the new one?

thanks for the help

#56
vladlenas

vladlenas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts

hi, i want to buy a DELL 1510 wlan card, the install mac os on my xps 17

1. can i use this card also with windows 7 (i want to try a dual boot for first)

2. it's difficult to remove the intel card and install the new one?

thanks for the help

1.Perfectly works.
2.Five minutes of work.

#57
Grandefede

Grandefede

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 138 posts
I installed a retail leo whit combo upgrade at 10.6.7, I installed some programs and everything work, but everytimes, when on desktop there is an animation (as dock) the system freezes.
May be nvidia driver problem?

#58
tjesis

tjesis

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Netherlands

I installed a retail leo whit combo upgrade at 10.6.7, I installed some programs and everything work, but everytimes, when on desktop there is an animation (as dock) the system freezes.
May be nvidia driver problem?


I have exactly the same freezes with 10.6.7.
Have not tried with 10.6.6

Hopefully there is an easy fix for this.

#59
vladlenas

vladlenas

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
Grandefede,tjesis.And what videocards at you.

#60
bombadil7

bombadil7

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
thanks vlad..

anyway i have always kernel panic after installing the kexts.. FakeSMC error

i installed 2 times the system, i put the kexts and fix permissions.. but everytime i boot after putting fakesmc the system got kernel panic.. i neither can enter safe mode.. same error

please help me =)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy