Jump to content

Chameleon 2.3svn Official PKG Installer & Binaries

Bootloader Chameleon

  • Please log in to reply
2549 replies to this topic

#1521
rayap

rayap

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 163 posts
  • Gender:Male
With Chameleon-2.2svn-r2140, me too can only boot with -f
Looks like the extensions in /E/E do not load otherwise.

#1522
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,741 posts
  • Gender:Male
  • Location:Canary Islands
Install also the KernelPatcher.dylib module in Extra/modules.

Fabio

#1523
Larx

Larx

    InsanelyMac Geek

  • Donators
  • 230 posts
  • Gender:Male
  • Interests:Music, hackintosh, mac

Install also the KernelPatcher.dylib module in Extra/modules.

Fabio


THANKS FABIO ! Working now ! :D

#1524
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,896 posts
  • Gender:Male
  • Location:Stuttgart / Germany

Install also the KernelPatcher.dylib module in Extra/modules.

Fabio


Would be nice to get some infos about what module is needed and for what.
I use newer chameleon builds but never installed any of the modules in modules folder (for me its empty).
I use also C2D.

#1525
rayap

rayap

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 163 posts
  • Gender:Male

Install also the KernelPatcher.dylib module in Extra/modules.

Fabio

Works but appear not to load patched AppleRTC.kext from /E/E only from /S/L/E.
Thanks anyway.

#1526
meklort

meklort

    InsanelyMac Geek

  • Developers
  • 136 posts
  • Gender:Male

Works but appear not to load patched AppleRTC.kext from /E/E only from /S/L/E.


If AppleRTC is already in /S/L/E, the kernel will always use the one in the prelinked kernel.

#1527
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,480 posts
  • Gender:Male
  • Location:Tru, Venezuela
Hi rayap. In Mountain Lion 10.8 (also Lion 10.7) none extension will not load from /E/E using "UseKernelCache=Yes" which is the option by default (to bring fast boot). But it works with "UKC=No" (slow boot), because those OS X versions have kernelcache (prelinked kernel) instead of Extensions.mkext (Snow Leopard 10.6). Regards.

#1528
rayap

rayap

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 163 posts
  • Gender:Male
Thanks Guys. Previously revisions no issues, with patched AppleRTC in /E/E and retained vanilla AppleRTC in /S/L/E. Now resolved with r2140 by including KernelPatcher.dylib and deleting vanilla AppleRTC from S/L/E. Have never set "UseKernelCache" either way. Trying to keep S/L/E vanilla except for AppleHDA.

#1529
rvxtm

rvxtm

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 109 posts
  • Gender:Male
  • Location:Timisoara, Romania
  • Interests:Tech, Science, Biology, OSX86 stuff
My question is : do you still have to use "UseKernelCache=1" or is it default enabled even if i use the kernel patcher module for /e/e ?



#1530
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,480 posts
  • Gender:Male
  • Location:Tru, Venezuela
Just for record, "UseKernelCache=Yes" is the default option in Chameleon 2.1 and 2.2 svn.

#1531
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 181 posts
  • Gender:Male
  • Location:Bangladesh
With latest 2140 2.2svn my system goes on kp :(
Attached File  2013-01-02_20-46-41.jpg   727.41KB   83 downloads

System description on signature.

Thanks
Palash

#1532
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,480 posts
  • Gender:Male
  • Location:Tru, Venezuela
Hi plsh2me. There is nothing to do about Chameleon 2.2svn, you need a NULLCpuPowerManagement.kext (to pass the 0xE2 MSR registers in Sandy Bridge CPUs) until patching the AICPUPM.kext (using AICPMPatch), and also is recommended to fix your DSDT or SSDT table of P-States (see this topic for more information). Another recommendation, please forget about using .kexts from /E/E, just install it all them in /S/L/E and set "UseKernelCache=Yes". Good Luck.

#1533
k3nny

k3nny

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 553 posts
  • Gender:Male
Hi, compiled r2152 from voodooprojects to test the HD4000 in 10.8.3 but it hangs during the injection.
Tried dirrefent iGPU RAM settings from 32-96MB in combination with Virtu MPV setting which just seems to power on the iGPU when the dedicated card is selected. No success yet.
HD4000: PCI\VEN_8086&DEV_0162&SUBSYS_84CA1043&REV_09

One more thing. r2152 shows a huge log scanning each extension in /S/L/E which lasts about one minute.
Is there a setting to turn off this behavior?

#1534
oswaldini

oswaldini

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
  • Gender:Male
  • Location:Cracow, Poland
If i use "-v ncpi=0x2000 dart=0" at boot from command prompt everything is OK but when I put this in org.chameleon.Boot.plist loading stopped. With clean section Kernel Flags in org.chameleon.Boot.plist everything is OK.

Enoch 2151 and regular trunk 2153 has the same issue.
I report that issue at http://forge.voodoop...eon/issues/314/

#1535
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male
Is it posible to wake my computer with a mouse or keyboard if I use Chamelion?

#1536
oswaldini

oswaldini

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
  • Gender:Male
  • Location:Cracow, Poland
Yes if you are using USB, you must set it in BIOS. I don't know how it works with PS2

#1537
rvxtm

rvxtm

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 109 posts
  • Gender:Male
  • Location:Timisoara, Romania
  • Interests:Tech, Science, Biology, OSX86 stuff
One question, i use RealtekRTL81xx.kext (macman's realtek driver) , if i put it in s/l/e , it loads ok, but if i put it in e/e , it does not load at all, and yes, i use the kernelpatcher plugins for chameleon. FakeSMC loads, my audio driver loads and my sata driver loads ok, only the realtek kext refuses to load.

Is this behaviour normal ? i need to use it in e/e to use the internet for the first boot, without the need to boot into another OSX partition and move it to s/l/e.

Thanks.

#1538
vantin1992

vantin1992

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi there, do we still need to disable Fast Startup for Windows 8 with the new Chameleon when triple boot with Mountain Lion and Ubuntu on Hybrid GPT/MBR disk?

#1539
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
Hello, folks!

I've been trying to make the boot screen (that gray one that has the Apple logotype with the spinning pinwheel right bellow it) to appear with the correct resolution - not the annoying stretched one, in some cases smaller than the screen resulting in an ugly black frame around the screen - but any of my attempts ended in failure. I use graphics cards that are otherwise fully working: respectively, an Ion nVidia, a G210 and a 9800 GT. How can i get them to recognize and put to the proper resolution the boot screen?

Another related question: how can i use the boot screen that's used by real macs and also by clover? It's slightly different from the one given by the "legacy logo" option because it has a bas-relief effect on the dark-gray Apple logo. I suppose it's inside boot.efi, since clover can use it, but i cannot access it and, even if i could, i wouldn't know how to put it in chameleon.

Thank you very much.

#1540
gothic860

gothic860

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
  • Gender:Male
  • Location:Germany, Bavaria
enoch i386 folder link is broken on 1 page.

EDIT: Fixed or i made a mistake. Thanks anyway :).






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy