Jump to content

TeamViewer not working on 10.6.2


  • Please log in to reply
29 replies to this topic

#1
Ender Wiggin

Ender Wiggin

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
Hello all,

I recently installed 10.6.2 on my PC using the retail version + myHack RC5. Everything works great except TeamViewer which refuses to connect to it's servers and thus it's unusable with any computer outside the home network.

A very polite email to TeamViewer support was answered with a "Buzz off, you don't have an original Mac!" email.

So can anybody here help solving this problem. Anybody run into it and found a way around it?

#2
kamuiGT

kamuiGT

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
I had the exact same problem. Customer support said I didn't have an original Mac and asked if I had a meaningful serial on my Mac.

#3
Ender Wiggin

Ender Wiggin

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
As far as I can determine, the software is checking or using the serial number of the mac in order to connect to the server. And since the one in my box is "SOMESRLNMBR"...

Can this thing be changed somehow?

#4
tha_toadman

tha_toadman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 336 posts
  • Gender:Male
Ahh. That explains it! I encountered the same thing recently with that software as well.

I'm thinking that an SMBIOS file could solve that.

#5
sendblink23

sendblink23

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts
  • Gender:Male
  • Location:Guaynabo, PR
  • Interests:Bassist for the band: "La Hermana De Miguel" - http://myspace.com/lahermana...

Hello all,

I recently installed 10.6.2 on my PC using the retail version + myHack RC5. Everything works great except TeamViewer which refuses to connect to it's servers and thus it's unusable with any computer outside the home network.

A very polite email to TeamViewer support was answered with a "Buzz off, you don't have an original Mac!" email.

So can anybody here help solving this problem. Anybody run into it and found a way around it?



I would Reply Email them back and say F* YOU!

#6
HappyDenn

HappyDenn

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Taiwan
By faking a serial number (which makes the hack looking more like a real deal) in SMBIOS, I can use TeamViewer just fine.

#7
Espionage724

Espionage724

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 639 posts
  • Gender:Male
  • Location:Charleroi, PA 15022
Mine works fine.

fakesmc 2.5 with a default smbios.plist from latest chameleon untouched

#8
hermann88

hermann88

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
I solved this problem... Also me had te problem: "Access to the teamviewer server has been denied". To solve this annoying problem, I've installed the last Chameleon, and placed smbios.plist in the Folder Extra .. Remember to change the SMserial string into the smbios file with a random one!!!
sorry for my bad english, but if you need an help I can help you

#9
Guest: BuxB_*

Guest: BuxB_*
  • Guests
also TW here does not run when I am logged in as root (yeah yeah I know I should not be running a remote software anyhow logged in as root ..). Logging in as standard user but with admin rights (dunno if that makes a diff) TW runs just fine. Same machine with same SMBIOS.plist in Extra.

#10
bethere

bethere

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

I solved this problem... Also me had te problem: "Access to the teamviewer server has been denied". To solve this annoying problem, I've installed the last Chameleon, and placed smbios.plist in the Folder Extra .. Remember to change the SMserial string into the smbios file with a random one!!!
sorry for my bad english, but if you need an help I can help you


Hello can you help me ?

same problem here.. can you tell me how to edit your smbios.plist and what you mean by random one.. do you mean a random number or a fake teamviewer serial number ?



Thanks

#11
hermann88

hermann88

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male

Hello can you help me ?

same problem here.. can you tell me how to edit your smbios.plist and what you mean by random one.. do you mean a random number or a fake teamviewer serial number ?



Thanks


Here you are my smbios http://www.mediafire.com/?3ctadwj1fiy

#12
kexik

kexik

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
How about faking serial number?

#13
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i

How about faking serial number?

well just look into the smbios.plist Hermann88 provided and copy/paste the serial into yours, then you do not have to figure it out by yourself, that's what he provided it for .. :D

I dare say we are talking about this key here, right?

<key>SMserial</key>
<string>W88033FKY51</string>

and not

<key>SMmemserial</key>
<string>100000000</string>

#14
joedr

joedr

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
I placed the smbios.plist on my Extra folder and still have the same error.

I also changed the serial.

Anyone willing to add a more detailed explanation on how to get this done?

Appreaciate your help in advanced!

#15
joedr

joedr

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

I placed the smbios.plist on my Extra folder and still have the same error.

I also changed the serial.

Anyone willing to add a more detailed explanation on how to get this done?

Appreaciate your help in advanced!


I tried a different smbios.plist and works like a charm now.

Thanks!

#16
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
joedr, can you please zip and attach "the different smbios.plist"?

Thx!

#17
joedr

joedr

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
Here is the one on my extra folder!

Attached Files



#18
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
.. working! Thx

#19
dj_Duff

dj_Duff

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Moscow

Here is the one on my extra folder!

Yes, TeamViewer works now with this plist (i've edited SN) !!
thanks!!!

#20
joedr

joedr

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
I am glad it is working for you guys!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy