Jump to content

AppleIntelE1000e.kext for 10.8/10.7/10.6/10.5


  • Please log in to reply
677 replies to this topic

#61
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 307 posts
  • Gender:Male

Thanks! please check link to sources in readme.txt(http://osx86drivers.sourceforge.net/)

Go to source link ( http://sourceforge.n...6drivers/files/ ) and click "Develop" to show how to get the source code.
In short, use subversion as follows to get the source code ( of all the projects )

svn co https://osx86drivers...ot/osx86drivers osx86drivers

#62
wayover

wayover

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts

Go to source link ( http://sourceforge.n...6drivers/files/ ) and click "Develop" to show how to get the source code.
In short, use subversion as follows to get the source code ( of all the projects )

svn co https://osx86drivers...ot/osx86drivers osx86drivers

It's easy way to get source code. Thanks a lot!

#63
SS_G

SS_G

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
How to make 82575EB working?
I have Intel® Workstation Board S5520SC.

#64
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 307 posts
  • Gender:Male
A new version based on 1.3.10a has been tested and uploaded ( in the first post of this topic ).
It took some time to install a working SandyBridge system on my DH67CF for testing.

#65
dontblinknow

dontblinknow

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Thought I'd add my experiences with this kext as well.

In general the driver seems to work fine, however with a good amount of network traffic, I can cause it to get into a kernel panic relatively quickly. I can do this by running utorrent on mac for a download that takes a long time (try a 4 GB iso for example).

I'm running 10.6.7 with a Asus P8P67 Pro/intel 2600k cpu.

My kernel panics always have the error along the lines of "m_free: freeing an already freed mbuf"

Anyone else see this behavior?

#66
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 307 posts
  • Gender:Male

My kernel panics always have the error along the lines of "m_free: freeing an already freed mbuf"

Are there any console messages right before that ?

Let me know whether the following build makes any difference.

http://www.mediafire...bgav3ib4i9gmkm6

#67
dontblinknow

dontblinknow

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Are there any console messages right before that ?

Let me know whether the following build makes any difference.

http://www.mediafire...bgav3ib4i9gmkm6



Nothing telling in the console messages. This only happens when I use a network intensive application like uTorrent. It was happening within the first 30 minutes on a big torrent (> 10 GB) with the latest version of uTorrent, but after going back to an older version the mean time of failure is now about 6-8 hours.

I'll take a picture of the actual kernel panic next time if that helps.

Thanks for the new build. I'll try running it and see if it makes a difference.

#68
dontblinknow

dontblinknow

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Nothing telling in the console messages. This only happens when I use a network intensive application like uTorrent. It was happening within the first 30 minutes on a big torrent (> 10 GB) with the latest version of uTorrent, but after going back to an older version the mean time of failure is now about 6-8 hours.

I'll take a picture of the actual kernel panic next time if that helps.

Thanks for the new build. I'll try running it and see if it makes a difference.



Kernel panic occurred again, but I was unfortunately not able to capture the image. Will try to do so if it happens again, but for now this build does not fix the issue.

#69
dontblinknow

dontblinknow

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

Kernel panic occurred again, but I was unfortunately not able to capture the image. Will try to do so if it happens again, but for now this build does not fix the issue.


I think that previous kernel panic may have been a fluke. Been running now for over 6 hours with no issues with the new build you posted. Will let you know if there are any other issues but it seems very promising.

#70
dontblinknow

dontblinknow

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

I think that previous kernel panic may have been a fluke. Been running now for over 6 hours with no issues with the new build you posted. Will let you know if there are any other issues but it seems very promising.



Been running over 24 hours now, and no issues. Thanks for the fix!

#71
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 307 posts
  • Gender:Male

Been running over 24 hours now, and no issues. Thanks for the fix!

Good to hear that !
I updated the first post link.

#72
VooD

VooD

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 781 posts
  • Gender:Male
  • Location:Spain

Good to hear that !
I updated the first post link.


So are 82579 nics finally working fast and stable?

#73
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 307 posts
  • Gender:Male

So are 82579 nics finally working fast and stable?

Though I don't have the answer, I am using this kext myself regularly on DH67CF and DZ68DB.

#74
VooD

VooD

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 781 posts
  • Gender:Male
  • Location:Spain

Though I don't have the answer, I am using this kext myself regularly on DH67CF and DZ68DB.

Thanks for the answer, other user also reported is working perfectly with 82579.

#75
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 307 posts
  • Gender:Male
Code base updated to 1.3.17.

#76
cmf

cmf

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 145 posts
thanks, working nicely on my intel dx58so2 board :P (i82567L and i82574L, 0x10cd/0x10d3 *feeding the search engine*)

oh, and 10.7 dp4, of course :unsure:

#77
Cipolippo

Cipolippo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:Genova
1.3.17. don't work on intel 82579 id 0x1503 on Asus p8z68-v .. ;) Any idea?
Thanks.

#78
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 307 posts
  • Gender:Male

1.3.17. don't work on intel 82579 id 0x1503 on Asus p8z68-v .. :o Any idea?
Thanks.

Mine is also 0x1503, and working naturally.
How NOT work ? - driver not loaded, crash, no carrier, no IP, 1.2.10a works but 1.3.17 not, etc.

#79
ajaylion

ajaylion

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
doesn't work on lion ;) works well on sl

#80
Cipolippo

Cipolippo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:Genova

Mine is also 0x1503, and working naturally.
How NOT work ? - driver not loaded, crash, no carrier, no IP, 1.2.10a works but 1.3.17 not, etc.

Mine is Intel® 82579V Gigabit Network Connection PCI\VEN_8086&DEV_1503&SUBSYS_849C1043&REV_05 on Asus P8Z68-V and Core i7 2600K
i try 1.2.10a and now 1.3.17 on dp4 11A494A lan connect dhcp asign ip bad, manualy config not work. no internet connect in any mode.
I not tray sl.
Thanks.





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy