Jump to content

cmf

Members
  • Content count

    144
  • Joined

  • Last visited

  1. okay, a bit weird, but if the BIOS says it is a GK110B, it is one. also: 10.9.1 has no updated nvidia drivers just some new GeForceTesla drivers (still R310) and updated OpenCL framework (so you might want to give this a try).
  2. yeah, definitely GK110B: "GK110B P2083 SKU 21 VGA BIOS" (@0x686) original GTX 780 is just "GK110" and "SKU 20", Titan is "SKU 10" and GTX 780 Ti is "SKU 30". The "A1" in GPU-Z might be hardcoded, what does it say in the OS X System Information / Revision ID?
  3. http://www.insanelymac.com/forum/topic/288721-gtx-780/ And yes, GPU-Z should be able to dump the BIOS. I also noticed that Nvidia actually announced CUDA 6 yesterday (for whatever reason not on their own blog ...), but no SDK or OS X drivers yet. The R330 Windows/Linux drivers have support for it though.
  4. What's the device id and revision id of your card? And can you make a BIOS dump and upload it? I wasn't aware of any chip changes in the GTX 780 line, but they might have started using the same revised chips that they're also using for the GTX 780 Ti (GK110B). I'm also annoyed by the 10.9.1/10.9.2 situation. I did expect a release this week, but maybe next week then ... On another note: CUDA 6 will be released soon (maybe at SC13 next week?), so I also expect new drivers from Nvidia (probably R330 if they had to do the same changes/additions like they had to on Linux/Windows). @any mod who's reading this: could splice the last few posts into the GTX 780 thread (#125 onwards)? Because this really doesn't belong here. And then close this thread, because there is nothing more to say since 10.9.
  5. I don't know about Clover, but in chameleon I have to disable the "GraphicsEnabler", otherwise I wouldn't even get to the login screen. But since it's working fine if I disable that option, this obviously means the card is supported as-is by OS X (full EFI support I guess?). Does Clover have a similar option? And yeah, if OpenCL doesn't work properly, you're screwed, because CoreImage uses it - so about _everything_ in OS X. I'm using the MacPro5,1 profile btw, but this shouldn't make much of a difference.
  6. are you sure you installed mavericks correctly? maybe some installer utility you used messed something up? driver version should be 8.18.22 (apple version) and/or 310.40.05f01 (nvidia version) - better check all GeForce* and NVDA* kexts. thats exactly the same driver that was already used in DP7, DP8 and the first GM.
  7. This fix was never meant for any GK1xx cards and might even result in problems, because sm_2x (fermi) != sm_3x (kepler). Although the compiled binaries should generally be upwards compatible, there might be other things that get messed up because of the different sm version. That being said, this fix isn't even necessary any more in 10.9 (even for sm_21 cards) as I've already written in the first post (the compiler in 10.9 can properly produce and handle up to sm_35 code now - thats GK110). Concerning the GTX 780: I have no issues besides the general OpenGL slowness of the driver (really hoping for R330 drivers in 10.9.1 or 10.9.2 soon ...). On the other hand, OpenCL is actually pretty fast and you probably won't see any performance increases in future drivers as it is already at the max - at least for well written programs. It scales pretty much perfectly for my code (6x over a GT650M). So, I don't know what you did wrong, but it should just work OOTB in 10.9.
  8. just tested my gtx 560 ti in 10.9 DP8 and everything is working ootb.
  9. This thread applies to fermi cards only, where non-GF100/GF110 means any GF10x/GF11x card where x != 0 For GK110 based cards (Titan and 780), I'd highly recommend updating to 10.9 - I doubt we'll ever see full and proper OpenCL support for these in 10.8. In 10.9 OpenCL is working OOTB on these cards. And since I haven't mentioned it anywhere yet: 780 OpenCL support has been added in some earlier DP.
  10. cmf

    GTX 780

    quick update: dp4 still has R310 drivers, but with a slightly updated version (310.40.05b18). and the apple version changed to 8.18.12 (from 8.16.* before). I've also installed dp4 on my workstation now and the gtx 780 does indeed work in dp4, including opencl support! there might be a few graphical glitches in some apps, but no crashes or kernel panic so far note that the gtx 780 is recognized as "NVIDIA GK11x" (and "Pre-Release GK11x OpenGL Engine") by os x, but this shouldn't be much of an issue. also note: I couldn't get the dp1 installer to work (hangs after windowserver started up), so I'd recommend copying an dp4 image from another mac or installing with another graphics card for now.
  11. cmf

    GTX 780

    @hackimacki: still R310 in dp3 (310.40.05b06), still glitches and general problems even on my mbp, so nope. @davidm71: I'm not sure actually, since you don't need the GraphicsEnabler any more, but you might need a newer chameleon version for "nvda_drv" support.
  12. cmf

    GTX 780

    ha, I didn't think that apple would actually bother back porting gtx 780 code to R310 drivers. I'll still wait for the DP3/DP2 update next monday before testing 10.9 on my workstation though. and yeah, nvidias 10.8.4 drivers obviously won't work in 10.9 (they don't even work across 10.8.x versions). so, hoping/waiting for R313 drivers in DP3 (although there are chances we might get a 310.40.00.10 driver first, since there is a library for that one contained in the CUDA framework ...) also: updating first post with info for intel mainboards ...
  13. cmf

    GTX 780

    haven't tested 10.9 yet (still uses R310 drivers like 10.8.4, so probably not gonna work anyways), but nvidia has just released updated drivers for 10.8.4: http://us.download.nvidia.com/Mac/Quadro_Certified/313.01.02f01/WebDriver-313.01.02f01.pkg (will test this soon, chances should be good though) edit: working
  14. cmf

    GTX 780

    hm, don't think npci actually matters. what's "ub method"? and which chameleon version/revision are you using? I should try using macpro3,1 instead of 5,1 though ... were you using 5,1 before? edit: still a nope for me, using npci=0x3000 and macpro3,1 edit2: using latest chameleon trunk source now, still the same issue ... which chameleon modules are you using btw? edit3: alright, got it working when I set "GraphicsEnabler" to "No" opencl is however still broken (I'd assume this just isn't fully implemented in the drivers yet, especially considering the windows/linux drivers have a lot of opencl issues, too) I have it semi-working* using another nvidia card as the primary card for now. chameleons secondary card detection sucks though ... will have to fix that when I got the time. *semi-working: no opengl on the 780, opencl fails (context creation and device querying works fine, but it segfaults on command queue creation), cuda works however (hello 2 tflop/s nbody). opencl info is pretty much identical to other kepler cards: [Device 1] Name: GeForce GTX 780 Vendor: NVIDIA Corporation Type: GPU Device Version: OpenCL 1.1 Device C Version: OpenCL C 1.1 Driver Version: 8.14.11 313.01.01f03 Compute Units: 12 Work Group Size: 1024 Clock: 901 MHz Global Memory: 3072 MB Local Memory: 48 KB Cache Size: 0 Bytes Cache Line Size: 0 Bytes Available: Yes Double-Precision: No Extensions (13): cl_APPLE_ContextLoggingFunctions cl_APPLE_SetMemObjectDestructor cl_APPLE_clut cl_APPLE_fp64_basic_ops cl_APPLE_gl_sharing cl_APPLE_query_kernel_names cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_gl_event cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics
  15. cmf

    GTX 780

    quick how to: install 10.8.4 install latest chameleon (svn trunk) set "GraphicsEnabler" to "No" in org.chameleon.Boot.plist (setting this to Yes will make the login screen not show up!) add "nvda_drv=1" to your "Kernel Flags" install and enable R313 nvidia drivers (http://us.download.nvidia.com/Mac/Quadro_Certified/313.01.02f01/WebDriver-313.01.02f01.pkg) this should be the point where you swap your old graphics card with your gtx 780 or: install 10.9 install latest chameleon (svn trunk) set "GraphicsEnabler" to "No" in org.chameleon.Boot.plist note: if you're using an intel main board and can't even reach your bios or boot loader (just a "0_" in the lower right corner of your screen), you'll have to update your gtx 780 to a newer bios: http://www.evga.com/forums/tm.aspx?m=1944772 (I'm not sure that this will work on non-EVGA cards and I have no idea if other vendors have updated bios versions for their cards). opencl is known not to work (driver issues, need to wait for newer drivers), cuda (5.0 and 5.5) does work however. original post:
×