Jump to content

[AMD] Installing Snow Leopard 10A432 on AMD System


  • Please log in to reply
181 replies to this topic

#81
andrewq2

andrewq2

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts

This is the screenshot of my problem.. then pc shutdown.. someone can help me on this? Thanks

looks like an disk error if possible go into leopard and verify disk/permissions

#82
jsN

jsN

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hello There!

Thank you for this guide, I followed it, then restarted my computer, but unfortunately when I'm in the Boot Selection, I am not able to boot Snow volume because that's not in the list (I had a dual boot 10.5.6 & Windows 7... so Win 7 and the old macintosh is bootable). Surely I {censored}ed up something :( I'd tried both GUID Partition and MasterBoot... not working...
If anyone could help me, I would be glad :)

#83
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPip
  • 466 posts
  • Gender:Male
  • Location:Southern California

Hello There!

Thank you for this guide, I followed it, then restarted my computer, but unfortunately when I'm in the Boot Selection, I am not able to boot Snow volume because that's not in the list (I had a dual boot 10.5.6 & Windows 7... so Win 7 and the old macintosh is bootable). Surely I {censored}ed up something :) I'd tried both GUID Partition and MasterBoot... not working...
If anyone could help me, I would be glad :)


It sounds like you are never making it to Chameleon and are stuck in the Windows boot selection. If you have Snow on a different hard drive than your windows installation and can select the disk to boot from in your bios, try that and boot from the drive that has Snow on it. If you have Snow on the same disk as other OS's, you can add a boot selection for Snow using EasyBCD in Windows. But since you already have Leopard 10.5.6 on your computer, make sure you are not using the bootloader for that partition because it will not boot Snow. You have to boot Snow from the bootloader on that partition.

#84
ChiefWiggum

ChiefWiggum

    InsanelyMac Protégé

  • Members
  • PipPip
  • 77 posts
Anybody got this working on a AMD SSE2 system ?
Do I have to wait for different kernel ?

I have followed the steps but my boot stops at
"waiting for dsmos" => Freeze after this & hard disk powers down.

#85
andrewq2

andrewq2

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts

Anybody got this working on a AMD SSE2 system ?
Do I have to wait for different kernel ?

I have followed the steps but my boot stops at
"waiting for dsmos" => Freeze after this & hard disk powers down.


You will need to wait until the xnu sources are released and voodoo or another team can code sse2 emulation into the kernel.

#86
gorg

gorg

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

NoGo on an Asus M2A32-MVP.
Hi - did the installation on a clean disk (with chameleon RC2.640, replaced "boot", and test7-kernel).
Very early I get:

**/dev/rdisk0s3
Can't initialize disk cache
/dev/rdisk0s3 (hfs) EXITED WITH SIGNAL 8

I get the same error when I boot into single user and do a "fsck".

Mobo: Asus M2A32-MVP de luxe (SB600)
10.5.6 is running fine here.....

any idea - apart from "switch to Intel" (which I might do sooner or later..)
G.H.


I get "Can't initialize disk cache" and "EXITED WITH SIGNAL 8" when booting with "-s -x32". Same motherboard. You can google around only to arrive to this thread. No answers here either (yet). 

#87
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPip
  • 466 posts
  • Gender:Male
  • Location:Southern California

well i just force compiled it and going to try booting again :angel:



I ended up deleting my dsdt.aml file and Snow booted up. Now that I have Snow running, I'll try to create a dsdt.aml file within Snow.





My system just halts at AppleIntelCPUPowerManagement timed out no matter what I try. Tried different kexts and have put my patched dsdt.aml in the root of my drive but all I get is that god damn time out. And no, it does not boot in to Snow after a couple of minutes, it just halts right there.



Try deleting your dsdt.aml file and see if it will boot. Mine did. Mine was hanging just like yours and it turned out it was the dsdt.aml file I had force compiled.

#88
majinvegeta

majinvegeta

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

I get "Can't initialize disk cache" and "EXITED WITH SIGNAL 8" when booting with "-s -x32". Same motherboard. You can google around only to arrive to this thread. No answers here either (yet).


try to start in maxmem=1024 or maxmem=2048 and see. :)

#89
virtudude

virtudude

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

try to start in maxmem=1024 or maxmem=2048 and see. :(


Weird. This fixed it for me. What's the bug this is a workaround for?

I have 8GBs of RAM. Is that too much? :-)

#90
majinvegeta

majinvegeta

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
it's a problem trusting over 4gb ram. you can set manually the maxmem flag step by step 1024 - 2048 - 3072 ecc ecc as soon as the error return for adjust your sistem at maximum stable performance.
Example I've 6gb and run at 5gb ... better than nothing :)

#91
alex romania

alex romania

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
So where do you guys find this DSDT.aml ? ;)

#92
andrewq2

andrewq2

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts

So where do you guys find this DSDT.aml ? :(

Search DSDT in the search box...... you will find a windows app and a mac app.
Note: not all motherboards are compatible.

#93
alex romania

alex romania

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

Search DSDT in the search box...... you will find a windows app and a mac app.
Note: not all motherboards are compatible.


Yeah i found them both, the windows app dosen't support my type of bios and the nix doesn't seam to work, since i can't ever get past the same boring KP on the first boot.

#94
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia
Updated to 10.6.1

Posted Image

#95
majinvegeta

majinvegeta

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

Updated to 10.6.1

Posted Image


how do you made your cpu recognized in sys profile? my 7850 isn't recognized... an i can't install adobe cs4 :°) . Can you help me on this?. Thanks

#96
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia
i use about this mac .pkg to get my cpu read to about this mac...

http://www.mediafire...php?3cjyyttyidy

i havent try adobe cs4... i dont have the installer, only cs3 ;)

#97
alex romania

alex romania

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
This time it worked for me as well, using your kexts. Lacking sata /on board sound card.


Later edit

Got sound to work with voodoohda and sata sort off (used AppleNForceATA),it fails often, (ntfs) partitions on my sata hdd just get unmounted,the real issue is still the dsdt.aml, im u using the GUI patcher btw, it no error but a warning, thing is...every time i reboot from SL pc gets stuck and have to reset CMOS ><

#98
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia

This time it worked for me as well, using your kexts. Lacking sata /on board sound card.


Later edit

Got sound to work with voodoohda and sata sort off (used AppleNForceATA),it fails often, (ntfs) partitions on my sata hdd just get unmounted,the real issue is still the dsdt.aml, im u using the GUI patcher btw, it no error but a warning, thing is...every time i reboot from SL pc gets stuck and have to reset CMOS ><


you need to patch your dsdt.aml to fix cmos problem google for it or u can use this :

Length should be changed to 0x02, its normally 0x04.

Device (RTC)
{
  Name (_HID, EisaId ("PNP0B00"))
  Name (_CRS, ResourceTemplate ()
  {
	 IO (Decode16,
	 0x0070,			 // Range Minimum
	 0x0070,			 // Range Maximum
	 0x00,			   // Alignment
	 0x02,			   // Length   <<--- the original is 0x04 or 0x08 just change this one to 0x02
	 )
   })
}

you can try http://www.mediafire...php?2mnxd0j44mf for apple nforce ata...

#99
alex romania

alex romania

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Thanks :(

I didn't realise that the dsdt which comes out of the GUI patcher isn't really "patched", after a bit of work i managed to fix that( http://www.hackint0s.../f213/84309.htm used the DSTD step from over there) sata still dosen't work well tho ><

#100
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia
good to hear that its fix for you now...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy