Jump to content

[HOW TO] Pin Config!


  • Please log in to reply
98 replies to this topic

#21
ckybam69

ckybam69

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
ages i got the same info as you but when i upload everything it doesnt work. could you send me your kext so i can just use that?

#22
Tek_No

Tek_No

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 316 posts
I don't get it.

I just flipped all bytes under Vista and saved the bytes in a plain text file

Then booted into Leo 10.5.5, opened the text file and copied the contents to the clipboard.

Then started PlistEdit Pro and tried to paste the bytes into the kext.

I'm always getting an "invalid hex data entered" error message although I'm sure that the data is correct hex data (0-9 and a-f)

Any ideas on this???

Take care,
Tek_No

#23
epifus

epifus

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I test it on my RealTeck HDA, it did not work :)

#24
quis

quis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
Are you talking about modifying the original AppleHDA? Or patched one?
And is it to put these into the ConfigData column?

Finally what's the effect of doing this??

Questions from a newbie...

#25
vlad1966

vlad1966

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 270 posts
  • Gender:Male
  • Location:Earth
  • Interests:Computers (especially Macs) OS X, sports cars (fast cars in general), blondes.
Can this method work w/a PCI sound card?

I'd love to get digital out working with my HT Omega Claro Plus.

#26
dyrdymal

dyrdymal

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Can someone post this for Dell E520 (I just don't have Vista installed)...?

Thx,

#27
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,880 posts
  • Gender:Male
  • Location:Stuttgart / Germany
You can use Win XP also !

#28
dyrdymal

dyrdymal

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

You can use Win XP also !

well.. I can't! there's no "Device Class GUID" in device properties, and I've searched whole registry for PinConfigOverrideVerbs - not there at all...
So - anyone with dell d520 and Vista...?

Thanks,

#29
AlienX2

AlienX2

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

You can use Win XP also !


Where is guid class of sound card device?

#30
MacNutty

MacNutty

    Mad for Mac

  • Members
  • PipPipPipPipPipPipPip
  • 648 posts
  • Gender:Male
  • Location:India
Is this the complete solution for patching audio or something else also is needed to get it work? Because I tried no success. If you can please explain in detail the right way of patching the audio.

#31
enb14

enb14

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 615 posts
  • Gender:Male
  • Location:Central America
Guys this is what I got with my ALC888

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}007\PinConfigOverrideVerbs]
"0000"=hex:10,1c,d7,00
"0001"=hex:40,1d,d7,00
"0002"=hex:01,1e,d7,00
"0003"=hex:01,1f,d7,00
"0004"=hex:11,1c,e7,00
"0005"=hex:60,1d,e7,00
"0006"=hex:01,1e,e7,00
"0007"=hex:01,1f,e7,00
"0008"=hex:12,1c,f7,00
"0009"=hex:10,1d,f7,00
"0010"=hex:01,1e,f7,00
"0011"=hex:01,1f,f7,00
"0012"=hex:14,1c,07,01
"0013"=hex:20,1d,07,01
"0014"=hex:01,1e,07,01
"0015"=hex:01,1f,07,01
"0016"=hex:1f,1c,17,01
"0017"=hex:40,1d,17,01
"0018"=hex:21,1e,17,01
"0019"=hex:02,1f,17,01
"0020"=hex:30,1c,27,01
"0021"=hex:21,1d,27,01
"0022"=hex:45,1e,27,01
"0023"=hex:01,1f,27,01
"0024"=hex:40,1c,37,01
"0025"=hex:30,1d,37,01
"0026"=hex:81,1e,37,01
"0027"=hex:01,1f,37,01
"0028"=hex:50,1c,47,01
"0029"=hex:90,1d,47,01
"0030"=hex:a1,1e,47,01
"0031"=hex:02,1f,47,01
"0032"=hex:60,1c,57,01
"0033"=hex:10,1d,57,01
"0034"=hex:81,1e,57,01
"0035"=hex:41,1f,57,01
"0036"=hex:70,1c,67,01
"0037"=hex:10,1d,67,01
"0038"=hex:91,1e,67,01
"0039"=hex:41,1f,67,01
"0040"=hex:80,1c,77,01
"0041"=hex:11,1d,77,01
"0042"=hex:c5,1e,77,01
"0043"=hex:01,1f,77,01
"NumVerbs"=hex:2c,00,00,00

So my question is if I also have to add NumVerbs or just 0043?

#32
enb14

enb14

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 615 posts
  • Gender:Male
  • Location:Central America
Well this is my colaboration to the osx world, try this converter from windows so then you will have your pin in order to be used for OSX.


Tested on Vista 32bit, ALC888 (DG33FB intel motherboard) I hope this works for you.

Requires .net Framework 3.5

Attached Files



#33
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,880 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Anyone done ALC889A (Ga-EP-35) already ?

#34
AlienX2

AlienX2

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
still not work for me :) i tried tested it. Anyone done with correct port who is intel D945GNT user or IDT/Sigmatel 9221 user (my device id is 0x83847680 and my audio controller is 0x80860202)??

#35
enb14

enb14

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 615 posts
  • Gender:Male
  • Location:Central America
AlienX2 I usted to have that motherboard and is a real pain to get the audio to work. in 10.4.1 throuth 10.4.3 it worked flawlessly, but now it seems to not work anymore on 10.5.x

If you make it to work let us know.

#36
DB1

DB1

    InsanelyMac Sage

  • Donators
  • 407 posts
Anyone please do for Asus P5k VM (ALC883), I would be most grateful - i have not had winduz for several years.

BTW will this work as in a plist only type kext (as Cyclonefir) for EFI munky boot partition method or Chameleon Extra>Extensions set up?

I'll try it if someone can provide the data for my mobo.

#37
MacNutty

MacNutty

    Mad for Mac

  • Members
  • PipPipPipPipPipPipPip
  • 648 posts
  • Gender:Male
  • Location:India

Well this is my colaboration to the osx world, try this converter from windows so then you will have your pin in order to be used for OSX.
Tested on Vista 32bit, ALC888 (DG33FB intel motherboard) I hope this works for you.

Requires .net Framework 3.5


Do you get sound on speakers and headphones too? I have the same MB. Can you help please?

#38
enb14

enb14

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 615 posts
  • Gender:Male
  • Location:Central America
Just from speakers, from input I can't test it even in windows due to my Antec P180 case which doesn't supports Intel HDA so I can't tell you if front panel works.

#39
AlienX2

AlienX2

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

AlienX2 I usted to have that motherboard and is a real pain to get the audio to work. in 10.4.1 throuth 10.4.3 it worked flawlessly, but now it seems to not work anymore on 10.5.x

If you make it to work let us know.


Yea That's true. i want to wait for someone fix or taruga will solve or D945GNT group.

#40
amador

amador

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
  • Gender:Male

Yea That's true. i want to wait for someone fix or taruga will solve or D945GNT group.




IDT 92HD206 8-channel audio CODEC. < mine has an error too NO SOUND at all is there any way how to fix this?.. KEXT NEEDED? PLS HELP. :D

PC SPEC:

Kalyway 10.5.2 DVD Intel_Amd (sse2/sse3) EFI V8 WORKING :(
MOBO : ECS 780GM-A
CPU : X2 6000+
RAM : 1 GB DDR2 X2 1066 MHZ
HD : SEAGATE 500 GB SATA II
DISPLAY AND AUDIO IS ONBOARD

BTW. I ADD PCI LAN CARD TO TRY AND SKIP THE QUESTION DO YOU ALREADY OWN A MAC..I JUST READ IT IN THE FORUM,,AND IT WORKS :)





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy