Jump to content

ATI / NVIDIA OnBoard (P) ATA Driver


  • Please log in to reply
58 replies to this topic

#21
fireshark

fireshark

    Your Mom

  • Members
  • PipPipPipPipPipPip
  • 489 posts
I have run into problems with the 10.4.6 install for whatever reason. I suppose 10.4.6 is good for you

#22
Gdfath3r

Gdfath3r

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 212 posts

Does anyone compared this driver to the original AppleOnboardPCATA in XBench for nForce 4 ?


;)

Hello MacGirl!

Id like to ask you how you did realize SSE3 on dualcore Opteron?...I have here a Opteron 170, and I would to use it with SSE3, but the functional disk which I have, has kernel which has no support for SSE3 on dualcore. Thank you in advance for help.

#23
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

:offtopic:

Hello MacGirl!

Id like to ask you how you did realize SSE3 on dualcore Opteron?...I have here a Opteron 170, and I would to use it with SSE3, but the functional disk which I have, has kernel which has no support for SSE3 on dualcore. Thank you in advance for help.

I don't even have a clue, but it appears that SSE3 kernels does not work on AMD's Dual Cores, I can only get a SSE3 Kernel work in VMware, at least with 10.4.4, .5 and .6 because it worked fine with 10.4.3

#24
mtakach

mtakach

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Are there any plans to create a driver for SATA drives for motherboards with an ATI chipset, or does anyone know of any out there?

#25
gondawa

gondawa

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
How install this driver? I have followed this explanation
http://forum.osx86pr...topic=13197&hl=

but with the driver that i can find on this thread v2 think.

BUT NOW MY OS CANNOT BOOT ;) .

Ihave 10.4.5myzar.

My hdd is a ata 40gb and when i have tried Xbench my hdd have very very poor performance (3.000 kb/S) !!!

I am reinstalling mac osx now. But how install now for a working os? :D

Edit: My motherboard is Asus P5nd2SLI deluxe : nforce4SliIntel edition

#26
Morden

Morden

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
  • Gender:Male
  • Location:Kazakhstan,Astana
I had the same problems, Zappadoc's driver didn't help, cause Zappadoc didn't added string for nForce 4 SLI IE PATA. Device id of your PATA controller is 003510de, isn't it? I had to compile driver from Darwin sources on my own.

#27
gondawa

gondawa

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
I novice in the "mac" world and change Kerxt etc it's so new for me... AND THE REST TOO
But for the device id .. How to get it?
I have cheked NVIDI nForce4 Intel edition Parallel Ata Controller and i found : PCI\VEN_10DE&DEV_0035&SUBSYS_818A1043&REV_F2\3&411E6FE&0&78

thus i think my device id is 0035 .. not 003510de . I'm wrong?

I'm learning..be cool :-)


EDIT :: thanks to Morden my problem is resolved. !

#28
nepali_gurkha

nepali_gurkha

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
ok, hey

I have a Hp computer and it has like a ATI RS480 Host Bridge and
ATI IXP SB400 IDE Controller 1002-4376-2A26103C-00 not sure what thiese numbers mean = "(255) (0-20-1)" but any way this modified kext should work but it dosn't in booting up it says "com.apple.AppleOnboardPCATA.kext" has no kernel dependency. I'm running 10.4.6 so i don't see the problem, the only thing it might be is my hard drive is connect in the 2nd line in the IDE cable and the 1st is my DVD burner.... do u guys think its that?

Thanks
-Tabha

#29
Moonblood

Moonblood

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
does it wotk on nforce4 4x to?

#30
shedt

shedt

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts

ok, hey

I have a Hp computer and it has like a ATI RS480 Host Bridge and
ATI IXP SB400 IDE Controller 1002-4376-2A26103C-00 not sure what thiese numbers mean = "(255) (0-20-1)" but any way this modified kext should work but it dosn't in booting up it says "com.apple.AppleOnboardPCATA.kext" has no kernel dependency. I'm running 10.4.6 so i don't see the problem, the only thing it might be is my hard drive is connect in the 2nd line in the IDE cable and the 1st is my DVD burner.... do u guys think its that?

Thanks
-Tabha



I think i have the same or similar system.


is there a similar driver but with sata support?

did you find a solution yet?

#31
shedt

shedt

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts

Are there any plans to create a driver for SATA drives for motherboards with an ATI chipset, or does anyone know of any out there?



ok, hey

I have a Hp computer and it has like a ATI RS480 Host Bridge and
ATI IXP SB400 IDE Controller 1002-4376-2A26103C-00 not sure what thiese numbers mean = "(255) (0-20-1)" but any way this modified kext should work but it dosn't in booting up it says "com.apple.AppleOnboardPCATA.kext" has no kernel dependency. I'm running 10.4.6 so i don't see the problem, the only thing it might be is my hard drive is connect in the 2nd line in the IDE cable and the 1st is my DVD burner.... do u guys think its that?

Thanks
-Tabha



does anyone know how this could be added?

#32
Crazor

Crazor

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
Man this is INSANE! Works TERRIBLY fast on my nForce4 board! System boot time is like 10s(!) to desktop now compared to 1-2 minutes before. Thank you so much for your work!
Using ASUS P5N32-SLI Deluxe here...

Vista, better strap your running boots! =)

#33
tomazzzzzzzzzzz

tomazzzzzzzzzzz

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
hi

i v an MSI MS-7184 with ATI SB400 218S4EASA32HK DH0826.00 0519SS ( HP DESKTOP 5129FR )

installed the AppleOnboardPCATA.kext but the hd is still slow & i can t start any installer

anyone know if there s a solution available ?

#34
abamac

abamac

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Zappadoc: Thank you for this driver. Huge drive performance gain (over AppleGenericATA)
on my Compaq R3000T running osx86 10.4.6. Also enabled my optical drive,
as was the case with a previous post.

If anyone is struggling to identify their chipset, try cpuz (if you're able
to boot windows). I wasn't able to find an osx util to give similar info.

Northbridge ATI ID5833 rev. 02
Southbridge ATI SB200 rev. 00

#35
squimmy

squimmy

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 120 posts
Mine doesn't work - just gets stuck on "waiting for root device", the generic ATA kext works but only without UDMA so it is very slow.


I'm on an ATI IXP chipped motherboard - the device id thing is either 1002-4376 or 1002-4379, i'm not sure. Is there a way I can find out from within OS X? I'm on 10.4.8 BTW.



Thanks.

Edited by squimmy, 01 March 2007 - 11:25 PM.


#36
squimmy

squimmy

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 120 posts
My hard drive is connected to the second connection of the cable, the first being my dvd player just like "nepali_gurkha".

Is this what is causing my problem?

#37
lwt

lwt

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
omg
my broad is D101ggc ,it look's like cannot use it
cause ,my harddisk is ST 250G(sata)

excuse me,could you make another driver for sata.
thanks
;)

#38
FreakyMac

FreakyMac

    InsanelyFail

  • Members
  • PipPipPipPipPipPip
  • 395 posts
  • Gender:Male
  • Location:Joplin, Missouri :D
Will this work for my Nvidia nForce4 MCP51??

#39
AcidRain9

AcidRain9

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:New England
I am running OSX 10.4.8 on my 500 Gb PATA Drive and was wondering about installing this kext.
i have an MSI K9N Nforce 570 Mobo
is it even supported by the kext?

here are my xbench results for my hdd:

Disk Test 20.02
Sequential 14.40
Uncached Write 11.13 6.83 MB/sec [4K blocks]
Uncached Write 11.60 6.57 MB/sec [256K blocks]
Uncached Read 24.77 7.25 MB/sec [4K blocks]
Uncached Read 16.30 8.19 MB/sec [256K blocks]
Random 32.82
Uncached Write 29.63 3.14 MB/sec [4K blocks]
Uncached Write 20.99 6.72 MB/sec [256K blocks]
Uncached Read 84.82 0.60 MB/sec [4K blocks]
Uncached Read 34.82 6.46 MB/sec [256K blocks]

#40
ole2

ole2

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:Grenoble, France

Zappadoc: Thank you for this driver. Huge drive performance gain (over AppleGenericATA)
on my Compaq R3000T running osx86 10.4.6. Also enabled my optical drive,
as was the case with a previous post.

If anyone is struggling to identify their chipset, try cpuz (if you're able
to boot windows). I wasn't able to find an osx util to give similar info.

Northbridge ATI ID5833 rev. 02
Southbridge ATI SB200 rev. 00


instead of rev, could you post your ATI components PCI ID's?

for example:

1002-4370-308B103C-02 Audio Controller ATI IXP SB400 AC'97 Audio Controller
1002-4371-00000000-00 PCI Subtractive (0-2:3) ATI IXP SB400 PCI-PCI Bridge
1002-4372-308B103C-11 SMBus Controller ATI IXP SB400 SMBus
1002-4373-308B103C-00 EHCI USB Controller ATI IXP SB400 EHCI USB 2.0 Controller
1002-4374-308B103C-00 OHCI USB Controller ATI IXP SB400 OHCI USB Controller
1002-4375-308B103C-00 OHCI USB Controller ATI IXP SB400 OHCI USB Controller
1002-4376-308B103C-00 EIDE Controller ATI IXP SB400 IDE Controller
1002-4377-308B103C-00 ISA Bridge ATI IXP SB400 PCI-ISA Bridge
1002-4378-308B103C-02 Hayes Compatible ATI IXP SB400 AC'97 Modem Controller
1002-5955-308B103C-00 VGA Controller ATI Mobility Radeon XPRESS 200
1002-5950-308B103C-01 Host Bridge ATI RS480 Host Bridge
1002-5A36-00000000-00 PCI Bridge (0-16) ATI
1002-5A37-00000000-00 PCI Bridge (0-32) ATI
1002-5A3F-00000000-00 PCI Bridge (0-1) ATI

thanks





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy