Jump to content

OMN'S DSDT BIOS FIX-Getting past the CPU=1


  • Please log in to reply
313 replies to this topic

#121
5enses

5enses

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Nice to hear from ya OMN! I will wait for my turn on this thread -_-

#122
OriginalMACNUT

OriginalMACNUT

    InsanelyMac Legend

  • Donators
  • 617 posts
  • Gender:Male
Had a Few Problems, 1 of my Tracer memory was the cause for the System error :) Should be here today though.

*UpDate 8:19am 2/12/08*
Mem Just cam Fedex, Is installed and seems to be working correctly now with no crashes. I have D/L the bios and starting work on them now.
In the mean time I'll just add them here, as my Website is on My Mac for uploading to the Site.

Should be done with in the Hour.
Thanks,
-Omn

#123
5enses

5enses

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Had a Few Problems, 1 of my Tracer memory was the cause for the System error ;) Should be here today though.

*UpDate 8:19am 2/12/08*
Mem Just cam Fedex, Is installed and seems to be working correctly now with no crashes. I have D/L the bios and starting work on them now.
In the mean time I'll just add them here, as my Website is on My Mac for uploading to the Site.

Should be done with in the Hour.
Thanks,
-Omn


Hmm is this regarding my bios or someone else before me? Cause if it's one hour i'll patiently wait online ^^

#124
OriginalMACNUT

OriginalMACNUT

    InsanelyMac Legend

  • Donators
  • 617 posts
  • Gender:Male
I might have got your done. I've done 6 so far. I will post them all once there done.
Hex editing is not hard, just takes time, and making sure the Hex header is still correct, as If I don't, you will be left with a brick :wacko:
So I take my time to ensure everything is correct.

I just have a few more left. :D

#125
5enses

5enses

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

I might have got your done. I've done 6 so far. I will post them all once there done.
Hex editing is not hard, just takes time, and making sure the Hex header is still correct, as If I don't, you will be left with a brick :(
So I take my time to ensure everything is correct.

I just have a few more left. :)


Alright, take all the time you need :)

#126
OriginalMACNUT

OriginalMACNUT

    InsanelyMac Legend

  • Donators
  • 617 posts
  • Gender:Male
If you can save you Bios in a .rom image I might be able to look at it. Currently in .2m image which My tools can't open.

Alright, take all the time you need :(



#127
5enses

5enses

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

If you can save you Bios in a .rom image I might be able to look at it. Currently in .2m image which My tools can't open.


I can only open the 1m file? is that alright?

#128
Turanli

Turanli

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts

I might have got your done. I've done 6 so far. I will post them all once there done.
Hex editing is not hard, just takes time, and making sure the Hex header is still correct, as If I don't, you will be left with a brick :(
So I take my time to ensure everything is correct.

I just have a few more left. :)


I hope mine is one of those 6? :)
The Asus G50V...

Thanks!

Btw, is there any tutorials out there that describes the process you go through when u do your magic :P ?

#129
OriginalMACNUT

OriginalMACNUT

    InsanelyMac Legend

  • Donators
  • 617 posts
  • Gender:Male

I can only open the 1m file? is that alright?


Use the File that you need, just need to be Back-up to a .rom image and hope I can open it :(

#130
5enses

5enses

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Here is my BIOS (1M) in .ROM for you OMN

http://www.mediafire...php?md1rwdinnwz

#131
OriginalMACNUT

OriginalMACNUT

    InsanelyMac Legend

  • Donators
  • 617 posts
  • Gender:Male
Foxconn_P35_AX-S__762F1P13
http://rapidshare.co...F1P13_.rar.html

P5N7A-VM
http://rapidshare.co...M-0404.rar.html

ASUS P5Q PRO 1501
http://rapidshare.co...O-1501.rar.html

ASUS P5QL-E 0801
http://rapidshare.co...S-0801.rar.html

EeePC 900HA 305
http://rapidshare.co...S-0305.rar.html

Hi! i would really like a modded bios for my Asus G50V gamer laptop:

Org bios(newest):
http://dlcdnet.asus....V/G50V209as.zip

HW:
Intel Core 2 Duo P8600 / 2.4 GHz - 1066MHz CPU FSB
Intel PM45 Chipset
ICH9-M SATA Controller
4GB DDR2 800Mhz Ram (2Gx2)
9700m GT
Intel WiFi Link 5100 - Not working
Realtek ALC663 - Not working

I tried doing as written here on how to mod the bios(http://forum.insanel...howtopic=112033) but it didn't really work. i couldn't find the 4 aliases, described in the tut...
This is the .dsl output i got:
http://rapidshare.co...7756/G50Vas.dsl

G50Vas - done :( yOUR IN THERE YAY oops caps
http://rapidshare.co...as.209.rar.html

Distributor Model Name: HP Pavilion Elite m9350f

OEM Model Name: ASUS M2N78-LA (aka "Pegatron Viola 2.02")

HP BIOS version: AMI 5.24

HP BIOS link: http://crowdsurfoffa...m/osx86/VIO5.24
(completely) Fixed DSDT.dst: http://crowdsurfoffa.../osx86/DSDT.dsl
(completely) Fixed DSDT.aml: http://crowdsurfoffa.../osx86/DSDT.aml
The BIOS of this AMD machine is from AMI. I was able to open this BIOS for editing with mmtool and AMIBCP 3.13. I was able to read (and will assumably be able to write) my BIOS using AFUDOS from the latest amiflash.zip from ami.com. Here's more specs:
CPU: AMD Phenom™ 9850 Quad-Core Processor

Northbridge: NVIDIA nForce 720a rev. A2

Southbridge: NVIDIA ID075C rev. A2
I see that someone helped user Icchan-san with his HP Pavilion Elite m9250f. Please help me with this one! The model numbers are super close, though to forewarn you, this machine is an AMD/nForce model...
In AMIBCP I actually see a 'mode-setting' menu option for how SATA appears to the OS... but I don't actually see it in my BIOS... regrettably, I believe I once had the option to set my SATA to AHCI-mode before upgrading my BIOS to a newer version (and I can't find any older versions online...)


VIO5
http://rapidshare.co...IO5.24.rar.html

Dear Macnut,

Could you modify my bios please.
Link: ftp://europe.asrock.com/bios/775/G43Twins-FullHD(1.20).zip
SPECIFICATION:

Asrock G43Twins-FullHD

Intel Core 2 E5200

2048Mb DDR2 800MHz
Thank You VERY MUCH


Done
http://rapidshare.co...FH1.20.rar.html

Here is my BIOS (1M) in .ROM for you OMN

http://www.mediafire...php?md1rwdinnwz


It don't have the Settings to change to AHCI, however the CPU strings needed fixed. You might try it now, though if no change use the original bios.

Here is the link, Just change the name of the Bios if you need it shorter. I renamed it so I can keep track of models

http://rapidshare.co..._m5620.rar.html

#132
5enses

5enses

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Thanks OMN, I shall try it out with a copy of Kalyway.


I know this is kinda off topic, do you have any knowledge on how i could change that onboard sata mode to AHCI? I think is neccessary in order to install osx am i right?

#133
OriginalMACNUT

OriginalMACNUT

    InsanelyMac Legend

  • Donators
  • 617 posts
  • Gender:Male
Depends I guess, everyone said it's needed.
But I guess I'm lucky as I've not had to do it myself, which in my case may be rare, however the option is no longer there inside the bios it self.
I would suppose you could add it back, but that is over my head.

Sorry I can't be much more help
-Omn

#134
5enses

5enses

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Ahh darn, thanks for your help ^_^

Anyways, Kalyway seems to run smoothly, just can't install it at all.

"/Volumes/DATA/BaseSystem.pkg.149xo7gbX" Pretty sure its AHCI related or something.
(If anyone sees this and knows a solution please pm me)

#135
OriginalMACNUT

OriginalMACNUT

    InsanelyMac Legend

  • Donators
  • 617 posts
  • Gender:Male
Have you tried Leo4all? That what I used before going to boot 132 and using the retail dvd

#136
5enses

5enses

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Have you tried Leo4all? That what I used before going to boot 132 and using the retail dvd


Yeah I've just tested Leo4All v3.. keeps on repeating "waiting for root device" in darwin..

#137
Spydey Ninja

Spydey Ninja

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:97007
Glad to hear that you are back up OMN, I hate it when RAM goes bad. I was just wondering if you had a chance to work on a bios mod for my machine yet? :-) I posted back on page 6, post #120. If you need my specs again, they are below. Thanks again for the help! :-)

Here are my specs (custom built by myself) :

AMD Phenom X4 9950 oc'ed 3.2 Ghz
Asus M3A79-T Deluxe Motherboard (ATI 790FX/SB750 chipset)
4 gigs of 1066 DDR2 RAM (2x2 gig sticks)
2 Sapphire ATI 3870s
1 500 Gig SATA internal HDD (Primary)
1 250 Gig SATA internal HDD (secondary)
1 500 Gig eSata external HDD
1 250 Gig USB external HDD

I am currently running the newst BIOS from Asus, I believe it is the 602. If you go to their site select Motherboard --> Socket AM2/AM2+ --> M3A79-T Deluxe --> Vista 32 bit, you should find under the bios menu, the newest bios, 602. It is a .rom file so hopefully that will work. Thanks in advance for your help and have a great day or evening!! :-)

P.S. I have tried to attach the .rom file just in case the link doesn't work but the forum won't let me. Sorry. :-(

Also, I am running iDeneb v1.3 10.5.5 Everything is working (so far) except that I have to boot in safe mode to even get to the desktop, otherwise it just goes to a blueish color screen and stays like that. I thought that maybe I needed to run cpus=1 but I don't, I just need to boot into safe mode to run os x. OS X only sees one core and will only run on one core, even when I don't use cpus=1. So I am hoping that this bios mod will fix the safe mode issue and also the single core issue. Thanks again! :-)

#138
OriginalMACNUT

OriginalMACNUT

    InsanelyMac Legend

  • Donators
  • 617 posts
  • Gender:Male

Glad to hear that you are back up OMN, I hate it when RAM goes bad. I was just wondering if you had a chance to work on a bios mod for my machine yet? :-) I posted back on page 6, post #120. If you need my specs again, they are below. Thanks again for the help! :-)

Here are my specs (custom built by myself) :

AMD Phenom X4 9950 oc'ed 3.2 Ghz
Asus M3A79-T Deluxe Motherboard (ATI 790FX/SB750 chipset)
4 gigs of 1066 DDR2 RAM (2x2 gig sticks)
2 Sapphire ATI 3870s
1 500 Gig SATA internal HDD (Primary)
1 250 Gig SATA internal HDD (secondary)
1 500 Gig eSata external HDD
1 250 Gig USB external HDD

I am currently running the newst BIOS from Asus, I believe it is the 602. If you go to their site select Motherboard --> Socket AM2/AM2+ --> M3A79-T Deluxe --> Vista 32 bit, you should find under the bios menu, the newest bios, 602. It is a .rom file so hopefully that will work. Thanks in advance for your help and have a great day or evening!! :-)

P.S. I have tried to attach the .rom file just in case the link doesn't work but the forum won't let me. Sorry. :-(

Also, I am running iDeneb v1.3 10.5.5 Everything is working (so far) except that I have to boot in safe mode to even get to the desktop, otherwise it just goes to a blueish color screen and stays like that. I thought that maybe I needed to run cpus=1 but I don't, I just need to boot into safe mode to run os x. OS X only sees one core and will only run on one core, even when I don't use cpus=1. So I am hoping that this bios mod will fix the safe mode issue and also the single core issue. Thanks again! :-)


Can you use RapidShare?
I would pref. if you link the bios, no way of any error on my part that way.

Sounds like it's putting the other Cores to sleep and locking the PC up, well, based on prev. exp. that is. I'll have a look, but can't promise anything


*UPDATE*
I've looked at the Bios, Can you try running Fassl DSDT patcher. this would take me to long to edit, as it shots back over 201 error, I've found the problem, but fixing the rest would take forever manually editing in hex.
Thanks,
-Omn

#139
Doctors

Doctors

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hey there MACNUT,
Looking for bios to enable 2 core support for my MSI EX600 laptop (PM965 chipset)

link to original bios: http://rapidshare.co.../bios-ex600.zip


Thanks in advance,
regards

Doctors

#140
Spydey Ninja

Spydey Ninja

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:97007

Ahh darn, thanks for your help ^_^

Anyways, Kalyway seems to run smoothly, just can't install it at all.

"/Volumes/DATA/BaseSystem.pkg.149xo7gbX" Pretty sure its AHCI related or something.
(If anyone sees this and knows a solution please pm me)




I was having the same issue with my machine. I have a dual boot: Vista 32 bit and OS X86 iDeneb v1.3 10.5.5. For the first few times that I tried to install os x, I would get the same "waiting on host" message but nothing. So this is what I did: I disconnected any and all un-needed peripherals (sp?) i.e. external HDD, cameras, printers, usb thumbdrives, and my extra internal HDD. I only ran the single internal SATA HDD that had my OSes on it. Then in the bios I went to the screen that shows the date, time, and devices connected to my machine. I had to change the hdd to run from IDE to AHCI for my install to even work. The down side is that I can't run Vista. If I need to run Vista, I have to change the BIOS back to IDE. The only way to circumvent this change back and forth is for me to reinstall vista and use the AHCI drivers during the vista install.

So, the option for IDE <--> AHCI should be in your bios options. I had to pull out my mobo manual to find it. Hopefully that helps. :-)

If I am not making any sense, just ignore my random rambiling, hehehe :D .

Can you use RapidShare?
I would pref. if you link the bios, no way of any error on my part that way.

Sounds like it's putting the other Cores to sleep and locking the PC up, well, based on prev. exp. that is. I'll have a look, but can't promise anything


*UPDATE*
I've looked at the Bios, Can you try running Fassl DSDT patcher. this would take me to long to edit, as it shots back over 201 error, I've found the problem, but fixing the rest would take forever manually editing in hex.
Thanks,
-Omn


I am at work right now and they have rapid share blocked so cant get access to it right now. I am not familiar with FAssl DSDT patcher but will look around for info on it. Do you have a link for it possibly? Do you think that the Fassl DSDT patcher will fix the error of just using one core and the 201 errors that came up? Also, do you think that it would be better if I switched back to the previous bios version? I believe that it is version 504. Version 504 was solid on my system and when I switched to 602, it took like 5 reboots just to get it to POST and then it reset all my bios settings, some to defaults and others to settings that I don't even use or would need, which messed up my system at first. :wacko: After I got all the kinks worked out in the bios settings, it finally would boot and POST properly, but even now every once in a while it will freeze when it trys to mount/load a drive and I need to reset. I would assume reverting back to 504 would be betterfor both my system and possibly for your bios modding. What do you think? I will check out the Fassl DSDT patcher but won't be able to try it until I get home from work. Thanks though for your help!! :-) :D





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy