Jump to content

[How To] GMA900 with QE and CI support on Leopard.


  • Please log in to reply
364 replies to this topic

#361
Anti-Alias

Anti-Alias

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
I'm on an Intel GMA900 and this doesn't seem to work at all. :wacko:

#362
kocoman

kocoman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 325 posts
So it seems there's another thread for the GMA900/GMA950 on 10.6.2

Intel GMA 900 done right: full QE/CI for leopard, no hacked kexts needed

http://www.insanelym...howtopic=141549

I hope it will help others, I could not find that thread until today

#363
RichTin

RichTin

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
My laptop is toshiba and I use ikatos v7 but can't boot, it always stop in logo Apple


Please, help me how to boot from a CD with ikatos v7, it always stop in logo Apple

#364
Klaus Rudi Peter Dietrich

Klaus Rudi Peter Dietrich

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Ladies and Gentlemen I have returned hahaha,

About 3 years ago I brought you the "how to 915/900" for Tiger, left the scene for a while, but now out of boredom I'm back.... And with something I'm sure you'll all love.

Guys, I have to admit I was frustrated as hell reading this forum and reading people say "get new cards etc..." especially when like more than half of us are on laptops!

That's not the attitude we should have around here, now sure I didn't write a whole new driver from scratch, but I still got somewhere... And that's because I was persistent, even apple gave up on this card lol...

So I hope this spells out to everyone not to give up so easy when you can't have things your way... persistence is everything.

So anyway I spent a week reading, and doing some research and within a few hours I had it working (just when i was ready to give up...) attached is a screenshot of my computer with FULL hardware acceleration!

Posted Image

So far I've tested:

  • iTunes (Cover Flow)
  • DVD Player
  • VLC
  • Photobooth
  • Frontrow
  • Ripple effect with widgets
  • Quicktime always crashes with me, regardless of this... I think it's just my installation so yeah...
Before we start I want to clearly state the following:
I am not responsible, nor will I be held responsible for any damage this does to your card, monitor, laptop/desktop, Installation of OSX or any other operating system.

As long as you have back-ups you should be fine!

Please do not PM me saying it doesn't work or how do I do this or that, that is what this thread is for.


Also, special thanks to: Proud Bajan - I followed your 950 guide and hexed edited these files.

Now, down to business:

I'll try and make it as simple as I can.

Download the following Kext files from: GMA 900 Kext files
1. Backup all your AppleIntel equivalents in your /system/library/extensions folder
2. Copy these new ones over to that same directory (/system/library/extensions)
3. After you copy these across you may recieve a few errors from OSX saying it couldn't load blah blah, hit ok and ignore them
3. Pull up a terminal window and type the following:

sudo su
 
 <password>
 
 1. cd /
 2. cd /system/library/extensions/
 3. chmod -R 755 AppleIntelGMA950.kext
 4. chown -R root:wheel AppleIntelGMA950.kext
 5. chmod -R 755 AppleIntelIntegratedframeBuffer.kext
 6. chown -R root:wheel AppleIntelIntegratedframeBuffer.kext

After doing so open up finder and navigate to /system/library/extensions and delete the extensions.mkext (drag it to your trash).

Then restart and you should be good to go!

Issues:

So far all i've noticed is a little bit of mouse tearing with some intensive apps, like iTunes and Firefox, I'm not sure how to fix this issue, but I'll read up on it. And please if you have any suggestions on how to fix it, post them here :D

Enjoy guys, I'm as happy as ever.

Edit: Forgot to mention my specs lol...

Dell Inspiron 6000
----------------------------------
1.6Ghz Centrino
512DDR 400Mhz
128mb shared Intel GMA 900
Phillips DVD combo drive
Intel wireless 2200 (not working, can't be bothered to try)
Broadcom Network card.

Leopard 10.5.2 - Kalyway.

Humor: I hex edited these files on my vista laptop ahhaha


I did everything like you said - it does NOT WORK. Also I've tried other solutions frpm other guys (including the link of kocoman!). None of them worked. I don't know what to do anymore... It's just Software and no qe...

#365
kocoman

kocoman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 325 posts

I did everything like you said - it does NOT WORK. Also I've tried other solutions frpm other guys (including the link of kocoman!). None of them worked. I don't know what to do anymore... It's just Software and no qe...


Can you not quote the whole message next time, because the reader would focus 100% on the quote instead of your reply

what version of OSX? laptop model?

I am still using 10.5.8 on Aspire 3620

I hope the new http://www.insanelym...p;#entry1492469 10.6.4 kernel will fix the sse3 issue.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy