Jump to content

Webcam support limited by Apple's UVC driver. [PARTIALLY SOLVED]


  • Please log in to reply
172 replies to this topic

#21
00diabolic

00diabolic

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 812 posts
  • Gender:Male
  • Interests:Modding anything.

conclusion: the frameworks of 10.4.8 and certain kexts and bundles from there could help us out. As this hptx1285 also must be chicony / sonix
I am not sure wether or not leo would crash with this framework from 10.4.8 and kexts - but it could be worth a try.
cheers

aRt


Yes Exactly!!!!!!!!!!! :)

I think that the UVC driver and software used for cams in Leopard is the problem with most cams. If we can get the old tiger stuff and use that it should work. :moil: Now I have gotten part of the 10.4.10 UVC package and saw no difference. I have not tried 10.4.8 yet though nor can i find it anyway. Yet I have read that a lot more cams have worked in 10.4.8 then in any of the other versions of OSX so far. We need to come up with a list of files to get from 10.4.8. Its not just kext its also the quicktime components that we need to collect and then install in Leopard. I will see what I can dig up as far as all of the needed files.

#22
Eesh Dewan

Eesh Dewan

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Location:New Delhi, India
i think you were asking for this file from 10.4.9 install. hope you find a solution for the webcam riddle.

Attached Files



#23
Monkey_@@

Monkey_@@

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
  • Gender:Male
Here is what I have:

HP Webcam:

Version: 6.06
Bus Power (mA): 500
Speed: Up to 480 Mb/sec
Manufacturer: Chicony Electronics Co., Ltd.
Product ID: 0xb015
Serial Number: SN0001
Vendor ID: 0x04f2


Now, I've installed aGent Webcam G3 but the main WebCam Monitor screen is always blank. BUT, if I select Monitor -> Video Settings I can see my image on the preview box!!!

I've tried to delete VDC.plugin but still no changes either in Skype, iChat, Photo Booth, Quicktime or anything else... all of them showing just a black screen... so, any ideas???

#24
artbj

artbj

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
the 10.4.8 and 10.4.9 frameworks do work - and yeah - maybe we only need the quicktime components from one of those two versions
who knows...
im gonna try that kext
thx

#25
glitchbit

glitchbit

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 196 posts
I may have found a temporary solution but I have not yet tested it out

http://forum.insanel...mp;#entry768311

#26
artbj

artbj

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
here is a ton of sonic drivers for os xhttp://www.sonix.com...x/family.do?f=3a bunch of em... gonna try some - u guys get started too :Dhttp://www.sonix.com...ct.do?p=SN9C202this is imo - possibly a good try for us as our dv hp computers do have a mic beside the cam itself - this is probably some sheit that connect to one chip.lets try guys ! :DaRt

#27
Monkey_@@

Monkey_@@

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
  • Gender:Male
I've tried that IOUSBFamily.kext.rar... no results... :)

Maybe this can give us some help also...

http://techslaves.or...dex.php?page=52

#28
Eesh Dewan

Eesh Dewan

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Location:New Delhi, India
i am on acer crystal eye webcam on my aspire 4710 laptop. i could see a part of the frame in login options when i installed 10.4.9 whose kext i have uploaded. not even that lucky in 10.4.8, 10.5.1 or 10.5.2. tried macam, but no go.

let me know if i can be of any help.

#29
00diabolic

00diabolic

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 812 posts
  • Gender:Male
  • Interests:Modding anything.

i think you were asking for this file from 10.4.9 install. hope you find a solution for the webcam riddle.


THANKS. I still need to try it out. We need are all of the files the cam uses for this to work I think. That means the kext and the quicktime components also.

Here is a list of all of them that we need form 10.4.8/10.4.9 (I think 10.4.8 is the best at cam support):
IOUSBFamily.kext which holds AppleUSBVideoSupport.kext
QuickTimeUSBVDCDigitizer.component,
QuickTimeIIDCDigitizer.component
VDC.plugin
RawCamera.bundle

I am not 100% this is the whole list but it has to be as this is all the stuff that loads when you use the cam. If there is one or two others please let me know. Also 10.4.8 may not have all of these files and that would make sense (especially VDC.plugin).

Here is what I have:
Now, I've installed aGent Webcam G3 but the main WebCam Monitor screen is always blank. BUT, if I select Monitor -> Video Settings I can see my image on the preview box!!!

I've tried to delete VDC.plugin but still no changes either in Skype, iChat, Photo Booth, Quicktime or anything else... all of them showing just a black screen... so, any ideas???


Once we get all the files from 10.4.8 I think it will solve your problem. The leopard versions just really limit the cams you can use.


the 10.4.8 and 10.4.9 frameworks do work - and yeah - maybe we only need the quicktime components from one of those two versions
who knows...
im gonna try that kext
thx


What did you come up with? We really need all of the files and from 10.4.8 would be the best to use.

I may have found a temporary solution but I have not yet tested it out

http://forum.insanel...mp;#entry768311


Not bad but its kind of an ugly solution. Having to go through all that to use your cam well I would not want to do that.


here is a ton of sonic drivers for os xhttp://www.sonix.com...x/family.do?f=3a bunch of em... gonna try some - u guys get started too ;)http://www.sonix.com...ct.do?p=SN9C202this is imo - possibly a good try for us as our dv hp computers do have a mic beside the cam itself - this is probably some sheit that connect to one chip.lets try guys ! :DaRt


I have tried those before. There is no better match for me then what I have now which is SN9C201. However perhaps you guys will see a difference. Also the quicktime component never seems to load from the sonix driver. If we could get it to load it might really help us sonix and chioney users.


I've tried that IOUSBFamily.kext.rar... no results... ;)

Maybe this can give us some help also...

http://techslaves.or...dex.php?page=52


I already mentioned looking at that page. That is how I arrived at the VDC.plugin solution and where I found out what the cam uses to load in the first place. Did you not see all my other posts above? We should be able to get closer with files from tiger now.


i am on acer crystal eye webcam on my aspire 4710 laptop. i could see a part of the frame in login options when i installed 10.4.9 whose kext i have uploaded. not even that lucky in 10.4.8, 10.5.1 or 10.5.2. tried macam, but no go.

let me know if i can be of any help.


Its not all that one kext. See the list above we need all of the files to make this work. If we get AppleUSBVideoSupport.kext and all the quicktime stuff from 10.4.8 we should be in business.

#30
YzorYzor

YzorYzor

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
[codebox]HP Webcam:

Version: 6.06
Bus Power (mA): 500
Speed: Up to 480 Mb/sec
Manufacturer: Chicony Electronics Co., Ltd.
Product ID: 0xb023
Serial Number: SN0001
Vendor ID: 0x04f2
[/codebox]
This is my webcam .. I get the blue-light on the cam but no image. Is there a known solution for this Cam?

#31
00diabolic

00diabolic

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 812 posts
  • Gender:Male
  • Interests:Modding anything.

HP Webcam:  Version:	6.06  Bus Power (mA):	500  Speed:	Up to 480 Mb/sec  Manufacturer:	Chicony Electronics Co., Ltd.  Product ID:	0xb023  Serial Number:	SN0001  Vendor ID:	0x04f2
This is my webcam .. I get the blue-light on the cam but no image. Is there a known solution for this Cam?


Did you read above? The best solution is the UVC drivers from 10.4.8. If we can get someone to post those thats running that version of tiger we are in business. I do not have full support and its because of leopards UVC driver package. Tigers was better and more cams worked with it. We need all of the files from 10.4.8 to make it work right.

#32
YzorYzor

YzorYzor

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
Hmm you mean trying to delete the DVC plugin? No not yet tried it, but I was looking for a more universal solution, The UVC drivers you mention seems to be the one...

Requestion: Can someone post UVC drivers from Tiger 10.4.8 ???

#33
Monkey_@@

Monkey_@@

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
  • Gender:Male
I've got the 10.4.8 installation DVD... is there any way to extract those files from it? If so, how can I do that?

#34
samsu

samsu

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I have HP 6700 and using 10.5.3

I have iChat, Yahoo messenger working with camera but Skype, photo booth not working. photo application from my login account is not working either. photo booth seem to start my camera but image is total white.

This is how it shows in my system profile.
HP Webcam:
Manufacturer: Chicony Electronics Co., Ltd.
Product ID: 0xb015
Vendor ID: 0x04f2

This behavior is opposite to some other posts where photo booth is working but iChat is not. I also tried to remove VDC.plugin but it did not help.

Any help guys???

-Sam

#35
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

Isn't rossetta for old mac apps, like pre OSX apps? Am I right there or wrong? How can I use Ichat through rosetta?

I used IUSB chat and got nothing with that. I can get the cam to work in photobooth but only to take a pic for use as a avatar in the accounts screen in preferences. Which is sooo weird.. How can it work there and not work in the full app?

Rosetta is not for pre OS X apps, is for OS X apps compiled for PPC Macs.

Pre OS X apps can run on some PPC Macs with System 9 natively and on some only with System 9 within OS X, but Leopard hasn't support now.

Even that Rosetta can emulate the instrucctions from PPC to X86 you cant use it with drivers.

#36
asstastic

asstastic

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
  • Gender:Male
  • Location:Austin, TX
ok, I managed to pull
AppleUSBVideoSupport.kext
QuickTimeUSBVDCDigitizer.component,
QuickTimeIIDCDigitizer.component

from a 10.4.8 Jas DVD with pacifist. these came from the essentials install package on the DVD so I don't think they've been tampered with or come from another OS version. it would be nice to have a genuine 10.4.8 DVD on hand to be sure but you can test these out.

it looks like VDC.plugin and RawCamera.bundle were added at a later date since neither of them were on the DVD in fact "/System/Library/PrivateFrameworks/CoreMediaIOServicesPrivate.framework/" is missing completely on 10.4.8.

I've tried everything I can think of to get my webcam working and still no luck.

could someone with a working camera post the IORegistry information. The easiest way to do this if you have xcode installed is to run the "USB Prober" that comes with and copy the information from there.

Attached File  10.4.8_webcam_support.zip   400.51KB   608 downloads

#37
mjp216

mjp216

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
i have an acer laptop and the webcam comes up as a USB camera. it works flawlessly with ichat and also in online flash. i haven't tried with maccam because, well, {censored} maccam. all i want to do is get my camera working in photobooth. im not going to buy a new webcam because 1. i dont want to 2. i shouldnt have to and 3. the reason im posting is to solve the problem without doing so. when i start photobooth it loads up fine but i get a black screen, oh well... any suggestions??

Acer CrystalEye webcam:

Version: 1.00
Bus Power (mA): 500
Speed: Up to 480 Mb/sec
Manufacturer: SuYin
Product ID: 0xa101
Serial Number: CN0314-OV03-VA-R02.00.00
Vendor ID: 0x064e

#38
jivhg

jivhg

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 211 posts
  • Gender:Male
  • Location:in your house
No Success here:

HP Webcam:

Version: 6.06
Bus Power (mA): 500
Speed: Up to 480 Mb/sec
Manufacturer: Chicony Electronics Co., Ltd.
Product ID: 0xb023
Serial Number: SN0001
Vendor ID: 0x04f2

But, I have made a shocking discovery :(

/Library/QuickTime/DesktopVideoOut.component/Contents/MacOS/DesktopVideoOut: mach-o, but wrong architecture
2008-06-18 21:03:45.971 Photo Booth[33527:10b] Error loading /Library/QuickTime/DesktopVideoOut.component/Contents/MacOS/DesktopVideoOut: dlopen(/Library/QuickTime/DesktopVideoOut.component/Contents/MacOS/DesktopVideoOut, 262): no suitable image found. Did find:
/Library/QuickTime/DesktopVideoOut.component/Contents/MacOS/DesktopVideoOut: mach-o, but wrong architecture


I got this error in terminal while running:

/Applications/Photo Booth.app/Contents/MacOS/Photo Booth

So, this may be a hint.

I wonder what "but wrong architecture" is supposed to mean. Is it our processors?

#39
k0yla

k0yla

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

No Success here:

HP Webcam:

Version: 6.06
Bus Power (mA): 500
Speed: Up to 480 Mb/sec
Manufacturer: Chicony Electronics Co., Ltd.
Product ID: 0xb023
Serial Number: SN0001
Vendor ID: 0x04f2

But, I have made a shocking discovery :)



I got this error in terminal while running:

/Applications/Photo Booth.app/Contents/MacOS/Photo Booth

So, this may be a hint.

I wonder what "but wrong architecture" is supposed to mean. Is it our processors?



Haha, very interesting discovery. I am one of the ones waiting on this as well.

#40
KiTzBiTz

KiTzBiTz

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts
My Acer Suyin Webcam works fine with EvoCam. Record Video & Audio.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy