Jump to content

10.4.4 Azalia Audio ALC880 and networking


22 posts in this topic

Recommended Posts

Hello All!!


i was reading this forum for quite a while now and tought i might help a bit :)




i got a HP Pavilion PC with:

CPU:Intel Pentium 4 640 3.2Ghz with PAE, NX, SSE3

Ram: 1Gig od DDR2 Ram

Mainboard:ASUS PTGD-LA (custom)

Sound: ALC880

LAN: Realtek 8139 10/100

HDD: SATA Maxtor DiamondMAC 10 8mb cache

DVDRW: HP DVD Writer 640

VGA: ATI Radeon X600PRO 256MB


This machine works out the box (yes everyting works!! --> except the resolution change problem) for Mac OS X86 10.4.3 but not for 10.4.4.


What does not work in 10.4.4:

- Audio

- Lan


How to fix this two thing:


1.) FOR LAN:



Copy IONetworkingFamily from the 10.4.3 installation (it is located in /System/Library/Extensions) to 10.4.4 (/System/Library/Extensions)



Open the Terminal:

Write sudo -s and press "enter"

Wrtite your password and press "enter" again.


Now go to: /System/Library/Extensions


chmod -R 755 IONetworkinFamily.kext/

chown -R root:wheel IONetworkinFamily.kext/


Repair permisions and reboot. It should work now (it does for me)




This board uses the Realtek ALC880 audio codec.


First: from the 10.4.3 Extensions folder copy the AppleHDA.kext, Apple02Audio.kext to the Extensions folder in 10.4.4 (i also copied AppleAC97Audio.kext ----> i am not sure if this one needs to be replaced, i yust did it :D)



Open the Terminal:

Write sudo -s and press "enter"

Wrtite your password and press "enter" again.


Now go to: /System/Library/Extensions


chmod -R 755 AppleHDA.kext/

chown -R root:wheel AppleHDA.kext/


chmod -R 755 AppleAC97Audio.kext/

chown -R root:wheel AppleAC97Audio.kext/


chmod -R 755 Apple02Audio.kext/

chown -R root:wheel Apple02Audio.kext/



Remove the extension.kextcache from /System/Library



Repair permissions





DO NOT REMOVE OR REPLACE THE AppleAzaliaAudio.kext! This will give you an error at boot!


Yust for the record:

The mouse tearing is still pesent in both the 10.4.3 and in 10.4.4!


In the Attachment there are my Extension files from 10.4.3!


[Edit - Attachment containing apple kexts removed]

Edited by 0uch!p0tat0
Link to comment
Share on other sites

I am posting the AppleAzaliaAudio.kext because a guy said he doesnt have it...


I tried the steps described above.....sound works, network still doesnt. My card is recognized as Bilt in, but it doesnt get an IP adress. All works great in 10.4.3. Any other ideeas?

Link to comment
Share on other sites

I have an Intel D945PSN with the sigmatal 9220 audio codec running 10.4.4. Followed instructions. Sound is now controllable in system prefs but no audio signal is coming out of any of the ports... Also networking lets me have a built-in ethernet port now (before it was gray) but selecting it crashes system prefs. Sigh...

Link to comment
Share on other sites

Naturally, I'm still soundless.


I have Intel ICH6, but AppleAzalia won't initialize (com.apple.iokit.IOHDAudioFamily: no valid version of this dependency can be found). The only extension registering that "dotty" name is IOHDAudioFamily.kext.


Which confuses the heck out of me because IOHDAudioFamily.kext is a PlugIn of AppleAzaliaAudio.kext! W.T.F.!? :shock: And even more confusing, the system profiler (software/extensions) tells me that IOHDAudioFamily is VALID, AUTHENTIC, and its dependencies are SATISFIED.


I've gotten so many versions of HDA (High Definition Audio) and AppleAzalia, replaced and chowned and cleared cache and rebuilt kextcache and rebooted and tried over and over, I think I have carpal because of it! <_<


Ditto with AppleAC97Audio.kext - the ICH6 listing here wants 266e8086, I have to edit it to read 26688086, but no workee anyway.


The SPECIFIC chipset and driver:

82801FB ICH6 High Definition Audio Controller

C-Media 9880L or Microsoft UAA Bus Driver for High Definition Audio


Why can't an ICH6 act like all the other ICH6s? :angry:


The motherboard in question: MSI 915GM-FR


The Wiki said someone had audio working on this MB, I sure want to know how or why! Maybe it was 10.4.1... :unsure:


Anyhow, I've spent a week learning about the audio kexts and the plist files and their plugins and checking dependencies and... :laser:


I probably am going to take a chicken exit and get a USB audio device (like an Apple brand)... :happymac:

Link to comment
Share on other sites

I had used the 10.4.3 AppleHDA.kext as well, with no luck.


I was trying with v. 1.1.0a20 from my 10.4.3 installation (also tried 1.1.0a41 from 10.4.4).


What version are the successful people using?


Also, to people having success:


Is the name of your output device "HD Audio Output?" And on the D945 series with 5.1 audio, which audio port becomes active? Green, pink, or blue?

Link to comment
Share on other sites

I have audio!!! Rocking out right now. :) Thanks to kevlar!


As he said, just use the AppleHDA.kext version 1.1.0a20 from 10.4.3.


DON'T use AppleAzaliaAudio.kext or AppleAC97.kext. If your sound output device in sys. prefs. says HD Audio or something of the like, you need to dump those two kexts.


Using just the AppleHDA.kext, your sound output device will say Internal Speakers. This is what you want.


On my D945PSN, the audio signal comes out of the blue sound port on the back. The green and pink ports on both the front and back don't send anything out. (haven't tried recording).

Link to comment
Share on other sites

An update on the networking for D945PSN using IONetworkingFamily from 10.4.3:


After plugging in a cable, ethernet does work! :angry: However, if you try to view the system prefs area for ethernet, system prefs crashes. Luckily by default DHCP is enabled.


Crash reporter:


Exception: EXC_BAD_ACCESS (0x0001)

Codes: KERN_INVALID_ADDRESS (0x0001) at 0x6b2f3c6e


Anyone else having this behavior with system prefs?

Link to comment
Share on other sites

I didn't apply any extra patches to the 10.4.3, or the Ghost image installed 10.4.4 - Networking actually was problematic at first, but eventually it got doing its DHCP thing and was a happy critter. The 10.4.4 image was set up for dialup networking I think, that was the main issue (no modem).


10.4.4 had a nagging tendency to ask for login keychain, which was on the default user's home - so I just erased that keychain folder and it stopped dogging me about it.


Can you use the GUI when in safe mode? See if that still crashes it. Also, give a go at different color depths - thousands or millions.

Link to comment
Share on other sites

  • 2 weeks later...

Can anyone PM me, cause i have some 'questions' regarding the AppleHDA.kext, Apple02Audio.kext, AppleAC97Audio.kext files? I need to source them...

Another quick question, what does it mean to repair the permissions??

Thanks a bunch...

Link to comment
Share on other sites


  • Create New...