Jump to content

iLife Garageband Only won't install


jfn
 Share

14 posts in this topic

Recommended Posts

Obtained iLife "GarageBand only" and the dmg verifies and mounts fine, but when I run iLife 06.mpg it immediately says it can't open and quits. I went into the package and tried to install Distribution.dist, which (thought it doesn't load the correct strings) allows me to start installing, at which point it immediately reports an error and stops. GarageBand.mpkg says it won't run as a standalone and quits.

 

I changed my version and build strings to 10.4.4 and the new iMac Core Duo build already.

 

Any idea what might be wrong? Also, does anyone have an md5 checksum of this dmg so that I can check it? I'm downloading it again to make sure. I can't easily use the whole iLife dmg, as all my free space is on a shared drive that's FAT32, and it doesn't support files larger than 4gb.

 

Thanks!

Link to comment
Share on other sites

i 've already installed it !!!

but now i have dowloaded the full ilife 06

 

i think that you must look inside the packet and launch the installer inside.

(right clic and select " show packet content" )

 

personalize and select ONLY GarageBand....

 

this worked for me.

 

dont forget to download quicktime 7.0.4 from apple site (you have already qt 7.0.4, but it dont work and i dont know why !!!), install it (it is an universal binary... ;-) )

 

and it work very well

Link to comment
Share on other sites

I was concerned about using the Quicktime from the website because of this thread: http://forum.osx86project.org/index.php?showtopic=7241 ... though it's unclear if it's actually a problem. If it caused no problems for you that's awesome... but since I have to use SSE3 emulation it might be different.

 

Anyways, the installer doesn't say anything about Quicktime, whereas I thought other people received specific error messagse that indicated they needed to upgrade.

 

I am using the "Distribution.dist" installer inside "iLife 06.mpkg" - I've tried the main mpkg and deeper installers and none work. This one lets me select what to install (and I only select GarageBand), but then reports an error as soon as it starts installing. The install log says this is the error:

 

Failed to locate package at path /Volumes/iLife 06 GarageBand Only/iLife 06.mpkg/Contents/Installers/GarageBand.mpkg/Contents/Installers/GarageBand.pkg

 

... but that package is there! I can see what's in it and try to run it (thought it says I have to use the main iLife installer).

 

Anyone know what might cause this? Is it really Quicktime related?

Link to comment
Share on other sites

If you have the version "GARAGE BAND 06" alone... on the installations, costumize the programs your want to install, and then uncheck the other programs (like iDVD..iMovie..etc.. ), and check only GARAGE BAND...

After Instalation, you need to re.install the last version of Quicktime to use Garage Band.

Link to comment
Share on other sites

same thing happened to me.. What I did is to go into contents of Ilife to Garageband and then again into Garageband.mpk.. Go into the folder called Installers and install those packages individually..

 

1- Garageband installer

2- Apple Loops

3- Garageband Entruments

 

and so on...

 

 

hope this helps

Link to comment
Share on other sites

Does anyone know how to modify the Garageband.mkpg so that I don't get "ERROR_NO_STANDALONE" (when running the Distribution.dist inside it), which is localized to "you need to run the actual iLife installer"? Maybe if I can isntall directly from this it will fix my problem....

Link to comment
Share on other sites

Thanks learning_bird. I used Pacifist and was able to install it. It asked me to upgrade Quicktime (guess changing my version string to 10.4.4 didn't help), so I did and that went fine. I'll check my other apps later to make sure they didn't get broken.

Link to comment
Share on other sites

I might as well mention it here too. Some Rosetta apps stopped working for me when I installed Garage Band and QuickTime, and my system is very close to the dev system (see sig). The two apps that broke were UT04 (largely unplayable) and Halo (playable with neutered graphics). All my other Rosetta apps continued work, including Office, Quake III, and RCW. At first I suspected AltiVec was damaged, but I seem to recall that the G4 version of Quake III still worked, so I guess not. Anyway, I decided to reformat and reinstall everything but QuickTime, so it wouldn't bite me in the ass later on. I have no idea what else QT breaks and I don't want to find out.

Link to comment
Share on other sites

Yeah, I read your other posts and was worried about it, but I figured I'd try and be able to post my own results to help out. So far no problems, but I'll post here if I find that Quicktime messed something up. Garageband runs smoothly.

Link to comment
Share on other sites

  • 1 month later...

Is this easier than using Pacifist?

 

Before you launch the installer, create a file in /tmp with the name "com.apple.mpkg.iLife". You might want to use the Finder "Get Info" command to check that there is no hidden name extension, depending on how you create the file.

Link to comment
Share on other sites

  • 2 years later...

As usually Internet knows all:

 

http://www.demonoid.com/files/details/2589...page=7#comments

 

Created by poub 3 years ago 

Applications : Macintosh

Launch the iLife installer and click on "customize". then select only GarageBand application (don't select garageband demo songs).

 

Well.. that the way it was supposed to work but the archive is broken. Sorry.

 

But don't worry, don't put your file on the trash because you get everything. You only need to delete 3 files and you will be ok.

 

Here the fix to install GarageBand:

- Mount the dmg on your desktop

- Right click on iLife06.mpkg and select "Show package contents"

- Go into installers and Copy GarageBand.mpkg on your desktop. (After the installation of GarageBand you will be able to delete it)

- open Terminal and type "cd " (with a space, don't press enter)

- drag your GarageBand.mpkg package on this windows (you're going to see the path of where the package is located on your hardrive, it must be something like ~/Desktop/GarageBand.mpkg) 

- press return

- now copy and paste the following commands:

 

rm Contents/Installers/GarageBand.pkg/Contents/Resources/InstallationCheck

rm Contents/Installers/GarageBand_MIDI_Tiger.pkg/Contents/Resources/InstallationCheck

rm Contents/Installers/GarageBand_Loops_Tiger.pkg/Contents/Resources/InstallationCheck

 

Now right click on GarageBand.mpkg, select "Show Package Contents" and go to installers.

Double click on GarageBand.pkg, It will install GarageBand

Double clik on GarageBand_MIDI_Tiger.pkg ...

Double clik on GarageBand_Loops_Tiger.pkg ...

Double clik on GarageBand_Instruments.mpkg ...

 

Then you should be ok.

 

Alternatively you can re-integrate those package into the "iLife 06 iPhoto only" or "iLife 06 iMovie only" seeds.

 

And do not forget about:

 

Posted by technilogica 2 years ago [ Complain ] [ Send PM ]

@melonrecords

 

I had to delete two more files before installing the instuments:

Go into: GarageBand.mpkg/Contents/Installers/GarageBand_Instrume

nts.mpkg/Contents/Installers/

 

and delete: GarageBand_Instruments_Tiger.pkg/Contents/Resources/InstallationCheck

 

and: GarageBand_FactoryContent.pkg/Contents/Resources/InstallationCheck

Link to comment
Share on other sites

  • 5 months later...

when i downloaded it, once inside of the Installers directory inside the iLife 06 directory there should've been two items, GarageBand and also iLife Registration... you install the registration, then install GarageBand. Thats what worked fine for me.

Link to comment
Share on other sites

 Share

×
×
  • Create New...