Jump to content

ASUS P5LP-LE (HP a6120n) Installation Guide - Sleep works!

time ed

99 posts in this topic

Recommended Posts

Before We Begin --

a) I will cover EFI/Leopard installation on an off-the-shelf PC equiped with a ASUS P5LP-LE (Leonite) motherboard using both patched kexts and efi-gfx strings. If you don't have a Asus Leonite motherboard, or even similar hardware, the installation methods are the same for any machine. You will need only a few different files.

B) My hardware:

-- E4400 Core2Duo processor 2Ghz/800Mhz FSB.

-- 2Gb 667 PC-5300 RAM.

-- 945G/ICH7-DH controller.

-- Nvidia 7600GT (256Mb) in 16x PCI-E slot.

-- ALC888S onboard audio controller.

-- 2 400Gb drives on SATA slots 1 and 2.

-- SATA controller mode is AHCI.

-- Onboard GMA950 is diabled in the BIOS.

-- Onboard Intel 82562V NIC - working (see post #39)

c) You can install with either with GMA950 or the Nvidia 7600GT, no problem. I use the 7600GT.

d) I maintain my home directory on a volume separate from the OS. Doing so makes backups and reinstalls a snap.

If you have a separate drive or partitition to use, but you've never moved a home directory, Koos has a great tutorial here:


e) The files required for installation (plus backups) are kept in my home directory. During installation, I executed commands in terminal from that volume. That's what works for me, and that's what I'll demonstrate here. There are other methods of Leopard/EFI installation documented in this forum, including thumb drive, custom DVD, external disk, flat image, and so-on. Pick what works for you. If you've never done this before, I recommend you read these threads all the way through before starting:





f) EFI requires certain BIOS settings to work (XD+1, maxCPULimit). Depending on the brand your board was assembled under, and the make and serial of the BIOS, you may or may not be able to change these settings. One thing is for sure: if you purchased a machine with the Asus P5LP-LE in the last year, and it came with Vista pre-installed, the required settings are correct.

g) To properly install Leopard, you must have SATA drives with the controller mode set to AHCI in the BIOS. Changing the controller mode on a pre-existing installation (such as Windows) will render it unbootable. Plan accordingly.

h) I will not cover dual-boot. If you value your Windows installation, there are some dual-booting guides you can combine with this one.


Files required for this exercise:

a) Retail Leopard (go ahead and buy it - make sure Jobs gets his cut)

B) BrazilMac DVD patcher http://forum.osx86scene.com/viewtopic.php?f=16&t=2008

c) efi_pc_v80 (or latest): #leopard on IRC

d) dsmos.kext (in efi_pc package): #leopard on IRC

e) AppleSMBIOS.kext: http://www.macdotnub.info/downloads/get.php?id=9

f) NVInject: http://nvinject.free.fr/downloads.php

g) Time Machine fix: #leopard on IRC

h) Taruga's HDA patcher http://forum.insanelymac.com/index.php?showtopic=32859

i) If you have ALC888S, this codec: http://psykopat.free.fr/apple/AppleHDA/realtek/ALC888-D.txt

or my codec attached below.

j) the patched AppleIntelIntegratedFramebuffer.kext from Tiger (if you plan to use GMA950).

k) AppleIntel8255x.kext (attached below as 82562v.zip).

Note: please read these threads to understand which types of 82562v NIC's will work with this fix:





If you intend to use efi-gfx strings:

a) IORegistry Explorer: http://www.mediafire.com/?4b2ap1lagzh

B) Plist Editor: http://www.mediafire.com/?7l9swyahtzv

c) mcmatrixs' gfxutil: http://rapidshare.com/files/83220759/gfxutil.zip.html

d) this .plist: http://www.mediafire.com/?8hcvbho1rhd

e) com.apple.Boot.plist: http://www.mediafire.com/?0btisthlyk1

NOTE: You need a working system first!: The object of bootable strings with efi_pc_v80 is to give your system information about your graphics, networking, and audio devices at boot time. Using strings also relieves the need for injector kexts (added bonus).


To get XYZ video card or ABC audio device to work you will have to pass the system some properties of the device along with its location in the IO Device Tree. How does that work? By adding device properties to an XML file (.plist), using mcmatrixs' tool to convert the XML to hex, then adding the hex string to a boot file for your system to interpret.


Not all devices work. First, your system must already have a driver for the device. Next, you must determine the properties of the device your system requires. For that, you will have to experiment. Audio on my system requires a modified HDA kext along with layout-ID and pin configuration in the string. Some audio devices need only location. Some Nvidia cards require more device information than others. You get the idea.


The best thing to do is scout around the netkas forum (http://forum.netkas.org) for .plists describing devices similar to yours. Edit the plist with the correct path for device and give it a try. If it fails, you will have to research the properties for your device and try again. If it works, please post for others...


Optional (but recommended):

a) Your original Tiger or Windows installation disc (if you decide to abort)

B) Boot-it NG (for reformatting your drive FAT32 if you do abort) http://www.terabyteunlimited.com/bootitng.html

c) DamnSmallLInux http://www.damnsmalllinux.org/ or Knoppix http://www.knopper.net/knoppix/index-en.html

A LiveCD should always be in your toolkit. When all you need is a terminal, DSL/Knoppix boot 100x faster than the OSX install disc. You can even use Ubuntu if you're more comfortable with desktop and file manager. Under Ubuntu, kext's show up as folders and you can drag them around. Make sure you mount drives read/write http://www.frozentech.com/content/livecd.php


Getting started:

1. Create a patched install DVD with BrazilMac script. Be sure to set the path variables at the top of the script. If in doubt, set the full path. Remember to run the script as root.

2. Move all of your gathered files into one command-line-friendly directory on some separate drive.

3. TEST your install DVD. You should be able to boot cleanly, run the installer to the point of no return, and all the utilities. Take notice of how long the DVD takes to load and any quirks along the way. Mine loads cleanly in less than 10 minutes. Test network tools to see if your NIC is recognized. Play with DiskUtil. Open terminal and find your installation files.

4. Exit DVD and back up your home directory; or, if you're ready, skip to step 6.


OSX Installation:

5. Boot the DVD.

6. Once the installer is loaded, open Disk Utility.

-- Highlight the drive you're formatting.

-- Click the Partition tab.

-- Click the drop down menu and select "1 Partition".

-- Click Options and select the GUID Partition Table-format.

-- Click Apply. The drive will format.

7. When the drive is ready, click infofd5.png in the Disk Utility menu to get the ID's for the drive and partition. Write them down.

-- Your diskID will be in the form: disk[number] e.g.: diskidlm7.png

-- Your parition ID will be in the form: disk[number]s[number] e.g.: partiduv0.png

-- For the commands below, X will be your diskID and Y will be your partition ID, e.g.: /dev/disk0s2

8. Exit Disk Utility and open Terminal.

9. In terminal, cd to the pc_efi directory where you gathered your files. Mine were in my home directory on a separate drive. For instance, I would cd to /Volumes/<drive name>/Users/<me>/Leo_Patches/pc_efi_v80.

10. Run the following commands EXACTLY:

(NOTE: the "#>" symbols below are meant to represent a cursor prompt in a terminal. Please don't type them.)


#> diskutil unmountDisk /dev/diskX

[ignore "...cant get UUID of host: ERROR 35" if you see it]

#> ./startupfiletool /dev/rdiskXsY ./boot_v8

[terminal spits back a few lines]

#> dd if=./guid/boot1h of=/dev/rdiskXsY bs=512 count=1

[terminal spits back a few lines]

#> dd if=./guid/boot0 of=/dev/diskX bs=400 count=1

[terminal spits back a few lines]

Pay attention to what's returned after commands. As long as you don't see errors such as "no such command" "resource busy" "no such device", you should be good.


11. At this point you have two options:

a) test your partition by exiting the Installer and rebooting. If you were successful with startupfiletool, you will boot in to the error "com.apple.boot.plist not found", at which point you'll have to boot back into the installer.

B) continue the installation. If you choose to continue, exit Terminal, click Continue, agree to the license, select your drive.

-- When you reach the Summary panel, make sure you click "Customize" and deselect everything but the main system.

-- Click Continue...

12. When the installation completes, you must either boot back in to the installation DVD or a liveCD. Do NOT try to boot the desktop.

13. Once the installer (or liveCD) loads, open Terminal and cd back to your installation files/home directory.

14. Remove the original AppleSMBIOS.kext, CPU Power Management, and IONetworkingFamily like so:


#> rm -rf /Volumes/<drive name>/System/Library/Extensions/AppleSMBIOS.kext

#> rm -rf /Volumes/<drive name>/System/Library/Extensions/AppleIntelCPUPowerManagement.kext

#> mv /Volumes/<drive name>/System/Library/Extensions/IONetworkingFamily.kext/Contents/MacOS/IONetworkingFamily IONetworking.orig

15. Copy over your new kext's:

#> cp -R dsmos.kext /Volumes/<drive name>/System/Library/Extensions/

#> cp -R AppleSMBIOS.kext /Volumes/<drive name>/System/Library/Extensions/

#> cp IONetworkingFamily /Volumes/<drive name>/System/Library/Extensions/IONetworkingFamily.kext/Contents/MacOS/

If you intend to use the GMA950:

#> mv /Volumes/<drive name>/System/Library/Extensions/AppleIntelIntegratedFramebuffer.kext AppleIntelIntegratedFramebuffer.kext.orig

#> cp -R AppleIntelIntegratedFramebuffer.kext /Volumes/<drive name>/System/Library/Extensions/

If you intend to use the GeForce card:

#> cp -R nvinject.kext /Volumes/<drive name>/System/Library/Extensions/

If you intend to use the onboard Intel 82562v NIC:

#> cp -R AppleIntel8255x.kext /Volumes/<drive name>/System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/

#> mv /Volumes/<drive name>/System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/AppleIntel8254XEthernet.kext Intel8254x.orig


16. Change permissions, etc:

#> cd /Volumes/<drive name>/System/Library/Extensions/

#> chmod -R 755 nvinject.kext dsmos.kext AppleSMBIOS.kext AppleIntelIntegratedFramebuffer.kext IONetworkingFamily.kext

#> chown -R root:wheel dsmos.kext

#> chown -R root:wheel AppleSMBIOS.kext

#> chown -R root:wheel IONetworkingFamily.kext

#> chown -R root:wheel AppleIntelIntegratedFramebuffer.kext

#> chown -R root:wheel nvinject.kext

17. Exit Terminal and the Installer. Reboot.

You should boot right to the welcome screen. Go through the set up and registration rigamarole and you'll be at a desktop. Run Software Update and take the upgrade for 10.5.1/iTunes/Quicktime. Reboot.


18. Unzip Toruga's patcher. Drag the codec on to the unzip'd app (the frog head icon). The application will start and ask for your password. As soon as you authenticate the patcher will chug away. When it's finished, it will display a dialog box of specs for your sound chip. Reboot. You should have sound with full capabilities. I even have S/PDIF in and out!!


18a. After adding device path, layout-ID, and pin configuration to efi-gfx string; then removing alcinject.kext, but leaving Taruga-patched AppleHDA.kext, sound capability is the same. I have tested built-in line in (microphone) and line out (2.1), headphone, S/PDIF in and out. All work very well. I have not tested 5.1 or 7.1 output as I do not have the equipment.


The GeForce card works out of the box. With either NVinject or efi-gfx strings I have DVI out, and dual-DVI monitor capability, QE/CI, full resolution, the works.


If you use the onboard GMA950 with the Tiger framebuffer kext, all should be good. I have read many threads about mouse tearing and/or artifacts with the GMA950 under Leopard. I have experienced slight artifacts only with Firefox, and have seen no other problems. From what I've read, its either feast or famine with the GMA950 under Leopard.


Using efi-gfx Strings

Now that your system is working with GUID and efi_pc_v80, you can use bootable (efi-gfx) strings. If you have exactly the same hardware as me (meaning a 945G Leonite mobo, 7600GT graphics card, and ALC888S audio), you can use linked com.apple.Boot.plist right away. Follow steps 7-9 below. If not, you have some reading to do.

Start here: http://forum.netkas.org/index.php/topic,104.0.html

If you have questions about mcmatrixs' utility or device path syntax, go here: http://forum.netkas.org/index.php/topic,64.0.html

Once you're ready to make your string, go here: http://forum.netkas.org/index.php/topic,9....28.html#msg1028

In a nutshell, you must:

1. dump your ioreg.

2. find your device path.

3. find your device properties.

4. edit your device path and properties in xml .plist.

5. convert .plist to hex.

6. add hex string to com.apple.Boot.plist.

7. replace com.apple.Boot.plist in /Library/Preferences/SystemConfiguration - repair permissions

8. remove injector kext's, restore vanilla IONetworkingFamily.

9. clear cache and reboot.


[EDIT 2.12.08] Updated to 10.5.2 using the Netkas Method ( http://netkas.org/?p=50 ). Took all of ten minutes.

Took the graphics driver upgrade afterwards with no problems. I think the machine might have gained a little performance!


[EDIT 3.6.08] Finally got my onboard Intel NIC working. See post #39.





Application short-cuts with Stacks:



Vista under VMWare Fusion in Unity mode. Fusion is one slick app:






Link to comment
Share on other sites

Hi Time Ed, please tell me sleep works on your installation method. If so, I will gladly destroy my Vista installation! Also, I have a wireless N card that works out of the box with Leopard. I will post the details when I get home from work this afternoon.

Link to comment
Share on other sites

Yes! Sleep works perfectly on this machine.


I've tested it from the Apple menu, timed via Energy Saver in System Preferences, and with the power button on the machine.

It takes about 20-or-so seconds for the display to return on wake.


Shutdown and restart all work fine as well....

Link to comment
Share on other sites

Fantastic! The wireless N card I spoke of earlier is the Netgear RangeMax Next Wireless-N PCI Adapter. Model number WN311B. Strangely it shows up in Leopard as built-in ethernet, but works out of the box. I am going to try your install method after I emerge from the mountain of end of semester school work this weekend!


Scratch that about the N card. Reception was very spotty along with dropped connections. Using PCI ethernet with tulip.kext instead.

Link to comment
Share on other sites

How do I not get resource busy...I've tried everything? Can you tell me EXACTLY how not to get resource busy?


In Terminal:

diskutil unmountDisk /dev/diskX


where X is number given to you when you click "info" in Disk Utility after highlighting the drive you want to install to...

Link to comment
Share on other sites

In Terminal:

diskutil unmountDisk /dev/diskX


where X is number given to you when you click "info" in Disk Utility after highlighting the drive you want to install to...


I just figured out what I was doing wrong...the last step I thought the disk is "where" the efi is...it is where efi is going!





Link to comment
Share on other sites

Well I have got everything working except sleep. Doesn't matter to me...I will gladly pay the extra $100 a year in electricity (disable sleep) for Leopard. I purchased a Visiontek ATI 2600XT video card at Circuit City last night. It works perfectly with my dual monitor setup. The only problem is that DVI is currently not supported with the #radeonhd installer.


Have any ideas about my sleeping problem?



Link to comment
Share on other sites

That's a shame about sleep. What fails?


The trade-off, I guess, is video cards. I tried a 2400Pro, 2600Pro, and 2600XT with every possible kext/natit/efi combination I could think of, and nothing worked. I either had blank menus or a pixelated screen. I gave up and went back to the GMA950. I'm not sure if I'm going to try an Nvidia card. If I find one cheap, I might...

Link to comment
Share on other sites

I haven't looked much into the sleep problem yet...all I can say is that it will not come back out of sleep. I had a distorted screen (kinda looked like Space Invaders) when I first tried the 2600XT. After I wiped my progress and did a clean install everything worked peachy keen.

Link to comment
Share on other sites

Awesome. Thanks a lot. I have an HP Pavilion m8020n with ASUS P5LP-LE. Thanks a lot. Now that I've seen someone on my hardware running it, I have more confidence. Running an 8800GTS 320MB. Hopefully that works with NVInject (lots of success stories so i am safe)

Link to comment
Share on other sites

  • 3 weeks later...

One Question... I've the same Motherboard in my HP and have problems rebooting and shutting down the PC sometimes. Only difference between my and your installtion is, that I use dmos.kext from pc_efi_v80. Do you think dmos.kext from v52 would solve this?

Link to comment
Share on other sites

Your mobo hardware is exactly the same as mine except for maybe video and ethernet card?


dsmos.kext is a binary decrypter - I wouldn't think it would have anything to with startup/shut down/sleep functions.


Does the machine sleep? Does the problem happen all the time or every once in a while?

Link to comment
Share on other sites

  • 4 weeks later...

  • Create New...