Jump to content
InsanelyMac Forum
MrUnknown

Marvin's AMD Utility

Recommended Posts

DON'T PANIC !

 

 

Marvin's AMD Utility

 

For AMD users, this utility allows you to locate the binaries in your OSX installation which are encrypted or have cpuids. Then it will permit you to patch them so that they will operate on your AMD system.

 

Choose from the following 4 options:

 

Make Lists of Binaries
The utility will locate all binaries that are encrypted and those which have cpuids and will provide lists of them to use as you choose.

Create Patcher Package

This creates the standard patcher package for use in single user mode. The utility provides a folder containing:
  • A folder of decrypts (decrypted binaries)

  • A script that installs the decrypts for you (replace.sh)

  • A data file containing the addresses of cpuids needing to be patched (cpuid.txt)

  • The Maxxuss Patcher which is used to patch the cpuids listed in the data file.

Patch all cpuids using a cpuid data file

This allows you to patch all of your cpuids using a cpuid data file that you specify. Where you got the data file is hard to know. Maybe you got it from Marvin's utility. Or maybe it was just floating around the galaxy somewhere.

 

If this type of operation makes you panic, never fear - just click the "simulation" button. The cpuids won't be patched but you will be informed about what would happen if you tried.

 

Oh, you did patch the cpuids and it didn't go as planned. Don't Panic. Just click the "undo" button and try it again.

Patch all binaries

Now you are being bold. Just click that button and let Marvin have his way with your precious binaries. If you are lucky, all of the encrypted ones will be decrypted and all of those pesky cpuids will be patched.

 

Marvin says that you can find his utility here:

 

 

 

And the answer? - 42 of course.

 

 

marvinvu2.png

marvinvu2.4934f772a0.jpg

Share this post


Link to post
Share on other sites
Advertisement
How do I go about using this? Do I need to have Leopard installed first? I'm running 10.4.10 right now.

 

Same question here... :)

I'm running 10.4.10...

Share this post


Link to post
Share on other sites
Same question here... :)

I'm running 10.4.10...

 

I works in Tiger and leopard. I used it from 10.4.10 and it patched my big cat.

 

:D

Share this post


Link to post
Share on other sites
the same question

 

I would download it and run it ;)

 

-point it to your restored dvd

-patch it

-install leo

 

boot you Tiger

-point it to the leopard partition

-patch it

 

enjoy your 9a581 on amd

Share this post


Link to post
Share on other sites

DON'T PANIC!

 

Folks - let's put on our thinking caps.

 

Marvin's utility runs on OSX. So, to run it, you need to have a running OSX installation. And if it is running, it doesn't need Marvin's utility.

 

So, you need an installation of OSX that isn't running for Marvin's utility to patch.

 

To summarize - one OSX partition with OSX that runs and another partition with an OSX installation that needs to be patched.

 

And neither partition has to be Leopard. You can patch 10.4.6 if that is what you desire.

Share this post


Link to post
Share on other sites

great app, extremely useful

however has anyone had any luck cpuid patching nvdaresman.kext in leopard, it never seems to work for me for some reason

Share this post


Link to post
Share on other sites

Is anyone try this with official OSX-Loepard.10.5.dmg?

Can you tell me step by step what to do?

I try it, but no result. :D

Share this post


Link to post
Share on other sites
great app, extremely useful

however has anyone had any luck cpuid patching nvdaresman.kext in leopard, it never seems to work for me for some reason

 

 

maxxuss patcher does not work on kexts that`s well known. One had to patch nvdaresman.kext with a hex editor. But Marvin was able to patch it for me.

Just make sure that you fixed permissions.

chown root:wheel and chmod 755

Share this post


Link to post
Share on other sites

Where would I get the cpuid data file? No need to post a link, just give me a hint. I guess I'm too dense to get the hint in the original post. :)

Thanks

 

EDIT: Never mind...Duh! The tool generates a cpuid data file.

Share this post


Link to post
Share on other sites

but where do I get the decrypts?

 

I need one for NVDAResman.kext !

 

When I run Create Patcher Package for the above file I get:

WARNING! Patcher folder won't have decrypts - none were created

Share this post


Link to post
Share on other sites

What do I need to run this utility?

 

I have tried on a real Macbook/Leopard as well as on a AMD/Tiger and nothing.

 

All it does is ask a administration password then nothing.

Share this post


Link to post
Share on other sites

edmund - Marvin patches Leo after it has been installed onto a partition. It is run from another known working OSX installation. You need two partitions. An iso or dmg could be patched, but it would be a very difficult thing to do. All of the installer packages on the disk image would have to be expanded (basically they would be installed into folders). Then run Marvin to patch whatever it finds inside those folders. Then the folders would need to be recompressed into their original packages and placed onto a new iso or dmg. The amount of work involved is essentially the same as installing it onto a partition - that is how far you would be breaking down the installation packages for patching. Yes, if you knew which packages contained binaries with encryption or cpuids, you could just expand those. But Marvin is designed to work on any current or future OSX release for which the location of encryption and cpuids is not known. Therefore, all packages would need to be expanded to find which files Apple decided to encrypt or embed cpuids.

 

ptesone - The status from Marvin should have said: - Encrypted: 0 and CPUID: 1. NVDAResman.kext does not have an encrypted binary - there is nothing to decrypt. But it does have a CPUID that needs to be patched. The CPUID is code that checks for an Intel processor before it will run. Unfortunately, there is a known problem patching cpuids in kexts. It is being worked on, but the method is entirely different. Marvin will patch the kext using the standard method, but this may not help - try it out. If Marvin did not find NVDAResman.kext as having a cpuid (look in the cpuid.txt file or the log file), then you need to change the permissions on the kext. Go to Terminal and type:

 

(you need to insert the name of the partition on which Leo is installed - like Leopard or OSX or whatever you called it - but without the "<" and ">")
(and use the quote marks for safety)

sudo chmod 755 "/Volumes/<your Leo partition name>/System/Library/Extensions/NVDAResman.kext/Contents/MacOS/NVDAResman"
(then type your password)

If you have already patched your Leo installation and you ask Marvin to do it again, he will get confused and stop - sorry about that. To patch NVDAResman.kext, point Marvin to the Extensions folder and run "Create a Patcher package". Then run again with "Patch all cpuids using cpuid file" and point Marvin to Leo and to the cpuid.txt file in the patcher package that was just created. Or, see if maybe a kext from 10.4.x will work. I examined most of the prerelease versions of Leo to see if one of them had a version of NVDAResman.kext without the cpuid, but no luck.

 

Nomade - I can't really think of a reason that Marvin is not working. It has been tested on both Intel and AMD machines running both Tiger and various versions of Leo including the final release. I just downloaded the file from Rapidshare and it worked just fine. One thought - did you expand the zip file in Windows? The zip was created on OSX and the Archive/Compress routine separates the original file into two parts to preserve them for later reconstruction - some OSX files are comprised of two parts and other OS's only recognize one part. In Windows, the two parts do not get combined and therefore the app probably won't run. In Windows, you might see two files in the folder - the second one would be called: "._Marvin's AMD Utility v.25" (there is a leading dot and underscore). That is the part that did not get recombined. The only solution it to expand the zip on OSX by double-clicking it or using a very recent version of Stuffit.

Share this post


Link to post
Share on other sites

Still no luck running it.

 

I have tried on my Macbook running Leopard 10.5.1 as well as on a DELL SX280 running Tiger 10.4.11.

 

Both have the same results... nothing

 

Is there any way to trace what is going on? Why no interface are showing?

 

thanks

Share this post


Link to post
Share on other sites
Guest Snowski

Excuse me if I sound retarded but I'm still lost here.

 

I have a working Tiger 10.4.10 install (see sig) and would like to know what exactly I have to do after getting the Leopard DVD.

 

Thx

Share this post


Link to post
Share on other sites

Could it be possible to install Leopard and patch it with Marvin's tool from the Installer? I install the OS, reboot and launch the installer again and open this utility from Terminal. Would that work or is it a waste of time? Then I wouldn't need two OS X installations ;)

 

One more thing, do I have to patch the installer before using it?

 

Thanks!

Share this post


Link to post
Share on other sites

I've updated my 10.5.1 components using "Software Update"... (I know it's m fault) now Mac boots normally... I can see the desktop... but in 10-20sec the screen goes black and I'm forced to login window... I login - the same happens...

 

I'm sure I have to patch my files, but the problem is that I have patcher package made with Marvin's DVD Utility before instaling that updates...

(I've tried to run those patcher - no changes)

 

I wonder if there is some kinda of non-GUI version of the patcher that I can run from single-user mode?

Or can someone post here patcher for the latest, fully updated Leo?

Share this post


Link to post
Share on other sites

Would be great if this worked on a leopard install that keeps rebooting to the login screen. I have a 2nd Mac and would like to run it over the network to patch the buggy install.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.



×