Jump to content
brendankoch

How can I Edit com.apple.boot.plist?

39 posts in this topic

Recommended Posts

Can someone please tell me how to edit my com.apple.boot.plist file so that I can change the resolution to 1280x1024? I get permission errors even when using sudo.

Share this post


Link to post
Share on other sites
Advertisement

If you boot in Single User mode you are root so you can type

nano /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

 

edit whatever you want the type Control-X to save and exit.

 

If you booted in GUI run Terminal and type

sudo su

type your password

type the command same command line as in single user mode.

Share this post


Link to post
Share on other sites
If you boot in Single User mode you are root so you can type

nano /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

 

edit whatever you want the type Control-X to save and exit.

 

If you booted in GUI run Terminal and type

sudo su

type your password

type the command same command line as in single user mode.

Much more simpler way to do this is to browse with Finder to /Library/Preferences/SystemConfiguration/com.apple.Boot.plist and just drag damn' file to your desktop. After that edit your file (the desktop one) and save it. To finish the job you drag the desktop version in the same folder where the old one was ... /Library/Preferences/SystemConfiguration/ and it should appear some dialog window....press the Authenticate button and type your password when it's asked for. Good job ... all done! :)

 

By the way ... did you changed your root password?

To do so you open Terminal and type sudo passwd root.

Then you type your password and after that type your chosen root password (twice)

Now it should repeat first part and it should work. :D

Share this post


Link to post
Share on other sites

Why would you want to drag it to the desktop to edit? Just edit the original one. Use a text editor like Smultron (yes, there's an Intel compiled version). When you try to save it, you'll get authentication popup and you just enter the password to save it correctly. Even simpler.

Share this post


Link to post
Share on other sites

Hi all...

 

I´m edit the file /Library/Preferences/SystemConfiguration/com.apple.Boot.plist and insert the lines:

<key>Graphics Mode</key>

<string>1280×1024×32</string>

 

I restart my osx86 (10.4.3) and my screen resolution dont´t change. (original is 1024x768).

 

I open the file again and the lines are there!!

 

What I can do to change may resolution to 1280x1024.

My monitor is LG 710SH 17" and my vga is one FX 5200 with 256mb 128 bits.

 

Tanks and I hope some one can help me.. please..

 

Andre

Share this post


Link to post
Share on other sites
Hi all...

 

I´m edit the file /Library/Preferences/SystemConfiguration/com.apple.Boot.plist and insert the lines:

<key>Graphics Mode</key>

<string>1280×1024×32</string>

 

I restart my osx86 (10.4.3) and my screen resolution dont´t change. (original is 1024x768).

 

I open the file again and the lines are there!!

 

What I can do to change may resolution to 1280x1024.

My monitor is LG 710SH 17" and my vga is one FX 5200 with 256mb 128 bits.

 

Tanks and I hope some one can help me.. please..

 

Andre

Do you ever tryed to type "Graphics Mode"="1280x1024x32" at the Darwin bootloader?

If this also don't work then maybe it's not possible with your Nvidia card in VESA mode.

Share this post


Link to post
Share on other sites
How I can do it in Darwin bootloader? (tanks for the fast response :( )

Press F8 at boot (quickly) and you should have something like this:

qemu7tk.th.jpg

Share this post


Link to post
Share on other sites
Much more simpler way to do this is to browse with Finder to /Library/Preferences/SystemConfiguration/com.apple.Boot.plist and just drag damn' file to your desktop. After that edit your file (the desktop one) and save it. To finish the job you drag the desktop version in the same folder where the old one was ... /Library/Preferences/SystemConfiguration/ and it should appear some dialog window....press the Authenticate button and type your password when it's asked for. Good job ... all done! :D

 

That's not simplier, that's just GUI way.

Share this post


Link to post
Share on other sites

Dear DrJägermeister,

 

Your tip work, I insert im my bootloader and my new resolution are working. But how I can do this automatic?

 

Tanks

Share this post


Link to post
Share on other sites

Open Treminal from the Utilities Folder, then run this:

sudo pico /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

the system ask for your password, then add it after the

Kernel Flags

"Graphics Mode"="1280×1024×32"

 

I don't know why it is not working with

Graphics Mode

1280×1024×32

 

Just a hint, diconnect the TV connector before boot if it is connected of course.

Share this post


Link to post
Share on other sites

I have some sort of the same problem.. I use -s to get single user mode, and I use emacs to edit the Boot file, but I get "read only". Ok I'll just chmod it to a+w, but then it get the following message: Read-Only file system..

 

what to do?

Share this post


Link to post
Share on other sites

How can I make an other partition default. And can I make this bootloader run automatically (without F8) and wait a few minutes to choose if i want to run an other OS???

Share this post


Link to post
Share on other sites

You can try this:

<key>Kernel Flags</key>

<string>rd=diskXsY</string>

 

to boot on another partition, but it didn't work for me (probably because of NTFS, perhaps with FAT32 it'll work who knows...)

 

And with this you'll have the timer:

 

<key>Timeout</key>

<string>8</string>

 

8 seconds here...

 

(As you can see in the file, <key>Timeout</key> and <key>Kernel Flags</key> could already be wrote, don't make twice...)

Share this post


Link to post
Share on other sites
Hi all...

 

I´m edit the file /Library/Preferences/SystemConfiguration/com.apple.Boot.plist and insert the lines:

<key>Graphics Mode</key>

<string>1280×1024×32</string>

 

I restart my osx86 (10.4.3) and my screen resolution dont´t change. (original is 1024x768).

 

I open the file again and the lines are there!!

 

What I can do to change may resolution to 1280x1024.

My monitor is LG 710SH 17" and my vga is one FX 5200 with 256mb 128 bits.

 

Tanks and I hope some one can help me.. please..

 

Andre

 

Maybe if you add a refresh rate it works? Example: 1280x1024x32@75

 

Greetz keeshond

Share this post


Link to post
Share on other sites

Hi there,

I'd like to move to 1280x1024 as well but I tried all these tips with no success. There are other way to set that display resolution? I've a Toshiba M70-166, LCD native res is 1280x1024.

 

 

 

Thanks in advance...

Share this post


Link to post
Share on other sites

I was editing my com.apple.boot.plist file and saved it back and now when I boot it immediately says "missing boot.plist file". I guess I majorly messed it up someway. Anyway to get to it without having to reinstall the whole OSX86 DVD?

Thanks

Share this post


Link to post
Share on other sites
Open Treminal from the Utilities Folder, then run this:

sudo pico /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

the system ask for your password, then add it after the

<key>Kernel Flags</key>

<string>"Graphics Mode"="1280×1024×32"</string>

 

I don't know why it is not working with

<key>Graphics Mode</key>

<string>1280×1024×32</string>

 

Just a hint, diconnect the TV connector before boot if it is connected of course.

 

you mention TV Connector ... exactly what are you referring to there? I have an ATI AIW card with coax connected ... are you referring to that?

 

thx

Share this post


Link to post
Share on other sites

got it working with macgirls method

thanks a lot!

 

 

 

*didn't get it to work on jas 10.4.8 but yes on uphuck 10.4.9 v1.3*

 

 

Is it possible to use 1680x1050?

Share this post


Link to post
Share on other sites

Works nearly fine.

"Graphics Mode"="1680x1050x32" in my com.apple.Boot.plist results in 1400x1050 (unchangable). A real progress in contrast to the formerly unchangable 1024x768.

But does anyone know why it works only with 1400px and not with 1680?

 

 

Edit:

?video at Startup shows that there are only 4:3 ratio resolutions like 1024x768, 1280x1024 etc. available. Is there any trick to get 16:10 ratio resolutions like 1280x800 enabled?

Share this post


Link to post
Share on other sites
you have to

fsck -fy

and

mount -uw /

 

Before you can edit in single user

 

 

Doesn't work in install DVD's Terminal :blowup:

Also, sudo, pico and chmod/chgrp are "unknown commands".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×