Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Álvaro Martins

To Sound or not to sound with AD1986A

12 posts in this topic

Recommended Posts

Hi guys,

 

As many of us, im having the Sound problem.

I have identified my sound card, AD1986A.

 

It look that is an ALC97... is this correct?

 

Wich driver would you advise me to test?

 

Sound card specs by samsung:

Sound


High Definition Audio

Controller


HD Audio Codec,  AD1986A

Conversion


Built-in high performance 20-bit ADC & 24-bit DAC

Internal Interfaces


Embedded stereo speakers, 2 internal microphone

Speaker Power Rating


2 Speakers x 2 Watt with enclosure each

External Interfaces


Microphone, Headphone, Optical S/PDIF out port

Controls


Keyboard volume control, SRS enable / disable

 Microphone


Mono Microphone; Factory Option

Microphone


Mono

Sensitivity


-44dB

Output Impedance


2.2K?

 

When i go to sound preferences, it detects some sound card, after i install AzaliaAudio.pkg

I also can change volume of the sound card.

 

But i dont have any sound.

 

Picture7.png

 

 

Can you guys please advise any hint?

 

Best reg,

 

Alvaro Martins

Share this post


Link to post
Share on other sites

Same problem here, the card shows up at systempreferences but not at the systemprofiler. Volume adjustment also isn't possible. weird. I installed the card using taruga's AppleHDAPatcher... bu no sound :thumbsup_anim:

 

any suggestions?

Share this post


Link to post
Share on other sites

The sound card not appearing in system profiler is "normal", anyway the support for it is still limited with Taruga's patch (no updates since a while, I hope he hasn't discontinued it). It should give you some sound tho, so you could try to plug your speakers elsewhere, it may come from any port of the card (even from inputs, often from mic input).

Share this post


Link to post
Share on other sites

Still havent found the solution...

Im was thinkink...

 

I have one kernel panic with azaleas driver... but... im still sane to try again...

 

Anyone know how can i find device id under linux? suse 10.2?

 

I have found vendor Id but not device Id.

 

I though i could try ac97 driver ( I think it is my vendor or codec)

http://www.analog.com/en/prod/0,2877,AD1986A,00.html

 

AD1986A i know that it is ;)

 

 

best reg,

 

Alvaro

Share this post


Link to post
Share on other sites

I will pay 50 dolares to someone who help me leading to a final solution of my sound card.

If 50 isnt enough name your price.

 

I dont want to buy an usb sound card for my laptop...

 

best reg,

 

Alvaro

Share this post


Link to post
Share on other sites
I will pay 50 dolares to someone who help me leading to a final solution of my sound card.

If 50 isnt enough name your price.

 

I dont want to buy an usb sound card for my laptop...

 

best reg,

 

Alvaro

 

one mont later and i add more 25 dolars to this driver and who help me get this done.

 

75 dolares.

 

Best reg,

 

Alvaro

 

ps: i know that money dont buy everything! but it helps!

Share this post


Link to post
Share on other sites

there has been no progress, you can get stereo out, if you edit the azalia driver with your vendor + id number.

for more you need supported audio card or usb audio.

Share this post


Link to post
Share on other sites
one mont later and i add more 25 dolars to this driver and who help me get this done.

 

75 dolares.

 

Best reg,

 

Alvaro

 

ps: i know that money dont buy everything! but it helps!

 

 

What sound card do you have?

 

What MOBO? Brand name?

 

Did you figure out the audio issue you had?

 

JMM

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×