Jump to content

HP EliteBook 840G2 with Opencore 0.5.7/Catalina 10.15.4 can't boot first install


127 posts in this topic

Recommended Posts

Hi,

I request your help to be able to boot a dedicated HP EliteBook for Catalina 10.15.4 with Opencore 0.5.7

I have created my USB2 key with gibMacOS-master.

I use GenSMBIOS-master to generate my UUID, serial..., and I use iasl-win-20180105 to decompile my DSDt.aml

Please see my attached config.plist and config (drivers,kext,ACPI)..

 

Here is my hardware description:

Model - Notebook HP EliteBook 840 G2
CPU - Intel(R) Core(TM) i5-5300U CPU @ 2.30GHz
RAM - 2 x 8 GB SODIMM DDR3 Synchronous 1600 MHz (0.6 ns)
GPU - Intel HD Graphics 5500 (rev 09) and Opal PRO [Radeon R7 M260X]
DISKS - 128GB SATA (m.2:no, SATA:yes, NVMe:no)
AUDIO CODEC - Intel Corporation Broadwell-U Audio Controller (rev 09)
WIFI/BLUETOOTH - DW1820A BCM94352Z AE 802.11AC BT4.1 867Mbps Wifi Adapter BCM94352 M.2 NGFF S4V6
NETWORK - Ethernet Connection (3) I218-LM Intel Corporation
INPUT DEVICES - Is the keyboard PS/2, is it backlit? yes Is the touchpad I2C? laptop Is there a touch display? No
 

Thank you for your advices

E-20200406.zip

On 4/6/2020 at 9:51 PM, LucAndersen said:

You can find the error message inside the zip file, but here is a small part

5:024 00:142 OCB: Performing OcScanForBootEntries...
66:028 01:003 OCB: Found 1 potentially bootable filesystems
66:170 00:141 OCB: Filesystem 0 (A38B0698) named BOOT (Not Found) has 0 entries
66:311 00:141 OCB: Scanning got 0 entries
66:453 00:141 OCB: Performing OcShowSimpleBootMenu... 0
66:595 00:141 OCB: BootNext has not been found
66:736 00:141 OCB: BootOrder is unavailable - Not Found
66:878 00:141 OCB: Initial default is 0, fallback
72:047 05:169 OCB: Should boot from Reset NVRAM (T:128|F:0|DEF:0)
72:157 00:109 OCB: NVRAM cleanup...

 

Edited by LucAndersen

I have had Zero success getting OC to work on this laptop, it maybe a BIOS issues as HP's don't let you make advanced setting changes. I am including my CLOVER EFI, give it a try.

EFI.zip

  • 2 weeks later...
On 4/21/2020 at 1:01 PM, tydell said:

EliteBook need to have UnblockFSConnect active in config to boot 

Thanks. I figured out also that specific config in OC for my HP EliteBook 840G2 (i5-5300U-HD5500)

Now i'm stuck in 

 

127:419 01:021 OC: Prelink injection WhateverGreen.kext () - Success
127:699 00:279 Prelinked status - Success
127:892 00:192 AAPL: [EB|`LD:LKFS] } Ok(0)
128:069 00:176 AAPL: [EB|`LD:LKC] } Ok(0)
128:247 00:178 AAPL: [EB|#FWFM] 0xFF1FFF3F
128:424 00:176 AAPL: [EB|#FWFT] 0xE00FE137
128:601 00:177 AAPL: [EB|#CSR:OUT] 0x00000067
128:783 00:182 AAPL: [EB|`BST:FBS] {
128:963 00:179 AAPL: [EB|`BST:FBS] BA.ADSZ: 0
130:002 01:039 AAPL: [EB|`BST:FBS] BA.KSDSZ: 0
130:144 00:141 OCSMC: SmcReadValue Key 4D535463 Size 1
130:285 00:141 OCSMC: SmcReadValue Key 4D534163 Size 2
130:462 00:176 AAPL: [EB|`B:WFDW] Err(0xE), 0 @ LocHB 71B4903C-14EC-42C4-BDC6-CE1449930E49
130:639 00:177 AAPL: [EB|#LOG:DT] 2020-04-23T03:45:25
130:815 00:176 AAPL: [EB|#LOG:EXITBS:START] 2020-04-23T03:45:25


 

Here is the debug OC file

and the config.plist

 

Thanks

opencore-2020-04-23-034312.txt

Edited by LucAndersen
On 4/21/2020 at 1:01 PM, tydell said:

EliteBook need to have UnblockFSConnect active in config to boot 

 

So after setting UnblockFSConnect  to true

and setting LapicKernelPanic to true also.

I get nowhere, now the system reboot.

 

1. I have checked the BIOS.

2. may be I don't know how to use my extracted DSDT.AML ?

 

I desperate need your help.

On 4/23/2020 at 4:53 AM, LucAndersen said:

Thanks. I figured out also that specific config in OC for my HP EliteBook 840G2 (i5-5300U-HD5500)

Now i'm stuck in 

 

127:419 01:021 OC: Prelink injection WhateverGreen.kext () - Success
127:699 00:279 Prelinked status - Success
127:892 00:192 AAPL: [EB|`LD:LKFS] } Ok(0)
128:069 00:176 AAPL: [EB|`LD:LKC] } Ok(0)
128:247 00:178 AAPL: [EB|#FWFM] 0xFF1FFF3F
128:424 00:176 AAPL: [EB|#FWFT] 0xE00FE137
128:601 00:177 AAPL: [EB|#CSR:OUT] 0x00000067
128:783 00:182 AAPL: [EB|`BST:FBS] {
128:963 00:179 AAPL: [EB|`BST:FBS] BA.ADSZ: 0
130:002 01:039 AAPL: [EB|`BST:FBS] BA.KSDSZ: 0
130:144 00:141 OCSMC: SmcReadValue Key 4D535463 Size 1
130:285 00:141 OCSMC: SmcReadValue Key 4D534163 Size 2
130:462 00:176 AAPL: [EB|`B:WFDW] Err(0xE), 0 @ LocHB 71B4903C-14EC-42C4-BDC6-CE1449930E49
130:639 00:177 AAPL: [EB|#LOG:DT] 2020-04-23T03:45:25
130:815 00:176 AAPL: [EB|#LOG:EXITBS:START] 2020-04-23T03:45:25


 

Here is the debug OC file

and the config.plist

 

Thanks

opencore-2020-04-23-034312.txt

Hi there!

I have an HP Omen 15 ax-201np

Intel Core i7-770HQ

NVidia GeForce GTX 1050

16 GB RAM

And i got stuck at the same point as you....

I'll link my EFI for further analysis...

Only time i was able to boot was with a clover efi, and then decided to move to opencore because i would be able to solve the big majority of icncompatibilities... if i were able to boot.

Bootlog will be anexed as well as opencore efi

In need of desperte help.

opencore-2020-05-04-121534.txt

EFI.zip

Try this

 

UEFI - Quirks

ReleaseUsbOwnership = True.  <- will not boot without this being set to True or On.

 

Got everything working but Sleep and the track pad. all in all, I wouldn't select this for a Hackintosh, the HP 840 G3 is more compatible, everything working on that one.

Edited by Donw35

thank you again @Donw35.

 

I am using your based Clover with Mojave. it's finally working!  Thank you very much.

Right now it's a little jerky.

- Trackpad is not working.

- Wifi (DW1820A BCM94352Z) is not working so i'm using a USB-ASUS-AC53.

- CPU is high without doing nothing, fan is running

 

While I have access to a "mac"  I can create a Opencore boot to try on the second HP EliteBook 840G2

How do you create your ACPI files ? (for Clover and for OpenCore).

excellent, I have had zero Luck with the track pad.. Sleep isn't working in Catalina either, has to do with USB but I am not going to spend much time with OS X on this computer, mainly for Kali lunix...

 

I have clover on my HP 840 G3 and everything works..

  • 3 weeks later...

Hi I also have a HP 840 G2 and I finally succeeded using opencore. I had to go back to 0.5.5 to do that. Using 5.8 or 5.9 I could not see my macos partition. I used a 840 G1 EFI as basis (sorry I deleted that file). The ACPI-Patch section still need some tuning so a WIP.

Hope this helps as a start.

EFI.zip

Hi I also have a HP 840 G2 and I finally succeeded using opencore. I had to go back to 0.5.5 to do that. Using 5.8 or 5.9 I could not see my macos partition. I used a 840 G1 EFI as basis (sorry I deleted that file). The ACPI-Patch section still need some tuning so a WIP.

Hope this helps as a start.

 

I now use 0.5.9 it seems I need to install ApfsDriverLosder.efi to see my macos partition.

The internal one does not work with my laptop

Edited by Slim61
extra info
  • 2 weeks later...
  • 3 weeks later...
On 4/13/2020 at 2:14 AM, Donw35 said:

I have had Zero success getting OC to work on this laptop, it maybe a BIOS issues as HP's don't let you make advanced setting changes. I am including my CLOVER EFI, give it a try.

EFI.zip

Can you share HP EliteBook 840G2 with Opencore 0.5.9 ?. Thank !

On 5/27/2020 at 1:29 PM, Slim61 said:

Hi I also have a HP 840 G2 and I finally succeeded using opencore. I had to go back to 0.5.5 to do that. Using 5.8 or 5.9 I could not see my macos partition. I used a 840 G1 EFI as basis (sorry I deleted that file). The ACPI-Patch section still need some tuning so a WIP.

Hope this helps as a start.

EFI.zip

Hi I also have a HP 840 G2 and I finally succeeded using opencore. I had to go back to 0.5.5 to do that. Using 5.8 or 5.9 I could not see my macos partition. I used a 840 G1 EFI as basis (sorry I deleted that file). The ACPI-Patch section still need some tuning so a WIP.

Hope this helps as a start.

 

I now use 0.5.9 it seems I need to install ApfsDriverLosder.efi to see my macos partition.

The internal one does not work with my laptop

Thank you very much for sharing your experiences.

I was about to start from scratch reconfiguring Opencore with 840G1.

 

For the HP840G2, I will try your EFI/kext... and will retest with Opencore 0.6.0

 

  • 3 weeks later...
On ‎7‎/‎18‎/‎2020 at 1:03 PM, Epimenide said:

Starting with the EFI posted above, I've been able to get to a fully functional 840 G2 Broadwell (changed the WiFi card, obviously) on OpenCore 0.5.9.

I've cleaned it a bit, and updated the Kexts, but left in the -v boot flag in, to allow for troubleshooting, in case.

Didn't bother to add boot chime or GUI!

EFI_840G2b_OC_5.9.zip

Thank you, I am just getting to know OC. I started with 0C 0.6.0 and I was able to install macOS Big Sur. However, a few things don't work, wifi (I have BCM94352Z), battery and trackpad. I still have to work a lot to make macOS Bigsur fully operational.

 

Edited by Axon_80
13 hours ago, Axon_80 said:

Thank you, I am just getting to know OC. I started with 0C 0.6.0 and I was able to install macOS Big Sur. However, a few things don't work, wifi (I have BCM94352Z), battery and trackpad. I still have to work a lot to make macOS Bigsur fully operational.

EFI_6_0_820G2.zip

That’s odd, I’ve the BCM94352Z as well, and has always worked without any specific tweak… Is it detected in another OS?

Could be a Big Sur issue, perhaps: battery is always tricky, trackpad could be something different (for me it works with VoodooPS2, it’s found and works with one & two fingers, but no multitouch gestures)

2 hours ago, Epimenide said:

That’s odd, I’ve the BCM94352Z as well, and has always worked without any specific tweak… Is it detected in another OS?

Could be a Big Sur issue, perhaps: battery is always tricky, trackpad could be something different (for me it works with VoodooPS2, it’s found and works with one & two fingers, but no multitouch gestures)

Yes, these problems only in Big Sur. My EFI still needs a lot of work. When I fix everything and Big Sur works fine it will make my good EFI available for you to test.

2 hours ago, Axon_80 said:

Yes, these problems only in Big Sur. My EFI still needs a lot of work. When I fix everything and Big Sur works fine it will make my good EFI available for you to test.

Looking at the documentation of AirportBrcmFixup, it seems you've to enable a specific boot flag (-brcmfxbeta) to allow WiFi to be patched on non-supported OSs (that at this point Big Sur probably is), just guessing here…

 

  • 2 weeks later...
On ‎7‎/‎19‎/‎2020 at 10:28 AM, Epimenide said:

Looking at the documentation of AirportBrcmFixup, it seems you've to enable a specific boot flag (-brcmfxbeta) to allow WiFi to be patched on non-supported OSs (that at this point Big Sur probably is), just guessing here…

 

Fully working EFI OpenCore 6.0 (HP 820G2 i5) for Big Sur beta 3. Ok for me, but you can probably optimize it because I'm just learning OC.

 

Edited by Axon_80
  • 3 weeks later...
On 7/28/2020 at 2:22 PM, Axon_80 said:

Fully working EFI OpenCore 6.0 (HP 820G2 i5) for Big Sur beta 3. Ok for me, but you can probably optimize it because I'm just learning OC.

EFI.zip

I just wanted to say thanks for this.  I've been looking to move to OpenCore from Clover for a while but never seemed to have the time to properly get to try it.  I've used your EFI on my HP 840 G2 and installed BS PB4 without any issues.  Have you optimised it any further?  I would like to look at getting the trackpad running a little more Mac-like (swipes etc.) but other than that it is working great - you have saved me a load of work!

On 7/28/2020 at 4:22 PM, Axon_80 said:

Fully working EFI OpenCore 6.0 (HP 820G2 i5) for Big Sur beta 3. Ok for me, but you can probably optimize it because I'm just learning OC.

EFI.zip

Can you PLEASE prepare a guide about OpenCore for HP 820 G2. The files that you provided work perfect. I really want to see the steps of creating EFI for this laptop. Thank you.

4 hours ago, erko2001 said:

Can you PLEASE prepare a guide about OpenCore for HP 820 G2. The files that you provided work perfect. I really want to see the steps of creating EFI for this laptop. Thank you.

There are many guides on how to set up a OC.
I also used other people's work, thanks to @Epimenide

Edited by Axon_80
×
×
  • Create New...