Jump to content

[How To] Misc Solutions

17 posts in this topic

Recommended Posts

Misc Information


This is a compilation of many different misc solutions available. It is not exhaustive. If you don't find what you want, search for it.


Please do not post questions in this thread looking for a solution that is not listed. Use other threads for that.


Please do post other good known similar solutions in this thread. I will try to incorporate any posted solutions into the list. Otherwise, users can read the thread for any other solutions.



AMD Enabler - Read this


Battery meter - For laptops, enable battery meter, read this


Boot OSX from a Pendrive - Read this


Cardbus/PCMCIA Controller

ID 104C:8039 Texas Instruments PCIxx12


ID 104C:8031 Texas Instruments PCIxx21


ID 104C:AC46 Texas Instruments PCI4520

Clone your hard drive - Get app here


DVD Player function on SSE2 in Tiger - See this


Hiding Files like mach_kernel - Read this.


iTunes Removal - Read this


JMicron IDE patch for 10.4.8 DVD - Member thedguy created a PPF patch to the JaS 10.4.8 Intel SSE3 Only Reseed DVD to allow it to boot on JMicron IDE drives. Find it on the Demon (OSX 10.4.8 Jmicron JMB IDE patch) and read about it here.


Laptop lid - close and no sleep - Use insomnia.kext here


Laptop too HOT - Read this


MacDrive - can't find your partition. Be sure you have updated to latest version. If you run or have deleted either Daemon Tools or Alcohol 120%, then there is a little file that is interfering with MacDrive. Even if you deleted the 2 apps, the file is left behind. Find SPTD.SYS file in C:\Windows\System32\Drivers and rename it to something like SPTD.SYS.OLD and reboot. Doing this might interfere with mounting virtual drives. If you need to mount the virtual drive, rename the SPTD file to its original name and reboot. This will again interfere with MacDrive. Stuck with only one of two features at a time.


Power Management - see Battery Meter above


Reboot fix - Computer hangs when it reboots, then read this


SMB/AFS (Samba/AppleFileSharing) fix - For 10.4.7 and maybe 10.4.8. If you can't access Windows shares or Apple shares, try this



nForce (ATA and SATA)

and an older
, and
. Also,
effort by

Silicon Image PCI card
- Read


- How to install on a system with VIA SATA. Read

Time sync - If you find that your Windows time and OSX time are several hours different, then read this.


USB replug - If you suffer from having to replug your USB devices on every boot, read this.


USB2 - Read this. Versions for 8.4.1 kernel and 8.8.1 kernel by orByte.


VMWare - gives the error "Virtual machine kernel stack fault (hardware reset)". Read this.


Windows - Hide the Partition - (No salami) Read this or this.


Windows - Mount the Partition - stop the Initialize messages. Read this.

Share this post

Link to post
Share on other sites

OK........I had found the solution

There are seperate drivers of MAC OS X 10.4 for USB. For Example, seperate ddriver for WebCam(USB), Infrared etc.

For support only for Flash Drive, just download the KIT which matches your version of MAC OS X 10.4 from:


and you will have your USB for Flash Drive WORKING!

Share this post

Link to post
Share on other sites

Hi Rammjet and Everyone...got a question for you as you seem to be the professionals:


I am currently owning a basic Intel system with one CPU E6850, dual core, 3 gig, further an ASUS P5N-SLI with two ASUS EN7900GT cards in SLI. In addition one IDE HD, and on HD on SATA (non-SCSI), which might be the cause for the following problem (this is an install problem and posted maybe in the wrong section, sorry for that but i could not find a solution for that yet in this forum):


I had installed the Mac OSX (JaS prepatched 10.4.8. version from defiant) on the SATA hard disk, and the IDE first partition had the WinXP on. But it was not succesfull, and too late to fix the issue with the fdsik -e to flag the WinXP partition to make it active and use the os selector.


I am using further Acronis disk director suite as recommended with OS selector.

I am using the Wiki.org something install guide dual boot for the 10.4.8. version.

Install DVD is the prepatched JaS MACOSX 10.4.8., patched by defiant (thanks guys!!)


Before the MAC installation on the SATA, i experiemented with the VMware workstation 6 and could install the non-prepatched JaS 10.4.8. without any problems on the SATA....cool, but very slow, so i though this is not a premanent solution...


At the moment I moved the SATA hard disk to disk number 2, and my IDE is disk number 1, all of them have 4 partitions on it, the IDE has FAT32 partitions, and the SATA has NTFS partitions. So i gave it a try and I could not successfull install the MAC version on the SATA disk (obviously).


So I ended up with, for my point of view, only one solution to make the IDE HD your primary active disk, with the following scheme:


WinXP on first partition (NTFS), 70gb, primary active

MACOSX on second (formated into FAT32), 70gb, primary

WinData on third and fourth (NTFS), 70gb each, both logical


My SATA disk I have currently not connected to the mainboard as I want to make it a clean install on the IDE.


However, I formatted all disks and partitions in the above formats, after booting the Jas DVD it recognized the partitions but I could not earese the FAT32 partition for MAC, so I eareased the entire HD IDE and partitioned it afterwards in MS dOS partition for the first, third and fourth and the second one was MAC extended journaled as recommended. Currently, WinXP is installed on the first partition.


Ok, partition was successfully recognized and I began with the installation progress, now, as described in the various guides that this is the tricky part, I used several option out of the installer to install the JaS version successfully but ended up with a blank screen after the apple boot screen (yes the one with the aten apple bit and spinning-sort-of-clock beneith). I tried all options, with NV40 chip, without, with recommended softare, without, with and with out X11 and printer drievers etc...


I have therefore two question:


1. Shows this blank screen the problem that my graphic cards do not recognize MAC? If so, how can I bypass that or install a driver macvidia before installing the Mac software, also I recognized that when choosing none of the Ttitan drivers (only the Intel pkg is selected), a message pop-ups during boot to reboot the system in several languages.

My question still remains how I got the MACOS installed and booting in the VMware workstation application with the same system?


2. Might be that my hard disks are wronlgy setup? What would you recommend to do, and how many partitions would be recommended, as said before, I got one HD on SATA and one on IDE (but I know that connecting the SATA disk MAC would not recognize the hard disk thats when the IDE got in, which would be recognized during MAC OS install from the disk utility installer). Each disk has around 300GB.


Any suggestions, help ;;;;;;;...... best regards and thank you thousand times

PS my scripting skills are very limited, as I am a burned WIN clicker...sorry mates :-) cheerio

Share this post

Link to post
Share on other sites

Is there a thread on this site discussing the black screen on boot-up? I've been searching, but nothing found yet.

Share this post

Link to post
Share on other sites

Sounds like an unsupported video driver. If you installed video drivers when you installed osx, you need to remove them.


All you have to do is just press F8 at Darwin's prompt and then type -s (single user mode) then


at root type mount -uw /


and /movevideodrivers


then it will be prompt to move video drivers by class ( nvidia ; ati ; or intel gma) voila!


type yes to confirm or enter to skip !

Share this post

Link to post
Share on other sites

I have an abot fality sli board with a e6750 core 2 duo. And a geforce 7600 PCI express card and 4 Gigs of ram my install goes flaw lesly on a sata drive reboots plays the intro video with sound won't detect the keyboard then gos through choosing the layout them when it asks if I want to transfer settings I click no then it freezes for a moment then goes back to the begginging and plays the video again and askes me to choose the keyboard again. Safe mode wont fix it either. I can't get past this it makes no sense how do I get past this?

Share this post

Link to post
Share on other sites

I have Kalyway Leopard mac Osx 10.5.1 installed on my PC and then a few months after was gifted a macbook pro. And I'm trying to get the 500gb HD that i used to install leopard back so I can use it on my PC, but I cant get it to detect in windows. any help would be great. Thanks

Share this post

Link to post
Share on other sites
windows can't read HFS partition. you'd have to use a third party software like partition magic to read the mac os partition..

A better program would be MacDrive.

Share this post

Link to post
Share on other sites
SMB/AFS (Samba/AppleFileSharing) fix - For 10.4.7 and maybe 10.4.8. If you can't access Windows shares or Apple shares, try this

This patch also worked for me, on OS X 10.5. (Leo4All v2)

Share this post

Link to post
Share on other sites

Laptop lid - close and no sleep - Use insomnia.kext here


This link is dead. Searching for "insomnia.kext" now, but having to do some serious digging and not finding much yet.


Can we fix the link? Thanks!

Share this post

Link to post
Share on other sites

I think the instructions here for installing retail Leopard are also very useful for those users who are already up and running but have some spare time and fancy creating an emergency bootable partition on an external USB/Firewire/pen-drive disk partition. The simplified process goes as follows -

  • Get Leopard up and running on any disk partition first (or boot from a LiveDVD ...)
  • Use disk utility from Leopard/LiveDVD to partition external USB disk as GUID
  • Install retail Leopard with latest updates, patches and PC_EFI_v9 bootloader to USB disk
  • Boot from USB drive to test it and get it working and copy the PC_EFI_v9 installer to the desktop on it
  • Once set up and happy all is running well, boot from your original (non USB) disk and use Disk Utility to create a new .DMG image of the new bootable USB recovery partition on your original desktop
  • Boot from USB once more and copy back the new .DMG (around 4GB!) recovery file to the desktop on the USB disk
  • Now you should have an emergency bootable USB recovery tool which can quickly build a fully patched and personalised system - winner!

The only thing to note when recovering the DMG image to other disks is that you must re-apply the PC_EFI_v9 bootloader. Good luck and hope this helps people who feel they need more redundancy in their osx86 tinkering!


[EDIT] I have since noticed that some mainboards don't fully support USB boot properly - I advise checking that your mainboard can boot from USB properly before attempting to make a bootable USB leopard 'recovery' partition ...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.