Jump to content
InsanelyMac Forum
sigxcpu

HOWTO: Intel DP965LT and others

Recommended Posts

Hello,

 

I've managed to make my Marvell (vendor 11ab id 6101) PATA controller on Intel DP965LT board to work.

 

Edit /System/Library/Extensions/AppleVIAATA.kext/Contents/Info.plist

 

around line 91 replace

 

<string>0x05711106</string>

 

with

 

<string>0x610111ab</string>

 

You can reboot or just load the extension with

 

sudo kextload -v /System/Library/Extensions/AppleVIAATA.kext

 

 

BTW, for others that have problems, I've managed to boot OSX on this board (after few days of frustration) with -legacy parameter (semthex 10.4.8 kernel).

 

It works like a charm now (~130 Xbench score). Got many points on HDD (Raptor 73GB) and less points on video board (NVIDIA 6600 with Titan). CPU is Core 2 Duo E6300 (1.86GHz)

 

 

Enjoy! :sorcerer:

Share this post


Link to post
Share on other sites
Advertisement

do you think it ths would work on dg965wh? also did you use the 10.4.8 dvd install? and lastly when do we edit this file? on the dvd before the isntall? thanks.

Share this post


Link to post
Share on other sites

Nope. Install using some other method (restore on an external/internal hdd drive using the install disk and boot from that drive to install) and then make your dvd working using this method.

I've installed using other mainboard and used that installation.

Share this post


Link to post
Share on other sites

Also, if I've brought up this topic, I'll use it for two other things that are NOT working:

 

1. LAN (any change to work?). Now I'm using an old Intel 100 card

2. Sound (STAC9227). Any chance to work? I've found the vendor id, device id part in AppleHDA, but there are ~17 layouts of codec. Which one should be modified with my vendor id, device id, at least to try?

Share this post


Link to post
Share on other sites
Nope. Install using some other method (restore on an external/internal hdd drive using the install disk and boot from that drive to install) and then make your dvd working using this method.

I've installed using other mainboard and used that installation.

My first post here, and before seeing this topic, i was strugling to install (10.4.6 or 10.4.8 install DVD), to my new DG965WH with 6400, from DVD-ROM with no luck.

I was trying all the possible configurations, jumpers master to slave for both DVD-ROM and HDD, changing DVD-ROM, with no luck at all.

 

I also tryied installing via VMware on my Raptor (XP pro), but again i had other problem about Can't find Bootable CD (allthough i mounted correctly the iso), so i ended with no install at all.

 

I am tottaly lost with all these topics (i started reading yesterday).

Can you please explain your proccedure so i will try?

How i can copy the installation DVD 10.4.8 to another HDD and boot from it?

Does it matter if that 2nd HDD will be Sata?

 

Too many question !!!!!! Sorry.

 

Regards

Kle500

Share this post


Link to post
Share on other sites

Use ANY other HDD that is recognized by the Mac OS (USB external drive is the best choice). Restore on that HDD (you will loose data, so backup it before) and then boot from it. You will install faster than from the DVD :compress:

Share this post


Link to post
Share on other sites

Thank you Very much!

but the same problem:

1.Lan-82566DC Gigabit Network Connetion;

2.Audio-SigmaTel 9227.

 

Looking forward to these drivers! :angel:

Share this post


Link to post
Share on other sites

Hello,

 

Friday, Saturday, Sun and Mon, trying to install, I downloaded many available images(Jas, iATKOS, ka... ect) .

I have an Intel DP35DPM, and the install always stops with a white "no sign" above apple logo. I have used the -v option, and it stops loading and gives "wating for root device", and goes in a loop.

 

I see many people talking here about the parameters at the boot promt, but after trying ? to get help, everything goes so fast, I cant' read at all.

 

I would like to know if someone knows about the available parameters at boot prompt. That legacy, option what it is for? Wow sun is out I need some sleep... I hope I can have something good comes later...

 

thanks in advance.

Share this post


Link to post
Share on other sites

i have that same board and i can get the audio working with hdapatcher 1.16 and a dump i found. here are the files

 

 

AppleHDAPatcher_v1.16.app

9227.txt

 

can someone please translate this into English so i can use it. i would really like to get my Ethernet working

http://x86osx.com/bbs/view.php?id=networkc...1c06ae472250c19

thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×