Jump to content
Drovosek

Battery charge is 100% frozen

2 posts in this topic

Recommended Posts

For my laptop Hp Pavilion 15-au028ur worked patch for HP 3165sf
I also experimented with manual patching and assembled my own version:

#Maintained by: RehabMan for: Laptop Patches
#Battery_HP-DV6-1380ek.txt

# created by RehabMan 2019-xx-xx
# based on Battery_HP-DV6-1380ek.txt
# additional patches for dv6-1380ek provided by chihab222, credit gsly

# works for:
#  HP Pavilion 15-au028ur, per Drovosek

into method label B1B2 remove_entry;
into definitionblock code_regex . insert
begin
Method (B1B2, 2, NotSerialized) { Return (Or (Arg0, ShiftLeft (Arg1, 8))) }\n
end;

# 16-bit EC0 registers
#                BADC,   16,
#                BFCC,   16,
#                MCUR,   16,
#                MBRM,   16,
#                MBCV,   16,
into device label EC0 code_regex BADC,\s+16, replace_matched begin ADC0,8,ADC1,8, end;
into device label EC0 code_regex BFCC,\s+16, replace_matched begin FCC0,8,FCC1,8, end;
into device label EC0 code_regex MCUR,\s+16, replace_matched begin CUR0,8,CUR1,8, end;
into device label EC0 code_regex MBRM,\s+16, replace_matched begin BRM0,8,BRM1,8, end;
into device label EC0 code_regex MBCV,\s+16, replace_matched begin BCV0,8,BCV1,8, end;

# 16-bit method access
into method label CLRI code_regex (\^.*)MBRM replaceall_matched begin B1B2\(%1BRM0,%1BRM1\) end;
into method label UPBS code_regex (\^.*)MBRM replaceall_matched begin B1B2\(%1BRM0,%1BRM1\) end;
into method label UPBI code_regex (\^.*)BFCC replaceall_matched begin B1B2\(%1FCC0,%1FCC1\) end;
into method label UPBS code_regex (\^.*)MCUR replaceall_matched begin B1B2\(%1CUR0,%1CUR1\) end;
into method label UPBS code_regex (\^.*)MBCV replaceall_matched begin B1B2\(%1BCV0,%1BCV1\) end;

The only problem - when it reaches 100% charge, it no longer falls until you reset the CMOS (15-30 seconds hold down the power button on the laptop). In the rehabman guide there is a patch for ASUS in this case, there is a patch method FBST. There is no such method in my DSDT.

Can someone help?

Here's a patched and clean DSDT: https://vk.com/doc183234383_509697931

Share this post


Link to post
Share on other sites
Advertisement

I managed to cope with the problem. I read the relevant topic on the applelife forum, they recommend using the special boot argument with ACPIBatteryManager.kext,
either use VirtualSMC with a driver and additional cakes, or use cakes from HWSensors3.

Links:
https://applelife.ru/threads/applesmartbattery-batareja-noutbukov.31744/
-----
https://bitbucket.org/RehabMan/os-x-acpi-battery-driver/downloads/
https://github.com/RehabMan/OS-X-ACPI-Battery-Driver/commit/28a0fbdcd5ed7598315948af4e1228683ff2fff2#diff-04c6e90faac2675aa89e2176d2eec7d8
https://sourceforge.net/projects/hwsensors3.hwsensors.p/
https://github.com/acidanthera/VirtualSMC/releases

What did I do:

In ACPI / patched put your patched DSDT

Removed ACPIBatteryManager.kext
I downloaded HWSensors3 and dropped the other cakes into the Other folder - FakeSMC.kext, VoodooBatterySMC.kext and just in case ACPIMonitor.kext (but judging by what is written in the Readme it is not needed for the battery, but this is not certain).
The bug with the freezing of the charge indicator is 100% corrected.
But there is a mini-bug: Sometimes the charge percentage indicator freezes at random values, for example, 92% and then the N-th number of minutes does not change. If you click on the charge icon in the top panel, then after a couple of seconds, the charge indicator will be updated to the current one, for example, 98%.
Perhaps after a large number of minutes, the indicator will update itself, but the figure with the charge percentage "will make the jump."
Slice told me that most likely the SMC or something else is involved in updating the charge in macOS and to fix it, it is necessary that the HWMonitorSMC2 application be launched and it updates the charge itself.

Then I deleted FakeSMC.kext, VoodooBatterySMC.kext and ACPIMonitor.kext and used the cakes and driver from VirtualSMC. He was all the same as above with the HWSensors3 cakes.

So, we can assume that the problem is solved.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MacNutty
      After going through the Dortania guide about OpenCore, I managed to get Big Sur working on my Dell Inspiron 7572 Laptop. Here is the list of things which work and which does not:
      WORKING:
      - Audio (Realtek ALC3246) No sound from headphones though.
      - Intel UHD 620 graphics.
      - Backlight, keyboard and trackpad.
      - Bluetooth.
      - iMessage, FaceTime and App Store.
      NOT WORKING / Issues:
      - Wifi (Got a cheap Wifi USB adapter to work TPLink TL-WN725N)
      - Sleep not working correctly. Display does not turn on.
      - Shutdown keeps the laptop running with display off. Restart works correctly.
      - Internal SATA drives not showing up.
       
      After following the guide about ACPI on Dortania website. I patched the SSDTs manually. Didn't know whether I did it correctly or not.  
      Request you all to help me resolve the above issues, so that I can have a perfect hackintosh.
    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi.  A possible solution is here, but I am NOT offering any support for this.  
      macOS Installation 
      Important: You MUST BE LOGGED-IN to download attachments from this forum
      See macOS installation steps here See Known Issues here for additional installation steps that may not yet be included in my attached config files See CLOVER (UEFI) installation later in this first post
      See OC (UEFI) draft EFI here
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Microphone port  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the USBPorts.kext in the attached EliteDesk800.zip archive) Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card). A possible solution is here, but I am not offering any support for this.
       
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A or 02.12.00 Rev.A or 02.14.01 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers OcQuirks (replaces AptioMemoryFix) Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here and here to understand my graphics properties for use with WhateverGreen.kext Read this to see my attempt at graphics patching without WhateverGreen.kext (WEG) to get a better understanding of what WEG is doing
       
      Current Versions
      Catalina 10.15.7 Clover (UEFI) r5122 Lilu.kext 1.4.9 WhateverGreen.kext 1.4.4 AppleALC.kext 1.5.4 IntelMausi.kext 1.0.4 (acidanthera version) EFIChecikDisabler.kext 0.5  
      ScreenShots
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
      EliteDesk 800 G4 Mini - CLOVER Rev 1.4.zip
    • By Franklin_NGO
      Hello,
      I tried to patch the DSDT (battery) for my thinkpad L380, but to no avail. Could anyone help me on this?
       
      Here are my hardware and software:
      Bootloader: opencore 0.5.9 (DSDT and EFI in the attached file, SMBIOS removed) Hardware:thinkpad L380 (detail info: https://psref.lenovo.com/syspool/Sys/PDF/ThinkPad/ThinkPad_L380/ThinkPad_L380_Spec.PDF) CPU: I5-8250U GPU: UHD 620 SSD: 970 Evo plus Wifi card: native broadcom card (wifi worked without kext, bluetooth doesn't work due to not properly patch USB) OS: MacOS Catalina 10.15.7  
      Thank you and good day.
       
      DSDT.dsl
      EFI.rar
    • By Donw35
      10302020 - Big Sur Beta 11.01 update, using OC .0.6.3, no issues but update took a long time, just wait
      10152020 - Big Sur Beta 10 update, using OC .0.6.3
      09302020 - Big Sur Beta 9 update, no issues.
      09222020 - Big Sur Beta 8 update, no issues.
      09192020 - Big Sur Beta 7 update, no issues.
      09042020 - Big Sur Beta 6 update, no issues.
       
      I have moved on with this and do not use my HP G2 for Hackintosh, its mainly used for Kali Linux for Packet analysis these days, with that said I am using the HP 840 G3 for Hackintosh. I transitioned to OpenCore and Big Sur for this laptop but feel free to continue to ask questions. 
       
      My G3 has the BCM84360CS2 mod, I got the module from eBay for $10 and the adapter for $10 off amazon.
       
      Big Sur Beta 5 is working using the below EFI folder. OpenCore 6.1.0 and latest kexts
       
      Method: USB Big Sur installation
      Create an Big Sur Beta5 or Catalina USB installer (google is your friend here, plenty of tutorials there) Mount the EFI partition of your USB installer using Clover Configurator Copy the EFI file attached here. Boot your laptop using F9 and choose the USB installer and follow the prompts  
       
       
      Catalina and old method in the Spoiler
       
       
      Credits go to Jake Lo for creating this EFI file. I did make some changes to his, this one is Open Core 6.1.0 and latest Lilu.kext and WhatEverGreen.kext
      HP_840_G3_BSB5.zip
×