Jump to content
About Just Joined group Read more... ×
Mister3000

High Sierra on Asus n53SV laptop (Sandy Bridge)

11 posts in this topic

Recommended Posts

hi guys,

 

Im hoping some one can help me out of this jam. maybe this is an easy fix but im lost.

 

I've been running yosemite for years on my asus N53SV but i figured its time to upgrade.. and since i was told mojave its too much trouble im fine with going to High Sierra.

my issue is this:

 

I created a usb boot and grabbed a clover folder from a website that claimed everything worked out of the box. i was able to boot in to the setup screen, however my image looks all distorted. im guessing it has something to do with the fact that i replaced the panel on  my laptop from a 720P to a 1080p display. i was able to solve this same issue when i was on yosemite by using a patched DSDT but if i use that same old patch DSDT then i get issues/conflicts like my internal keyboard and trackpad not working.

 

This are my specs:

ASUS N53SV

HD3000 1080p

i7 2670qm

512 GB SSD

8GB Ram

 

maybe someone can point me in the right direction.. 

 

Im attaching aa picture in case someone has seen this issue before.

 

Thanks

 

 

IMG_1482 (1).JPG

Share this post


Link to post
Share on other sites
Advertisement

Enable DualLink in your config. Assuming you currently use SNB layout-id 0x00010000 and MBP8,1 SMBIOS, you may also try layout-id 0x00020000 and MBP8,3 SMBIOS.

Edited by Hervé

Share this post


Link to post
Share on other sites

waoh !!

and just like that Herve' has gotten through yet another jam. thanks a lot man, you have been helping me since my first hackingtosh my old Dell D630 :)

I did as you said. went on to clover configurator and enable DualLink and also on SMBIOS choose MBP8,2 and now i got full 1080p picture.

 

Thanks again man, you are genius !!

Share this post


Link to post
Share on other sites

OK,

Im back with yet another  issue.

i was able install high sierra.

then installed clover on the SSD and replaced the clover folder with the one from my usb stick installer.

 

but now when trying to boot from SSD i get 

boot0af: error

 

tried following the guides in the internet to fix this problem and i get operation not supported.

 

any ideas ?

 

 

IMG_1491.JPG

Share this post


Link to post
Share on other sites

I just found my own mistake.

i realized that I wrote “identifier” on the command instead of the disk number for my os installation.  :(

Share this post


Link to post
Share on other sites

Hi there, 

Looking for a little help here.

 

Just updated to high sierra 10.13.6 and now all i get is black screen after boot up.

Have read much about it, and all i can find is that i need the intelfixup kext. however that kext its already part of whatevergreen and lilu, both of those kexts are already on my efi folder.

Any ideas whats causing the black screen after upgrading from 10.13.2 to 10.13.6 ?


sandy bridge ASUS N53SV i7 

HD3000 intel graphics / GT540M Discrete graphics

 

Thanks

Share this post


Link to post
Share on other sites

I've got your exact laptop except that my display is only 13x7 so you need DualLink and I do not. I have 10.13.6 running perfectly and 10.12 was as well, except that I KP on wake. Does your unit sleep and wake OK ?

 

Upload your EFI folder and I'll do the same with mine. You are welcome to my DSDT but you need to be updated to the latest Asus  BIOS v215.

 

I do not use IntelFixup or WhateverGreen.

 

Let's collaborate & figure this out :)

Edited by bisk
add info

Share this post


Link to post
Share on other sites

Yep, but my problem is that I reboot/freeze on wake. This is a dual GPU system where I believe that I have disabled the dedicated NVidia GT540M correctly as there is no sign of it in the registry. I probably should start a new topic for this, eh ?

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By gekko.be
      I have an old Hackintosh that I have brought back to life. An ASUS P5KPLAM-SE mobo, Intel Core 2 Quad, with a Sapphire HD 5670 1GB graphics card. It used to work just fine on High Sierra 10.13.3 (I think it was .3) However I only used the DVI port. Updated to 10.13.6 and with AMD kexts rollback to the previous versions I got everything o wrk just fine: boot, HDMI video, HDMI audio etc etc. The only problem I face is that my USB keyboard and mouse freeze/hang seemingly very random... I can not seem to get it right. Unplugging and replugging the USB device makes it work again, sometimes for a few seconds sometimes for an hour ... No idea what's wrong... Have tried tons of options in clover, USBInjectall.kext with port limit patch, whatever I could find... Would there be anyone out there who would have an idea of what could be the problem?
    • By macinsane
      *This guide is deprecated and will not be maintained anymore*

      Update: Now running Mojave! Thanks to mojave2core! Yeah   Still using C2D in 2019!
      Inserted a nice and cheap GT710 that is not relying on nVidias Webdrivers and runs OOB under Mojave.
       
      Nice, seeing High Sierra running on this old but capable system! It rocks with a new ASUS GT1030
       
      Config:
      Gigabyte EP43-DS3L
      Core2Quad Q9300
      6 GB DDR2 RAM
      Asus GT1030 2GB
      Sandisk SSD 128GB
      TP-Link AC1200 Wifi USB
      Inateck KT4006 USB 3.0 PCIe (No boot)
       
      SMBIOS: iMac14,1
      Clover: 4297  4360
       
      A good deal of DSDT editing was necessary to get this machine to boot High Sierra but finally it works flawlessly, even sleep and wake!
      You NEED to have the DSDT put in place for installation because otherwise macOS doesn't recognize the SATA ports.
      There are a few important BIOS settings: SATA hast to be set to AHCI and "native" and HPET has to be run "64-bit", I'd recommend to disable IDE and the serial and parallel port.
      For the GT1030 nVidia Webdrivers are needed, have to boot with nv_disable=1 until you have them installed.
      You have to install Clover in legacy mode because this old fella does not support UEFI.
       
      Only downside: The so often recommended Inateck USB-card isn't recognized by BIOS, so you cannot boot from it. It works perfectly within macOS though, have the ac-Wifi connected to it.
      config.plist.zip
      DSDT.aml.zip
    • By eLDeus
      Hello, can't figure out why there's no Line-In input option with VoodooHDA, but I definetly have it in my built-in audio card on the motherboard.
      Thanks!
×