Jump to content
Donw35

HP 840 G2 G3 EliteBook ** WiFI and Bluetooth resolved** (Catalina working)

45 posts in this topic

Recommended Posts

Catalina update 10.15.3 without issues, make sure you update your kexts before hand.

Catalina update 10.15.2 without issues, make sure you update your kexts before hand.

Catalina update 10.15.1 without issue although you may have to make sure clover boots from the right partition.

HP 840 G2/G3, working with OS X 10.15 Catalina, for this to work you will need the SSDT-ECUSBX.aml and place that  EFI/CLOVER/ACPI/Patched. 

Make sure you remove Remove all patches about renaming acpi of EC or H_EC, revert all ACPI renaming in ACPI DSDT.

 

My method to install OS X on the SSD from a working real Mac via SSD to USB converter. I then install Clover and add my kexts and set the config.plist

 

Not working

SD Card reader

Finger Print device

 

Working

Video - screen looks better in OS X then it does in Windows 10

Display port

VGA port

WiFi and BlueTooth working OOO using the below hack

Battery status with Rehabman's DSDT patch

Brightness controls

Sounds - using VoodooHDA

* Microphone - cannot turn it off or mute

Keyboard backlight - controlled though BIOS anyways

touchpad - using VoodooPS2Controller

USB3 - this laptop has two on board only and I haven't test them using the docking station

USB3.1 C

Ethernet - using IntelMausiEthernet

Sleep - kind of, closing the lid doesn't go to sleep but goes to sleep over time.

Web Cam, works but I covered it up.

 

 

IMG_2447.JPG

 

SSDT-ECUSBX.aml

CLOVER.zip

CLOVER_HP_840_G3_02032020.zip

Edited by Donw35
updated

Share this post


Link to post
Share on other sites
Advertisement

I resolved the WiFi and Bluetooth issues by using a supported module

 

NOTE I have found that the NCM94322 doesn't work well in Catalina, it does kind of work but other problems like iMessage and FaceTime are problematic. I recommend using the BCM94360, its supported and all works. 

 

BCM943224PCIEBT2 Card To NGFF(M.2) Key A/E Adapter from Amazon for $14

MacBook Air 13 A1369 11 A1370 WiFi Bluetooth Air Port Card from eBay $10

 

 I had to do some cutting on the A/E adapter but was able to get it to fit, its a lot taller but the case closes without problems. I rather like this hack as the WiFi and Bluetooth are needed services and OS support will increase over all performance and confidence. 

 

IMG_0001.jpg

Edited by Donw35

Share this post


Link to post
Share on other sites

If you want Mojave on this system, this is what I did.

 

Copied EFI folder to a thumb drive

took the SSD out of the laptop and installed Mojave from a real mac

installed clover and put the EFI folder from the thumb drive

reboot and done.

 

IMG_0043.jpeg

Share this post


Link to post
Share on other sites

I haven't done it but you will have to contact HP and flash the bios using a CMOS.bin file.

For those that are interested, here is my clover stuff for the HP 840 G3

 

HP G2 800.zip

Edited by Donw35

Share this post


Link to post
Share on other sites

Donw35, thanks for your post.

 

I am interested in trying this on my G3, and my plan was to follow this guide:

https://www.tonymacx86.com/threads/guide-hp-probook-elitebook-zbook-using-clover-uefi-hotpatch.261719/

 

But as i understand correctly, I can just install it without doing all the tweaks and stuff, but just copy and paste your clover folder (because it contains the config and .kext's)?

Quote

 

If you want Mojave on this system, this is what I did.

 

Copied EFI folder to a thumb drive

took the SSD out of the laptop and installed Mojave from a real mac

installed clover and put the EFI folder from the thumb drive

reboot and done.

 

 

Do you mean the clover folder with the EFI folder?

 

Share this post


Link to post
Share on other sites

Yes, install Mojave on a hard disk from a real Mac, then install clover, then use my EFI folders. done.

 

Note, without the proper wifi card you will not have have Wifi or bluetooth, Intel doesn't work

Share this post


Link to post
Share on other sites
On 9/28/2018 at 9:36 PM, Donw35 said:

I haven't done it but you will have to contact HP and flash the bios using a CMOS.bin file.

For those that are interested, here is my clover stuff for the HP 840 G3

HP_840_G3_Clover.zip

Donw35 this your DRIVER UEFI , they are too many, you put them ALL ...

the renames see in the pictures are correct for your HW

The kext are to be updated

Test this Clover and Post ioreg with these settings if it starts

 

Schermata 2018-11-11 alle 08.28.56.png

Schermata 2018-11-11 alle 08.32.51.png

Schermata 2018-11-11 alle 08.36.42.png

Clover.zip

Share this post


Link to post
Share on other sites

Correct, that is an old EFI folder, I am going to remove it and add the latest one when I get home. sorry for the confusion.

 

EDIT- I added the new clover folder

 

 

 

Edited by Donw35

Share this post


Link to post
Share on other sites
On 9/26/2018 at 2:32 AM, Donw35 said:

If you want Mojave on this system, this is what I did.

 

Copied EFI folder to a thumb drive

took the SSD out of the laptop and installed Mojave from a real mac

installed clover and put the EFI folder from the thumb drive

reboot and done.

 

IMG_0043.jpeg

Hey! Great build, but i have some remaining questions:

 

Where'd you find a working VGA driver? Can you give me  a link or the name of it?

 

What if i don't own a real mac, how can i upgrade then? I don't wanna lose my current files of my High Sierra build. (If there's no other choice than doing a clean install of  Mojave and backing up important stuff on another drive or so, that's ok.

 

Because i can't upgrade directly somehow.

Share this post


Link to post
Share on other sites

The video drivers are supported by OS X already nothing to do unless your system has desecrate graphics chip.

 

I haven't done a upgrade or an USB install but its well documented

Share this post


Link to post
Share on other sites

Hello @Donw35,

 

I am a complete noob and maybe I'm missing something, so I hope that you will have 5 minutes to spare to help me ^_^

 

I used the hackintosher.com EFI folder that i put on the EFI partition of my USB installer. I then replaced the content of the CLOVER folder with your files. However, when I try to boot from my USB drive, I am greeted with a black screen.

 

Do you have any idea?

 

Thanks in advance for your great help!

Share this post


Link to post
Share on other sites

Ok, I'm dumb as a rock. I simply proceeded with a vanilla install and then used your EFI files directly on the laptop's drive.

 

So here is my little contribution:

  • DisplayPort image works (tested with a HDMI <> DP cable)
  • No sound output (except via the 3,5mm jack), even after installing VoodooHDA
  • Battery percentage works
  • Both USB 3,1 ports work (tested with a keyboard and a mouse, as well as with a USB hub)

 

I wonder what keeps the sound from working.

 

Anyway: thank you so, so much for the files! You saved me 3-4 more hours days of searching.

Share this post


Link to post
Share on other sites

Hi,

 

Thank you for this topic.

I have a similar laptop (820 g3) and i am attempting to install osx el capitan.

I believe your work would be of great help if i can get a functional clover for Sierra.

Would it be possible for you to re-upload you clover files please?

 

Thanks

 

Edited by Pikiman

Share this post


Link to post
Share on other sites
El 26/8/2018 a la 1:40, Donw35 dijo:

BCM943224PCIEBT2 Tarjeta a NGFF (M.2) Adaptador A / E de Amazon por $ 14

MacBook Air 13 A1369 11 A1370 WiFi Tarjeta de puerto Bluetooth Air de eBay $ 10

 

Hola ¿Tienes un enlace a este producto? gracias

Hello do you have a link to this products? thanx and sorry my english

Edited by linuxmac

Share this post


Link to post
Share on other sites

updates to 10.14.6 without issues, make sure to update your kexts

Share this post


Link to post
Share on other sites

Hi everyone... will get a Samsung 970 EVO and split/ dual boot Mojave and W10.

 

BIG Question - since my 840 G3 is the touchscreen, any way of getting the touch to work in MacOS? :))

Share this post


Link to post
Share on other sites

I have a Elitebook 840 G2 with touch screen, works out of the box. the OS isn't well suited for touch but it does work. Keep in mind that the M.2 in your Laptop is an SSD not an NVME, make sure the Samsung 970 EVO is going to work, I don't think it will.

Share this post


Link to post
Share on other sites

first of All, thanks for sharing your own experience and Clover with us here ... it made it much easier to install, since i'm not a fan of DSDT patching stuff ! 

Nonetheless I have some issues would be glad if someone can help me with: 

1- I can't upgrade Clover every-time i do that the Laptop fails to boot ,it shows Apple Logo only and shut down no idea what the problem , so I keep on the latest version shared here 4920 . 

2- the Sound output doesn't change automatically when 3.5 mm plugged in , with googling I understood this has to do with AppleALC patching i'm not sure .

3- the laptop doesn't always sleep with closing Lid or it sleeps and wakes up immediately , I wonder if USB wifi is the reason ?

I did order BCM94360CS2 card and its adapter maybe this issue would be solved after replacement.

Away from that I guess the device is doing great on Mojave ! i'm glad that I could use it for everyday stuff and my studying 

anyone has faced those troubles or has suggestions - solutions ? would be thankful ! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By chan29ster
      Hello,
       
      Few days back I had bought HP Elite Desk 800 g1 workstation and its config. is:
       
      Intel Q87 Chipset motherboard
      Intel core i5 4570s processor
      4gb DDR3 ram
      500gb hdd
      4gb GTX 1050 TI OC LP
       
      In this machine I successfully installed macOS Sierra 10.12.6 (16G29). But I'm getting an error in verbose mode like some contagious file. Also I'm getting an error of shutdown. I have attached the screenshot of the same. I have also recorded the video and its url is : 
      You may see it at 0:40 seconds. Later on when whole process get completed then I get an error of shut down "You shut down  your computer because of a problem." Again and again I'm getting this error on every restart. If I'm somewhere wrong for any kext or any other thing for that, here is my EFI folder (https://drive.google.com/open?id=1k-MSKSHXK9TL3WOBPZj6O789jBau7kWx). Also I have attached my config.plist file. Audio is working, but didn't recognised the device. About this Mac is also showing details properly.
       
      Please help me out it would be grateful and appreciated
       
      Thanks




      config.plist
    • By rguibi
      Hello

      I have a laptop HP EliteBook 840 G2 - Core i5 5300U - 2.3 GHz and graphic card intel HD5500 and installed a SIERRA , but the definition of the graphics card is not installed
    • By End3rPower50
      Hi, I want to install MacOS Catalina on my laptop.
      I was installed MacOS Mojave previously but i had a lot of problem, for example my wifi's card (Dell DW1820A) had a problem: My pc sometimes doesn't boot up or pc after some minutes crashed or slowed. 
      Now i want to try again to install macOS.
       
      this is my spec: 
      HP 15-AY034NL 
      CPU: i7 6500U  with HD520
      SSD: 500GB SSD Samsung
      Wifi & Bluetooth: Dell DW1820A (Bluetooth: BCM2045A0) (Wifi: BCM94350ZAE)
      USB 3.0 
      Ethernet: Realtek 8100
       
      Attached in this thread, my old clover configuration created by me (CLOVER OLD) and clover with Wifi driver (CLOVER) created by Hervè (I had asked help at insanelymac's community)
       
      P.S SORRY FOR MY BAD ENGLISH.
      Thanks in advance 
      -ANTONIO
      CLOVER OLD.zip
      CLOVER.zip
    • By benmills1
      Hi, i can someone help me with installing mac OS Mojave on my HP ENVY - 15-as102na?
      I have an imac to use for setting up my usb & installing MacOS Mojave.There are various kext files etc that i'm not sure about and need some help as some are hardware specific.
      I tried previously but got stuck on an apple logo and couldn't get past that, and tried today and had problems with Clover.
      Once i get mac os on my 128gb m.2 ssd ( which i'll upgrade to either a 256gb or 512gb depending on how well this hackintosh works)
      I have a free 2.5" inch hdd bay where i'd like to install windows on in the future.
      I think i may have to replace my wireless card ( based on a few google results) which i'm fine with as long as i can see it working without just so i know i won't waste money
      Specs:
      Cpu: i5 7200u
      GPU: HD 620
      8GB ram
      Wifi card- Intel Wireless 7265 ( Intel® 802.11ac (2x2) )
      Motherboard - HP 81D2 & BIOS version is f.56
      https://support.hp.com/gb-en/document/c05311862
      Thanks
    • By Majed DH
      Hi everyone. 
      I have HP 15-da0xxx series laptop. i got macos mojave installed on it. but I was trying to get my intel graphics working but i couldn't change dmvt preallocation. 
      So I updated the bios (unfortunately). And since then i could not boot any version of clover. 
      I tried two versions that were working and even an installer that worked before is not working:
       
      I searched alot about the error and found nothing relared to macos or hackintosh..  would it be solved by patching the dsdt? 

      Any suggestions people ? 
×