Jump to content

Help installing Mojave on Xeon W-2175 and Asus WS C422 mobo

719 posts in this topic

Recommended Posts

Hi all again.

New problems for my rig. Any help appreciated from the forum.

Can't install new nor update my old Mojave Beta 4 (18A336e) installation with Mojave Beta 6 or newly released Beta 7.

Something in the kernel changed in the last version of Mojave Beta 6 (build 18A353d). Both kernel patches "xcpm_program_msrs (c) Pike R. Alpha and  "xcpm_pkg_scope_msrs © Pike R. Alpha" wich previously worked with HighSierra respectively earlier builds of Mojave seems now to be obsolete. Now once again stuck at "end random seed +++++++++++++++++++++". 

Tried all different combination with AptioMemoryfix, OSXAptioFixDrv and OsxAptioFix2 and 3Drv. Tried with FakeCPUID.kext in all sorts of combination with and without kernelPM checked. 

I'm out of energy and ideas.


Happy if somebody could try to help me out.

Problem solved.


 New kernel patch  "_xcpm_pkg_scope_msrs"  from PMhart saved my day.

31 d2 e8 ae fc ff ff -> 31 d2 90 90 90 90 90


Credit to @fabiosun for leading me on the right way.

Happy day's are here again:hysterical:




For the first time with this rig I can get rid of FakeCPUID in Clover thanks to my saver @fabiosun with this  (only) kernel patch:

 89D804C4 3C227722 -> 89D804C1 3C227722   xcpm_bootstrap © Pike R. Alpha




Edited by obus



New problems with cpu-performance!



This is idle with only bootstrap patch:

89D804C4 3C227722 -> 89D804C1 3C227722   xcpm_bootstrap © Pike R. Alpha





This is idle with kernel patch: _xcpm_pkg_scope_msrs_PMhart

31 d2 e8 ae fc ff ff -> 31 d2 90 90 90 90 90"

and WITH FakeCPUID. 





Edited by obus

yep now we have to recover xcpm part as we said in other thread

firstly you can try to add in config.plist 

_xcpm_pkg_scope_msrs_PM tighter boot strap kernel patch

  • 4 weeks later...

Hi again @obus.

Hi all. 


Now I switched to Asus WS C422 Pro/SE with Xeon W-2123.
As for the start, the system works fine. I used your config.plist from the topic above, thank you all.

With other config files it crashed into a panic at +++++++++++++++++++++++++++++++++++++++++, probably CPU PM.


I'm still sorry for my english

Edited by yapan4
5 hours ago, obus said:

Are you using Fake CPUID and/or kernelpatch?

Yes. Use both. However, I do not use PluginType Clover fix. For CPU Info in About This Mac I use 0x0501 CPU Type (is for 4 core Xeon and cosmetics only)



2 hours ago, Loloflat6 said:

Try this FakeSMC.kext in Contents/Plugins there are LPCSensors.kext, GPUSensors.kext, CPUSensors.kext and ACPISensors.kext

Put it in Clover/kexts/Other


Thank you @Loloflat6, I will try...

Screen Shot 2018-09-11 at 21.02.48.png

Screen Shot 2018-09-11 at 21.03.09.png

Screen Shot 2018-09-11 at 21.03.49.png

Screen Shot 2018-09-11 at 21.26.52.png

Edited by yapan4
2 hours ago, Loloflat6 said:

Hi  @yapan4


Try this FakeSMC.kext in Contents/Plugins there are LPCSensors.kext, GPUSensors.kext, CPUSensors.kext and ACPISensors.kext

Put it in Clover/kexts/Other


:no:Your FakeSMC is the same version that I currently use, including Plugins.

Utilities in windows also do not see the fans. So this is not the fault of HWMonitor or macOS. This is probably the server specificity of the motherboard. May be @obus knows more about it...

2 hours ago, obus said:

Using iStat for the moment and have no attached fans at all because of my systems water-cooling.

Try with this!


If no fan are attached, see picture below. Later I'll explain more...


VirtualSMC v1.0 already tried. It works but capabilities are limited. Waiting for new versions.

Screen Shot 2018-09-12 at 02.21.43.png

Edited by yapan4
9 hours ago, obus said:

We need to get rid of Fake CPUID and the kernel patch we use today. @fabiosun  and I have tried different ways with no avail.

Check out this site: https://www.macos86.it/viewtopic.php?f=23&p=12086#p12086

Ok, then postpone IPMI - BCM question to better times.


And after the release of Mojave, we will return to the CPU.


And thanks for the link.

16 hours ago, yapan4 said:

Short report for beta 11 - any changes for me. Still needed FakeCPUID and  _xcpm_pkg_scope_msrs_PMhart for properly boot.

CPU Performance not tested yet

The same for me. No changes at all. :no:


Small note - system properly boot also with Kabylake H FakeCPUID 0x0906E9.
CPU PM and performance not tested after this.



Dear @fabiosun . Sorry that offended your professional dignity with my wrong conclusion about MSR 0xE2. Sorry...

W-2123 with HT.png

W-2123 without HT.png

My tests with- and without HT.

Edited by yapan4
  • Create New...