Jump to content
vesting

[HELP] Lenovo T520 High Sierra

4 posts in this topic

Recommended Posts

Hello,

I own a Lenovo Thinkpad T520 with this hardware:

CPU: Intel Core i5-2520M 2.50 GHz
Motherboard: Lenovo 4242Y13 Chipset Intel sandy bridge
RAM: 8Gb DDR3 dual channel
Graphics: Intel HD Graphics 3000
Storage: 320 Gb HDD 7200 rpm.
Wireless Card: Intel 82579LM Gbit network connection
Trackpad.
Ports:

  1.  - 2 USB 2.0
  2.  - 1 USB 3.0
  3.  - 1 VGA
  4.  - 1 Card reader
  5.  - 1 Ethernet

Is it Hackintosh compatible? I would like to install High Sierra, or at least El Capitan. I read that someone made it following the T410's guide, but they had the i7 version of the T520 with NVidia graphics. can you help me please?

Thank you for your time.

 

Share this post


Link to post
Share on other sites
Advertisement

That model carries the same specs as many popular business Sandby Bridge laptops such as the Dell Latitude E6220 (or other E6x20 models) or HP EliteBook 2560p for instance: same CPU, iGPU, chipset, LAN card, etc. It's entirely compatible with all versions of OS X since good old Snow Leopard 10.6.8 up to latest High Sierra 10.13.4.

 

You only may encounter trouble with the wireless card because

1) Intel cards are not compatible with Apple's OS

2) ThinkPad are infamously subject to whitelisting, i.e. Lenovo BIOS only supports certain models.

 

According to p120 of the T520 Hardware Maintenance Manual, the only non-Intel WLAN card is a Realtek RTL8188CE model (FRU 60Y3247, would appear to be a Foxconn TH77H219). That's what your ought to run on as I believe it's compatible with OS X/macOS. Failing that, you'd need a modded BIOS where whitelist has been removed. Of course, a USB dongle remains an alternative to mini-PCIe card...

 

Thinkpad T410 was 1st gen Arrandale platform afaik, so quite different from your 2nd gen model.

Edited by Hervé

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r4989 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4989 for VMware.zip". Mount Clover-v2.4k-4989-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By dbx103
      I'm having so much problem following guide and forums making impossible for me to understand,  MaciASL, Could someone disable my Nvidia card by editing my files.
       
      origin.zip
    • By 22eme_arkane
      Hi everyone !
       
       I build a new os on High Sierra and i have problem with my Skarkoon RAID 5 - 5 bay, is unmounting, work fine in windows but not in Mac Os.
      I use a card eSata in chipset Marvell 88SE9215, and i have the kext 3-party eSata  but nothings change.
      I try with the AppleAHCIPort.kext v328, nothings change.
       
      Any solution ?
       
      Thanks a lot !
       
      Config : GA-Z68X-UB3-B3 // BIOS UEFI, Version: U1f //
    • By bummercheese
      I have what's been said to be a natively supported wifi card, but for the life of me I cannot get it working properly with High Sierra. It is detected in DPCIManager but the wifi symbol at the top is hollowed and I can't turn it on.
       
      Here's some basic info about my hackintosh. It's running an i7 9700k with an MSI Z390-A PRO, a GTX 1070, and it's SMBIOS is running as an iMac 18.1

      Someone else has posted here about this with an ac66, which I think is very similar and uses the same device number 43A0. But he didn't get his problem solved in the end. And I have looked up this problem in a million different ways, I haven't found a solution that works from any yet.
       
      I've tried a large amount of different kext patches, kexts (fakepciid, airportbrcmfixup, etc), changing fake ID, modifying kext info.plist files, and every combination of those, none have gotten it to properly work.
       
      I have gotten it to work in one way but it's so unstable that it's unusable. Using the IO80211family.kext from yosemite works, but then it will randomly freeze about 10-15 minutes in, and then it'll not boot 9/10 times, and when it will it'll freeze on the login or right after. It gives errors about out of date kext, only way get back in is by reinstalling. So I figure this method is unusable.
       
      I'm just stumped on why a supposed confirmed working out of box card doesn't just just work, even with every amount of tweaking and adding kexts. I'm in my 4th day of almost nonstop testing and researching on how to fix this, and I'm too stubborn and determined to just buy a different card. Any suggestions would be greatly appreciated. 
×