Jump to content
BauerMac

How to enable all 6 SATA drives while using M.2 SSD?

9 posts in this topic

Recommended Posts

Hey,

 

I want to use 7 drives on my ASUS X Hero MB.
The MB supports up to 6 SATA drives, and also has 2 M.2 slots, so I thought it was possible to run at least 7 drives.
Apparently, it isn´t that easy.

 

I have a Samsung 850 EVO MZ-N5E500BW M.2 drive that I use as boot drive.
It´s a SATA drive, and from what I can read, using a SATA drive in the M.2 slot will either disable one or two of the other SATA slots, depending on which type of M.2 setup you choose.
So now I can only use a total of SIX slots in the machine for storage, which is a huge bummer, since I need the extra SSD drive.
 
I can of course connect the extra SSD drive via an adapter and use an external USB port, but that´s a very impractical solution.
 
QUESTION:
Can anyone tell me if it´s possible to somehow connect 7 drives to my ASUS X Hero MB?
(Buying a new PCIE M.2 drive is not an option, since the M.2 drive I have is the boot drive, and I don´t wanna F around with cloning, replacing etc)
 
Thanks in advance! :)
 

Share this post


Link to post
Share on other sites
Advertisement

Hi, 

 

Not sure if I can help with this. But maybe I can give some insight to something. 

 

Could it be that your board just got an AHCI limitation? In this case, I'd suggest you not using AHCI and maybe NVMe. Now I am not sure if your board supports NVMe. Some people even mod their UEFI to get NVMe support. Now since one drive will use NVMe in this case, and the other six drives will use AHCI, you might not get into this problem, and you will be able to have 7 drives. The only down side is, you would have to get NVMe m.2 drive. 

 

Another solution could be that you get a mass storage PCIe card. Well a RAID card that works with MacOS. But you might not need RAID. In this case, you don't use the RAID function the PCIe RAID card gives. You can get inexpensive RAID cards, such as HighPoint Rocket Raid RR2720SGL. You can hook up SATA drives with it with SATA connectors. If you only got m.2 to connect, it must be SATA bu with an enclosure having SATA connector (not sure if those enclosures exists). There is a downside to this as well, the RAID card will show its own bios signs before booting, just like the motherboard does, this will of course make the booting experience a bit downgraded taking a few seconds more. If this isn't a problem, then this might be something you might want to consider. The RR2720SGL is quite inexpensive, last I checked it was about 160 USD. It got two SAS connectors, and can run 8 drives. All you need with it is mini SAS to 4x SATA 3 cable, either one or two of them, depending on how many you want to connect. Assuming you won't connect many, if this solution is for you. 

 

**Edit**

 

The RR2720SGL works out of the box for Mac OS X / MacOS. However, I have only used it to macOS Sierra 10.12. I don't use it anymore, and therefore don't know if this will work for High Sierra, but I am assuming it will.

 

:)

Edited by Dwarfy

Share this post


Link to post
Share on other sites

Thanks a lot, @Dwarfy for taking time to reply :)

Yeah, I know I could probably get some other storage device, but the thing is; I already HAVE a 500GB Samsung SSD that I want to use instead of paying $$$ for another one ;)

 

I´ll check the AHCI limitation you mention, and see if I can somehow do something about my MB´s NVMe/SATA support. May be the only way to do it, since I don´t see any other options to connect the SSD internally.

Thanks again! :)

Share this post


Link to post
Share on other sites

Hyeya,

 

Sounds good. 

 

I can understand that at this point you don't want to spend more money on SSDs and / or a RAID card. 

But if there is a limitation for AHCI, and it cannot be changed, then you most likely would have to get a drive with NVMe support. 

And if that isn't a solution, then a Mass Storage controller card, such as a RAID card (without using RAID). However, I am hoping that. you can some how work around the limitation. Possibly hoping that there is no limitation, and ASUS made that board run as many drives thrown at it. Hoping as many connectors for drives as many drives can be hooked up and utilised. Though not to sound rude, but I already find it a bit pointless that a non NVMe SSD is in m.2 slot. Assuming ASUS most likely thought the user of the board would utilise the m.2 slots with NVMe SSD. 

 

Not sure if UEFI modding will help in this case either. Hopefully there isn't any limitation, and just something you need to enable in UEFI to run seven drives.

 

As of now this is all I could think of. I am open to get lectured, lol. And if someone wants to amend into any of what I have said , then feel happy to do so. 

 

:) 

Share this post


Link to post
Share on other sites

Thanks again :)

I´m doing some research to find some hack/solution for this, so far I haven´t found anything.
I´m thinking there must be some BIOS setting or similar that can circumvent the disabling of SATA slot #1 when using M.2, but perhaps it´s a physical limitation.

Not sure about your suggestion re NVMe in the M.2 slot. I just plugged in a "regular" M.2. SSD and it seems to work fine, but you may be right :)

Share this post


Link to post
Share on other sites

Hyeya,

 

I might be right, but I am not sure. 

 

The reason I mentioned about NVMe capable drive for m.2 to be used, is because if there possibly is a limitation for AHCI, then it won't affect your setup of drives, as one is with NVMe. 

 

Your motherboard is a high-end gaming motherboard, not that only gamers buy and utilise it, but most people buying such motherboard opt to get NVMe SSDs. Now, it isn't because of NVMe that NVMe drives are faster, NVMe is just a standard, a communication protocol SSDs got. The manufacturers just got more focus on this standard. And these drivers don't necessarily need to use AHCI, well there is no need for a NVMe drive to be used as an AHCI drive. 

 

Since your board is fairly new, and supports NVMe, most people would most likely utilise the m.2 slots for NVMe drives. And what I was saying earlier in my other post, I'd believe ASUS would think people would opt for NVMe. drives in those m.2 slots. If that is done, it could be that you get seven drives running, as you are not crossing any AHCI limitation s. But I could be wrong. 

 

:) 

Share this post


Link to post
Share on other sites

As seen on the manufacturers product page....

 

 

 

*2 When the M.2_1 socket is operating in SATA mode, SATA port 1 will be disabled.
 
*3 When the M.2_2 socket is operating in PCIEX4 mode, SATA port 5. 6 will be disabled.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Candrahm
      Hi everybody,
       
      I'm new here and French. 
      I success to hack my Asus X751LJ and pass it to High Sierra 10.13.6, not easily, and everything works except the keyboard and the touchpad.
      I tried VoodooPS2Controller, ApplePS2SmartTouchpad, even VoodooI2C, but nothing works...
      Could someone help me? Is there a DSDT problem? Witch kext should I use?
      I post my ACPI and Kexts folders and my IOReg.
      Please... Help me. I'm desperate...
      MacBook Pro de Candrahm.ioreg
      Archive.zip
    • By BauerMac
      Hey guys,
      I hope you can help me solve a mystery.
      Even the amazing Mald0n has been working hard to help me find a solution, but now were are both stuck.
      Creative thinking or maybe just help to see the forest for the trees would be highly appreciated.
       
      PROBLEM:
      Mac will not sleep.
      Monitors sleep fine, and come back on with touch of keyboard.
      GPU and CPU coolers are constantly running on idle to low load and will not go on standby no matter what we have tried.
      Even when using full “Shut down” via apple menu the lights from the MoBo or GPU are pulsing slowly, which they normally dont as far as I recall.
      (This specific issue could possibly be solved by using ErP Ready in BIOS. Haven´t tested this since that´s a smaller issue ATM)
       
      Everything else seems to be working fine.
      This problem started appr a week ago, and I have no idea why.
      No major installs, updates or changes that I can think of.
       
      GOALS:
      • To be able to activate sleep via apple menu.
      • To have it sleep within 15-30 secs and wake up quickly (like it did before) via push on Power button

      TECH SPEC:
      • Running 10.13.6
      • Asus Maximus X Hero Wifi
      • Gtx 1080 Ti
      • 32 GB Corsair RAM
      • Intel i7 8700K
      • 2 monitors via Displayport
      • 6 internal disks (2 HDD, 4 SSD)
      • 1 external backup
      • 1 internal USB hub/SD reader
      • 3rd party Bluetooth and Wifi (Asus MB not compatible)
      • No Blutooth mouse, KB etc

      WHAT I HAVE DONE SO FAR:
      • Used Mald0n’s custom DSDT with latest config
      • IUpdated to latest Security Update
      • Updated to latest BIOS
      • Updated NVIDIA webdriver and CUDA to latest
      • Disconnected LED monitors and tested with old Mac monitor via DVI to see if Displayports were the issue
      • Disabled Adobe CC Sync
      • Run CleanMyMac
      • No start-up apps or extensions in System Prefs
      • Disk Utility: checked all disks
      • Terminal: no info on wake reason at all. (Possibly because it doesn´t sleep, hence nothing is interrupting it).
      • Blutooth allowed to wake sleep: set to OFF
      • Power manager: only setting is “never switch off monitors”. The rest are off/unchecked
      • BIOS: Tested by setting "ErP ready" to S5 > no difference
      • DSDT and EFI folder screenshot attached.

      I think that’s it - otherwise just ask
      I have read a lot of articles on this type of issue, but none with a clear answer.
      So if anyone can solve this mystery, it would be amazing!
      Thank you in advance!
       
      Bauermac DSDT.aml.zip



      UPDATE:
      Of course it was something seemingly insignificant and stupid that prevented sleep: An unfinished PRINTER job.... 
      After clearing the printer queue, it went to sleep but woke up immediately after due to a USB power issue. Possibly an internal USB/SD hub.
      Mald0n used his magic and made a new DSDT file to fix that, and now the machine is running almost perfectly apart from a fickle Bluetooth (fingers crossed).

      Hope this can help others out there with issues.

       
    • By fighttoby
      I have tried to install clover via no UEFI legacy mode (and with UEFI method) using the method here (http://www.tonymacx86.com/yosemite-desktop-guides/144426-how-install-os-x-yosemite-using-clover.html)
      both times I can get to just past the clover boot screen and it freezes after that.
      I have verbose (-v) selected in boot options: On the non-UEFI install then it hangs on:
      "Waiting on <dict ID="0"><key>IOProviderClass</key>...."
       
      I have had a lot of issues with trying to get the installer working and many different things that had to be disabled but now it just gets to here and stops. Some times it will glitch out on this screen and give me a the circle with the line through it and text garbage around it where the text in the pictures are.
       
      Need help please.
       
      This is the laptop im using the specs are the same nothing has changed.
      https://www.asus.com/Laptops/ASUS_VivoBook_X202E/


      config.plist
    • By mossy
      so im trying to install El Capitan on my old laptop but im having mouse issues i tried all the kext and looked online 
       
      this is TUT i followed 
       
      https://osxlatitude.com/forums/topic/8645-dell-latitude-d630-with-core2duo-and-nvidia-quadro-nvs-135m-el-capitansierra/
       
      ASUS K50IN T6500
    • By mossy
      Hi i have old laptop and i wanted to install os x i looked online for some TUT's but i didnt understand some people say works some say no 
       
      i being trying all day boots me to install menu for sierra but i cant move the mouse or the keyboard so can some plz help me 
       
      ASUS K50IN Intel® Core™2 Duo Processor T6500 2.10 GHz
       
      NVIDIA® GeForce® G102M, with 512MB VRAM
       
       
×