Jump to content
MaLd0n

High Sierra on Supermicro X10DAI / Dual Xeon E5-2690V4 / DSDT

138 posts in this topic

Recommended Posts

Now have a Olarila app, just download app and clover folder for your Chipset!
 

Install MacOS with Olarila Image, Step by Step, Install and Post Install

 

https://olarila.com/forum/viewtopic.php?f=50&t=8685

 

-Install, check here bone.png

http://www.insanelymac.com/forum/topic/323052-guide-sierra-high-sierra-on-intel-5-6-7-8-and-9-chipset-series-nehalem-sandybridge-ivybridge-haswell-broadwell/

 

-Clover Folder ninja.png

CLOVER.zip

 

-DSDT moil.gif

DSDT.MaLd0n Supermicro X10DAI.zip

 

-DSDT Patches construction.gif

-FIX ERRORS AND WARNINGS
-HPET
-SATA
-sSATA
-DMAC
-SLPB
-DARWIN
-LPC
-XHCI
-EHCI
-PLUGIN TYPE
-ALZA to HDEF
-HDEF
-RTC
-IRQs
-SBUS
-BLC0
-BUS1
-MCHC
-ALS0
-SHUTDOWN
-LAN #1
-LAN #2
-SPSR
-WIFI
-EC
-PNLF
-HDMI
-NVME

-Geekbench frantics.gif

03.jpg

 

-SS beachball.gif

01.jpg

02.png

 

-Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
guitar.gif
Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, MMido and many, many, many others!
 
We're all here to have fun and learn from each other!
yoji.gif
 

Share this post


Link to post
Share on other sites
Advertisement

I have this same motherboard but with dual E5-2683 V3 any changes I need to make here to the included files?

 

Thanks!

Share this post


Link to post
Share on other sites

U can use same clover folder, same dsdt

 

check only voodootscsync with correct value for ur processors

 

and if u use Nvidia, use Nvidiafix kext instead whatevergreen

Share this post


Link to post
Share on other sites

MaLd0n, If I use your DSDT and config files my system wont boot into os x, I get part way then KP.

 

Currently I have a working setup with 10.13.2 and XCPM loaded and speed step working via SSDT and freqVectorsEdit.sh 

 

Currently I have the latest X10DAI supermicro bios X10DAi7_605 that I modded with me_cleaner.py to remove Intel ME and added support for NVME using NvmExpressDxe_2.ffs (Version 3 does not work) and my system is working and booting with native speed step enabled via XCPM and NVME working.

 

I also tried UEFIPatch_0.3.11 on my bios but then my system would not boot without Kernel Panic. But I liked the idea of Bios Remove lock from MSR 0xE2 register and this patch for my CPU: # PowerMgmtDxe | Haswell

F7731B4C-58A2-4DF4-8980-5645D39ECE58 10 P:75080FBAE80F89442430:EB080FBAE80F89442430 
 
Here is my Bios, Config.plist, Drivers64UEFI and Kexts in clover:
 
Thanks for your support and genius! <3

Share this post


Link to post
Share on other sites

 

MaLd0n, If I use your DSDT and config files my system wont boot into os x, I get part way then KP.

 

Currently I have a working setup with 10.13.2 and XCPM loaded and speed step working via SSDT and freqVectorsEdit.sh 

 

Currently I have the latest X10DAI supermicro bios X10DAi7_605 that I modded with me_cleaner.py to remove Intel ME and added support for NVME using NvmExpressDxe_2.ffs (Version 3 does not work) and my system is working and booting with native speed step enabled via XCPM and NVME working.

 

I also tried UEFIPatch_0.3.11 on my bios but then my system would not boot without Kernel Panic. But I liked the idea of Bios Remove lock from MSR 0xE2 register and this patch for my CPU: # PowerMgmtDxe | Haswell

F7731B4C-58A2-4DF4-8980-5645D39ECE58 10 P:75080FBAE80F89442430:EB080FBAE80F89442430 
 
Here is my Bios, Config.plist, Drivers64UEFI and Kexts in clover:
 
Thanks for your support and genius!

 

-Send me tables
-Send me one Ioreg too

Share this post


Link to post
Share on other sites

Here you go, use the last URL I gave you or here are direct:

 

IO reg dump:

https://drive.google.com/open?id=1tdikpA57BKMKoO3DOiLxXQuLqHuHyOxt

 

Table: dump:

https://drive.google.com/open?id=1kZe2aYY-EhMuj9xqe4TLnLWJJCRpg_8W

Put in clover/acpi/patched, reboot, send me new ioreg

DSDT.aml.zip

Share this post


Link to post
Share on other sites

looks good

 

sleep work?

 

 

When I set it to sleep, display blanks and then display comes on back on and nothing else. As if it never happened and the display just went to sleep.

Share this post


Link to post
Share on other sites

looks good

 

sleep work?

 

 

Ok its doing something else now: Screen goes blank, a few moments pass by I hear the fans spin up for half a second and then it shuts off and turns right back on accept its booting back into clover!

Share this post


Link to post
Share on other sites

So I changed the Config a bit to add the ACPI fixes: FixRegions / DeleteUnused  and FixMutex and now when I choose sleep, Screen goes blank, a few moments pass by I hear the fans spin up for half a second and then it shuts off and turns right back on accept its booting into the bios screen.

let's try

DSDT.03.zip

Share this post


Link to post
Share on other sites

let's try

attachicon.gifDSDT.03.zip

 

Tried this when I set to sleep it goes to sleep like it should accept will not wake from Keyboard or USB. I pressed the power button to turn back on and it booted into the bios and never resumed from sleep

 

perhaps a Bios setting is off? What are your BIOS settings for this board?

Share this post


Link to post
Share on other sites

Some problems with sleep too :D bad bad

 

Yeah sleep is not too big of a concern. 

 

What is a big problem is my keyboard stops responding after some time, and if I unplug it and plug it back in again it does not work and I have to force reboot the system. Interestingly the mouse still works.

 

Perhaps its a BIOS / Clover setting?

Share this post


Link to post
Share on other sites

Try it

if u use one usb injector remove

USB.zip

 

add some patches in config.plist

 

XHCI to XHC
5848 4349
5848 435f
 
EHC1 to EH01
45484331 
45483031 
 
EHC2 to EH02
45484332 
45483032 
 
and patch limit port too ;)

Share this post


Link to post
Share on other sites

What did you mean by "if u use one usb injector remove" ? Also should I be using that DSDT from the USB.zip file?

 

I am having issues with system stability, perhaps you can advise on Bios and Clover settings? 

 

I went back to a more stock BIOS with me not removed as I suspected it was causing instability with os x.

 

Also strange is the system fans seem to be jumping up for half a second and then back down.

 

Is it possible to have DSDT to allow me for another GTX 1070 card, two total

Share this post


Link to post
Share on other sites

I made some changes, getting fewer console error messages.

 

I am using BIOS with NVME efi driver mod. Right now I am booted from Sata SSD.

 

Testing now for stability, I tried to add my other GTX 1070 (for dual card) but I cant get it to boot with that. Had it working before your DSDT.

Share this post


Link to post
Share on other sites

dual GPU don't work good

CF, SLI dont work in hacks

u can use two gpus, but have a problems


try without DSDT

Share this post


Link to post
Share on other sites

I mean I had it working with without the DSDT, I dont use SLI its for Davinci Resolve. 

 

IF I send you dumps of it working without the DSDT applied can you patch it so its in the DSDT?

Share this post


Link to post
Share on other sites

u use same bios or u mod new bios?

yes, send me original tables and one ioreg without DSDT with two GPUs

we try

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By penghubingzhou
      URL:https://github.com/penghubingzhou/VoodooI2C-DSDT
       
      VoodooI2C-DSDT is a repository that is aiming at collecting various successful DSDTs for Voodoo I2C.
      Purpose
      The purpose of this repository is to provide some useful code examples for people who haven't yet make Voodoo I2C work. Maybe It don't have your model of laptop, but code in this repository may have some help and references for you.
      Note that the code in this repository is ONLY FOR REFERENCES and it can‘t replace your own work!
      For Submission
      This repository welcomes everyone to submit DSDT code examples that have successfully made VoodooI2C work by PR. To submit your example, please put the DSDT file (or Hotpatch SSDT file), an ioreg without Voodoo I2C installed, and Info.txt in a folder named by your laptop model. Info.txt should include:
      Your CPU model (better for including CPU platform)
      Your touchpad Device ID
      The mode you use (GPIO interrupt or polling)
      Satellite Driver You Use
      Then, fork this repository and clone it, put your file in and commit it to your repository. After checking the conflicts, you can send your commit as a PR to me.
      An example for submitting can be found in Lenovo Xiaoxin Chao 7000-14.
      Credits
      @Alexandred for VoodooI2C @daggeryu for the idea in this repository @penghubingzhou and @williambj1 for maintaining
    • By MaLd0n
      ---INSTALLATION TUTORIAL---
       
      ---Original Post---
      https://olarila.com/forum/viewtopic.php?p=77102#p77102
       
      ---CLOVER FOLDER---
       
      CLOVER.zip
       
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM / REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By Gorec
      Hi.
      I apologize in advance if I didn't post in the right category and if my title and description aren't specific enough :c
       
      My config in a nutshell:
      CPU: i7 5820k GPU: MSI GTX 1060 3GB RAM: 16 GB MOBO: MSI X99 SLI PLUS I attached RunMe output with all the details of my built.
       
      Some background:
      I have my Hackintosh for about half a year. That time I managed to make it works and fix major issues, but some of them left unresolved since then and I ignored them until now.
      I use my Hackintosh for Adobe projects (PR, AE, PS, IL, AU and a lot more) - most of them connected with video editing of course browsing with Chrome and other small tasks.
       
      Problems:
      Random restarts - this is the biggest one. I'm starting to work on bigger and bigger projects and at this time I think I can't allow this to happen that often. In the past, they happened like once a day or a couple of times a week. However, now it's just frustrating when it happens even 5 or more times a day. I've tried to observe and find out what can be the cause but I haven't managed to find any connections. I thought it happens when Premiere or another app is using GPU, but I haven't seen increased usage when it restarts. I think that it can be connected with GPU, memory or PSU or... meh, anything else. I don't have resources to check if it'll work with other components. There should be some fix for this. I will really appreciate any help with this :c Restart instead of shutdown & sleep doesn't work. I've tried to look through some Google results for this and tried many solutions (as you can see in attached Clover folder), but I think the right one for many of these issues is to make my own DSDT. Glitches, freezes and other things while encoding a video. It happens very often when I try to do this. Maybe it is an issue with GPU or (hopefully) only with GPU drivers which can be fixed with some patch. Today my headphones stopped working. I have a multi-output device configured in the Audio MIDI Setup app which includes my headphones (HyperX Cloud via USB) and Soundflowerbed virtual audio device for capturing system audio. Today while I was trying (like 15 times) to encode a video in Media Encoder in the background and watch video on YouTube I stopped hearing anything from my system. Of course, it restarted a couple of times as always, but even this didn't solve this. If I plug them directly with mini jack (not via USB Soundcard which was in the box and which I always used) in the front IO or the back I only hear some loud noise It takes EX-Fat formatted volumes a few minutes to mount after each restart. I found a workaround to format it with NTFS since I have Tuxera installed and I will reformat these volumes when I will find time for this, but maybe there is some fix for this. GPU is a little bit hot. HW Monitor shows it is only 45-55 degrees, but for my hand is a little bit hot, idk. Also related to GPU - glitch after POST but before entering Clover boot menu. It is a black screen with little white squared glitches for a few seconds. Maybe it indicates the GPU drivers are loading, but maybe it shouldn't be like this. And if I can ask about that - I can't make all applications hide on startup. I, obviously, have "Hide" checkbox checked on every login item in settings, but it doesn't work, none of the apps is hidden in the dock. Is there a way to fix this? Also a small but annoying problem - I can't turn off permanently Mojave update notification (since I tried to install it, and I had to reverse to High Sierra because I had a black screen and I didn't have time for repairing all of them. Tags are not working in Finder - every time I tag a file or folder and make a change in it (for example save a text file) the tag disappears.  
      So, with knowing all of that, is there a way to make a proper DSDT file for my Hackintosh? I tried to look through some guides on how to make it but I think I reached my abilities to understand how Mac OS works and what all of these things are, so I'm asking you guys politely, would someone like to help me? At least with these random restarts? :/
      I really begin to think that I'm a newbie in configuring all of that Clover things - even after what I managed to do with my PC. Help me, pleease... :c
       
      If you have any questions post it below, I will really appreciate any help <3
      Send me MBP-Gorec.home.zip
×