Jump to content
Sign in to follow this  
Followers 0
owiowi

Can't detect display after updating to 10.12.5?

3 posts in this topic

Recommended Posts

Hi everyone, 

I got a very odd problem after updating to 10.12.5 and I'll try explaining it to the best I can along all troubleshooting I did...

 

I have a Macbook Pro retina 13" (early 2015) that I've always used with two Samsung external monitors (both are the same model). One of them is connected directly through the HDMI port located on the right side of the Macbook Pro, the other one connected through a thunderbolt-to-HDMI cable. It has always worked until last week when I updated to 10.12.5.

After the update, I quickly noticed that my Macbook Pro wouldn’t detect any external display via thunderbolt-to-HDMI. Thus, I started a long process of troubleshooting, and here’s all I’ve tried:

  • Assuming it could have been a defective cable, I’ve tried 3 different ones, still no luck
  • I’ve tried both thunderbolt entry, still no luck
  • I’ve tried thunderbolt-to-VGA, it WORKS, yes, I know this is insane.
  • I’ve tried to connect thunderbolt-to-HDMI (still with all 3 cables) on older Samsung monitors (again two older monitors were the same model, it was my old setup)… it worked
  • Then, I assumed it was the Samsung monitors that were broken (the two of them at the same time…? Odd, isn’t it?). Thus, I tried to connect them on my mac mini, the same way I always did on my Macbook pro… And it works…
  • Then I tried to reproduce the problem on my mom’s Macbook Pro retina 13” (exact same model I have the problem with and same update)... It works
  • Then I assumed the problem must be coming from my Macbook Pro. Thus, I booted on Windows 8 (bootcamp), it works.
  • Starting to lose my mind… I booted from an external hard drive I have (running an early sierra version), it didn’t work either (I had used this external hard drive in the past and it was WORKING)
  • I've done a factory reset, still not working

EDIT (forgot to mention):

  • SMC, no luck
  • NVRAM, no luck

 

So in a nutshell, the problem seems to appear only via thunderbolt-to-HDMI, only on this specific Macbook Pro, and specifically on macOS.

 

I’m no expert and I don’t know what else I can do. Of course I've tried contacting Apple many times but they keep blaming me for updating my mac and/or Samsung for making the environment not compatible, which I believe is a total nonsense. 

 

Has anyone encounter any similar problem? Does anyone know what it could be?

 

 

I’m desperate so I’d like to thank y’all in advance for your help.

 

Cheers

Share this post


Link to post
Share on other sites
Advertisement

First of all, thank you for you answer!

Yes, I failed to mention it but I tried SMC and NVRAM but no luck.

I'll try the combo update and update this post with the outcome once I'm done.

 

Again, thank you so much for you help!

 

EDIT:

- I tried to cables that are direct thunderbolt-to-hdmi, it doesn't work BUT...

- I tried an thunderbolt adapter with an HDMI entry (which wasn't working prior trying your suggestion)... and IT WORKS!!!!!!!!! 

 

I guess the problem isn't completely solved but for now I can live with that!

You're a GEM, thanks a ton!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By wegosi
      Hello.
      Could, please, anybody with knowledge help me?
      Problem: on internal monitor all colors are perfect. on External - I have banding gradients and colors.

       
      My system: 
      ASUST N56VB
      Catalina 10.15.3
      Intel HD4000
      Intel® HM76 Chipset
      External monitor 21:9 2560x1080 via HDMI.
      Clover 5115
       
      What I tried:
      1. Different versions of Lilu and WhateverGreen
      2. Different combinations in config.plist in devices

      In mac Graphics/Displays I see only 24bit of color depth. Is it OK?
       

      Installed kexts:

       
      I don't update WhateverGreen, because then my external monitor stops working at all
       
      My config.plist:

       
       
      Graphics info:

       
      What other info should I provide?
      How to fix it? Thank you in advance
       
      config.plist
       
      EFI zip (not other options to upload here? max 7.85mb on forum, right?):
      https://drive.google.com/open?id=1bUFt_ouKNmdKJH1451AbPGQmh-K9OsHU
       
    • By e285ne
      Hello,
       
      could you help me with Intel UHD 620 HDMI port?
       
      HP ProBook G6 440
      Intel Core i5-8265u
      Catalina 10.15.4

      I've installed Catalina 10.15.4
      But I can't get HDMI working
      When I connect HDMI cable I got freezes and errors as in file freezes.png (attached)

      [IGFB][INFO ] Setting DP power failed (0xe00002bc), ignoring empty dongle handling (likely HDMI/TMDS case)

      I also looked into IOregistryExplorer and see that the connect type is 00400000 there for FB@1
      I tried to patch it via setup.plist but it seems that there is no change in IOregistryExplorer.
      Though the Hackintool sees the change (image attached)
      e285ne.zip
    • By rxfx
      So I’ve been working at trying to get the wifey’s [HP Envy Recline 23-k310 All-in-One]’s display to properly wake from sleep for months now. I’m kinda at my wits end; It’s probably something so simple and I’m overthinking it.
       
      The computer sleeps properly, but when it wakes, I get no display (no backlight either). The keyboard and peripherals seem to work after wake; able to key in the passcode/password and sound works when I use the volume up/down buttons. But I get absolutely no display. I’ve done 3 other successful hackintoshes (though, none had any dGPUs/eGPUs). But I’m somewhat confident that I’ve disabled the Nvidia Optimus (NVIDIA GeForce 830A)/N15S-GM) I couldn’t find any _ini when I poll the SSDT’s and no signs of Nvidia In System Report, Hackintosh, or IOReg. It’s disabled via the Frame Buffer patch in clover (I use 0x0D220003 for platform ID. I definitely have the Lilu and Whatevergreen kexts in L/E. I’ve tried a plethora of Clover settings, changing SMBIOS’s, darkwake bootflags, and AppleBacklightfixup.kext in both Clover/Kexts and L/E to no avail. Power management has been set using the Pike R. Alpha ssdtPRGen implementation. I’ve gone through and setup the proper SSDTs for the USB patching. Besides adding the HDMI audio output patch (which I don’t use/or have anything plugged into since its an AIO), everything else works on point. But…
       
      “Help me Obi-Wan[’s], you’re my only hope!!”
       
      I’ve attached an “Error Report.zip” including an IOReg report, config.plist, and a generated report form black.dragon74’s tool. I would love any recommendations or possible fixes/files/patches to these files to resolve this issue that has been stumping me for months.
       
      HP Envy Recline 23-k310 AIO
      Intel i3-4330T
      Intel HD Graphics 4400
      8GB 1600 MHz RAM
      Intel H87 Chipset [HP/Quanta Laurel2-1G mainboard]
      macOS Catalina 10.15.3 (with iMac 14,3 SMBIOS)
      Error Report.zip
    • By gengstapo
      @Hervé
       
      Im having similar issue with my HS setup, dell latitute 3480, i5-7200U
      Once the hdmi plugged in, the laptop display went blank, only could see the external tv
      But, when i put my laptop to sleep & wake up again, both screen got display (hdmi still connected)
      Even the hdmi could be plugged off & in (after sleep), the laptop display is fine
       
      What could be the culprit?
      Dell’s MacBook Pro IORegistry.zip
      config.plist.zip
×