Jump to content

Erro instalação - Sierra na Mobo Gigabyte Z170X-UD5 com SSD M.2 NVMe


Go to solution Solved by junausp,
216 posts in this topic

Recommended Posts

não confunda EFI com UEFI

 

bios UEFI - Interface Unificada de Firmware Extensível

 

EFI é a partição criada sempre que vc formata o HD pro mac, ela não é usada pela Apple e a gente usa pro hack, ficando dessa forma com sistema totalmente limpo

 

esquece seu notebook, ele é somente pra criar o pen drive e instalar o clover, o resto é no seu desktop ;)

 

o Clover vai criar a pasta EFI na raiz do seu HD, mas não é a partição EFI criada pela Apple

 

 

Sim sim não confundi. É que outro dia como seguia o tutorial do site tony era um pouco diferente.

 

Mas acho q entendi o que falou. Mas só uma dúvida, o Sierra será instalado sem ter o clover ainda?

 

E quando disse para eu instalar o Clover, seria em que local?

Mald0n fiz o que falou (eu acho) na BIOS:
 

Yrqj7E8.jpg

 

No Boot:

 

U9bqCF7.jpg

 

Mas não faz nada:

 

RSb38OA.jpg

 

 

PS: como eu coloco imagens pequenas como vc faz, aqueles thumbnails para quando clicar ver em tamanho maior?

Sim, tira do zip e instala no pendrive com aquelas configs pra UEFI mode, e volta sua bios pras configs de fábrica tb

 

Usa o full editor e posta, escolher aquivo, Attach this file

Maldon coloquei os dois SSD m2 na máquina para entrar no Windows que está instalado em um deles e ver se ele enxerga o outro. Pelo Windows no gerenciador de disco aparece o outro m.2 como na figura que anexei.

 

E o mais estranho é que na BIOS quando vou no item NVME Configuration, aparece No NVME Devices Found. Mas se não aparece nenhum disco na Bios como o Windows carrega?

 

Detalhe: quando coloco o Pen Drive e dou boot por ele, depois da tela do clover quando deveria começar a instalação, logo após correr alguns sinais na tela (+++++++++++++++++++) o micro reboota.

 

Será que está acontecendo por não estar achando o ssd m2 ou por ele não estar particionado corretamente ou ainda é alguma coisa nas configurações do pendrive?

 

 

post-162706-14906070014011_thumb.jpg

use a opção kernelPM do próprio Clover

Como faço para usar essa opção. Não estou achando na tela do Clover quando dou o boot com ele.

use a opção kernelPM do próprio Clover

Achei mas não adiantou. Rola um monte de coisas e reboota o micro.

 

5c21c2ff83cd49f0f33230317bcc5b51.jpg

Cara, vc tem de deletar a ionvmefamily, estou vendo ela daqui no log error

usa os patches do pike, só ver a versão do sistema

Deletar do Sierra(instalador)? Ou acha melhor renomear?

 

Teria fácil o link para esses patches do pike?

ou vc usa o método hacknvme ou vc usa o patch

 

com o patch vc vai usar a kext da apple ionvmefamily, o ouro vc usa a kext do rehab

Ok usando o patch que vc me passou, para aplicar no meu config do pendrive, eu não preciso daquela kext Hacknvme. Estou certo?

sim, mas vc precisa da kext ionvmefamily, que a gente precisava deletar...lembra?

1) Ok mas essa kext não está na instalação do Sierra?

 

 

2) Além da pergunta anterior esqueci de perguntar sobre o que tinha visto no site ... que fala desse patch etc.. 

Um tal de Determining the ACPI path of your NVMe device(s) onde pega um tal de Bios device name pelo Windows e depois gera um arquivo de nome SSDT-NVMe-Pcc.aml

 

Eu tenho que fazer isso também?

sim, mas vc precisa da kext ionvmefamily, que a gente precisava deletar...lembra?

Maldon essa kext ionvmefamily que vc diz que precisa, ela não é da Apple e já não está na própria instalação?

Ok então não preciso fazar mais nada, só bootar e ver se instala. Pois bem fiz isso e vai numa boa até o momento onde pede o idioma. Após isso quando abri o Disk Utility:

 

post-162706-0-39537300-1490704162_thumb.

 

e mesmo rodando  pelo terminal aparece o USB e um monte de coisas que nem sei o que é mas ouvi falar que é normal(ou não?), mas nada do SSD m2 :

 

post-162706-0-75775000-1490704387_thumb.

 

Espero que estamos chegando quase lá rsrs..

 

 

 

post-162706-0-39537300-1490704162_thumb.jpg

post-162706-0-75775000-1490704387_thumb.jpg

vc tem de ter certeza de qual versão do sierra vc está usando e usar os patches pra versão ;)

 

mas pelo menos a instalação subiu

Fizemos certo. Quando me perguntou eu havia dito que era o 10.12.3 que havia baixado da AppStore.

 

Mas como resolvo agora essa questão de não achar o m.2. E só por garantia como checo exatamente se a versão do Sierra do Pendrive é mesmo a 10.12.3? Com tanta coisa agora já tenho minhas dúvidas.

Ok olhei lá e vou tentar como um cara fez e deu certo que foi:

 

just copy IONVMeFamily.kext from SIERRA to your CLOVER kext folder (EFI – CLOVER – kexts – Other) of your INSTALL SIERRA USBstick. Apply the patch to your CLOVER config.plist

 

Só que eu não sei como fazer essa última parte: "Apply the patch to your CLOVER config.plist"

Seria pelo Clover Configurator?

×
×
  • Create New...