Jump to content

Where is the kernel in a just created vanilla USB installer on yosemite


Go to solution Solved by heavymx,
9 posts in this topic

Recommended Posts

Hi.

 

I'm new in the forums, so if this topic already exist, I didn't find it.

It may be a dummy question, but I've been searching all around the web
for 2 days and I haven't found the right answer.

I think for this question I have tu use an example

IMPORTANT .. in the next example I DIDN'T USE ANY KIND OF BOOTLOADER

1.- In VMWare the new machine is created as mac, and nothing important to be modified

2.- the installer is created in an already existing (virtual) mac (may be a Niresh one)

3.- In the past .. I used to create an installer (VERY IMPORTANT - to be used in
VIRTUAL MACHINES, and AMD CPU
), let's say Mavericks installer. I created a new HD
(which was used as a USB stick), then I did the restore procedure to get the installer.
then the only thing to be replaced was the mach_kernel in root of the installer, so
I copied and replaced that kernel for the patched one. then I attached this HD (the installer)
to the new Virtual Machine and booted from the HD just created (the installer), and the

installer ran without issues. I installed the OS and the last step was boot from the installer

again, utilities -> terminal and go to replace the kernel in the root of the new created system.

and everything worked nice!!!

MY BIG QUESTION:
BUT .. in YOSEMITE and EL CAPITAN   --- I can't find where is the kernel in the installer
just created to be replaced for the patched one!!!

please take in account that I'm not using any kind of bootloader!!

 

I created the /System/Library/Kernels directory  (in the installer) and dropped the patched kernel

there, but didn't work  .. it seems like the installer reads the kernel from other source

I hope someone can help me.

 

My stuff:

OS: Linux (Kubuntu)

CPU: AMD Phenom II X4 955

GPU: Nvidia GTS 250

MB: ASUS m2n sli deluxe

RAM: 8GB

 

Thanks
Guillermo

hello

 

take a good read in amd sub forum

 

http://www.insanelymac.com/forum/topic/310098-el-capitan-install-preparation/

 

good hack

Hello!!

 

Thanks for your reply.

 

that method (your link the video) is exactly the one I use to build the USB. with the exception of enoch (Chameleon). because:

1.- IN VMWare when you create a mac (as is) it uses efi instead bios like a real mac.

2.- yes, chameleon can read the kernel from where it was dropped (/S/L/K)in the usb stick, but I'm not using chameleon!!

      because I want to use efi. although I know I can edit the VM to use BIOS insted efi and that way i can use chameleon,

      but I don't know if later after installation I could get back to efi.

3.- because I did it in my way  with mavericks, in other words vanilla, and I only replaced the kernel for the patched one in root (not bootloader, not chameleon,chimera or clover), and VMWare could boot without issue!!

 

so, my real question is where is read the kernel from on a vanilla USB without bootloader?

 

 

Well it's probably not possible since yosemite and el capitan.

 

but in maverick I could!!!

 

 

Many thanks artur_pt

The installer doesn't use the kernel as such. It reads it from the prelinkedkernel but for an AMD install you need the kernel in S/L/K for it to work. 

  • Like 1

Many thanks for your reply Shaneee.

 

So, based in your answer, is there  way to tell the (Yosemite or El Capitan) installer (without bootloader) to read the kernel from S/L/K?  ... I tried to edit the com.apple.boot.plist and I added the next lines:

 

<key>Kernel</key>

<string>System\ Library\ Kernels\ kernel</string>

 

Syntax as this manpage

 

But didn't work

 

I tried then:

<key>Kernel</key>

<string>/System/Library/Kernels/kernel</string>

 

but didn't work too

 

Or:

 

there is no option out there but with a bootloader using bios instead efi.

 

 

I tried clover efi, with S/L/K but  .. firmware exception.  .. didn't work.

 

many Thanks in adavnce.

 

Guillermo.

You can use Chameleon/Enoch to set it up with BIOS in VMWare then once it's done switch to EFI.

 

I don't know how else to do it. 

Many thanks Shaneee .. I'll try it .. I think it's my last option!!! .. I hope to get some success!!

You can use Chameleon/Enoch to set it up with BIOS in VMWare then once it's done switch to EFI.

 

I don't know how else to do it. 

Well, I found a way thanks to a guide that I found here in the forum for building a prelinked kernel  .. ..now I'm very tired, (I just got home from work), but I've just being able to make a booting installer for AMD without bootloader! (at least in my system (phenom) and vmware works)

 

I haven't installed the OS yet because of lack of time, but at least the installer boots in vmware 12.

 

I'll try to make the full installation on weekend. if everything goes fine, I'll post the full procedure.

 

Thanks shaneee for the tip of the prelinkedkernel.

  • Like 1
  • Solution

Well!!  I could make the AMD working installer for vmware (without bootloader) only for Yosemite.  it is based in this guide

But I couldn't get it for El Capitan!! I think is for the SIP issue.

 

Very Important: This post is focused for an installation for AMD processors in VMWare

 

The Only things you have to do different (in the guide above thanks fusion71au) is:

 

1.- build the installer in a Mavericks installation  <--------> see post #4 in the guide above (Blue letters) <---IMPORTANT

2.- in the step 5 don't extract the kernel from Essentials.pkg because you're going to use your

     patched kernel for AMD, and put it in /S/L/K in your USB .. (create the Kernels directory)

3.- in the step 6 is not necessary to delete the original prelinkedkernel because it's not created

4.- In my case in the step 7 (post #4) it was not necessary to drop any kexts in (Installer/S/L/E). I think it's because

     in VMWare the emulation is in a high percent like a real mac, or may be the patched kernel has the essential kexts built-in.

5.- step 9 is not necessary because you're not going to install any kind of bootloader.

 

Installer ready

 

It should boot in VMWare 12 (if you have your AMD working kernel for your hardware)

 

make your Installation.

 

 

 

Post Install:

 

After Installation boot again from your USB (or virtual installer (HD))

 

utilities>terminal

ls /Volumes

find the name of the volume you installed your Yosemite in (let's name it for this example "Yosemite" without quotes).

chmod -R 755 /Volumes/Yosemite/System/Library/Extensions
chown -R 0:0 /Volumes/Yosemite/System/Library/Extensions
touch /Volumes/Yosemite/System/Library/Extensions
kextcache -volume-root /Volumes/Yosemite -kernel /Volumes/Yosemite/System/Library/Kernels/kernel -prelinked-kernel /Volumes/Yosemite/System/Library/PrelinkedKernels/prelinkedkernel -l -n /Volumes/Yosemite/System/Library/Extensions

Probably the first 3 commands are not necessary because we didn't drop any kext in S/L/E   --- I'm not an expert so I did the all 4.

 

 

reboot.

Your installation must work.

 

 

Thanks

 

GC

  • Thanks 1
×
×
  • Create New...