Jump to content
Allan

[Guide] Asus Z97 Deluxe /i7 4790k/ GTX 980 - Upgraded

76 posts in this topic

Recommended Posts

Hello, i'll share my experience with Asus Z97 series. I build this Hack for video editing, and offered me a good performance and stability.

 

NewOS.png

 

The hardware specs:

  • EVGA  GTX980 4GB SC ACX2.0 DDR5 
  • ASUS Z97-Deluxe, w/ Wi-Fi and Bluetooth - With 2702 BIOS version
  • Intel Core i7-4790K
  • Corsair Vengeance 32GB DDR3 1600Mhz 4x8
  • CoolerMaster WaterCooler Seidon 120V RSA00-AFBAG1
  • SSD SanDisk 480GB - Model: G26
  • SSD Kingston HyperX Fury 240 GB

The pieces:

2.png

 

BIOS settings:

 

 

  • Boot section

 

Boot.png

Secure Boot Menu.png

CSM.png

  • USB section

USB Configuration.png

  • Storage

PHC Storage Configuration.png

 

 

For Install:

 

Create a Penboot of OS X El Capitan 10.11.0, and install Clover in UEFI mode. The process of install is the usual.

For install OS X and boot i just use 

-v nv_disable=1

Post-Install:

After entering in OS X, i've installed Clover in UEFI mode and upgrade OS X for 10.11.5 version using a Combo Update.

Keeping the boot-args.

 

Now you can download and install the last version of Nvidia Web Drivers, using NVIDIA Web Driver Updater.app

After that, change the boot args:

nvda_drv=1

Kexts that I've used:

Kexts.zip

 

About USB 3.0 recognition and speed.

 

I have the proper USB 3.0 recognition and speed, using only these methods.

 

DSDT patchs.

EHC1 to EH01

EHC2 to EH02

XHC was not necessary change it, this device comes with this way (name) natively.

 

I used the @Pjalm patches (Intel 9) and (USB Power).

 

Clover patches:

<dict>
<key>Comment</key>
<string>change 15 port limit to 30 in AppleUSBXHCIPCI</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g72M/v//EA==
</data>
<key>Name</key>
<string>AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g72M/v//Fg==
</data>
</dict>

Note: I made some tests with FakePCIID + FakePCIID_XHCIMux and USBInjectAll, but I got best results only using DSDT patches.

 

What works:

 

SpeedStep and Power Management - Ok

QE/CI - Ok

USB - Ok and in full speed  :w00t:

Trim for SSD - Ok

RAM Speed, just change XMP mode to 1 in BIOS and in your config.plist - Ok

Audio - (ALC1150) Ok I use AppleHDA Patcher for this

HDMI video - Ok

Onboard Bluetooth - Ok

Onboard WiFi - Ok

Ethernet Port - Ok partially 

Just 1 port works (I218V), 'cause the other port (I211) is not compatible with OS X. 

Sleep - Ok - Only via Power Button.

 

What don't work - per hour

HDMI audio

 

 

GeekBench results:

 

GeekBench.png

 

 

Novabench results:

 

Novabench.png

 

 

Cinebench results:

 

Cinebench.jpg

 

Big thanks to:

 

gengik84 - for all perfect help!  ^_^

artur-pt - for DSDT tips

toleda - for your patches

PJALM and RehabMan - for DSDT patches.

Mirone and Micky1979 - for AppleHDA patcher

Micky1979 and fantomas1 - for Web Drivers updater tool

Piker R. Alpha - for SSDT script

Clover guys - for Clover obviously  :P

 

My thoughts about this Hack: This Asus Z97 Deluxe edition offers a big compatibility with OS X. For works with hard production these hardware can bring to you a good experience and excellent performance.

 

If you really need HDMI audio will be a problem, 'cause in my case i can't find a solution yet. To replace this, use a good speakers.

I used a guitar sound box with a P10 to P2 converter.

Edited by Allan
Upgrade

Share this post


Link to post
Share on other sites
Advertisement

Guide upgraded for El Capitan.

Hello Allan,

 

I wanted to ask you a favor :

I have about your setup (view my signature running on macOS 10.12.1) but I have problems of stability :

 

- every time the mouse is jerky

- the system balks

- If I leave the computer stopped for 5 minutes when I return to work it seems to be unstable (I think a problem acpi)

 

everything else works well (Wifi, BT, Audio, Nvidia)

 

Can I ask the courtesy to check my DSDT.aml (view attachments under acpi/origin)?

 

thank you so much

 

PS: Installation made by me in vanilla mode

Asus Z97i Plus.zip

Share this post


Link to post
Share on other sites

:) V20.6

 

curl -o ~/ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/Beta/ssdtPRGen.sh

 

 

 

/ssdtPRGen.sh

 

ssdtPRGen.sh v0.9 Copyright © 2011-2012 by † RevoGirl

v6.6 Copyright © 2013 by † Jeroen

v21.1 Copyright © 2013-2016 by Pike R. Alpha

-----------------------------------------------------------

Bugs > https://github.com/Piker-Alpha/ssdtPRGen.sh/issues <

./ssdtPRGen.sh: line 3865: /Users/UltraLaser/Library/ssdtPRGen/Data/Versions.cfg: No such file or directory

 

System information: Mac OS X 10.12.1 (16B2555)

Brandstring: "Intel® Core i3-4330T CPU @ 3.00GHz"

 

Notice: Downloading extractACPITables.zip ...

Notice: Downloading User Defined.cfg ...

Notice: Downloading Sandy Bridge.cfg ...

Notice: Downloading Ivy Bridge.cfg ...

Notice: Downloading Haswell.cfg ...

Version: models.cfg v160 / Haswell.cfg v151

 

 

Scope (_PR_) {222 bytes} with ACPI Processor declarations found in DSDT (ACPI 1.0 compliant)

Notice: Downloading Restrictions.cfg ...

Generating ssdt.dsl for a 'iMac14,1' with board-id [Mac-removed]

Haswell Core i3-4330T processor [0x306C3] setup [0x0905]

With a maximum TDP of 35 Watt, as specified by Intel

Number logical CPU's: 4 (Core Frequency: 3000 MHz)

Number of Turbo States: 0

Number of P-States: 23 (800-3000 MHz)

Injected C-States for CPU0 (C1,C3,C6,C7)

Injected C-States for CPU1 (C1,C2,C3)

Notice: Downloading iasl.zip ...

 

Compiling: ssdt_pr.dsl

Intel ACPI Component Architecture

ASL Optimizing Compiler version 20140926-64 [Nov 6 2014]

Copyright © 2000 - 2014 Intel Corporation

 

ASL Input: /Users/UltraLaser/Library/ssdtPRGen/ssdt.dsl - 267 lines, 8226 bytes, 49 keywords

AML Output: /Users/UltraLaser/Library/ssdtPRGen/ssdt.aml - 1709 bytes, 16 named objects, 33 executable opcodes

 

Compilation complete. 0 Errors, 0 Warnings, 0 Remarks, 0 Optimizations

 

Do you want to copy /Users/UltraLaser/Library/ssdtPRGen/ssdt.aml to /Extra/ssdt.aml? (y/n)? n

Do you want to open ssdt.dsl (y/n)? n

 

 

 

Now i will try it!

Allan, thanks for ur support and apologizes for having polluted this thread

Share this post


Link to post
Share on other sites

Allan, thanks for ur support and apologizes for having polluted this thread

NP bro!

 

We are here for help and learn with other  ;)

Share this post


Link to post
Share on other sites

Post a pic here.

Hi Allan,

 

I can't take a pic, the screen turns off and restarts the pc.

 

But I resolved by updating the config.plist so:

 

- Add kext-dev-mode=1

- Add xcpm

- Add ClockID

- Remove in SMBIOS "Trust"

- ssdt generated with -target 2

 

I don't know why it works so flawlessly

Share this post


Link to post
Share on other sites

Hi Allan,

 

I want to try to do alone the dsdt.aml...

 

With MacIASL which patches should be included for our chipset? :

 

- Intel 9 -> Generic Fixes

- Intel 9 -> USB Power

- Intel 9 -> SMBUS

- Intel 9 -> SATA

 

In addition to these you will apply other?

Share this post


Link to post
Share on other sites

Do you think that this guide for El Capitan works well also for Sierra, sorry but in the web I didn't find any istallation guide for Sierra with Asus Z97 deluxe.

Many thanks in advice

Share this post


Link to post
Share on other sites

Hi Allan, sorry but I'm in trouble, coulkd you please send me your DSDT and config.plist files.

Many Thanks in advice.

Share this post


Link to post
Share on other sites

Hi Allan, please have a look to the DSDT that you have sent, if I open it with dsdt editor I receive an error message, I don-t know if this is normal of not.

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By SepehrM
      I'm trying to install High Sierra 10.13.3 on an ASUS N552VW laptop, and I get stuck after this message:
      "could not recover SATA HDD after 5 attempts, terminating" 
      And some other warnings afterwards.
      Specs:
      CPU: Intel Skylake 6700HQ 2.6GHz
      RAM: 16GB DDR4
      2TB HDD + 128GB SSD
      GPU: Intel HD Graphics 530 + Nvidia GTX960m
      I'm installing using a 16GB USB3 flash drive on one of HDD volumes (UEFI Mode)
       
      I uploaded the verbose log and clover config.plist
      config-new.plist

    • By JRevenge
      Ciao ragazzi,
      alla fine sono riuscito a risolvere il problema che riscontravo qualche mese fa, dopo l'ottima EFI sistemata da @gengik84 e l'ho risolto rimuovendo dart=0 che creava kernel panic e problemi quando la batteria scendeva sotto ad un livello di batteria basso. Adesso il sistema non crea più problemi di kernel panic, ma volevo chiedervi se allo stato attuale secondo voi c'è qualcos'altro da ottimizzare.
       
      Vi allego la EFI.
       
      Grazie anticipatamente.
      CLOVER.zip
    • By TheAngryYeti
      So after a gazillion tries with High Sierra, i gave up and decided to try Mojave. I had nothing to lose, afterall.
       
      I started from scratch. I reformatted my thumb drive. Made it bootable from the Mojave [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]. Booted with it. Selected my language. It installed a little bit. Rebooted. I Booted from the SSD. Installed a bit more. Rebooted. I Booted from the SSD again and it finished the installation.
       
      I went through the basic setup and got to the desktop. I ran [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] and selected my options and "built" it.
       
      Thinking i was a-ok, i decided to reboot, just to make sure all was well.
       
      After about 1min, i lose display.
       
      I thought i had messed something up in [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], so i decided to go back to my mac mini, redo the thumb drive all over again.
       
      I go to boot from the thumb drive and when i get to the language selection screen, i lose all USB usage, so i cant even get in to wipe the SSD and start over. So, Mojave is still on the SSD, but i cant get to it because i lose display.
       
      Im attaching a screenshot of Verbose mode right before i lose display.
       
      I would greatly appreciate any help to get back into it or at least help getting it re-installed!!
       
      -Sin

    • By TheAngryYeti
      First, my build:
       
      Asus ROG Strix H370-I mobo
      i5 8400 cpu
      32gb ddr 4 2133
      1tb samsung evo 860 ssd
       
      Ive finally gotten to the point where the installation of HS loads to the language selection screen, but then i lose all usage of every USB port.
       
      Im at a loss of what to do from here.
       
      According to others, i have the proper files in the kexts/other folder as well as the drivers64UEFI folder.
       
      Does anyone have any suggestions as to what i can do? Im getting kinda desperate as ive been at it for a week now and this is as far as ive gotten.
       
      -Sin
       
       
    • By TheAngryYeti
      So I FINALLY got my High Sierra thumb drive to boot and once I got to the language selection screen, I noticed I lost all connectivity to my keyboard and mouse.
       
      i tried plugging in both into all of my USB ports (2.0, 3.0, 3.1) to no avail.
       
      i made sure I had the latest USBInject kext and XHCI-Unsupported kext in the Other folder.
       
      i also noticed whilst troubleshooting, the thumb drive will ONLY boot using Verbose and plugged into one of the 2 3.1 ports.
       
      does anyone have ANY suggestions?? I’ve been struggling for a week now on this!!
       
      thanks in advance
       
      -Sin
       
      Build: Asus ROG Strix H370-I, i5 8400, 32Gb ddr 4 2133, 1Tb Samsung EVO 860 ssd
×