Jump to content

Trouble Installing AMD Kernel


5 posts in this topic

Recommended Posts

Hello, so since the last time I posted I've had a bit of luck and happened to find an old iMac in the dumpster at my job. I took it home, repaired it and now I have a legitimate means of getting a fresh copy of OS X! With that in mind, I've ditched the Niresh distro because no matter how many different things I tried I could NEVER get my graphics card to work properly. So I'm back at it trying to make a clean installer with the bare minimum to get me through, so far it's been going pretty good except one thing...the kernel. I honestly don't know where or how to install it onto the boot drive. I've looked around on these forums, on other forums(including Reddit >.>), etc. and I can't seem to find the answer that I'm looking for. My first attempt I just dragged/dropped into the USB drive after installing Clover, that obviously didn't work. I also renamed it to "mach_kernel" which didn't do anything either, lastly I tried installing it in a few places that I thought might be more likely such as the EFI drive. Am I missing something? Overthinking it? I'm at a loss. I'll break down my steps for creating the installer, hopefully someone can help me push through to the next step.

 

 

----------------------------------------------------------

 

 

My Specs:

 

AMD FX 8350

 

Asus M5A97 R2.0 Motherboard

 

MSI R9 290 Twin Frozr

 

4X4GB AMD R9 Gaming RAM @ 2133Mhz

 

Corsair 850W Gold Cert. PSU

 

Installing on a 2.5" spare laptop drive

 

 

-----------------------------------------------------------

 

 

Here's my method of creating the installer:

 

Step 1: Download the Install OS X Yosemite.app installer

 

Step 2: Run Terminal, type in this command:

 

"sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction"

 

Step 3: Once it finishes installing, I restart the iMac to complete any necessary changes

 

Step 4: Open and install the latest revision of Clover to the drive

 

Step 5: Restart the iMac again

 

Step 6: Place FakeSMC and NullCPUPowerManagement kexts into the 10.10 folder inside the USB installer

 

Step 7: Place the AMD kernel for 10.10.5 in the USB installer

 

Step 8: Create a config.plist file with Clover configurator on the iMac to match what I've needed to boot previously and place inside the EFI partition of the USB installer

 

Step 9: Remove the drive, attempt install on PC.

 

 

-----------------------------------------------------------

 

 

Some additional notes:

 

- The kernel I'm using is an AMD 10.10.5 kernel by Deepak, not sure if the OS X version I have is 10.10.5 since it won't tell me in the App Store when I load it, not sure if this is an issue or not

 

- The kexts were also provided by Deepak on his website on getting El Capitan to work

 

- I have installed Clover for UEFI boot, which my system is perfectly capable of, however I'm wondering if it might be a part of the problem

 

- When I actually boot the USB drive, it starts up for several seconds in verbose mode and then powers down my computer completely, restoring power a couple of seconds later.

 

 

I've been at this since April trying to get a working install of Mavericks and Yosemite, both unsuccessfully, so thanks in advance for any and all help, it's definitely appreciated!

You're make probably a few thoughts error.

1. Here is the link where you can find all runnable AMD kernel for AMD hackintosh:  http://www.insanelymac.com/forum/topic/285580-database-of-current-working-amd-kernels/page-4

 

2. the kernel for Yosemite belongs in to folder /System/Library/kernels/ (if the folder should not exist, so create the folder and add the matching kernel into the folder.

    (for Mavericks must be installed the mach_kernel into the main directory (root))

 

3. To resolve the problem with your graphics card look here: http://www.insanelymac.com/forum/forum/174-ati/

 

4. replaced by this package, the existing drivers in S/L/E http://www.insanelymac.com/forum/files/file/354-amd-replace-kext-for-yosemite/   then fix the permissions and renew the cache

 

otherwise look here for running AMD hackintosh, some users have also made a description: http://www.insanelymac.com/forum/topic/285110-amd-working-builds/page-13?do=findComment&comment=2167036

  • Like 1

 

"sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction"

 

There is you'r problem. El Capitan will not work on AMD with the Yosemite kernel. Wait untill the El Capitan kernel sources are released and a kernel is made.

  • Like 1

Thanks for both your guys help!

 

@Spakk I knew it was going to be something dumb like that DX I can't believe I didn't think of creating a folder for the kernel...Ill try your suggestions and see if I can get it to boot tonight.

 

@Shaneee I made that mistake when I first tried to make an installer because I'm dumb, thankfully I didn't have an El Capitan installer so the Terminal command didn't go through when I tried it XD I just deleted the parts where it says El\ Capitan.app and replaced it with Yosemite, no El\ of course.

 

I'll post my success...or failure, as soon as I can, thanks for the help!

So I tried your recommendations for the kernel as well as the keys and it seems that did not work. I probably should've tried to snap a picture of this before and troubleshoot from there but it was always a little too fast for me to take a snapshot. However, with a little bit of research it seems it could be one of the following: either I need different boot flags to do certain things like PCIRootUID and USBBusFix, or the kernel I am using isn't the right one or is corrupt. I hope is not the case and that I have to keep trying different kernels...I will keep trying different boot flags before I start testing different kernels from the download page Spakk provided.


Some additional notes I've come up with are as follows:

- My graphics card is not natively supported in OS X, not by a long shot. The 290 non-X version seems to be the least supported graphics card in the whole lineup of AMD cards, which could ultimately be a huge road block, and the fact that I got the Niresh distro to even partially work might be nothing short of a miracle. With all that being said, this could be the source of my problem or not even close to it, I have no idea still *scratches head*

- I've been installing the suggested kexts in the Clover EFI partition under the kexts/10.10 folder, am I supposed to be installing them there to boot? In the actual Install OS X Yosemite.app? Or perhaps do I need to make another folder in one of the partitions?


For now I'll be testing the boot flags and such to see if I can get any new results, in the meanwhile if anyone has any suggestions I'm all ears! And thank you in advance as always, any help is appreciated.

 

 

 

EDIT: Sorry my picture didn't post for some reason, here's an imgur link to check it out: http://imgur.com/70sOLLx

×
×
  • Create New...