Jump to content

Search the Community: Showing results for tags 'Kernel'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • InsanelyMac Lounge
    • Front Page News and Rumors
    • Reader News and Reviews
    • Forum Information and Feedback
  • OSx86 Project
    • New Releases and Updates
    • New Users Lounge
    • Developers Corner
    • Tutorials (The Genius Bar)
    • Technical FAQ
    • OSx86 Installation
    • Post-Installation
    • DSDT
    • Hardware Components and Drivers
    • Complete Desktops
    • Notebooks
    • Netbooks
    • Tablets
    • MacMod of the Month
    • Multi-booting and Virtualisation
  • International
    • Your Language
    • Deutsch
    • Español
    • Français
    • Italiano
    • Português
    • Русский
  • Apple World
    • Mac OS X
    • Apple Computers and Hardware
    • iOS Devices
    • Mac Applications
    • Mac Programming and Development
    • iOS Programming and Development
    • Mac Gaming
    • Mac Accessories
  • Discuss and Learn
    • Windows Discussion
    • *nix
    • Apple Opinions and Discussion
    • The Great Debates
    • Internet(s), Servers, and Networks
    • Buying Thoughts, Reviews, and Recommendations
    • Mods and Overclocking
    • The Big Issues [Real Life]
  • Everything Else
    • Creativity
    • Thunderdome (Random Stuff)
    • Laughs
    • The Marketplace

Categories

  • Kexts
    • Graphics Cards
    • Audio
    • LAN and Wireless
    • Other
  • Kernels
  • Bootloaders
  • DSDTs
    • Patches
  • Pandora
  • Apps
  • Miscellaneous
  • Customization

Categories

  • OSx86
  • Apple News

Found 123 results

  1. Hello everyone, Greetings from Brazil! I'm getting a kernel panic at the macOS High Sierra install process. Any ideas on what could be happening? Please refer to attached pictures. Thank you very much for your time and help. I really appreciate it. Motherboard Gigabyte G41MT-S2P F3 CPU Intel Core 2 Duo 2.6 GHz 8 Gb of RAM Video Zotac GeForce 9500GT 1 Gb jcrcarmo
  2. I recently got an Asus X55U laptop with the following specs: AMD Brazos C-60 1Ghz CPU 4GB DDR3 120GB HDD AMD HD 6290 Graphics. I am trying to use the Sierra 10.12.5 raw file from the Olarila forum. I understand that I need to change the kernel on the installer USB to one that supports AMD processors, but I am not sure which kernel to use or how to replace it. If anyone can help me with this I would appreciate it. Thanks. EDIT: Also when I try to use the Sierra Zone distro with the included AMD kernel, I get Error loading kernel cache (0x9) when trying to boot into the installer. EDIT 2: Nevermind this post. I just read that your CPU needs SSE4.1 to run Sierra and the C-60 only had SSE4A. I'll try an older version and make a new post if necessary.
  3. I've recently acquired a kernel that Bronya has been developing and I had wished to test it out on my system. I assumed the process of updating the kernel would follow the steps outlined here So I booted via USB into my macOS, deleted the existing kernel at macOS/System/Library/Kernels and replaced with the new kernel file, then deleted the existing PrelinkedKernels file too. Next I ran Kext Utility, and when it finished I rebooted. Upon booting into macOS again via clover on the drive, I ran Kext Utility again, just to be safe. Now, however, I no longer have any sound devices once booted and I am experiencing very long boot times, noting "kextd wait appleacpicpu" at the end of boot (see attached screenshot) Did I actually update the kernel correctly? Did I miss a step, or screw something up along the way? Thanks
  4. BEFORE TRYING THIS, DO THE OBVIOUS SOLUTION! REPLACE YOUR OPTIOFIX EFI FILE WITH VERSION 2, OR WITH VERSION 1. ONLY PROCEED IF DOING THIS DOES NOT WORK. Alright, so my first attempt at helping people that isn’t in a private discord. Hope this goes well. No one has posted this as a direct solution to someone asking for help with this error, so I thought I’d be the one to share it.

 I encountered this problem when I rebooted after making some minor changes and discovered I couldn’t boot back into the disk. All over the web, people keep suggesting clover-side tweaks and replacing kexts, and while they may solve the problem for some, absolutely nothing was working for me (and a few others), even when booting with no kernel cache at all. No boot flags worked, no .efi files would solve it. 

Holding spacebar in clover, no change. So, the solution ended up being system side, and not clover related. You needed to delete your prelinked kernel from the HDD and rebuild it. 

To do this, you just have to be able to get to your recovery drive or use an install USB that’ll give you access to the disk. Clover got me into my recovery drive just fine, another hint that it wasn’t related to clover - but regardless, whatever works for you. After you’re in a terminal, type the following commands.

 Df -h This will list all of your volumes, make sure you’re targeting your installation drive.

 If your volume has a space in the name, such as "Mac OS HS", you'll need to format it as such: "Mac\ OS\ HS" - This is simply how the command line associates spaces. touch /Volumes/[NAME HERE]/System/Library/Extensions && kextcache -u /Volumes/[NAME HERE]

 In my case, I replaced [NAME HERE] with my installation drive - "macOS\ 10.13". Chances are, this command will give you the error "Child process [directory] has exited due to signal 10" The line immediately after that will give you another bit of extremely important information that you need to take note of. "Error 107 rebuilding /System/Library/PrelinkedKernels/prelinkedkernel" That directory is what we're going to be targeting to fix our system. So, time to nuke it. rm -rf [location to /prelinkedkernel/prelinkedkernel] MAKE SURE YOU DOUBLE CHECK IT IS EXACTLY WHAT WAS OUTPUT WHEN YOU TRIED THE COMMAND ABOVE.

 IMPORTANT: YOU MAY RECEIVE A READ ONLY ERROR! DO NOT PANIC. I've done this on multiple machines and it really is hit or miss whether or not this will appear. Regardless, the solution is simple. The following code tag only applies to if you encounter this issue. Fsck mount -uw / RE-ENTER THE FOLLOWING COMMAND! You need a more specific location now. rm -rf /Volumes/[NAME]/System/Library/PrelinkedKernels/prelinkedkernel touch /Volumes/[NAME]/System/Library/Extensions && kextcache -u /Volumes/[Name] Now you should be receiving "/Volumes/[NAME] locked; waiting for lock." This is a good thing. Wait a few seconds, you'll receive "Lock acquired; proceeding." After that, you'll be back at -bash-3.2#, and it will appear as if nothing happened. Again, this is expected. For people who didn't have to use the Fsck command, simply type the following and receive the usual "Waiting for lock; Lock received" response. touch /Volumes/[NAMEHERE]/System/Library/Extensions && kextcache -u /Volumes/[NAME HERE] Now, use your up arrow on the keyboard to re-enter this command. If nothing happens, you're golden. If it detects kexts with invalid signatures, that's still okay - but for future reference, don't go the ##### approach/philosophy of installing kexts to your system drive. Take this as a warning. Go ahead and reboot, and start your installation just like normal. You'll now get past the 0x1 error. Congratulations! If you get hung up anywhere, go back to clover and add “-f” to the boot flags, then boot again. You should make it back to your desktop with no damage whatsoever.

 Like nothing ever happened! Now, as for what causes this, I honestly have no idea. All I know is when you have a working system, make some kind of modication/tweak/installation that HS doesn't agree with, you can possibly get this error on some systems. It's rare, but exists, and unfortunately this is the only way I've been able to get past it. It's not too much work, so don't be too intimidated. You'll have your system back in no time. If you'd like some personalized 1-on-1 support, read my signature and contact me that way. I'm more than happy to help, or at the very least take some time out of my day to analyze your issue and give my thoughts. Thanks for reading my first guide, I'm hoping to publish some more fixes to make High Sierra as painless as possible for every user.
  5. Hello everyone, I've been trying to install sierra in my new external HD and I'm stuck with this screen. I read here a guy change from -v to -x and worked, so I did it and I got the apple. Before changing it I was stuck with the same result but without the apple. Thanks in advance!
  6. Hello, can someone help me figuring this kernel panic out ? I just installed Mac OS Sierra with Clover UEFI bootloader but upon rebooting my pc, this happened while trying to start Sierra. Can someone help me ? My hardware specs: 1 x HDD Caviar Blue 500 GB 1 x Nvidia GT 730 (4GB - HDMI) 1 x 8 GB RAM 1 x Intel Core i3 (2100) - Graphics Onboard (Not connected): Intel HD 2000 PS/2 Mouse and Keyboard I attached the kernel panic error message below. Thank you in advance.
  7. System Configuration: Processor: AMD FX 8320 MB: M5A97 R2.0 GPU: RX 470 4GB I get the system to boot into osx sucessfully with "kernel=kernel.amd npci=0x3000 USBBusFix=Yes -f." Keyboard and Mouse refuse to funtion. I have put the usb fixes in for sierra and the kernel to make it function. Ive put IOMMU to yes and to 64bit, disabled uefi due to boot issues.
  8. Hi guys..I sucessfully installed Sierra 10.12.5 & Windows as a DualBoot..Im interested in trying macOS High Sierra..Im using an AMD FX 8320 Processor..Do we know when the beta kernel will come out ?
  9. EDIT: See post #3 for still waiting for root device issue! I have a HP Pavilion 15-p051us with an A10-5745M APU ( https://support.hp.com/us-en/document/c04346410 ).I created a USB installer for Sierra 10.12.5 using Pandora's Box and installed Enoch (I have a second USB drive with clover on it as well.) I copied the 10.12.4 kernel (I do not know of a 10.12.5 AMD kernel and the 10.12.4 has been reported to work) to /System/Library/Kernels and repaired permissions/rebuilt cache (This is the kernel: http://www.insanelymac.com/forum/topic/312714-amd-macos-1012x-sierra-kernel-testing-release-for-help-use-the-help-topic/page-31?p=2399141&do=findComment&comment=2399141 ). When booting with -v with Enoch I get the following error repeatedly. OPEMU: movzx ecx, byte [raw+0x16] warning: invalid kernel ip, won't attempt to handle trap When booting with my clover USB Drive with -v I get the line of pluses and then it auto reboots. Any ideas on what my problem is and how to fix it?
  10. Hey Guys i've tried to install Sierra on a computer that already has Yosemite on it , But when i tried to boot the installer i get this kernel panic . The reason why i'm trying to install sierra is that i have a GTX 1050 , and the Pascal web drivers are only For Sierra . Help Please . Specs : CPU : i5 3330 3 GHZ GPU : MSI Geforce GTX 1050 RAM : 8GO 1333 MHZ MB : ECS H61-H2 M6 UEFI BIOS
  11. Hi all, I've been searching long and hard for 2 days straight trying to install Hackintosh to my system. I've found many kernels but none that I've tried seem to work. My specs are AMD Phenom II X4 965 3.41 GHz, 12GB ram, NVIDIA Geforce GTX560, and a 1tb HDD. My only request for whoever is reading this id to help me locate/build a kernel for my system. Preferably, I would like 10.12, 10.11, or at the very least 10.10 (nothing less) for my MacOS. I am sort of a noob but I know basic terms and applications commonly used while Hackintoshing. Any help/suggestions would be appreciated. Thanks, Seth
  12. Hi guys, I ask to the developers of this community, I'm am developing a kext for a pci device for Mac OS and I want to add custom boot args to it to enable a diagnostic mode (it just defines a particular macro when the boot arg is detected) or to add other stuff in the future, can you help me? I'd like to add a boot arg that I want to call -kx_diagnose
  13. Hello everyone, I had sierra os running nice and clean (still needed some work to get wifi to work) and I decided to install windows into a second partition in the same hard drive. I used the official microsoft media creator to make a bootable usb and, even though the install failed, it still managed to mess up my sierra installation. Now, when I select macOS Sierra in clover it will give me a Kernel Panic: Please help
  14. Ciao a tutti, ho assemblato il mio mini Mac (hardware in firma) da qualche settimana ma sempre più frequentemente ho un kp all'avvio e dopo alcuni riavvii la macchina parte e rimane affidabile e efficente per il 99% delle volte. Vi riporto di seguito il resoconto del problema che si verifica, riscontrando che l'origine pare sia dovuta a airportd. Premetto che la scheda pci-e bcm94352hmb funziona perfettamente, almeno una volta avviata la macchina. Grazie anticipatamente a chi vorrà darmi una mano!
  15. Hello, Im trying to install macOS Sierra on a Virtual Machine using VMware on my AMD desktop, however there is no current support for such a machine using those prebuilt virtual disks that are all over the Internet. But i looked up and find that Bronya made a kernel patch for AMD processors(Still in beta), does anyone know how can i use this patched kernel on a Virtual machine? Patched Kernels for Sierra: http://wiki.osx86project.org/wiki/index.php/Patched_Kernels#macOS_10.12_Sierra Thanks!
  16. In the installer, where is the location of the kernel. I have looked in / and /System/Library but there isn't even a Kernels folder. Also can I get it to work with Chameleon if not what other bootloader can I use. Please avoid giving Clover. Thanks in advance....
  17. Hi everyone, I have 3 working OS X's on my ASUS Z10PE-D8 WS Dual Xeon build. That is: ElCapitan & Sierra (both working flawlessly apart from audio, but HDA works, so thats fine) and now recently I installed Yosemite (bit laggy and sometimes hangs during boot with an IOUSBFamily error of BUS 14 already in use??). All three work with Clover however, which is great as they're all on a single drive. The reason I installed Yosemite is because I bought a fusionIO card, for which the driver support stopped at Yosemite. In ElCapitan I get unresolved symbols/dependencies errors and the driver wouldn't load. I (and even SanDisk themselves) don't know if they will be supporting ElCapitan and later OS's, which is annoying. I know source code is available from SanDisk but I am not sure how much the source code needs changing before it can be recompiled for the 15.0 Darwin/XNU Kernel if this is at all possible? I am by no means a rootkit developer, so I wouldn't know if this is even a feasible route/starting point? If this is somehow possible it would mean I can ditch Yosemite again, which would be great as it runs laggy and Ethernet seems to be recognised but doesn't connect with self-assigned IP, so would be better if I could make it work on my smooth OS's (i.e. ElCapitan and later). If the above is too complicated or not possible at all without putting in some serious work and having an advanced techy brain...Is there a way to make it work on Yosemite? Do I need to come up with a custom injector kext and use FakePCIID to get the card recognised properly? Any help with this would be much appreciated. Thanks guys! And thanks for this great Forum!
  18. Since I installed Sierra I have the following problem: When I had the screen locked (I do not hibernate) for a while the whole OS freezes for a few seconds. I can move the mouse and click things but I do not get any visual feedback. Then after a while I get the feedback all at once. So things are happening but the drawing stalls. When I look into dmesg I see that the graphic card has some problems: This is just an excerpt. There are thousands of these messages in the kernel message buffer. I attached whole log (I did changed the size of the buffer so they wont get overwritten). Got a GTX660Ti with stock driver. dmesg.txt.zip
  19. After two days without a hickup, i had to reboot 3 times to get into my OS. After the 1st attempt it shut down when booting into El Cap, then rebooted again and after Clover it gave me the "Your Computer shut down because of a problem" msg. After two more attempts i managed to get into El Cap and it gave me a msg: You shut down your computer, would you like to reopen he prg. you used last?" I also got a crashreport, but i'm not knowing where to look for the error/problem, so i hope maybe someone is so kind and able to tell me what i have to look for. CrashReport.txt config.txt
  20. Hi. I'm new in the forums, so if this topic already exist, I didn't find it. It may be a dummy question, but I've been searching all around the web for 2 days and I haven't found the right answer. I think for this question I have tu use an example IMPORTANT .. in the next example I DIDN'T USE ANY KIND OF BOOTLOADER 1.- In VMWare the new machine is created as mac, and nothing important to be modified 2.- the installer is created in an already existing (virtual) mac (may be a Niresh one) 3.- In the past .. I used to create an installer (VERY IMPORTANT - to be used in VIRTUAL MACHINES, and AMD CPU), let's say Mavericks installer. I created a new HD (which was used as a USB stick), then I did the restore procedure to get the installer. then the only thing to be replaced was the mach_kernel in root of the installer, so I copied and replaced that kernel for the patched one. then I attached this HD (the installer) to the new Virtual Machine and booted from the HD just created (the installer), and the installer ran without issues. I installed the OS and the last step was boot from the installer again, utilities -> terminal and go to replace the kernel in the root of the new created system. and everything worked nice!!! MY BIG QUESTION: BUT .. in YOSEMITE and EL CAPITAN --- I can't find where is the kernel in the installer just created to be replaced for the patched one!!! please take in account that I'm not using any kind of bootloader!! I created the /System/Library/Kernels directory (in the installer) and dropped the patched kernel there, but didn't work .. it seems like the installer reads the kernel from other source I hope someone can help me. My stuff: OS: Linux (Kubuntu) CPU: AMD Phenom II X4 955 GPU: Nvidia GTS 250 MB: ASUS m2n sli deluxe RAM: 8GB Thanks Guillermo
  21. This thread is aimed at developers and people who are willing to help with the AMD kernel specifically the FX problems. Here are two diff files from my kernels in an attempt to get FX working as it should. I am no developer so I'm hoping someone can help us. If you've made a kernel different from these sources please share your diff too so it can help us. Note that this topic is not for testing but discussing the source itself. For FX testing visit here, http://www.insanelymac.com/forum/topic/310796-amd-os-x-el-capitan-1011-fx-kernel-task-force/ Shaneee-diff.zip xnu-3248.20.55-legacy-v4.diff.zip To build the kernel you will need xCode installed which is available from the App Store. Once installed perform the following commands to install the dependencies, curl -O https://opensource.apple.com/tarballs/dtrace/dtrace-168.tar.gz curl -O http://opensource.apple.com/tarballs/AvailabilityVersions/AvailabilityVersions-22.40.2.tar.gz tar zxf dtrace-168.tar.gz cd dtrace-168 mkdir -p obj sym dst xcodebuild install -target ctfconvert -target ctfdump -target ctfmerge ARCHS="x86_64" SRCROOT=$PWD OBJROOT=$PWD/obj SYMROOT=$PWD/sym DSTROOT=$PWD/dst sudo ditto $PWD/dst/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain cd .. tar zxf AvailabilityVersions-22.40.2.tar.gz cd AvailabilityVersions-22.40.2 mkdir -p dst make install SRCROOT=$PWD DSTROOT=$PWD/dst sudo ditto $PWD/dst/usr/local `xcrun -sdk macosx -show-sdk-path`/usr/local Now you can download the kernels source from here, http://opensource.apple.com/tarballs/xnu/xnu-3248.60.10.tar.gz Copy to your desktop or chosen folder and extract then in terminal type "cd " without the quotes and with the space and drag the extracted folder onto window and press enter. Now to apply a diff patch use the following, patch -p1 < /Path/To/Diff/File Replace /Path/To/Diff/File by dragging the diff file onto the terminal window. Then you can edit the source within the xnu-3248.60.10 folder as you wish and to build the kernel enter the following, make SDKROOT=macosx ARCH_CONFIGS=X86_64 KERNEL_CONFIGS=RELEASE install Once complete the Kernel and matching System.Kext are found in xnu-3248.60.10/BUILD/dst/System/Library. You can ignore the Frameworks.
  22. Won't boot.

    After I updated to 10.6.8, I was unable to boot properly. I booted my machine in verbose mode, and this showed up. I used the boot flags PCIRootUID=1, npci=0x3000 and GraphicsEnabler=Yes.
  23. Version

    2,373 downloads

    This is a patched version of an official vanilla kernel from El Capitan 10.11.0, allowing Z87 Haswell motherboards capable of booting without reboot loops or kernel panics. The following perl scripts have been applied to the vanilla kernel for 10.11.0: #1 perl -pi -e 's|\xe2\x00\x00\x00\x02\x00\x00\x00|\x00\x00\x00\x00\x02\x00\x00\x00|g' kernel #2 perl -pi -e 's|\xe2\x00\x00\x00\x4c\x00\x00\x00|\x00\x00\x00\x00\x4c\x00\x00\x00|g' kernel #3 perl -pi -e 's|\xe2\x00\x00\x00\x90\x01\x00\x00|\x00\x00\x00\x00\x90\x01\x00\x00|g' kernel I take no credit for the creation of the perl scripts used. Patches #1, #2, and #3 have been documented on this blog by the original owner here. Shout outs to Pike R. Alpha whose code the patches are based on, he lives here. Tested on EVGA Z87 FTW Please let me know if it works well for you so I can confirm the amount of success users are having. Thanks
  24. I'm really a noob to this, so forgive me if I ask stupid questions. I really think I just need guidance that I'm heading in the right direction. I used Fuision71au's guide along with some others on the internet to get a Virtualbox VM up and running and imessage working using clover. I'd like to run this on more of my pc's including some AMD FX based ones. My thought was that I could boot the VM on intel, make the changes necessary for AMD and then copy it over to the AMD machine. My understanding is that I need to swap the kernel out for the AMD kernel. I have the kernel and I know it goes into /System/Library/Kernels. 1. I can't just copy the kernel in, because it tells me that the operation is not permitted. I've tried using csrutil disable booted into recovery but it doesn't stick. I'm not sure why. It reverts to enabled after reboot. Is there another way to get the Kernel copied over to /System/Library/Kernels ? 2. Assuming I can get the kernel copied over I believe I need to make some changes to config.plist. I've found this post but honestly, I'm not sure what these do. I'd like to understand what needs to be in config.plist in order to get the AMD kernel to work properly. Is there a good guide to what the AMD kernel options and requirements are? Am I on the right track? Is there any knowledge or guideance or silver bullet you could tell me to get this working? Any assistance is appreciated.
  25. Hi guys! I'm trying to get El Capitan working on my new laptop, which is: ASUS Zenbook UX303UB. Processor: Intel core i5 6200U. Got 2x4 Gbyte of RAM (2 slots according to AIDA64). I made a boot-up USB from Windows running El Capitan in a virtual desktop successfully. Now at bootup I get the following panic error after Clover: panic(cpu 0 caller 0xffffff801e9213c6): "zone_init": kmem_suballoc failed "@/Library/Caches/com.apple.xbs/sources/xnu/xnu-3248.30.4/osfmk/kern/zalloc.c:2284" After some research, I tried to add this to my config.plist, with no success: <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <string>2</string> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>1</integer> <key>Size</key> <integer>4096</integer> <key>Frequency</key> <integer>1600</integer> <string>DDR3</string> </dict> <dict> <key>Slot</key> <integer>2</integer> <key>Size</key> <integer>4096</integer> <key>Frequency</key> <integer>1600</integer> <string>DDR3</string> </dict> </array> </dict> Has anyone encountered this error? How could I get to the installer screen? Thanks for any help!
×