Jump to content
sergiy.gagarin

Checkered B&W screen after L5430 Xeon LGA771 install. Any ideas?

6 posts in this topic

Recommended Posts

Guys, I am trying to upgrade old LGA775 P5Q board with new processor.
It is Xeon L5430 with adapter. It is working perfectly under Windows since I've updated microcodes in BIOS. Bios I am using is so called 5th Year anniversary mode BIOS.

 

Dual core E4400 is absolutely fine with the setup. So far i don't have problems with running it on Clover 10.10(tweaked) or 10.11(vanilla config with only latest FakeSMC) on e4400 but Xeon gives me checkered screen after initial apple on black loading screen on both installs. Black has fuzzy RGB dots.

 

Any ideas what this can be or how to troubleshoot that? Thank you.

post-252675-0-53764100-1446112405_thumb.jpg

post-252675-0-31957000-1446112444_thumb.jpg

post-252675-0-65176000-1446112487_thumb.jpg

Share this post


Link to post
Share on other sites
Advertisement

Seems like I have fixed it with the guide https://zhaomin.me/core_to_xeon.html

Guide was like except I've omitted first two steps since I had working setup I did it on.
Note for Quad Core you should put 3 (yes, it is No of Cores minus 1smile_osx.png

Now testing. IF it will fail I will do follow up.
Speedster is working for sure& Cant say about C and P states since never was trying to understand them but it is not panicing with them enabled in BIOS. Sleep is working but restarts on wakeup.
 

GUIDE

  • Add cpus=1 pciroot=1 tscsync and npci=0x2000 (based on motherboard spec.) boot-args.
  • Get into dektop without GPU driver.
  • Google and download VoodooTSCSync.kext.
  • Edit VoodooTSCSync.kext/Contents/Info.plist, change the value of IOCPUNumber to x (x=CPU threads-1).
  • Change boot-args to npci=0x2000 pciroot=1.
  • Rebuild kext cache and Reboot.

Share this post


Link to post
Share on other sites

 

Seems like I have fixed it with the guide https://zhaomin.me/core_to_xeon.html

Guide was like except I've omitted first two steps since I had working setup I did it on.

Note for Quad Core you should put 3 (yes, it is No of Cores minus 1smile_osx.png

 

Now testing. IF it will fail I will do follow up.

Speedster is working for sure& Cant say about C and P states since never was trying to understand them but it is not panicing with them enabled in BIOS. Sleep is working but restarts on wakeup.

 

GUIDE

  • Add cpus=1 pciroot=1 tscsync and npci=0x2000 (based on motherboard spec.) boot-args.
  • Get into dektop without GPU driver.
  • Google and download VoodooTSCSync.kext.
  • Edit VoodooTSCSync.kext/Contents/Info.plist, change the value of IOCPUNumber to x (x=CPU threads-1).
  • Change boot-args to npci=0x2000 pciroot=1.
  • Rebuild kext cache and Reboot.

 

Sir, you are a genius! I love you! I've spent countless hours to figure this out.

 

I finally got my EP35-DS3R with 771 xeon to boot.

 

One last problem, when waking from sleep the computer reboots. Have you had this issue?

Share this post


Link to post
Share on other sites

Hello, I also have a modified socket 775 board and a Xeon E5450 with a Radeon HD4870. I entered 0x0106D0 in Clover's FakeCPUID, now I don't even get the 'this is an unknown CPU 0x3a' error. However, the system won't go to sleep. I tested various darkwake modes. in the most the screen goes black, but everything stays on and after a movement or key press it is back again. Another variation is that the system goes to sleep, except the graphics card, or at least the fan. The system also don't want to wake up, I have to hard-reset. The card is recognized as ID 9440, RV770 Chip 'Wekiva'. The temperature sensor is displayed in HWMonitor, stays around 60°C or more.

Share this post


Link to post
Share on other sites

Boot flag "tscsync" is obligatory, must have it? If I have use other boot option npci=0x200 and VoodooTSCSync.kext with IOCPUNumber = 3.  I have cpu xeon E5410 (4 core & 4 threads).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By NikTheNoob
      Hi,
       
      I'm rather new to Hackintosh and trying my first build with OpenCore on AMD, but I run into issues causing OpenCore to crash before even loading the macOS installer. As I'm not sure which one is causing the crash, I'm trying to resolve all of them and one of the error messages has to do with WhateverGreen, which I was able to see in this slow-mo loading video. Basically I'm getting an error that I'm running an unsupported processor, even though I think I was following this guide by the step.
      What could be causing this and what do I need to do to resolve it?
       
      CPU: AMD Ryzen 2700X
      MB: Gigabyte Aorus X470 Ultra Gaming
      Memory: 4x8 GB HyperX Predator, 3000 MHz Cl15
      Storage: Samsung Evo 970 Nvme 512 GB, Crucial MX500 500GB SATA
      GPU: MSI Radeon RX580 GamingX 8GB
    • By marras
      Hi, I've an old machine (see the signature) that I want to use for xcode , when I'm too lazy to take my macbook pro. I tried install Sierra, and worked surprisingly well, but sadly it doesn't support the latest version of xcode. I tried to update to High Sierra, but in the first boot everything goes black. So I tried a clean install, and had the same result. Tried Mojave with the telemetry plugin hack (as I've not SSSE 4.2), and the installation went smooth, but in the first login, I've a mouse pointer (which moves!) over a blinking screen, gray and black, and seems stuck. Tried several SMBIOS, changing the Display port, HDMI, LILU with WhateverGreen, but with these 2 the verbose freezes pretty soon (if needed I can make a screenshot). So I know that this card should work OOB, but I've also seen that several people had this problem, but honestly I didn't figured it out how to continue. My pc doesn't have any integrated gpu.
      Please help me, I'm stuck!
      Thank you
    • By verdazil
      This is not intended to be a complete and comprehensive installation guide. There are many installation guides on the forum and installing macOS is no different from installing on other desktop builds. Rather, this is supplemental information specific to the my hardware listed below. I hope you find this information useful and this will save you a little time.
       
      Hardware
      MB: Huananzhi X79-ZD3
      CPU: Intel® Xeon E5-2689, 1.2-3.6 GHz
      Chipset: Sandy Bridge-E Q65 (C600/C200)
      Memory: Samsung 4x8 Gb ECC/REG DDR3, 1866 MHz
      Video: Saphire Nitro+ Radeon RX 590
      Monitor: BENQ-BL2711U + LG TV 42LF650V
      SSD + HDD: NVMe M.2 Samsung 970 EVO 250 Gb + HDD Seagate 2 Tb
      WiFi: Fenvi FV-T919 BCM94360CD
      Mac model: MacPro6,1
      MacOS version tested: Mojave 10.14.6 (18G1012)
       
      What works?
      - Video: 4K x 60Hz on BENQ-BL2711U + Full HD x 60Hz on LG TV 42LF650V
      - Sound: audio jack + HDMI audio on both monitors
      - Wi-Fi (out of the box)
      - USB2 && USB3 ports
      - LAN
      - Bluetooth (out of the box)
       
      What does not work?
      - Sleep mode: not tested / I don't need
       
      BIOS Configuration, what's important:
      Bios Version: 4.6.5.4
      Legacy USB Support: [Enabled]
      XHCI Hand-off: [Enabled]
      EHCI Hand-off: [Enabled]
      USB Mass Storage Driver Support: [Enabled]
      Hyper-threading: [Enabled]
      Active Processor Cores: [All]
      Serial Port: [Disabled]
      Intel(R) VT-d : [Disabled]
      Launch CSM: [Enabled]
      Boot option filter: [UEFI only]
      Launch Storage OpROM policy : [UEFI only]
      Launch Video OpROM policy : [UEFI only]
       
      Here is what I used to install and configure the system:
      Clover: make with Clover Builder https://github.com/Dids/clover-builder/releases Audio: https://github.com/vit9696/AppleALC Video: https://github.com/acidanthera/WhateverGreen/releases USB: https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads + PMHeart/DalianSky patches LAN: http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/ CPU Power management: https://www.insanelymac.com/forum/topic/324270-sandy-bridge-e-ivy-bridge-e-power-management-1013-appstore-release   Clover configuration:
      Clover version: v2.5k r5088
      You can get the configuration file and the necessary kexts from the link at the end of the message
      Note: you must insert your own SeralNumber && MLB && ROM && SmUUID in the config.plist file.
       
      How to use
      To make a bootable flash drive, you can use my EFI directory (link at the end of the message). Tested for Mojave 10.14.6 installation.
      https://drive.google.com/file/d/1tjbwuUWg_PlQCVt5PTRFG6HsNby_BcgN
×