Jump to content

[GUIDE] MSI H81M Motherboards - Basics of a Computer Build - Budget Hackintosh Builds - UEFI Dualboot - OS X El Capitan WIP*


158 posts in this topic

Recommended Posts

I'd rather not use it as everything else is working sweet with Clover. But my point being that apparently HDMI audio can work on Yosemite. This isn't because of a particular bootloader, but the kexts and config, right?!?

No support from them? :hysterical:

At least read this: http://prasys.info/2...ymac-seriously/, to have a better idea on who they are...

No support from them? :hysterical:

At least read this: http://prasys.info/2...ymac-seriously/, to have a better idea on who they are...

And that was back when we were all working on Snow Leopard 10.6.8. 

It hasn't changed any since.

  • Like 1

Ok. USB speakers aren't really a viable option for my set up. It's in my living room and hooked up to the TV and sound system. If I go ahead and use the other wizard to get it working. Could I then copy the kexts that it uses and then go back to Clover and replace the kexts that it uses? If so, what kexts and configs would I need to copy back to the Clover set up? Is it just AppleHDA?

Try this: ufo202 --- http://www.bhphotovideo.com/c/product/616368-REG/Behringer_UFO202_UFO202_USB_1_1.html

Thanks. I got a bluetooth receiver for my stereo and a usb bluetooth adapter for the computer. It works well, was still interested to see if anyone knew how to get the audio working through hdmi though. Just because it'd be nice to do it if it can be done. Thanks for the suggestions though.

You're going to hackintosh right off the bat? I'd suggest you install windows to make sure everything works before installing OS X. If you install OS X Yosemite then the guide may work for you. There's not much difference between motherboards of this type. Make sure processor and graphics are compatible with os x to have less pain to deal with.

Thx for quick reply. Should have been more precise. I built 2 Windows XP PCs before and I read quite a few threads about hack builds before collecting my gear. There is just so little input on B85 builds, so I was a little insecure. Nevertheless my build with the MSI B85M-E45 is a success. Built in GPU works great, OSX boots with no prob. I skipped built in audio, because I use Apogee Duet as my audio in/out. The hack is a major leap forward to my worn out Mac mini late 2009. The only gripe is it doesn't always boot down fully. I had to manually shut down to make the fans stop.

 

Specs:

Mobo: MSI B85M-E45

Cpu Core i3 4130

Built in GPU Intel hd 4400

Hdd seagate barracuda 1 tb hybrid drive

Belkin FireWire adapter

500 w budget psu

Thx for quick reply. Should have been more precise. I built 2 Windows XP PCs before and I read quite a few threads about hack builds before collecting my gear. There is just so little input on B85 builds, so I was a little insecure. Nevertheless my build with the MSI B85M-E45 is a success. Built in GPU works great, OSX boots with no prob. I skipped built in audio, because I use Apogee Duet as my audio in/out. The hack is a major leap forward to my worn out Mac mini late 2009. The only gripe is it doesn't always boot down fully. I had to manually shut down to make the fans stop.

 

Specs:

Mobo: MSI B85M-E45

Cpu Core i3 4130

Built in GPU Intel hd 4400

Hdd seagate barracuda 1 tb hybrid drive

Belkin FireWire adapter

500 w budget psu

You mean it doesn't turn off on its own? You could boot in verbose mode and when you try to turn off your computer, the verbose messages will pop up telling you what is happening when shutting down.

  • Like 1

I Think I found the solution. I activated the Fix Shutdown DSDT patch in Clover. The computer powers down after a longer moment. :)

I was thinking that it was a kext that was causing the problem, but if the dsdt patch works then your problem is solved.

  • Like 1

I have the h81m e33 motherboard with hd 7770 and with everything working but sleep. When I put the computer to sleep it only turns off the monitor whereas the computer itself keeps running. The guide says that the sleep should be working. However, I haven't done the ssdt power management step because my cpu operates at different frequencies already. Should I do this step to fix my sleep problem?

I have the h81m e33 motherboard with hd 7770 and with everything working but sleep. When I put the computer to sleep it only turns off the monitor whereas the computer itself keeps running. The guide says that the sleep should be working. However, I haven't done the ssdt power management step because my cpu operates at different frequencies already. Should I do this step to fix my sleep problem?

Always make an SSDT. No excuse to not do it. Doesn't take more that 1 minute to create it and configure Clover to use it. 

 

Other reasons why it might not sleep could be because of USB kext being used.

Always make an SSDT. No excuse to not do it. Doesn't take more that 1 minute to create it and configure Clover to use it. 

 

Other reasons why it might not sleep could be because of USB kext being used.

 

I ran

"curl -o ~/ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/master/ssdtPRGen.sh"

in terminal but I got this:

 

Warning: Failed to create the file ~/ssdtPRGen.sh: No 

Warning: such file or directory

curl: (23) Failed writing body (0 != 15636)

I'm having problems with installing OS X. After I select OS X Install partition in Clover, It goes to a black screen and the USB light on the USB Drive turns off. I'm trying to install 10.11.1 (El Capitan)

 

Specs:

Motherboard: MSI H81M-P33

CPU: Intel Pentium G3258 (Using FakeCPUID)

RAM: 4GB x2

GPU: NVIDIA GT 610 (Buying a GTX 960 soon)

 

BIOS is set to IGD for graphics

Monitor plugged into DVI

 

Any help is appreciated!

I'm having problems with installing OS X. After I select OS X Install partition in Clover, It goes to a black screen and the USB light on the USB Drive turns off. I'm trying to install 10.11.1 (El Capitan)

 

Specs:

Motherboard: MSI H81M-P33

CPU: Intel Pentium G3258 (Using FakeCPUID)

RAM: 4GB x2

GPU: NVIDIA GT 610 (Buying a GTX 960 soon)

 

BIOS is set to IGD for graphics

Monitor plugged into DVI

 

Any help is appreciated!

GPU: NVIDIA GT 610
Did you set Inject Nvidia  to true
 
<key>Graphics</key>
 
<dict>
<key>NVidia</key>

 

<true/>

I don't have any Kexts in my USB. Is that the problem?

What OS X version are you trying to install?

 

And remember that Intel Pentium IGPUs are not supported by OS X.

 

And plug in the USB installer on an Intel port, i.e. USB 2.0 back side.

  • Like 1
  • 2 weeks later...

Hi @GhostRider

 

My system:
MSI H81M-P33.
Intel  Core i3-4130 HD4400.

VGA GT630 and Monitor connnect with DVI.

 

Can i using NVIDIA GeForce Graphics Drivers with GT630 and update from 10.10 to 10.10.5 without issue.
Thanks you very much. Sorry for my bad English.

  • 2 weeks later...

Hi to everyone, the intention of my post is to ask anyone what would be the CPUID for the i7 5960X CPU and if buy changing this at the config.plist I still can use the Mac Pro 6.1 SMBIOS definition, thx in adv.

Hi to everyone, the intention of my post is to ask anyone what would be the CPUID for the i7 5960X CPU and if buy changing this at the config.plist I still can use the Mac Pro 6.1 SMBIOS definition, thx in adv.

I don't think you need a CPUID for this CPU. The Mac Pro 6,1 smbios is fine for your setup.

 

H there

 

Excellent step by step tutorial.

 

I had to use various tutorials to get el capitan running on my MSI GS 60 2PE 3K Laptop.

 

Tried clover method using this H81 motherboard tutorial to perform clean install, but never worked after 4 attempts of formatting USB drive and target drive.

 

Had immediate success using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/ MultiBst 6.1.1 Tonymac86 tutorial to reach desktop screen. But your tutorial made it instant to boot into desktop by using clover configurator.

 

I adopted Clover configurator steps from this H81M guide to get other items working. Strangely WiFi worked when i copied over the three items (config.plist / drivers64UEFI / kexts) from Intel Hd 4600 Graphics folder from MSI H81M Motherboards Pack from the InsanelyMac Downloads given in the tutorial. But touchpad (Elan), keyboard and audio did not work.

 

Used Easykext utility to re-install ELAN v3.8.5 kexts which was previously used to make keyboard and track pad work, but could not get it up. For Audio had to use Voodoo HDA instead of Realtek ALC 892. [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86 MultiBst's Realtek input kexts did not work neither. Am happy the least, sound is playable.

 

Can you help. I want to make wifi and bluetooth work, it was a fluke somehow it worked when i copied your filed over. My wifi/bluetooth is using Broadcom (BCM 94352 Z ngff 802.11 ac) . Is there anything i can just copy a kext file over to make it work? My HD 4600 graphics is in max 3k resolution and shows as 17mb. Any help on this? Thanks

 

H there

 

Excellent step by step tutorial.

 

I had to use various tutorials to get el capitan running on my MSI GS 60 2PE 3K Laptop.

 

Tried clover method using this H81 motherboard tutorial to perform clean install, but never worked after 4 attempts of formatting USB drive and target drive.

 

Had immediate success using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/ MultiBst 6.1.1 Tonymac86 tutorial to reach desktop screen. But your tutorial made it instant to boot into desktop by using clover configurator.

 

I adopted Clover configurator steps from this H81M guide to get other items working. Strangely WiFi worked when i copied over the three items (config.plist / drivers64UEFI / kexts) from Intel Hd 4600 Graphics folder from MSI H81M Motherboards Pack from the InsanelyMac Downloads given in the tutorial. But touchpad (Elan), keyboard and audio did not work.

 

Used Easykext utility to re-install ELAN v3.8.5 kexts which was previously used to make keyboard and track pad work, but could not get it up. For Audio had to use Voodoo HDA instead of Realtek ALC 892. [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86 MultiBst's Realtek input kexts did not work neither. Am happy the least, sound is playable.

 

Can you help. I want to make wifi and bluetooth work, it was a fluke somehow it worked when i copied your filed over. My wifi/bluetooth is using Broadcom (BCM 94352 Z ngff 802.11 ac) . Is there anything i can just copy a kext file over to make it work? My HD 4600 graphics is in max 3k resolution and shows as 17mb. Any help on this? Thanks

 

But you have a laptop no? The guide here isn't really gonna work for you. HD4600 requires an ig-platform-id that works on laptops, don't use ids used by desktops. I'm not sure about Elan touchpads and keyboards. As for bluetooth and wifi, you're going to have to find compatible kexts. From researching your 94352z can enable Wi-Fi using FakePCIID and BroadcomWifi kext from Rehabman. Bluetooth is unknown. Again, the key here is to use the model numbers to see if someone else has found a solution.

×
×
  • Create New...