Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Multiboot - GRUB2 + Mavericks

10 posts in this topic

Recommended Posts


Tenho um PC onde instalei Windows 8, Ubuntu 14.04 e OS X Mavericks 10.9.2 (ja funcionando internet e som da P5Q)
Windows em um HD e Linux + OS X em outro.

1-Gostaria de saber se o GRUB2 consegue rodar o mavericks sozinho ou se vai conseguir isso apenas em conjunto com o Chameleon.

Tentei sem sucesso no grub o seguinte comando:


insmod hfsplus

set root='(hd0,1)'
multiboot /boot
Pergunto isso pois segundo instruções do @oldnapalm neste link http://www.insanelymac.com/forum/topic/243344-boot-do-snow-leopard-pelo-grub2/ "O GRUB2 ainda não faz boot do Snow Leopard diretamente, apenas do Leopard" e a duvida é justamente se o Mavericks aceita o boot direto ou não.

Share this post

Link to post
Share on other sites

Não, o Gru2 não gerencia nenhum OS X do Snow para cima.

Ele vai ser gerenciado pelos outros bootloaders, como Clover e Chameleon.


Ex: 1º Clover - 2º Grub2.


E sua pergunta está no local errado, aqui é em Inglês. Então o post obviamente tem que ser em Inglês.

Aqui é o local correto: Português

Share this post

Link to post
Share on other sites

Obrigado pela ajuda com o grub Allan.
Vou tentar então o esquema que vi no link que mandei antes do Old onde ficava 1º Grub2 - 2º Chameleon (no modo quiet).

O problema de não ter postado na página em português é que por duas perguntas que errei, não atingi o minimo no OSx86 Part 2 que liberaria postar em qualquer página do fórum como fazia antes =/

Inclusive nem iria abrir um novo post, tentei usar o que ja tinha feito no passado na sessão em português, gostaria de saber quando vou poder tentar responder as perguntas novamente..

Estou bloqueado até no meu post "http://www.insanelymac.com/forum/topic/265756-asus-p5q-q9550-geforce-8400-gs/" este novo quiz e liberado apenas aqui no "New Users Lounge".

Share this post

Link to post
Share on other sites

opa... esse não tinha visto, muito obrigado novamente.. se precisar e algum puder transferir pra la fiquem a vontade!

Estou esperando liberar novamente pra responder as perguntas no "Part 2" que esta bloqueado não sei até quando.
Era membro antes deste quiz não sei pq cai nele, mas fazer o que =D

Share this post

Link to post
Share on other sites

Sabe o tempo pra liberar novamente o quiz? Ou mesmo se ele vai ser liberado pra uma nova tentativa? No momento ele esta como "unavailable".

Share this post

Link to post
Share on other sites

Descobri que depois que erra, tem que esperar um dia pra tentar novamente.
Agora consegui passar no teste e voltei a ser membro =D

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Lilith
      i have a little old mobo with socket 1156 no Sata 3 - biostar tpower i55 and i Was wondering if i had some chance to install a new nvme memory like Intel 760p.
      Due lack of support by my mobo i found a Pci Express card lycom dt-120 to expand my connectivity.
      After some researches i understood that i need a ‘bios support for the boot from nvme disk’. I want some of these nvme memory to install high Sierra and get a killer desktop.
      I think that i haven’t obviously a native bios support cause my mobo is pretty old, so i can’t get an nvme disk and install properly high Sierra hoping that boot?
      Or should i catch anyway? I Guess that same problem is for w10? 
      Thanks, Gabriele.
    • By giovanealex
      Hi guys.

      Sometimes I am a complete noob, so I deleted two kexts from S/L/E and now my Asus Q200E laptop with OS X El Capitan boot hangs on kernel panic. I still can enter go through Clover to reach Recovery Mode and use Terminal, so I've put the two kexts on a USB pendrive and after some struggle I've managed to succefully copy them using Terminal, but the boot is still stuck on kernel panic. As I remember, these are the commands I've typed:

      mount -rw

      cp -a /Volumes/usb-stick/name.kext /Volumes/my-osx-drive/System/Library/Extensions

      Is there anything else I should do? Is anything wrong? Should I type some command else? For instance, should I type something to fix permissions and rebuild cache?

      Thanks a lot!
    • By shawnv333
      edit- first gen i7 860 12 gig ddr3 ram, asus p7h55m board, intel H55 chipset, asus gt 640 2gig card

      Hello and good day. I have never had this much problems with hackintoshes. I am working on my third hack.

      I was having boot problems, trying different flags, getting in, but never really fixing or setting up proper backups.

      I have many hhd's, a ssd as well. I have two usb sticks made mostly from #####. My ##### did not want to see my hdd (the installer)
      Anyhow, currently I have 10.13 installed onto my external drive. Used a niresh build, because i'm pulling hair.

      But even that does not see my HDDs or SSD.

      I'm guessing it is a clover or kext issue or driver, but I don't know anymore.

      Everything I do makes another problem. Anyhow, I have a fresh install (Actually I have 3 or 4 installs.

      My old one on SSD, another install on seperate HDD, and another fresh one.

      As far as I can tell the nvidia web drivers giving me issues, but I cannot get recovery to work to remove the kexts (as far as I can understand)

      On my external drive, it was giving me a problem. I was talking on the phone while the post-install screen was waiting, and than the system rebooted. I needed to boot in single user to delete the file that says the hack was setup, because when i restarted it just brought me to a blank login.

      Anyhow, I have work i need to do. I'm laughing though, I have never had problem after problem.

      I need to learn more. And everything is booting so slow. Just my HDD's and SSD and external drive.

      I know my clover installs and EFI partitions are too much, messed up config.

      I want to just wipe all the EFI's and just start fresh, but I do not know how?

      I guess linux boot disc maybe? Just delete the EFI's except one and only work on that?


      Any tips or walk through just to start fresh. Thank you for reading
    • By chriz74
      In this video I first show the boot time of my system running on an OCZ Vertex 3 SSD APFS formatted and with TRIM enabled. As you can see the boot has a long pause at these "FIPSPOST_USER" stuff. The solution that always worked for me is to create a time machine backup and restore to disk. As you can see after the restoring that long pause is drastically reduced. The initial boot time is 45 seconds circa, after restoring is down to 22 seconds. TRIM is still enabled and disk is APFS.

    • By john_s
      I updated normally to 10.3.3. Rebooted and no sound was working as always after update, so I run toledas script one more time to enable audio. But after that, I got stuck on boot after initializing en1 like in picture
      Any ideas how to fix this?