Jump to content

Can't boot into my OSx86 partition


11 posts in this topic

Recommended Posts


I have got a problem. I can't boot into my Mac partition anymore since I have installed Windows on another partition on the same SSD.

Later I have read that I have to install OSx86 after Windows for dual boot.


Now, I will do this but now I have to boot in my OSx86 partition to safe my documents. How can I activate the OSx86 partition?


On my OSx86 partition there is the Chameleon bootloader installed. I have already tried to put the Chameleon files to a usb stick with Windows and boot to my OSx86 partition with this stick but it didn't work.


It would be great if somebody knows the answer!



Link to comment
Share on other sites

Try this:



You don't have to reinstall OS X, just the boot loader.


For more information on booting OS X and Windows from the same drive, go to the Multibooting and Virtualization sub forum.

I already tried this but it didn't work. I became an error where it said that there is no bootable OS on this boot device.

Link to comment
Share on other sites

Parts of the Windows boot loader has overwritten parts of Chameleon that was installed on your hard drive. It is normal for this to happen if you don't take the necessary precautions. And this is why you can no longer boot OS X when booting from the hard drive.


It's possible to have both co-exist and lots of people are doing this - especially laptop users with only one drive - but I have never done that and so I don't know the specifics.

There are guides but most of them require that you can at least boot into OS X. Unfortunately.


As long as your OS X installation is not damaged, the tutorial I gave to you will allow you to boot OS X via USB stick, if you follow it correctly. It works, I've done it (as you can see in the topic).

Make sure you're actually booting from the USB stick, not the hard drive.

  • Like 1
Link to comment
Share on other sites

I have tried it again, it didn't work (Win 8.1), then I tried creating the stick on a WIn 7 system, now I can boot into chameleon, but if I want to boot my Mavericks partition the system is rebooting and boots Windows again.

Do I need any kexts or something like that?


I just did the makeusb command, copied the Chameleon files to the root of the stick and copied the boot file to the root of the stick.


Do I need something more?

I tried pasting the NullCPUPowerManagement.kext and FakeSMC.kext to Extra/Extensions, but the result is the same.

Link to comment
Share on other sites

From my experience, once you install Windows (on the same drive, separate partition) as OS X there isn't much you can do. Gringo is correct in saying that Windows is corrupting the boot loader. In 8 years, from XP to 8.1 I have yet to find a solution.


My suggestion is to back-up the OS X partition and start over. When you install Windows on a separate hard drive ALL other drives containing other OSs must be disconnected  (optical drive and drives used for storage are ok) or Windows won't install. Often the installer will give a warning prompt shortly after the process starts and exits. If it does there is a good chance that the HDs containing other OSs will get corrupt. The same goes for installing on the same HD but different partitions.


Here is what I have always done. I gave up on trying to fix things years ago and just went with a fool proof method.

1) Format the HD into 2 partitions; 1 HFS+ the other Fat32 (or NTSF)

2) Install Windows FIRST on the 2nd partition

3) Install OS X on partition 1

4) Install Chameleon/Clover/Chimera


You can try to install Clover on the EFI partition (of the hard drive or from USB) and boot from there. Of course you need an UEFI motherboard for this to work. On that note, if you have the know how you can try reformatting the EFI partition, as well as setting the OS X partition as active. There are many guides here with the info you need.

Link to comment
Share on other sites

Your reboot issue is probably due to locked msr's/xnu power management in the mach kernel. If you have a haswell processor you need to patch the original mach kernel, or make a clover uefi usb, so that you will be able to select "patch kernel" and "patch aicpupm" when running the clover bootloader you won't need nullcpupowermanagement, get rid of that and repair permissions


Without knowing the full specs of your laptop I'm afraid I won't be much help. Also, boot into windows and download a trial of aida64 extreme, generate a system report and save that file, I've found doing this to be quite helpful as a reference point, and a sheet that let's me refer back to it to know my hardware.

Link to comment
Share on other sites

  • 2 weeks later...

Boot into live usb stick of Linux and use gptsync. This will fix your issue.

I was going round and round in circles cause of this issue, :).


You will then need to use gdisk or gptsync (mac advanced version) to make windows bootable.

Link to comment
Share on other sites


  • Create New...