Jump to content

issues with mdi radeon hd6450


2 posts in this topic

Recommended Posts

Im having issues with this particular graphics card...I bought this card for my father as on my mackintosh it worked out of the box....On his however after installation and restart I make it past the apple logo then go straight to a white screen where it stays with no cursor....However if I boot into safe mode and remove amd6000controller.kext then restart I can get to the desktop with very laggy graphics that are horrible.........Ive tried copying amdcontroller6000.kext to the desktop,deleting it from S/L/E and reinstalling it-that actually worked one time but every icon in launchpad was red...After that one successful restart it immediately started freezing at the white screen again....I am a noob to the mackintosh world so if anyone could please help me with instructions on as to how to fix this I d greatly appreciate it so much ,,as I also have to fix the ethernet afterwards....thank you.....Another thing-I am using the dvi connection



 UPDATE: today I noticed that using "graphicsEnabler=no" was a hit and miss...Sometimes I would get to the desktop with no issues and have awesome graphics no lag whatsoever and no pink icons...Other times I would still get a blank white screen....A few times I used the bootflag "-s" then typed in "graphicsenabler=no" one of those times i noticed an error about cpu power management,also one of the times I froze at white screen


UPDATE:the card Im running is msi radeon hd6450 which has 2gigs of dedicated memory...I spent all night once again trying to make the graphics work then I noticed something-when I first install using hdmi I have perfect graphics and acceleration but right after the niresh permissions fixes go through my screen turns grey for a second and comes back-when it does my icons in Launchpad are pink and as well when I restart the system I get the white screen again...I googled this and there was something about the amd6000controller.kext having permission issues?how do I fix this as to when I repair permissions or nireshs permissions don't break my graphics?Ive been going 3 weeks on this graphics issue and once its fixed I have the joys of making internet work


UPDATE:I VE tried several things including khatphats  hd6450 kexts-nothing works...When I reboot I get a blank white screen...any ideas? I did fix the Ethernet by purchasing an Ethernet card to disable onboard.I know this graphics card works because ive managed to get to the desktop a couple times with awesome graphics......As Ive said I run this card in my intel machine and get great graphics on 10.9.1 ,but this same card in my dad s amd machine hits a white screen when i leave the amd6000controller.kext in.if i remove the kext I can boot to desktop but with crappy,laggy graphics-safari blinking and flashing not even worth using....a few times i have made it to the desktop with this card and his graphics were perfect but upon reboot white screen again

Link to comment
Share on other sites


  • Create New...