Jump to content

Non-UEFI Guide to installing OS X Mavericks with Clover


62 posts in this topic

Recommended Posts

ADDENDUM: Perhaps we can get this done without the USB. I have two currently bootable drives. My Main drive and a lager drive, also bootable, that holds the main backed up. My goal is to get this second drive updated to Mavericks FIRST then to do some heavy deduplication of files and make the second drive, once I am satisfied it is stable, the main drive.

I can run install Mavericks now from my main applications folder. IT appears to do all it should do. I point it at the second drive and it mounts the base system and all the rest. Then of course I have to restart. When I restart I get a "Could not parse PLIST" error, then it continues on but down nothing more with the installation.

My current Hack Boot is the Beast one with the red tomato/apple logo. Could this be as simple as changing the PLIST you supplied earlier with the PLIST currently on the second drive? Oh how nice if I was that close?

Link to comment
Share on other sites



Your description of the problem suggests your system is not booting from your Clover FAT32 USB but from your hard drive via Chameleon/Chimera (hence you see the spinning underscore - this doesn't happen with a Clover boot).  So either your Clover USB is not bootable or your BIOS is ignoring it (boot priority is being given to your hard drive).


I need you to upload a screenshot of the output from OSX terminal after typing diskutil list with only your Clover FAT32 USB plugged in.  It should be as the screenshot in my post #46 step 5--->FDisk partition scheme, single partition, DOS FAT32 Clover.  If different, try making your Clover USB again with one of your other flash drives starting at step1...


Indeed it could be a BIOS setting also....when your machine is POSTing with only your FAT32 Clover USB plugged in,

  • press <Del>
  • set your BIOS to use optimised defaults first
  • then change hard disk operation mode from IDE to AHCI
  • HPET mode set to 64 bit
  • In the boot order section of your BIOS (it may be in "Advanced BIOS Features" under "Hard Disk Boot Priority"), set your FAT32 Clover USB as the first option (use + key to move it up to the top)




  • Press F10 to save BIOS settings & reboot

Cross fingers and hope you see the Clover menu.  For a non uefi boot, there is usually a 10-20 sec wait before it appears....



  • You can't install Mavericks by double clicking Install OS X Mavericks.app in your Applications folder ----> This only works on real Macs!
  • You can place the Mavericks installer on a 8GB HFS+ partition on your 3TB hard drive (with the createinstallmedia command) but I want you to complete one thing at a time....the most important thing is to create a bootable USB and the ability of that Clover FAT32 USB to boot the computer into OSX (or the OSX installer).
Link to comment
Share on other sites

Hello to all. I created a USB stick with Clover by following the guidance. I have successfully efi partition and the partition contains the installer ch Maverick. I boot from usb and launch the installation of Maverick but always freezes and I can not continue. can you help me? This is my notebook http://www.samsung.com/it/consumer/pc-peripherals-printer/notebook/essential/NP350V5C-S08IT-spec


Link to comment
Share on other sites

  • 1 month later...

Greetings all Mavericks wannabees!  I finally worked around getting Clover and the Mavericks installer onto a single USB.


I started with a 16 GB USB stick and used MacWorld's description of loading the Mavericks image onto the USB with Disk Utility.


I read the information provided by Slice and discovered that the mavericks software needs to be loaded onto a MBR formatted partition.

The Clover app needs to be loaded onto a FAT-32 partition.


I first used Disk Utility to make a two partition USB with the first slice being FAT-32, then without closing the partition utility making the

the larger slice as MBR. I first named the first slice(FAT-32) as EFI and the second as Mavericks (MBR). I installed Clover to the EFI slice and it worked!!! I then went through the Macworld procedure to load Mavericks onto the Mavericks slice.


No - I haven't tried running the the installer yet as I need to get a couple of Kexts onto the EFI slice.

When using the Terminal and issuing diskutil list, the USB shows up as EFI on slice 1 and Mavericks data on slice 2, just as it would be if you formatted the USB with GUID formatting.


Since  am currently running on 10.6, the command string using createinstallmedia command doesn't work there by necessating the use of Disk Utility to get the job done. Checkout MacWorld.com for those details.


Good Hacking

Link to comment
Share on other sites

You can actually create a Clover boot disk for non UEFI machines quite easily with cVad's BootDiskUtility in Windows.


I have posted an illustrated guide on how to create a Vanilla Mavericks Install USB in "Creating OS X USB installer using a Windows PC only".


Also @chris1111 has made a very nice, semi automated tool to create a Mavericks USB installer in OSX: EFI Mavericks Box. For non UEFI installs, you would choose options c & b.

  • Like 1
Link to comment
Share on other sites

  • 2 months later...

Quick question, what can I do when I've messed up and installed Chameleon AND Clover?  Is it possible to re-format the EFI partition and reinstall one or the other?  Or is it better to backup and just reformat the whole disk.  Also, any idea why my SCSI hard disk (attached through an LSI card and appears native in Chameleon) would not appear in Clover?  Does the boot disk (or USB stick) need that Apple LSI kext?

Link to comment
Share on other sites

  • 4 months later...
  • 2 weeks later...
  • 4 months later...
  • 1 year later...
  • 4 months later...
  • 10 months later...


What is GUID or "GPT" vs MBRLink


How can I tell if my mobo falls into this category?

I have a machine of similar vintage - a Gigabyte GA-P55aUD3/i5-750 - that can only boot from single partition, MBR layout USB drives.



Hi, I'm not sure if you're still active on this old thread. It appears the original guide has been taken down. I'm trying to do a  Mavericks install using clover on a gigabyte p55a-UD4P/i7 875k.

I've used the tonymac method but had some problems. Could you give me the steps I need to get my hackintosh build going?? There's not many guides for getting clover working older non-uefi mobo's .






Link to comment
Share on other sites


  • Create New...