Jump to content

Haswell success - GA-Z87M-D3H - GTX 670


52 posts in this topic

Recommended Posts

——————————

— EDIT —

— updated for Mavericks, now using Clover UEFI bootloader —

— with two automated scripts for creating the usb —

— the first one can be used to create a bootable USB for real Macs as well —

— link1 link2 —

— if you have any feedback or suggestions to the script, please, help me. I am new to programming —

——————————

 

Hello!

 

Sharing my reports on installing 10.9 on a Haswell machine.

System specs:
CPU: Intel Core i5-4570
M/B: Gigabyte GA-Z87M-D3H
GPU: EVGA GeForce GTX 670

 

How I did it:

 

BIOS version:

F9 (http://www.gigabyte.us/products/product-page.aspx?pid=4486#bios)

 

BIOS settings (everything default except):

xHCI Hand-off - Enabled

EHCI Hand-off - Enabled

xHCI mode - Auto

Intel HD Graphics - Disabled

 

I followed this guide pretty closely: http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners/

 

1. I created USB Installer according to the guide mentioned above.

 

2. I skipped the NullCPUPowerManagement.kext completely.

 

3. After installation, I booted into USB installer again and opened Terminal and entered following command (replace "YourHDNameHere" with the name you gave your HD/SSD, e.g. OS\ X):

cp /mach_kernel /Volumes/"YourHDNameHere"/

4. I downloaded the 10.7 Ethernet driver from Realtek website (http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false) and installed it into /Volumes/EFI/EFI/CLOVER/kexts/10.9/

 

5. For enabling TRIM, I used the KernelAndKextPatches section of the Clover config.plist:

<dict>
<key>KernelAndKextPatches</key>
<dict>
  <key>KextsToPatch</key>
  <array>
   <dict/>
   <dict>
    <key>Comment</key>
    <string>Enable TRIM</string>
    <key>Find</key>
    <data>
    QVBQTEUgU1NE
    </data>
    <key>Name</key>
    <string>IOAHCIBlockStorage</string>
    <key>Replace</key>
    <data>
    AAAAAAAAAAAA
    </data>
   </dict>
  </array>
</dict>
</dict>

6. For enabling GPU power management, i followed Riley Freeman's advice and replaced

libclh.dylib

from the NVIDIA web drivers.

 

Please, ask, if you have any questions.

The attached mach_kernel is extracted from 10.8.5 (build 12F33) Combo Update using The Unarchiver (https://itunes.apple.com/us/app/the-unarchiver/id425424353).

 

I used the vanilla OS X Nvidia drivers with my EVGA GeForce GTX 670, which is natively supported.
The problem was the audio drivers. I will edit my original post. I can play any video I like now.

Yes!!! Congrats!

When you create a the USB, with the original Guide with Vanilla, Have you found the /System/Installation?

and the /System/Library/Extensions in the USB?

 

I can´t find it!

 

Maybe my 10.8.4 is corrupted...

Thank you!

 

Make sure you are using the BaseSystem.dmg hidden in the "Mac OS X Install ESD".

When you have mounted the InstallESD.dmg, you can mount the BaseSystem.dmg using the following command:

open /Volumes/Mac\ OS\ X\ Install\ ESD/BaseSystem.dmg

Then restore it in disk utility like this:

FkwVu5M.png

Vlade, have you tried Smbios? With CHamaleon Wizard?

 

I'm stuck with .com.apple.lanched

 

and nothing happens!

 

Any suggestion, more hacks around the world ;)

Did u stuck at the com.apple then still waiting for root device ?

I tried the SMBios 9,1.

But maybe the last time I tried I think I might forgot to add the SMBios. Hope this is the key to solve my problem.

 

-v ncpi=0x2000 -f -x GraphicsEnabler=Yes

 

Try these boot flags EXZACTLY. See if it boots. Testing install only no graphics audio ect... let us know

 

as far as I remember I tried the boot with those flag. And stop at DSMOS has arrived.

Maybe if you add pci=off to the boot flags?

I haven't tried it yet. I will try it. Thx you.

With bootflags I am stuck in com.apple.lanched

The only error I can see in the screen its AppleHDA.

I deleted the applehda and no errors.

 

Without bootflags i can se the grey screen and the wheel turning around, and around (Like Jhon Lennon´s song)

 

My instint said it´s de Kernel, I have read all the forum. We need a new one. I cross my fingers waiting for 10.8.5 for Haswell... come on Apple!

An authentic kext's component files are owned by root:wheel, with permissions nonwritable by group and other.

The first post has you copy FakeSMC but not set the permissions (EDIT: OP does repair permissions later on so that would fix this. Did you do that?), so the following might work:

chown -R root:wheel /Volumes/[target volume]/System/Library/Extensions/FakeSMC.kext
chmod -R 755 /Volumes/[target volume]/System/Library/Extensions/FakeSMC.kext
×
×
  • Create New...