Jump to content

OSX 10.9 DP3 Bluetooth Not Working


12 posts in this topic

Recommended Posts



Need help on bluetooth with OSX 10.9 DP3.


I'm using Apple Bluetooth Module from Macbook Pro A1260 (BCM2046 Chipset). It was working great under Mountain Lion 10.8.4. It also work under OSX 10.9 DP1 and DP2. However, when I upgraded to DP3, the bluetooth module is no longer detected by the OS.


I've checked and verified that Device ID and Manufacturer ID are available in Info.plist in the IOBluetoothFamily.kext and its related kext.


I've also tried with various USB Bluetooth dongle that worked with 10.8.4 up to 10.9 DP2, however they did not work under 10.9 DP3.


I've also tried to use the kext from OSX 10.8.4, but still no luck.


Any advise to resolve the issue is very much appreciated.


System : Gigabyte GA-Z77P-D3 (Ver 1.1), i7 3770, Gigabyte GTX 650 OC, 8MB RAM, 1TB Samsung HDD, 1TB WD HDD

Link to comment
Share on other sites

Here is my bootflag;


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<key>Default Partition</key>
<key>Graphics Mode</key>
<key>Legacy Logo</key>
boot using chameleon V2.2svn r2544, earlier versions also no luck.
Link to comment
Share on other sites



tried it but still no luck.


tried to rebuilt the kernel cache and get the following message;


WARNING - Invalid signature -67054 0xFFFFFFFFFFFEFA12 for kext "/System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/IOBluetoothUSBDFU.kext"

WARNING - Invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext "/System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/BroadcomBluetoothHCIControllerUSBTransport.kext"

Link to comment
Share on other sites

The kext's signature not becoming invalid just because you check it. It's modified/rollbacked if it's signature is invalid. Did you tried to put older plugins to the iobluetoothfamily kext in dp1-2?Try to reinstall dp3, or get the iobluetoothfamily kext from the update package and replace yours.

Link to comment
Share on other sites

Remove UseKernelCache and its key.


Add this to org.chameleon.boot.plist:




<key>Kernel Flags</key>


Are you for real? You only use -f to debug and not to make it permananent by puting it in chameleon.plist
Link to comment
Share on other sites

  • 3 months later...

Did you guys get this working? I'm having a similar problem. 


I have just installed Mavericks to a new SSD and it doesn't recognise my BCM2046 as BT either (it's listed in the systemprofiler though so i know Mavericks knows it's there). I then booted into 10.8.5 in which i previously had a with a USB BT dongle so i un-paired my keyboard, re-paired it and now it's working flawless in 10.8.5. Heck it even works in BIOS and Chameleon...


Mavericks however is one tough and stubborn cookie, that shows no signs of give or crumbs. So, have you guys solved this one yet?

Link to comment
Share on other sites

for me was a really working prob to install 10.9 with bluetooth 4.0 usb stick witch was working OK in 10.8.5. I was unable to to get this usb working in 10.9 so my solution was to replace this stick with another but wit 3.0 version of bluetooth standard.

Now every thing seems to be OK, once in wile I need to make repairing at boot.

Link to comment
Share on other sites


  • Create New...